source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 11211

Revision 11211, 6.4 KB checked in by iwamoto, 7 years ago (diff)

hostapd: add patches for fix KRACK issue

Line 
1%define         base_name       hostapd
2%define         pkg_version     2.6
3%define         pkg_release     2%{?_dist_release}
4
5Summary:        IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
6Summary(ja):    IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
7Name:           %{base_name}
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10Source0:        %{base_name}-%{version}.tar.gz
11Source1:        %{base_name}-init.sh
12Source2:        %{base_name}-%{version}.config
13
14Patch11:        0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch
15Patch12:        0002-Prevent-reinstallation-of-an-already-in-use-group-ke.patch
16Patch13:        0003-Extend-protection-of-GTK-IGTK-reinstallation-of-WNM-.patch
17Patch14:        0004-Prevent-installation-of-an-all-zero-TK.patch
18Patch15:        0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch
19Patch16:        0006-TDLS-Reject-TPK-TK-reconfiguration.patch
20Patch18:        0008-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch
21
22License:        GPL2
23Group:          System Environment/Daemons
24URL:            http://hostap.epitest.fi/hostapd/
25
26Requires:       openssl, libnl >= 1.1
27Requires(post): %{_syssbindir}/chkconfig
28Requires(preun): %{_syssbindir}/chkconfig
29BuildRequires:  openssl-devel, libnl-devel
30BuildRoot:      %{_tmppath}/%{base_name}-%{version}-root
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34Packager:       miyabi
35
36%description
37hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
38IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
39The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
40
41%description -l ja
42hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
43IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
44最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
45
46%prep
47%setup -q
48%patch11 -p1 -b .0001-hostapd-Avoid-key-reinstallation-in-FT-handshake
49%patch12 -p1 -b .0002-Prevent-reinstallation-of-an-already-in-use-group-ke
50%patch13 -p1 -b .0003-Extend-protection-of-GTK-IGTK-reinstallation-of-WNM
51%patch14 -p1 -b .0004-Prevent-installation-of-an-all-zero-TK
52%patch15 -p1 -b .0005-Fix-PTK-rekeying-to-generate-a-new-ANonce
53%patch16 -p1 -b .0006-TDLS-Reject-TPK-TK-reconfiguration
54%patch18 -p1 -b .0008-FT-Do-not-allow-multiple-Reassociation-Response-fram
55
56cp %{SOURCE1} .
57cp %{SOURCE2} ./%{base_name}/.config
58
59%build
60cd %{base_name}
61%{__make} %{?_smp_mflags}
62
63%install
64[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
65
66pushd %{base_name}
67%{__make} install DESTDIR="${RPM_BUILD_ROOT}" BINDIR="%{_sbindir}"
68popd
69
70%{__install} -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
71
72%{__install} -D %{base_name}/hostapd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
73%{__install} -D %{base_name}/hostapd.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/hostapd.8
74%{__install} -D %{base_name}/hostapd_cli.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/hostapd_cli.1
75
76%post
77if ! /sbin/chkconfig %{base_name}; then
78  /sbin/chkconfig --add %{base_name}
79fi
80
81if [ "$1" -eq "2" ]; then
82  %{_initdir}/%{base_name} condrestart
83fi
84
85%preun
86if [ "$1" -eq "0" ]; then
87  %{_initdir}/%{base_name} stop
88  /sbin/chkconfig --del %{base_name}
89fi
90
91%clean
92[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
93
94%files
95%defattr(-, root, root)
96
97# Directory
98%dir %{_sysconfdir}/%{base_name}/
99
100# Program Files
101%attr(0755, root, root) %{_sbindir}/hostapd
102%attr(0755, root, root) %{_sbindir}/hostapd_cli
103
104%attr(0755, root, root) %{_initdir}/%{base_name}
105
106# Config Files
107%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
108
109# Document Files
110%doc %{base_name}/ChangeLog COPYING README
111%{_mandir}/man8/%{base_name}.8.gz
112%{_mandir}/man1/hostapd_cli.1.gz
113
114%changelog
115* Fri Oct 20 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6-2
116- add patch11-18 for fix "KRACK" issue
117
118* Sat Feb 04 2017 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.6-1
119- new upstream release
120
121* Sat Jan 02 2016 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.5-1
122- new upstream release
123
124* Sat Mar 21 2015 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.4-1
125- new upstream release
126- change hostapd_cli install path /usr/bin -> /usr/sbin
127
128* Sat Dec 06 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.3-1
129- new upstream release
130
131* Wed Jul 09 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.2-1
132- new upstream release
133
134* Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
135- add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
136  - fix segfault
137
138* Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
139- new upstream release
140- change .config
141  - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
142
143* Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
144- new upstream release
145- change filename hostapd.conf -> hostapd.conf.sample
146- change .config
147  - add WPS support
148
149* Sun Dec  2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
150- new upstream release
151
152* Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
153- new upstream release
154- add Summary(ja)
155- add section - %description -l ja
156- add parameter noreplace to %config
157- change spec file
158
159* Tue Oct  9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
160- add patch100 for fix CVE-2012-4445 (EPA-TLS message)
161
162* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
163- fix daemon script
164- change spec file
165- separation from patch file
166  - daemon script
167  - .config
168- add Source1 - hostapd-init.sh
169- add Source2 - hostapd-0.7.3.config
170- add Requires(post) - chkconfig
171- add Requires(preun) - chkconfig
172
173* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
174- rebuild with openssl-1.0.0c
175
176* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
177- new upstream release
178
179* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
180- new upstream release
181
182* Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
183- new upstream release
184
185* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
186- new upstream release
187
188* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
189- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.