source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 8773

Revision 8773, 4.7 KB checked in by miyabi, 10 years ago (diff)

new upstream release

RevLine 
[6961]1%define         base_name       hostapd
[8773]2%define         pkg_version     2.2
3%define         pkg_release     1%{?_dist_release}
[521]4
[6961]5Summary:        IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
6Summary(ja):    IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
7Name:           %{base_name}
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10Source0:        %{base_name}-%{version}.tar.gz
11Source1:        %{base_name}-init.sh
12Source2:        %{base_name}-%{version}.config
13Patch0:         %{base_name}-%{version}.patch
14License:        GPL2
15Group:          System Environment/Daemons
16URL:            http://hostap.epitest.fi/hostapd/
[521]17
[6961]18Requires:       openssl, libnl >= 1.1
19Requires(post): %{_syssbindir}/chkconfig
20Requires(preun): %{_syssbindir}/chkconfig
21BuildRequires:  openssl-devel, libnl-devel
22BuildRoot:      %{_tmppath}/%{base_name}-%{version}-root
[521]23
[6961]24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       miyabi
[2732]27
[521]28%description
[2732]29hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
30IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
31The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
[521]32
[6961]33%description -l ja
34hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
35IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
36最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
37
[521]38%prep
[6961]39%setup -q
[2653]40%patch0 -p1
[2732]41cp %{SOURCE1} .
[6961]42cp %{SOURCE2} ./%{base_name}/.config
[521]43
44%build
[6961]45cd %{base_name}
46%{__make} %{?_smp_mflags}
[521]47
48%install
[2732]49[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
50
[6961]51pushd %{base_name}
[521]52%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
[2732]53popd
[521]54
[6961]55mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
[2732]56
[6961]57install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
58
[521]59%post
[6961]60if ! /sbin/chkconfig %{base_name}; then
61  /sbin/chkconfig --add %{base_name}
[521]62fi
63
[6961]64if [ "$1" -eq "2" ]; then
65  %{_initdir}/%{base_name} condrestart
[2732]66fi
67
[521]68%preun
[6961]69if [ "$1" -eq "0" ]; then
70  %{_initdir}/%{base_name} stop
71  /sbin/chkconfig --del %{base_name}
[521]72fi
73
74%clean
[2732]75[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
[521]76
77%files
78%defattr(-, root, root)
[6961]79
80# Directory
81%dir %{_sysconfdir}/%{base_name}/
82
83# Program Files
84%attr(0755, root, root) %{_sbindir}/%{base_name}
[2732]85%attr(0755, root, root) %{_bindir}/hostapd_cli
[6961]86
87%attr(0755, root, root) %{_initdir}/%{base_name}
88
89# Config Files
[7751]90%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
[6961]91
92# Document Files
93%doc %{base_name}/ChangeLog COPYING README
94%{_mandir}/man8/%{base_name}.8.gz
[521]95%{_mandir}/man1/hostapd_cli.1.gz
96
97%changelog
[8773]98* Wed Jul 09 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.2-1
99- new upstream release
100
[8379]101* Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
102- add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
103  - fix segfault
104
[8305]105* Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
106- new upstream release
107- change .config
108  - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
109
[7751]110* Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
111- new upstream release
112- change filename hostapd.conf -> hostapd.conf.sample
113- change .config
114  - add WPS support
115
[7207]116* Sun Dec  2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
117- new upstream release
118
[6961]119* Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
120- new upstream release
121- add Summary(ja)
122- add section - %description -l ja
123- add parameter noreplace to %config
124- change spec file
[2732]125
[6961]126* Tue Oct  9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
127- add patch100 for fix CVE-2012-4445 (EPA-TLS message)
128
[2732]129* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
130- fix daemon script
131- change spec file
132- separation from patch file
133  - daemon script
134  - .config
135- add Source1 - hostapd-init.sh
136- add Source2 - hostapd-0.7.3.config
137- add Requires(post) - chkconfig
138- add Requires(preun) - chkconfig
139
[2653]140* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
141- rebuild with openssl-1.0.0c
142
[2732]143* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
144- new upstream release
145
146* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
147- new upstream release
148
[7751]149* Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
[2732]150- new upstream release
151
[521]152* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
153- new upstream release
154
155* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
156- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.