source: projects/specs/trunk/h/hostapd/hostapd-vl.spec @ 8379

Revision 8379, 4.7 KB checked in by miyabi, 10 years ago (diff)

add patch - fix segfault

RevLine 
[6961]1%define         base_name       hostapd
[8305]2%define         pkg_version     2.1
[8379]3%define         pkg_release     2%{?_dist_release}
[521]4
[6961]5Summary:        IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
6Summary(ja):    IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
7Name:           %{base_name}
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10Source0:        %{base_name}-%{version}.tar.gz
11Source1:        %{base_name}-init.sh
12Source2:        %{base_name}-%{version}.config
13Patch0:         %{base_name}-%{version}.patch
[8379]14Patch1:         %{base_name}-%{version}.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
[6961]15License:        GPL2
16Group:          System Environment/Daemons
17URL:            http://hostap.epitest.fi/hostapd/
[521]18
[6961]19Requires:       openssl, libnl >= 1.1
20Requires(post): %{_syssbindir}/chkconfig
21Requires(preun): %{_syssbindir}/chkconfig
22BuildRequires:  openssl-devel, libnl-devel
23BuildRoot:      %{_tmppath}/%{base_name}-%{version}-root
[521]24
[6961]25Vendor:         Project Vine
26Distribution:   Vine Linux
27Packager:       miyabi
[2732]28
[521]29%description
[2732]30hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
31IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
32The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
[521]33
[6961]34%description -l ja
35hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
36IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
37最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
38
[521]39%prep
[6961]40%setup -q
[2653]41%patch0 -p1
[8379]42%patch1 -p1
[2732]43cp %{SOURCE1} .
[6961]44cp %{SOURCE2} ./%{base_name}/.config
[521]45
46%build
[6961]47cd %{base_name}
48%{__make} %{?_smp_mflags}
[521]49
50%install
[2732]51[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
52
[6961]53pushd %{base_name}
[521]54%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
[2732]55popd
[521]56
[6961]57mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
[2732]58
[6961]59install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
60
[521]61%post
[6961]62if ! /sbin/chkconfig %{base_name}; then
63  /sbin/chkconfig --add %{base_name}
[521]64fi
65
[6961]66if [ "$1" -eq "2" ]; then
67  %{_initdir}/%{base_name} condrestart
[2732]68fi
69
[521]70%preun
[6961]71if [ "$1" -eq "0" ]; then
72  %{_initdir}/%{base_name} stop
73  /sbin/chkconfig --del %{base_name}
[521]74fi
75
76%clean
[2732]77[ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
[521]78
79%files
80%defattr(-, root, root)
[6961]81
82# Directory
83%dir %{_sysconfdir}/%{base_name}/
84
85# Program Files
86%attr(0755, root, root) %{_sbindir}/%{base_name}
[2732]87%attr(0755, root, root) %{_bindir}/hostapd_cli
[6961]88
89%attr(0755, root, root) %{_initdir}/%{base_name}
90
91# Config Files
[7751]92%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
[6961]93
94# Document Files
95%doc %{base_name}/ChangeLog COPYING README
96%{_mandir}/man8/%{base_name}.8.gz
[521]97%{_mandir}/man1/hostapd_cli.1.gz
98
99%changelog
[8379]100* Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
101- add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
102  - fix segfault
103
[8305]104* Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
105- new upstream release
106- change .config
107  - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
108
[7751]109* Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
110- new upstream release
111- change filename hostapd.conf -> hostapd.conf.sample
112- change .config
113  - add WPS support
114
[7207]115* Sun Dec  2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
116- new upstream release
117
[6961]118* Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
119- new upstream release
120- add Summary(ja)
121- add section - %description -l ja
122- add parameter noreplace to %config
123- change spec file
[2732]124
[6961]125* Tue Oct  9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
126- add patch100 for fix CVE-2012-4445 (EPA-TLS message)
127
[2732]128* Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
129- fix daemon script
130- change spec file
131- separation from patch file
132  - daemon script
133  - .config
134- add Source1 - hostapd-init.sh
135- add Source2 - hostapd-0.7.3.config
136- add Requires(post) - chkconfig
137- add Requires(preun) - chkconfig
138
[2653]139* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
140- rebuild with openssl-1.0.0c
141
[2732]142* Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
143- new upstream release
144
145* Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
146- new upstream release
147
[7751]148* Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
[2732]149- new upstream release
150
[521]151* Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
152- new upstream release
153
154* Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
155- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.