source: projects/specs/trunk/h/herqq/herqq-vl.spec @ 10547

Revision 10547, 2.9 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define _qt4_ver 4.8.0
2%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
3%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
4%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
5%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
6
7
8Name:           herqq
9Summary:        A software library for building UPnP devices and control points
10Version:        1.0.0
11Release:        5%{?_dist_release}
12
13# test application is GPLv3 but we do not ship it
14License:        LGPLv3+
15Group:          System Environment/Libraries
16URL:            http://herqq.org/
17
18Source0:        http://downloads.sourceforge.net/project/hupnp/hupnp/%{name}-%{version}.zip
19Patch2:         herqq-1.0.0-qtsoap-library.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires:  desktop-file-utils
23BuildRequires:  qt4-devel
24BuildRequires:  qtsoap-devel
25Requires: qt4 >= %{_qt4_version}
26
27%description
28Herqq UPnP (HUPnP) is a software library for building UPnP
29devices and control points conforming to the UPnP Device
30Architecture version 1.1.
31
32%package devel
33Summary:  Development files for %{name}
34Group:    Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: qt4-devel >= %{_qt4_version}
37
38%description devel
39Header files for developing applications using %{name}.
40
41%prep
42%setup -q
43# lQtSolutions to lqtsoap
44%patch2 -p1 -b .qtsoap-library
45
46%build
47# we have to disable bundled QtSOAP library
48qmake PREFIX=%{_prefix} -config DISABLE_QTSOAP \
49    -config DISABLE_TESTAPP -config USE_QT_INSTALL_LOC
50make %{?_smp_mflags}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54make INSTALL_ROOT=%{buildroot} install
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post -p /sbin/ldconfig
60
61%postun -p /sbin/ldconfig
62
63
64%files
65%doc hupnp/ChangeLog hupnp/LICENSE_LGPLv3.txt
66%{_qt4_libdir}/libHUpnp.so.1*
67
68%files devel
69%{_qt4_libdir}/libHUpnp.so
70%{_qt4_headerdir}/HUpnpCore/
71
72%changelog
73* Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-5
74- rebuild with gcc-5.4.0
75
76* Mon Oct 27 2014 Ryoiochi INAGAKI <ryo1@toki.waseda.jp> - 1.0.0-4
77- added Group tag
78- added %%clean section
79
80* Sun Jan  8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
81- rebuilt with qt-4.8.0
82
83* Sun Jul 31 2011 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
84- Initial build for Vine Linux
85
86* Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 1.0.0-1
87- post-review update to 1.0.0
88
89* Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-3
90- fix license to LGPLv3+
91- qt4 header dir for consistency
92- shlib soname tracked in %files
93- -devel should not duplicate COPYING
94
95* Tue Jul 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-2
96- qtsoap library
97- cleanup SPEC file
98
99* Tue Feb 22 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-1
100- Initial spec file
Note: See TracBrowser for help on using the repository browser.