source: projects/specs/trunk/h/help2man/help2man-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Supported build option:
2#
3# --with nls ... build this package with --enable-nls
4
5Name:           help2man
6Summary:        Create simple man pages from --help output
7Summary(ja):    --help の出力から簡単なマニュアルページを生成するツール
8Version:        1.36.4
9Release:        1%{?_dist_release}
10Group:          Development/Tools
11License:        GPLv2+
12URL:            http://www.gnu.org/software/help2man
13Source:         ftp://ftp.gnu.org/gnu/help2man/help2man-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16%{!?_with_nls:BuildArch: noarch}
17%{?_with_nls:BuildRequires: perl(Locale::gettext)}
18%{?_with_nls:Requires: perl(Locale::gettext)}
19
20Requires(post): /sbin/install-info
21Requires(preun): /sbin/install-info
22
23%description
24help2man is a script to create simple man pages from the --help and
25--version output of programs.
26
27Since most GNU documentation is now in info format, this provides a
28way to generate a placeholder man page pointing to that resource while
29still providing some useful information.
30
31%prep
32%setup -q -n help2man-%{version}
33iconv -f ISO-8859-1 -t utf-8 THANKS > THANKS~
34mv THANKS~ THANKS
35
36%build
37
38%configure %{!?_with_nls:--disable-nls}
39make %{?_smp_mflags}
40
41# Fix up manpage encoding
42for f in help2man.*.h2m; do
43  b=$(basename $f .h2m);
44  c=$(grep 'charset: ISO-*' $f | sed -e 's,^.*: ,,')
45  iconv -f $c -t utf-8 -o $b.1~ $b.1
46  mv $b.1~ $b.1
47done
48
49%install
50rm -fr $RPM_BUILD_ROOT
51make install DESTDIR=$RPM_BUILD_ROOT
52make install_l10n DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -fr $RPM_BUILD_ROOT
56
57%post
58/sbin/install-info %{_infodir}/help2man.info %{_infodir}/dir 2>/dev/null || :
59
60%preun
61if [ $1 -eq 0 ]; then
62  /sbin/install-info --delete %{_infodir}/help2man.info \
63    %{_infodir}/dir 2>/dev/null || :
64fi
65
66%files
67%defattr(-, root, root,-)
68%doc README NEWS THANKS
69%{_bindir}/help2man
70%{_infodir}/*
71%{_mandir}/man1/*
72
73%if "%{?_with_nls}"
74%{_libdir}/*.so
75%endif
76%lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/help2man.mo
77%lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/help2man.mo
78%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/help2man.mo
79%lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/help2man.mo
80%lang(pl) %{_mandir}/pl/man1/*
81%lang(fi) %{_mandir}/fi/man1/*
82%lang(fr) %{_mandir}/fr/man1/*
83%lang(sv) %{_mandir}/sv/man1/*
84
85%changelog
86* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.4-1
87- initial build for Vine Linux
88
89* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.36.4-2
90- Update license tag.
91- Convert THANKS to utf-8.
92
93* Tue Sep 05 2006 Ralf Corsépius <rc040203@freenet.de> - 1.36.4-1
94- Upstream update.
95- utf-8 encode l10n'd man pages.
96
97* Fri Dec 23 2005 Ralf Corsépius <rc04203@freenet.de> - 1.36.3-1
98- Upstream update.
99- Add build option --with nls.
100
101* Fri Dec 23 2005 Ralf Corsépius <rc04203@freenet.de> - 1.35.1-2
102- Fix disttag (#176473).
103- Cleanup spec.
104
105* Fri Apr 29 2005 Ralf Corsepius <ralf[AT]links2linux.de> - 1.35.1-1
106- Update to 1.35.1
107- Minor spec fixes.
Note: See TracBrowser for help on using the repository browser.