source: projects/specs/trunk/h/help2man/help2man-vl.spec @ 12121

Revision 12121, 4.9 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%global po_version 1.46.6
2
3Name:           help2man
4Summary:        Create simple man pages from --help output
5Summary(ja):    --help の出力から簡単なマニュアルページを生成するツール
6Version:        1.47.10
7Release:        1%{?_dist_release}
8Group:          Development/Tools
9License:        GPLv2+
10URL:            http://www.gnu.org/software/help2man
11Source:         ftp://ftp.gnu.org/gnu/help2man/help2man-%{version}.tar.xz
12Source1:        help2man-%{po_version}.ja.po
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Requires(post): /sbin/install-info
16Requires(preun): /sbin/install-info
17Requires:       perl-gettext
18BuildRequires:  perl-gettext
19Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke, yasumichi
24
25%description
26help2man is a script to create simple man pages from the --help and
27--version output of programs.
28
29Since most GNU documentation is now in info format, this provides a
30way to generate a placeholder man page pointing to that resource while
31still providing some useful information.
32
33%description -l ja
34help2man は、プログラムの --help および --version オプションの出力から
35簡単なマニュアルページを生成するスクリプトです。
36
37ほとんどの GNU 文書は現在 info 形式であるため、有益な情報が info で提供
38されていることを指し示すセクションをマニュアルページに生成する方法も
39提供しています。
40
41%prep
42%setup -q -n help2man-%{version}
43iconv -f ISO-8859-1 -t utf-8 THANKS > THANKS~
44mv THANKS~ THANKS
45%{__cp} %{SOURCE1} po/ja.po
46
47%build
48
49%configure
50make %{?_smp_mflags}
51
52# Fix up manpage encoding
53#for f in help2man.*.h2m; do
54#  b=$(basename $f .h2m);
55#  c=$(grep 'charset: ISO-*' $f | sed -e 's,^.*: ,,')
56#  iconv -f $c -t UTF-8 -o $b.1~ $b.1
57#  mv $b.1~ $b.1
58#done
59
60%install
61rm -fr $RPM_BUILD_ROOT
62make install DESTDIR=$RPM_BUILD_ROOT
63make install_l10n DESTDIR=$RPM_BUILD_ROOT
64
65%find_lang %{name}
66
67%clean
68rm -fr $RPM_BUILD_ROOT
69
70%post
71/sbin/install-info %{_infodir}/help2man.info %{_infodir}/dir 2>/dev/null || :
72
73%preun
74if [ $1 -eq 0 ]; then
75  /sbin/install-info --delete %{_infodir}/help2man.info \
76    %{_infodir}/dir 2>/dev/null || :
77fi
78
79%files -f %{name}.lang
80%defattr(-, root, root,-)
81%license COPYING
82%doc README NEWS THANKS
83%{_bindir}/help2man
84%{_infodir}/*
85%{_mandir}/man1/*
86%{_libdir}/help2man
87%lang(da) %{_mandir}/da/man1/*
88%lang(de) %{_mandir}/de/man1/*
89%lang(el) %{_mandir}/el/man1/*
90%lang(eo) %{_mandir}/eo/man1/*
91%lang(es) %{_mandir}/es/man1/*
92%lang(fi) %{_mandir}/fi/man1/*
93%lang(fr) %{_mandir}/fr/man1/*
94%lang(hr) %{_mandir}/hr/man1/*
95%lang(hu) %{_mandir}/hu/man1/*
96%lang(it) %{_mandir}/it/man1/*
97%lang(ja) %{_mandir}/ja/man1/*
98%lang(nb) %{_mandir}/nb/man1/*
99%lang(pl) %{_mandir}/pl/man1/*
100%lang(pt_BR) %{_mandir}/pt_BR/man1/*
101%lang(ru) %{_mandir}/ru/man1/*
102%lang(sr) %{_mandir}/sr/man1/*
103%lang(sv) %{_mandir}/sv/man1/*
104%lang(ta) %{_mandir}/ta/man1/*
105%lang(uk) %{_mandir}/uk/man1/*
106%lang(vi) %{_mandir}/vi/man1/*
107%lang(zh_CN) %{_mandir}/zh_CN/man1/*
108
109%changelog
110* Mon Aug 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.47.10-1
111- new upstream release.
112
113* Sat Jul 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.43.2-2
114- rebuild with VineSeed environment
115
116* Fri Jun 07 2013 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.43.2-1
117- new upstream release.
118
119* Tue May 31 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.40.1-1
120- new upstream release.(include Japanese locale)
121- delete Patch0. (fixed upstream)
122- translate description.
123
124* Fri May 06 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.39.2-3
125- add Patch0. (use gettext for format of strftime.)
126- update translation.
127
128* Tue May 03 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.39.2-3
129- update translation.(Fixed [JM:00259])
130
131* Wed Apr 27 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.39.2-2
132- update translation.(Fixed [VineSeed:23244])
133
134* Wed Apr 27 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.39.2-1
135- new upstream release.
136- add languages(de, el, eo, it, pt_BR, ru, uk, vi)
137- add Japanese translation.
138- stop to change encoding of manpages.
139- enable nls.
140- add Vendor, Distribution and Packager tag.
141
142* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.36.4-2
143- rebuilt with new environment
144
145* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.4-1
146- initial build for Vine Linux
147
148* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.36.4-2
149- Update license tag.
150- Convert THANKS to utf-8.
151
152* Tue Sep 05 2006 Ralf Corsépius <rc040203@freenet.de> - 1.36.4-1
153- Upstream update.
154- utf-8 encode l10n'd man pages.
155
156* Fri Dec 23 2005 Ralf Corsépius <rc04203@freenet.de> - 1.36.3-1
157- Upstream update.
158- Add build option --with nls.
159
160* Fri Dec 23 2005 Ralf Corsépius <rc04203@freenet.de> - 1.35.1-2
161- Fix disttag (#176473).
162- Cleanup spec.
163
164* Fri Apr 29 2005 Ralf Corsepius <ralf[AT]links2linux.de> - 1.35.1-1
165- Update to 1.35.1
166- Minor spec fixes.
Note: See TracBrowser for help on using the repository browser.