source: projects/specs/trunk/h/hdf5/hdf5-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: hdf5
2Version: 1.6.6
3Release: 2%{?_dist_release}
4Summary: A general purpose library and file format for storing scientific data
5License: BSD
6Group: System Environment/Libraries
7URL: http://www.hdfgroup.org/HDF5/
8Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
9Patch1: hdf5-1.6.4-destdir.patch
10Patch2: hdf5-1.6.4-norpath.patch
11Patch3: hdf5-1.6.6-tail.patch
12Patch5: hdf5-1.6.4-ppc.patch
13Patch7: hdf5-1.6.5-x86_64.patch
14Patch8: hdf5-1.6.5-sort.patch
15Patch10: hdf5-1.6.5-open.patch
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: openssl-devel, zlib-devel, gcc-gfortran, time
18
19%description
20HDF5 is a general purpose library and file format for storing scientific data.
21HDF5 can store two primary objects: datasets and groups. A dataset is
22essentially a multidimensional array of data elements, and a group is a
23structure for organizing objects in an HDF5 file. Using these two basic
24objects, one can create and store almost any kind of scientific data
25structure, such as images, arrays of vectors, and structured and unstructured
26grids. You can also mix and match them in HDF5 files according to your needs.
27
28%package devel
29Summary: HDF5 development files
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32
33%description devel
34HDF5 development headers and libraries.
35
36%prep
37%setup -q
38%patch1 -p1 -b .destdir
39%patch2 -p1 -b .norpath
40%patch3 -p1 -b .tail
41%patch5 -p1 -b .ppc
42%patch7 -p1 -b .x86_64
43%patch8 -p1 -b .sort
44%patch10 -p1 -b .open
45
46
47%build
48export CC=gcc
49export CXX=g++
50export F9X=gfortran
51%configure --with-ssl --enable-cxx --enable-fortran \
52           --enable-threadsafe --with-pthread
53make
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58find doc/html -type f | xargs chmod -x
59%makeinstall docdir=${RPM_BUILD_ROOT}%{_docdir}
60find doc/html -name Dependencies -o -name Makefile\* | xargs rm
61rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la $RPM_BUILD_ROOT/%{_libdir}/*.settings
62
63%check
64make check
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%post -p /sbin/ldconfig
71
72%postun -p /sbin/ldconfig
73
74
75%files
76%defattr(-,root,root,-)
77%doc COPYING MANIFEST README.txt release_docs/RELEASE.txt
78%doc release_docs/HISTORY.txt doc/html
79%{_bindir}/gif2h5
80%{_bindir}/h52gif
81%{_bindir}/h5debug
82%{_bindir}/h5diff
83%{_bindir}/h5dump
84%{_bindir}/h5import
85%{_bindir}/h5jam
86%{_bindir}/h5ls
87%{_bindir}/h5repack
88%{_bindir}/h5repart
89%{_bindir}/h5unjam
90%attr(0755,root,root) %{_libdir}/*.so.*
91
92%files devel
93%defattr(-,root,root,-)
94%{_bindir}/h5c++
95%{_bindir}/h5cc
96%{_bindir}/h5fc
97%{_bindir}/h5redeploy
98%{_docdir}/%{name}/
99%{_includedir}/*.h
100%{_libdir}/*.a
101%{_libdir}/*.so
102%{_libdir}/*.mod
103
104
105%changelog
106* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.6-2
107- applied new versioning policy
108
109* Thu Jan 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.6-1vl1
110- Removed krb5-devel from BuildRequires:
111- Rebuild for VineSeed
112
113* Wed Oct 17 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.6-1
114- Update to 1.6.6, drop upstreamed patches
115- Explicitly set compilers
116
117* Fri Aug 24 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-9
118- Update license tag to BSD
119- Rebuild for BuildID
120
121* Wed Aug  8 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-8
122- Fix memset typo
123- Pass mode to open with O_CREAT
124
125* Mon Feb 12 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-7
126- New project URL
127- Add patch to use POSIX sort key option
128- Remove useless and multilib conflicting Makefiles from html docs
129  (bug #228365)
130- Make hdf5-devel own %{_docdir}/%{name}
131
132* Tue Aug 29 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-6
133- Rebuild for FC6
134
135* Wed Mar 15 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-5
136- Change rpath patch to not need autoconf
137- Add patch for libtool on x86_64
138- Fix shared lib permissions
139
140* Mon Mar 13 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-4
141- Add patch to avoid HDF setting the compiler flags
142
143* Mon Feb 13 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-3
144- Rebuild for gcc/glibc changes
145
146* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-2
147- Don't ship h5perf with missing library
148
149* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-1
150- Update to 1.6.5
151
152* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-9
153- Rebuild
154
155* Wed Nov 30 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-8
156- Package fortran files properly
157- Move compiler wrappers to devel
158
159* Fri Nov 18 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-7
160- Add patch for fortran compilation on ppc
161
162* Wed Nov 16 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-6
163- Bump for new openssl
164
165* Tue Sep 20 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-5
166- Enable fortran since the gcc bug is now fixed
167
168* Tue Jul 05 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-4
169- Make example scripts executable
170
171* Wed Jul 01 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-3
172- Add --enable-threads --with-pthreads to configure
173- Add %check
174- Add some %docs
175- Use %makeinstall
176- Add patch to fix test for h5repack
177- Add patch to fix h5diff_attr.c
178
179* Mon Jun 27 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.4-2
180- remove szip from spec, since szip license doesn't meet Fedora standards
181
182* Sun Apr 3 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.4-1
183- inital package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.