source: projects/specs/trunk/h/hdf5/hdf5-vl.spec @ 12007

Revision 12007, 5.9 KB checked in by ara_t, 5 years ago (diff)

hdf5: rebuild with gfortran-8.2.0

Line 
1%define pkg_name    hdf5
2%define pkg_version 1.8.20
3%define pkg_release 2%{?_dist_release}
4
5Summary: A general purpose library and file format for storing scientific data
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD
11Group:   System Environment/Libraries
12URL:     http://www.hdfgroup.org/HDF5/
13
14Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.bz2
15# Source1: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}_docs.tar
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: zlib-devel, gcc-gfortran, time
19
20
21%description
22HDF5 is a general purpose library and file format for storing scientific data.
23HDF5 can store two primary objects: datasets and groups. A dataset is
24essentially a multidimensional array of data elements, and a group is a
25structure for organizing objects in an HDF5 file. Using these two basic
26objects, one can create and store almost any kind of scientific data
27structure, such as images, arrays of vectors, and structured and unstructured
28grids. You can also mix and match them in HDF5 files according to your needs.
29
30%package devel
31Summary: HDF5 development files
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
36HDF5 development headers and libraries.
37
38%package static
39Summary: HDF5 static libraries
40Group: Development/Libraries
41Requires: %{name}-devel = %{version}-%{release}
42
43%description static
44HDF5 static libraries.
45
46
47%prep
48%setup -q
49
50%build
51export CC=gcc
52export CXX=g++
53export F9X=gfortran
54%{configure} --with-ssl --enable-cxx --enable-fortran \
55             --disable-dependency-tracking \
56             --enable-hl --enable-shared
57%{__make} %{?_smp_mflags}
58
59%install
60%{__rm} -rf ${RPM_BUILD_ROOT}
61%{makeinstall} docdir=${RPM_BUILD_ROOT}%{_docdir}
62%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/*.la ${RPM_BUILD_ROOT}/%{_libdir}/*.settings
63
64%check
65%{__make} check
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70%post -p %{_syssbindir}/ldconfig
71
72%postun -p %{_syssbindir}/ldconfig
73
74
75%files
76%defattr(-,root,root,-)
77%doc COPYING MANIFEST README.txt release_docs/RELEASE.txt
78%doc release_docs/HISTORY*.txt
79%{_bindir}/gif2h5
80%{_bindir}/h52gif
81%{_bindir}/h5copy
82%{_bindir}/h5debug
83%{_bindir}/h5diff
84%{_bindir}/h5dump
85%{_bindir}/h5import
86%{_bindir}/h5jam
87%{_bindir}/h5ls
88%{_bindir}/h5mkgrp
89%{_bindir}/h5perf_serial
90%{_bindir}/h5repack
91%{_bindir}/h5repart
92%{_bindir}/h5stat
93%{_bindir}/h5unjam
94%attr(0755,root,root) %{_libdir}/*.so.*
95
96%files devel
97%defattr(-,root,root,-)
98%{_bindir}/h5c++
99%{_bindir}/h5cc
100%{_bindir}/h5fc
101%{_bindir}/h5redeploy
102%{_includedir}/*.h
103%{_libdir}/*.so
104%{_includedir}/*.mod
105%{_datadir}/hdf5_examples/
106
107%files static
108%defattr(-,root,root,-)
109%{_libdir}/*.a
110
111
112%changelog
113* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 1.8.20-2
114- rebuild with gfortran-8.2.0
115
116* Sat Jun 30 2018 Toshiaki Ara <ara_t@384.jp> 1.8.20-1
117- update to 1.8.20
118
119* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-2
120- rebuild with gcc-5.4.0
121
122* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
123- new upstream release
124
125* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-1
126- new upstream release
127
128* Wed Nov 30 2011 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.8-1
129- new upstream release
130- drop obsolete patches
131
132* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
133- new upstream release
134- drop Patch1,3,10
135- remove BuildRequires: openssl-devel
136
137* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.6-2
138- applied new versioning policy
139
140* Thu Jan 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.6-1vl1
141- Removed krb5-devel from BuildRequires:
142- Rebuild for VineSeed
143
144* Wed Oct 17 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.6-1
145- Update to 1.6.6, drop upstreamed patches
146- Explicitly set compilers
147
148* Fri Aug 24 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-9
149- Update license tag to BSD
150- Rebuild for BuildID
151
152* Wed Aug  8 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-8
153- Fix memset typo
154- Pass mode to open with O_CREAT
155
156* Mon Feb 12 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-7
157- New project URL
158- Add patch to use POSIX sort key option
159- Remove useless and multilib conflicting Makefiles from html docs
160  (bug #228365)
161- Make hdf5-devel own %{_docdir}/%{name}
162
163* Tue Aug 29 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-6
164- Rebuild for FC6
165
166* Wed Mar 15 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-5
167- Change rpath patch to not need autoconf
168- Add patch for libtool on x86_64
169- Fix shared lib permissions
170
171* Mon Mar 13 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-4
172- Add patch to avoid HDF setting the compiler flags
173
174* Mon Feb 13 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-3
175- Rebuild for gcc/glibc changes
176
177* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-2
178- Don't ship h5perf with missing library
179
180* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-1
181- Update to 1.6.5
182
183* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-9
184- Rebuild
185
186* Wed Nov 30 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-8
187- Package fortran files properly
188- Move compiler wrappers to devel
189
190* Fri Nov 18 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-7
191- Add patch for fortran compilation on ppc
192
193* Wed Nov 16 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-6
194- Bump for new openssl
195
196* Tue Sep 20 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-5
197- Enable fortran since the gcc bug is now fixed
198
199* Tue Jul 05 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-4
200- Make example scripts executable
201
202* Fri Jul 01 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-3
203- Add --enable-threads --with-pthreads to configure
204- Add %check
205- Add some %docs
206- Use %makeinstall
207- Add patch to fix test for h5repack
208- Add patch to fix h5diff_attr.c
209
210* Mon Jun 27 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.4-2
211- remove szip from spec, since szip license doesn't meet Fedora standards
212
213* Sun Apr 3 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.4-1
214- inital package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.