source: projects/specs/trunk/h/hdf5/hdf5-vl.spec @ 10570

Revision 10570, 5.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: hdf5
2Version: 1.8.14
3Release: 2%{?_dist_release}
4Summary: A general purpose library and file format for storing scientific data
5License: BSD
6Group: System Environment/Libraries
7URL: http://www.hdfgroup.org/HDF5/
8Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.bz2
9# Source1: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}_docs.tar
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: zlib-devel, gcc-gfortran, time
12
13%description
14HDF5 is a general purpose library and file format for storing scientific data.
15HDF5 can store two primary objects: datasets and groups. A dataset is
16essentially a multidimensional array of data elements, and a group is a
17structure for organizing objects in an HDF5 file. Using these two basic
18objects, one can create and store almost any kind of scientific data
19structure, such as images, arrays of vectors, and structured and unstructured
20grids. You can also mix and match them in HDF5 files according to your needs.
21
22%package devel
23Summary: HDF5 development files
24Group: Development/Libraries
25Requires: %{name} = %{version}-%{release}
26
27%description devel
28HDF5 development headers and libraries.
29
30%package static
31Summary: HDF5 static libraries
32Group: Development/Libraries
33Requires: %{name}-devel = %{version}-%{release}
34
35%description static
36HDF5 static libraries.
37
38%prep
39%setup -q
40
41
42%build
43export CC=gcc
44export CXX=g++
45export F9X=gfortran
46%configure --with-ssl --enable-cxx --enable-fortran \
47           --disable-dependency-tracking \
48           --enable-hl --enable-shared
49%{__make} %{?_smp_mflags}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%makeinstall docdir=${RPM_BUILD_ROOT}%{_docdir}
54rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la $RPM_BUILD_ROOT/%{_libdir}/*.settings
55
56%check
57make check
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62
63%post -p /sbin/ldconfig
64
65%postun -p /sbin/ldconfig
66
67
68%files
69%defattr(-,root,root,-)
70%doc COPYING MANIFEST README.txt release_docs/RELEASE.txt
71%doc release_docs/HISTORY*.txt
72%{_bindir}/gif2h5
73%{_bindir}/h52gif
74%{_bindir}/h5copy
75%{_bindir}/h5debug
76%{_bindir}/h5diff
77%{_bindir}/h5dump
78%{_bindir}/h5import
79%{_bindir}/h5jam
80%{_bindir}/h5ls
81%{_bindir}/h5mkgrp
82%{_bindir}/h5perf_serial
83%{_bindir}/h5repack
84%{_bindir}/h5repart
85%{_bindir}/h5stat
86%{_bindir}/h5unjam
87%attr(0755,root,root) %{_libdir}/*.so.*
88
89%files devel
90%defattr(-,root,root,-)
91%{_bindir}/h5c++
92%{_bindir}/h5cc
93%{_bindir}/h5fc
94%{_bindir}/h5redeploy
95%{_includedir}/*.h
96%{_libdir}/*.so
97%{_includedir}/*.mod
98%{_datadir}/hdf5_examples/
99
100%files static
101%defattr(-,root,root,-)
102%{_libdir}/*.a
103
104%changelog
105* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-2
106- rebuild with gcc-5.4.0
107
108* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
109- new upstream release
110
111* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-1
112- new upstream release
113
114* Wed Nov 30 2011 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.8-1
115- new upstream release
116- drop obsolete patches
117
118* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
119- new upstream release
120- drop Patch1,3,10
121- remove BuildRequires: openssl-devel
122
123* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.6-2
124- applied new versioning policy
125
126* Thu Jan 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.6-1vl1
127- Removed krb5-devel from BuildRequires:
128- Rebuild for VineSeed
129
130* Wed Oct 17 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.6-1
131- Update to 1.6.6, drop upstreamed patches
132- Explicitly set compilers
133
134* Fri Aug 24 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-9
135- Update license tag to BSD
136- Rebuild for BuildID
137
138* Wed Aug  8 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-8
139- Fix memset typo
140- Pass mode to open with O_CREAT
141
142* Mon Feb 12 2007 Orion Poplawski <orion@cora.nwra.com> 1.6.5-7
143- New project URL
144- Add patch to use POSIX sort key option
145- Remove useless and multilib conflicting Makefiles from html docs
146  (bug #228365)
147- Make hdf5-devel own %{_docdir}/%{name}
148
149* Tue Aug 29 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-6
150- Rebuild for FC6
151
152* Wed Mar 15 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-5
153- Change rpath patch to not need autoconf
154- Add patch for libtool on x86_64
155- Fix shared lib permissions
156
157* Mon Mar 13 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-4
158- Add patch to avoid HDF setting the compiler flags
159
160* Mon Feb 13 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-3
161- Rebuild for gcc/glibc changes
162
163* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-2
164- Don't ship h5perf with missing library
165
166* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-1
167- Update to 1.6.5
168
169* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-9
170- Rebuild
171
172* Wed Nov 30 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-8
173- Package fortran files properly
174- Move compiler wrappers to devel
175
176* Fri Nov 18 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-7
177- Add patch for fortran compilation on ppc
178
179* Wed Nov 16 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-6
180- Bump for new openssl
181
182* Tue Sep 20 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-5
183- Enable fortran since the gcc bug is now fixed
184
185* Tue Jul 05 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-4
186- Make example scripts executable
187
188* Fri Jul 01 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-3
189- Add --enable-threads --with-pthreads to configure
190- Add %check
191- Add some %docs
192- Use %makeinstall
193- Add patch to fix test for h5repack
194- Add patch to fix h5diff_attr.c
195
196* Mon Jun 27 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.4-2
197- remove szip from spec, since szip license doesn't meet Fedora standards
198
199* Sun Apr 3 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.4-1
200- inital package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.