source: projects/specs/trunk/h/hddtemp/hddtemp-vl.spec @ 12368

Revision 12368, 8.0 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

hddtemp-0.3-0.36.beta15

lshw-B.02.19.2-1

libndp-1.7-1

openssl-1.1.1f-1

smartmontools-7.1-1

Line 
1%bcond_with systemd
2
3%global _hardened_build 1
4%global beta    beta15
5
6Name:           hddtemp
7Version:        0.3
8Release:        0.36.%{beta}%{?_dist_release}%{?with_systemd:.systemd}
9Summary:        Hard disk temperature tool
10Summary(ja):    HDD温度測定ツール
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        GPLv2+
15URL:            http://savannah.nongnu.org/projects/hddtemp/
16Source0:        http://download.savannah.nongnu.org/releases/hddtemp/%{name}-%{version}-%{beta}.tar.bz2
17Source1:        %{name}.db
18Source2:        %{name}.service
19Source3:        %{name}.sysconfig
20Source4:        %{name}.pam
21Source5:        %{name}.consoleapp
22
23Patch0:         0001-Try-attribute-190-if-194-doesn-t-exist.patch
24Patch1:         http://ftp.debian.org/debian/pool/main/h/hddtemp/hddtemp_0.3-beta15-52.diff.gz
25# https://bugzilla.redhat.com/show_bug.cgi?id=717479
26# https://bugzilla.redhat.com/show_bug.cgi?id=710055
27Patch2:         %{name}-0.3-beta15-autodetect-717479.patch
28Patch3:         0001-Allow-binding-to-a-listen-address-that-doesn-t-exist.patch
29Patch4:         fix-model-length.patch
30# https://bugzilla.redhat.com/show_bug.cgi?id=1555871
31Patch5:         %{name}-user-context-type.patch
32
33BuildRequires:  gettext
34%if %{with systemd}
35# systemd >= 186 for scriptlet macros
36BuildRequires:  systemd >= 186
37Requires(post): systemd
38Requires(preun): systemd
39Requires(postun): systemd
40Requires:       %{_bindir}/consolehelper
41%endif
42
43%description
44hddtemp is a tool that gives you the temperature of your hard drive by
45reading S.M.A.R.T. information.
46
47%description -l ja
48 hddtempは、S.M.A.R.T.情報を読み取りHDD温度を出力します。
49
50
51%prep
52%setup -q -n %{name}-%{version}-%{beta}
53
54%patch1 -p1
55%patch2 -p1
56%patch3 -p1
57%patch0 -p1
58%patch4 -p1
59%patch5 -p1
60
61sed -i -e 's|/etc/hddtemp.db|/usr/share/misc/hddtemp.db|' doc/hddtemp.8
62chmod -x contribs/analyze/*
63rm COPYING ; cp -p GPL-2 COPYING
64cp -p debian/changelog changelog.debian
65
66
67%build
68%configure --disable-dependency-tracking
69make %{?_smp_mflags}
70
71
72%install
73make install DESTDIR=$RPM_BUILD_ROOT
74install -Dpm 644 %{SOURCE1} $RPM_BUILD_ROOT/usr/share/misc/hddtemp.db
75%if %{with systemd}
76install -Dpm 644 %{SOURCE2} $RPM_BUILD_ROOT%{_unitdir}/hddtemp.service
77%endif
78install -Dpm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/hddtemp
79install -dm 755 $RPM_BUILD_ROOT%{_bindir}
80ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/hddtemp
81install -Dpm 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/hddtemp
82install -Dpm 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/hddtemp
83%find_lang %{name}
84
85%if %{with systemd}
86
87%post
88%systemd_post hddtemp.service
89
90%preun
91%systemd_preun hddtemp.service
92
93%postun
94%systemd_postun_with_restart hddtemp.service
95
96%endif
97
98%files -f %{name}.lang
99%license COPYING
100%doc ChangeLog changelog.debian README TODO contribs/
101%config(noreplace) %{_sysconfdir}/sysconfig/hddtemp
102%config(noreplace) %{_sysconfdir}/pam.d/hddtemp
103%config(noreplace) %{_sysconfdir}/security/console.apps/hddtemp
104%if %{with systemd}
105%{_unitdir}/hddtemp.service
106%endif
107%{_bindir}/hddtemp
108%{_sbindir}/hddtemp
109%config(noreplace) /usr/share/misc/hddtemp.db
110%{_mandir}/man8/hddtemp.8*
111
112
113%changelog
114* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3-0.36.beta15
115- imported Patch5 from rawhide.
116
117* Sun Apr 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3-0.35.beta15
118- initial build for Vine Linux.
119
120* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.34.beta15
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
122
123* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.33.beta15
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
125
126* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.32.beta15
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
128
129* Fri Mar 07 2014 Jaromir Capik <jcapik@redhat.com> - 0.3-0.31.beta15
130- Fixing the model string size [24 -> 40] (#1061649)
131
132* Sat Jan 18 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.30.beta15
133- Improve comments in database (#1054593, Edward Kuns).
134
135* Sat Jan 18 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.29.beta15
136- Patch to try attribute 190 if 194 doesn't exist for defaults (#1054593).
137- Trim down database to just entries not covered by defaults.
138- Add some Samsung SSD's lacking a sensor to the database.
139
140* Thu Jan  9 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.28.beta15
141- Patch to allow binding to a listen address that doesn't exist yet.
142- Use systemd macros in scriptlets (#850145).
143
144* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.27.beta15
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
146
147* Fri Jan 25 2013 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.26.beta15
148- Drop obsolete After=syslog.target from systemd unit, add Documentation.
149- Drop obsolete sysv to systemd migration scriptlets.
150- Drop obsolete specfile constructs.
151- Update Debian patch set to 0.3-beta15-52.
152
153* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.25.beta15
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
155
156* Mon Apr 23 2012 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.23.beta15
157- Build with hardening flags on.
158
159* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.23.beta15
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
161
162* Thu Aug 18 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.22.beta15
163- Migrate to systemd, patch to glob usual device names w/o arguments (#717479).
164- Update Debian patch set to 0.3-beta15-48, ship its changelog in docs.
165
166* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.21.beta15
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
168
169* Sun Feb 14 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.20.beta15
170- Patch to fix ix86 build if sys/ucontext.h is pulled in by signal.h (#564857).
171
172* Thu Aug 20 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.19.beta15
173- Try to start daemon for all disks if none are specified in sysconfig.
174- Update URLs.
175
176* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.18.beta15
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
178
179* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.17.beta15
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
181
182* Wed Oct  1 2008 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.16.beta15
183- Sync with Debian's 0.3-beta15-45 for a fix for undesired spin-ups with
184  most current drives (#464912).
185
186* Sat Feb  9 2008 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.15.beta15
187- Sync with Debian's 0.3-beta15-38.
188- Update drive database to 2007-09-14.
189- Trim pre-2006 changelog entries.
190
191* Wed Sep  5 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.14.beta15
192- Adjust server chkconfig start/stop priorities to start before gkrellmd,
193  other cosmetic init script tweaks.
194- Mark hddtemp.db as %%config(noreplace).
195
196* Mon Aug  6 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.13.beta15
197- License: GPLv2+
198
199* Tue Jul 10 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.12.beta15
200- Improve init script LSB compliance.
201
202* Tue Jan  9 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.11.beta15
203- SATA sense fix (#221100, Jens Axboe).
204
205* Sun Dec 31 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.10.beta15
206- Apply patches from Debian containing bunch of hddtemp.db updates and
207  guess mode improvements for drives not in the database.
208
209* Wed Aug 30 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.9.beta15
210- Rebuild.
211
212* Wed May  3 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.8.beta15
213- 0.3-beta15, drive database 2006-04-26.
214- Specfile cleanups.
215
216* Wed Feb  8 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.8.beta14
217- Update drive database to 2006-02-07.
218
219* Wed Jan 18 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.7.beta14
220- Update drive database to 2006-01-18.
221- Init script is not a config file.
222- Mark console.perms snippet as noreplace.
Note: See TracBrowser for help on using the repository browser.