source: projects/specs/trunk/h/hddtemp/hddtemp-vl.spec @ 10196

Revision 10196, 7.7 KB checked in by tomop, 8 years ago (diff)

hddtemp-0.3-0.35.beta15

Line 
1%bcond_with systemd
2
3%global _hardened_build 1
4%global beta    beta15
5
6Name:           hddtemp
7Version:        0.3
8Release:        0.35.%{beta}%{?_dist_release}
9Summary:        Hard disk temperature tool
10Summary(ja):    HDD温度測定ツール
11License:        GPLv2+
12URL:            http://savannah.nongnu.org/projects/hddtemp/
13
14Source0:        http://download.savannah.nongnu.org/releases/hddtemp/%{name}-%{version}-%{beta}.tar.bz2
15Source1:        %{name}.db
16Source2:        %{name}.service
17Source3:        %{name}.sysconfig
18Source4:        %{name}.pam
19Source5:        %{name}.consoleapp
20
21Patch0:         0001-Try-attribute-190-if-194-doesn-t-exist.patch
22Patch1:         http://ftp.debian.org/debian/pool/main/h/hddtemp/hddtemp_0.3-beta15-52.diff.gz
23# https://bugzilla.redhat.com/show_bug.cgi?id=717479
24# https://bugzilla.redhat.com/show_bug.cgi?id=710055
25Patch2:         %{name}-0.3-beta15-autodetect-717479.patch
26Patch3:         0001-Allow-binding-to-a-listen-address-that-doesn-t-exist.patch
27Patch4:         fix-model-length.patch
28
29BuildRequires:  gettext
30%if %{with systemd}
31# systemd >= 186 for scriptlet macros
32BuildRequires:  systemd >= 186
33Requires(post): systemd
34Requires(preun): systemd
35Requires(postun): systemd
36Requires:       %{_bindir}/consolehelper
37%endif
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: tomop
42
43%description
44hddtemp is a tool that gives you the temperature of your hard drive by
45reading S.M.A.R.T. information.
46
47%description -l ja
48 hddtempは、S.M.A.R.T.情報を読み取りHDD温度を出力します。
49
50
51%prep
52%setup -q -n %{name}-%{version}-%{beta}
53
54%patch1 -p1
55%patch2 -p1
56%patch3 -p1
57%patch0 -p1
58%patch4 -p1
59
60sed -i -e 's|/etc/hddtemp.db|/usr/share/misc/hddtemp.db|' doc/hddtemp.8
61chmod -x contribs/analyze/*
62rm COPYING ; cp -p GPL-2 COPYING
63cp -p debian/changelog changelog.debian
64
65
66%build
67%configure --disable-dependency-tracking
68make %{?_smp_mflags}
69
70
71%install
72make install DESTDIR=$RPM_BUILD_ROOT
73install -Dpm 644 %{SOURCE1} $RPM_BUILD_ROOT/usr/share/misc/hddtemp.db
74%if %{with systemd}
75#install -Dpm 644 %{SOURCE2} $RPM_BUILD_ROOT%{_unitdir}/hddtemp.service
76%endif
77install -Dpm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/hddtemp
78install -dm 755 $RPM_BUILD_ROOT%{_bindir}
79ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/hddtemp
80install -Dpm 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/hddtemp
81install -Dpm 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/hddtemp
82%find_lang %{name}
83
84%if %{with systemd}
85
86%post
87%systemd_post hddtemp.service
88
89%preun
90%systemd_preun hddtemp.service
91
92%postun
93%systemd_postun_with_restart hddtemp.service
94
95%endif
96
97%files -f %{name}.lang
98%doc ChangeLog changelog.debian COPYING README TODO contribs/
99%config(noreplace) %{_sysconfdir}/sysconfig/hddtemp
100%config(noreplace) %{_sysconfdir}/pam.d/hddtemp
101%config(noreplace) %{_sysconfdir}/security/console.apps/hddtemp
102%if %{with systemd}
103%{_unitdir}/hddtemp.service
104%endif
105%{_bindir}/hddtemp
106%{_sbindir}/hddtemp
107%config(noreplace) /usr/share/misc/hddtemp.db
108%{_mandir}/man8/hddtemp.8*
109
110
111%changelog
112* Sun Apr 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3-0.35.beta15
113- initial build for Vine Linux.
114
115* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.34.beta15
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
117
118* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.33.beta15
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
120
121* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.32.beta15
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
123
124* Fri Mar 07 2014 Jaromir Capik <jcapik@redhat.com> - 0.3-0.31.beta15
125- Fixing the model string size [24 -> 40] (#1061649)
126
127* Sat Jan 18 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.30.beta15
128- Improve comments in database (#1054593, Edward Kuns).
129
130* Sat Jan 18 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.29.beta15
131- Patch to try attribute 190 if 194 doesn't exist for defaults (#1054593).
132- Trim down database to just entries not covered by defaults.
133- Add some Samsung SSD's lacking a sensor to the database.
134
135* Thu Jan  9 2014 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.28.beta15
136- Patch to allow binding to a listen address that doesn't exist yet.
137- Use systemd macros in scriptlets (#850145).
138
139* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.27.beta15
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
141
142* Fri Jan 25 2013 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.26.beta15
143- Drop obsolete After=syslog.target from systemd unit, add Documentation.
144- Drop obsolete sysv to systemd migration scriptlets.
145- Drop obsolete specfile constructs.
146- Update Debian patch set to 0.3-beta15-52.
147
148* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.25.beta15
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
150
151* Mon Apr 23 2012 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.23.beta15
152- Build with hardening flags on.
153
154* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.23.beta15
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
156
157* Thu Aug 18 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.22.beta15
158- Migrate to systemd, patch to glob usual device names w/o arguments (#717479).
159- Update Debian patch set to 0.3-beta15-48, ship its changelog in docs.
160
161* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.21.beta15
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
163
164* Sun Feb 14 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.20.beta15
165- Patch to fix ix86 build if sys/ucontext.h is pulled in by signal.h (#564857).
166
167* Thu Aug 20 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.19.beta15
168- Try to start daemon for all disks if none are specified in sysconfig.
169- Update URLs.
170
171* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.18.beta15
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
173
174* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-0.17.beta15
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
176
177* Wed Oct  1 2008 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.16.beta15
178- Sync with Debian's 0.3-beta15-45 for a fix for undesired spin-ups with
179  most current drives (#464912).
180
181* Sat Feb  9 2008 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.15.beta15
182- Sync with Debian's 0.3-beta15-38.
183- Update drive database to 2007-09-14.
184- Trim pre-2006 changelog entries.
185
186* Wed Sep  5 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.14.beta15
187- Adjust server chkconfig start/stop priorities to start before gkrellmd,
188  other cosmetic init script tweaks.
189- Mark hddtemp.db as %%config(noreplace).
190
191* Mon Aug  6 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.13.beta15
192- License: GPLv2+
193
194* Tue Jul 10 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.12.beta15
195- Improve init script LSB compliance.
196
197* Tue Jan  9 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.11.beta15
198- SATA sense fix (#221100, Jens Axboe).
199
200* Sun Dec 31 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.10.beta15
201- Apply patches from Debian containing bunch of hddtemp.db updates and
202  guess mode improvements for drives not in the database.
203
204* Wed Aug 30 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.9.beta15
205- Rebuild.
206
207* Wed May  3 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.8.beta15
208- 0.3-beta15, drive database 2006-04-26.
209- Specfile cleanups.
210
211* Wed Feb  8 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.8.beta14
212- Update drive database to 2006-02-07.
213
214* Wed Jan 18 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.3-0.7.beta14
215- Update drive database to 2006-01-18.
216- Init script is not a config file.
217- Mark console.perms snippet as noreplace.
Note: See TracBrowser for help on using the repository browser.