source: projects/specs/trunk/h/havp/havp.spec @ 8162

Revision 8162, 4.0 KB checked in by tomop, 10 years ago (diff)

updated many packages.

  • Property svn:executable set to *
Line 
1%define clamav_version 0.96
2
3Summary: HAVP - HTTP Anti Virus Proxy
4Name: havp
5Version: 0.92a
6Release: 2%{_dist_release}
7License: GPL
8Group: Applications/System
9URL: http://www.server-side.de/
10Source0: http://www.server-side.de/download/havp-%{version}.tar.gz
11Patch0: havp.patch
12BuildRequires: libstdc++-devel, zlib-devel, bzip2-devel, gmp-devel
13BuildRequires: clamav-devel => %{clamav_version}
14BuildRoot: %{_tmppath}/%{name}-%{version}-root/
15#Requires: libstdc++, zlib, bzip2, gmp
16Requires: clamav => %{clamav_version}
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: tomop
20
21
22%description
23HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
24It does not cache or filter content. At the moment the complete
25traffic is scanned. The reason for this is the chance of malicious
26code in nearly every filetype e.g. HTML (JavaScript) or Jpeg. I aim
27to stop especially dialer or browser exploits. But writing a http
28Anti Virus Proxy is a real dilemma! Huge downloads are a problem
29for virus scanning proxies. A Client should not receive data which
30is unchecked by the virus scanner, but big downloads should not timeout.
31
32%prep
33
34%setup -q
35%patch0 -p0
36#%patch1 -p1
37
38%build
39%configure --with-scanner=libclamav --enable-ssl-tunnel
40make %{?_smp_mflags}
41
42%install
43rm -rf %{buildroot}
44mkdir -p %{buildroot}%{_sbindir}
45mkdir -p %{buildroot}%{_sysconfdir}/havp/templates
46mkdir -p %{buildroot}%{_localstatedir}/log/havp
47mkdir -p %{buildroot}%{_localstatedir}/tmp/havp
48mkdir -p %{buildroot}%{_localstatedir}/run/havp
49mkdir -p %{buildroot}%{_initdir}
50
51install -m755 havp/havp %{buildroot}%{_sbindir}
52install -m755 etc/init.d/havp %{buildroot}%{_initdir}
53install -m644 etc/havp/havp.config %{buildroot}%{_sysconfdir}/havp/havp.config
54install -m644 etc/havp/whitelist %{buildroot}%{_sysconfdir}/havp/whitelist
55install -m644 etc/havp/blacklist %{buildroot}%{_sysconfdir}/havp/blacklist
56cp -r etc/havp/templates/* %{buildroot}%{_sysconfdir}/havp/templates
57chmod -R a+rX %{buildroot}/etc/havp/templates
58
59%clean
60rm -rf %{buildroot}
61
62%pre
63if ! grep -q '^havp:' /etc/group; then
64    /usr/sbin/groupadd -r havp
65fi
66if ! grep -q '^havp:' /etc/passwd; then
67    /usr/sbin/useradd -M -r -s /sbin/nologin -g havp havp || :
68fi
69
70%postun
71/sbin/ldconfig
72if [ $1 = 0 ]; then
73    if [ `grep havp /etc/passwd | wc -l` = 1 ]; then
74        /usr/sbin/userdel havp
75    fi
76    if [ `grep havp /etc/group | wc -l` = 1 ]; then
77        /usr/sbin/groupdel havp
78    fi
79fi
80
81%post -p /sbin/ldconfig
82
83%files
84%defattr(-,root,root,-)
85%doc INSTALL COPYING ChangeLog
86%{_initdir}/havp
87%{_sbindir}/havp
88%config(noreplace) %{_sysconfdir}/havp/havp.config
89%config(noreplace) %{_sysconfdir}/havp/whitelist
90%config(noreplace) %{_sysconfdir}/havp/blacklist
91%{_sysconfdir}/havp/templates/*
92%attr(750,havp,havp) %dir /var/log/havp
93%attr(750,havp,havp) %dir /var/tmp/havp
94%attr(750,havp,havp) %dir /var/run/havp
95
96%changelog
97* Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-2
98- rebuilt with current environment.
99
100* Sun Dec 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-1
101- new upstream release.
102
103* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92-1
104- new upstream release.
105
106* Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.90-1
107- new upstream release.
108
109* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.89-1
110- new upstream release.
111- built with clamav-0.95.
112
113* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-2
114- rebuild with clamav-0.93.
115
116* Mon Apr 14 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-1
117- rebuilt with VineSeed.
118
119* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-0vl1
120- new upstream release.
121
122* Sun Mar 11 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl2
123- built with clamav-0.90.1.
124
125* Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl1
126- new upstream release.
127
128* Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.82-0vl1
129- new upstream release.
130
131* Thu Jul 20 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.81-0vl1
132- initial build.
Note: See TracBrowser for help on using the repository browser.