source: projects/specs/trunk/h/haveged/haveged-vl.spec @ 12362

Revision 12362, 6.1 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

haveged-1.9.8-2

irqbalance-1.4.0-1

libtdb-1.4.3-1

samba-4.12.0-1

Line 
1Summary:        A Linux entropy source using the HAVEGE algorithm
2Summary(ja):    HAVEFE アルゴリズムを使った Linux のエントロピーソース
3Name:           haveged
4Version:        1.9.8
5Release:        2%{?_dist_release}
6Group:          System Environment/Daemons
7Vendor:         Project Vine
8Distribution:   Vine Linux
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
10
11License:        GPLv3+
12URL:            https://github.com/jirka-h/haveged
13Source0:        https://github.com/jirka-h/haveged/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14
15Requires(post):   chkconfig
16Requires(preun):  chkconfig, initscripts
17Requires(postun): initscripts
18
19BuildRequires:  automake gdb coreutils glibc-common
20
21%{!?_unitdir:%global _unitdir /lib/systemd/system}
22%{!?_userunitdir:%global _userunitdir /usr/lib/systemd/user}
23
24%description
25A Linux entropy source using the HAVEGE algorithm
26
27Haveged is a user space entropy daemon which is not dependent upon the
28standard mechanisms for harvesting randomness for the system entropy
29pool. This is important in systems with high entropy needs or limited
30user interaction (e.g. headless servers).
31 
32Haveged uses HAVEGE (HArdware Volatile Entropy Gathering and Expansion)
33to maintain a 1M pool of random bytes used to fill /dev/random
34whenever the supply of random bits in /dev/random falls below the low
35water mark of the device. The principle inputs to haveged are the
36sizes of the processor instruction and data caches used to setup the
37HAVEGE collector. The haveged default is a 4kb data cache and a 16kb
38instruction cache. On machines with a cpuid instruction, haveged will
39attempt to select appropriate values from internal tables.
40
41%package devel
42Summary:   Headers and shared development libraries for HAVEGE algorithm
43Summary(ja):   Headers and shared development libraries for HAVEGE algorithm
44Group:     Development/Libraries
45Requires:  %{name} = %{version}-%{release}
46
47%description devel
48Headers and shared object symbolic links for the HAVEGE algorithm
49
50%prep
51%setup -q
52
53%build
54#autoreconf -fiv
55
56%configure --enable-init=sysv.redhat
57
58#SMP build is not working
59#make %{?_smp_mflags}
60make
61
62%check
63make check
64
65
66%install
67rm -rf %{buildroot}
68make install DESTDIR=%{buildroot} INSTALL="install -p"
69
70chmod 0644 COPYING README ChangeLog AUTHORS
71
72# We don't ship .la files.
73rm -rf %{buildroot}%{_libdir}/libhavege.*a
74
75install -Dpm 0644 init.d/service.fedora %{buildroot}%{_unitdir}/%{name}.service
76
77
78%clean
79rm -rf %{buildroot}
80
81%post
82/sbin/chkconfig --add haveged
83
84%preun
85if [ "$1" -eq "0" ]; then
86  /sbin/service haveged stop >/dev/null 2>&1
87  /sbin/chkconfig --del haveged
88fi
89
90%postun
91if [ "$1" -ge "1" ]; then
92  /sbin/service haveged condrestart >/dev/null 2>&1
93fi
94
95%files
96%defattr(-, root, root, -)
97%license COPYING
98%doc README ChangeLog AUTHORS contrib/build/havege_sample.c
99%{_mandir}/man8/haveged.8*
100%{_sbindir}/haveged
101%{_libdir}/*so.*
102%{_sysconfdir}/init.d/haveged
103%dir /lib/systemd
104%dir %{_unitdir}
105%{_unitdir}/haveged.service
106
107%files devel
108%defattr(-, root, root, -)
109%{_mandir}/man3/libhavege.3*
110%dir %{_includedir}/%{name}
111%{_includedir}/%{name}/havege.h
112%{_libdir}/*.so
113
114
115%changelog
116* Mon Mar 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.8-2
117- added a .service file for systemd.
118
119* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.8-1
120- new upstream release.
121
122* Sat Jul 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.1-1
123- new upstream release.
124
125* Sun Mar 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7a-1
126- update to 1.7a
127
128* Sat Mar 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-1
129- initial build for Vine Linux
130
131* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-1
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
133
134* Sat Jan 19 2013 Jirka Hladky <hladky.jiri@gmail.com> - 1.7-0
135- Updated to the version 1.7
136- Version 1.7 brings developement libraries
137- Added devel package
138* Sat Oct 13 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-2
139- BZ 850144
140- Introduce new systemd-rpm macros in haveged spec file
141- Fedora 19 changes the way how to work with services in spec files.
142- It introduces new macros - systemd_post, systemd_preun and systemd_postun;
143- which replace scriptlets from Fedora 18 and older
144- see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
145
146* Tue Aug 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-1
147- Update to the version 1.5
148- Main new feature is a run time verification of the produced random numbers
149- PIDFILE set to /run/haveged.pid
150- converted README and man page to UTF-8. Informed the upstream to fix it.
151* Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-3
152- PIDFile should be stored at /run instead of the default location /var/run
153- There is  long term plan that directory /var/run will not further exist in the future Fedora versions
154- Asked upstream to add -p <PID_FILE_location> switch to influence the location of the PID File
155- Set PIDFile=/var/run/haveged.pid This is needed as long -p option is not implemented
156- https://bugzilla.redhat.com/show_bug.cgi?id=770306#c10
157* Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-2
158- Updated systemd service file, https://bugzilla.redhat.com/show_bug.cgi?id=770306
159* Tue Feb 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-1
160- Update to the version 1.4
161- Conversion to systemd, drop init script
162* Sun Nov 06 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-2
163- Fixed a bug on non x86 systems
164* Sat Nov 05 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-1
165- update from the upstream (1.3 stable)
166* Mon Oct 03 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-0
167-version 1.3 beta
168* Fri Sep 30 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-4
169- ppc64 build
170* Mon Sep 26 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-3
171- Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c11
172* Sat Sep 24 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-2
173- Added comment to explain why we need use Fedora specific start script
174* Wed Sep 21 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-1
175- Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c1
176* Wed Sep 07 2011  Jirka Hladky <hladky.jiri@gmail.com> - 1.2-0
177- Initial build
Note: See TracBrowser for help on using the repository browser.