source: projects/specs/trunk/h/hal/hal-vl.spec @ 5356

Revision 5356, 19.2 KB checked in by Takemikaduchi, 12 years ago (diff)

parted-3.0

Line 
1%define expat_version           1.95.5
2%define glib2_version           2.20.0
3%define dbus_version            1.2
4%define dbus_glib_version       0.80
5%define dbus_python_version     0.80
6%define pygtk2_version          2.8.0
7%define gnome_python            2.14.0
8%define udev_version            145
9%define util_linux_ng_version   2.14
10%define gettext_version         0.14.5
11%define libusb_version          0.1.10a
12%define consolekit_version      0.3.0
13%define acl_version             2.2.39
14%define policykit_version       0.9
15%define pciutils_version        2.2.1
16%define dmidecode_version       2.7
17%define gperf_version           3.0.1
18# %define parted_version                1.8.8
19%define parted_version          3.0
20
21%define hal_user_uid           68
22
23%define _localstatedir %{_var}
24
25Summary: Hardware Abstraction Layer
26Summary(ja): ハードウエア抽象化レイヤ
27Name: hal
28Version: 0.5.14
29Release: 2%{?_dist_release}
30
31Group: System Environment/Libraries
32URL: http://www.freedesktop.org/Software/hal
33License: AFL/GPL
34
35Source0: %{name}-%{version}.tar.bz2
36
37Patch0: hal-0.5.14-videodev.patch
38
39Patch2: hal-0.5.11-change-priority.patch
40
41# https://bugzilla.redhat.com/show_bug.cgi?id=488177
42Patch4: hal-remove-dell-killswitch.patch
43
44# http://lists.freedesktop.org/archives/hal/2009-March/013125.html
45Patch9: hal-KVM-evdev.patch
46
47# http://bugs.freedesktop.org/show_bug.cgi?id=22442
48Patch11: hal-HDAPS-blacklist.patch
49
50Patch100: hal-use-at-console.patch
51
52Patch200: hal-0.5.13-disable-keyboard-hotplug.patch
53
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: expat-devel >= %{expat_version}
56BuildRequires: glib2-devel >= %{glib2_version}
57BuildRequires: dbus-devel  >= %{dbus_version}
58BuildRequires: python-devel
59BuildRequires: hwdata
60BuildRequires: gettext >= %{gettext_version}
61%ifnarch s390 s390x
62BuildRequires: libusb-devel >= %{libusb_version}
63%endif
64BuildRequires: desktop-file-utils >= 0.9
65BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
66BuildRequires: pciutils-devel >= %{pciutils_version}
67BuildRequires: zlib-devel
68BuildRequires: gperf >= %{gperf_version}
69BuildRequires: parted-devel >= %{parted_version}
70BuildRequires: e2fsprogs-devel
71BuildRequires: libblkid-devel
72BuildRequires: libuuid-devel
73
74Requires: dbus >= %{dbus_version}
75Requires: dbus-glib >= %{dbus_glib_version}
76Requires: glib2 >= %{glib2_version}
77Requires: udev >= %{udev_version}
78Requires: util-linux-ng >= %{util_linux_ng_version}
79%ifnarch s390 s390x
80Requires: libusb >= %{libusb_version}
81%endif
82Requires: ConsoleKit >= %{consolekit_version}
83Requires: acl >= %{acl_version}
84Requires: hal-info
85Requires(pre): shadow-utils
86Requires(post): chkconfig
87Requires(preun): chkconfig, initscripts
88
89Obsoletes: hal-gnome
90
91%description
92HAL is daemon for collection and maintaining information from several
93sources about the hardware on the system. It provdes a live device
94list through D-BUS.
95
96%package gnome
97Summary: GNOME based device manager for HAL
98Group: Applications/System
99Requires: %name = %{version}-%{release}
100Requires: dbus-python >= %{dbus_python_version}
101Requires: pygtk2 >= %{pygtk2_version}
102Requires: pygtk2-libglade >= %{pygtk2_version}
103Requires: gnome-python >= %{gnome_python}
104
105%description gnome
106GNOME program for displaying the devices detected by HAL
107
108
109%package devel
110Summary: Libraries and headers for HAL
111Group: Development/Libraries
112Requires: %{name} = %{version}-%{release}
113Requires: dbus-devel >= %{dbus_version}
114
115%description devel
116Headers, static libraries and API docs for HAL.
117
118
119%prep
120%setup -q -n %{name}-%{version}
121%patch0 -p1 -b .videodev
122%patch2 -p1 -b .priority
123
124%patch4 -p1 -b .dell-killswitch
125%patch9 -p1 -b .kvm-evdev
126%patch11 -p1 -b .hdaps-blacklist
127
128%patch100 -p1 -b .drop-polkit
129
130%patch200 -p1 -b .disable-keyboard-hotplug
131
132%build
133
134autoreconf -f -i
135
136%configure \
137        --with-os-type=redhat \
138        --docdir=%{_docdir}/%{name}-%{version} \
139        --with-udev-prefix=/etc \
140        --disable-docbook-docs \
141        --enable-pcmcia-support \
142        --enable-umount-helper \
143        --disable-console-kit \
144        --disable-policy-kit \
145        --disable-acpi-ibm \
146        --disable-smbios \
147        --enable-parted \
148        --enable-acpi-toshiba \
149        --without-usb-csr \
150        --without-cpufreq \
151        --with-eject=/usr/sbin/eject
152
153%__make %{?_smp_mflags}
154
155
156%install
157rm -rf %{buildroot}
158make install DESTDIR=$RPM_BUILD_ROOT
159
160rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
161
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166
167%pre
168# Add the "haldaemon" user
169/usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
170        -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
171
172%post
173/sbin/ldconfig
174/sbin/chkconfig --add haldaemon
175
176
177%preun
178if [ $1 = 0 ]; then
179    service haldaemon stop > /dev/null 2>&1
180    /sbin/chkconfig --del haldaemon
181fi
182
183
184%postun
185/sbin/ldconfig
186#if [ "$1" -ge "1" ]; then
187#  service haldaemon condrestart > /dev/null 2>&1
188#fi
189
190
191%triggerpostun -- hal < 0.5.7
192#remove lingering fstab-sync entries from /etc/fstab
193/bin/cp -f /etc/fstab /etc/fstab.hal-save
194(IFS="
195"; while read line; do echo $line | awk '{print $4}' | grep -q managed || echo $line | grep -q "^#.*fstab-sync" || echo $line; done < /etc/fstab > fstab.replace)
196
197if [ -s fstab.replace ]; then
198  /bin/cp -f fstab.replace /etc/fstab
199fi
200
201%triggerpostun -- hal < 0.5.11-3
202# reset priorities
203if [ -f /etc/rc3.d/S98haldaemon ]; then
204  /sbin/chkconfig haldaemon resetpriorities
205fi
206
207
208%files
209%defattr(-,root,root,-)
210%doc AUTHORS COPYING ChangeLog HACKING INSTALL README NEWS
211#doc examples
212
213%dir %{_sysconfdir}/dbus-1/system.d
214%{_sysconfdir}/dbus-1/system.d/*
215
216%config %{_sysconfdir}/rc.d/init.d/haldaemon
217
218%dir %{_sysconfdir}/hal
219%{_sysconfdir}/hal/*
220
221/sbin/umount.hal
222%{_sbindir}/hald
223%{_bindir}/*
224
225%{_libexecdir}/*
226
227%{_libdir}/*hal*.so.*
228
229%dir %{_datadir}/hal
230%dir %{_datadir}/hal/fdi
231%{_datadir}/hal/fdi/*
232
233%{_mandir}/man1/*
234%{_mandir}/man8/*
235
236%{_sysconfdir}/udev/rules.d/90-hal.rules
237
238%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/cache/hald
239%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/run/hald
240
241
242%files devel
243%defattr(-,root,root)
244%{_libdir}/lib*.so
245%{_libdir}/pkgconfig/*
246%{_includedir}/*
247%{_datadir}/gtk-doc/html/*
248
249#%files gnome
250#%defattr(-,root,root)
251#%dir %{_datadir}/hal/device-manager
252#%{_datadir}/hal/device-manager/*
253#%{_bindir}/hal-device-manager
254#%{_datadir}/applications/*.desktop
255
256
257%changelog
258* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-2
259- rebuild with parted-3.0
260- add Patch0 (hal-0.5.14-videodev.patch)
261
262* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-1
263- update to 0.5.14
264- delete Patch12 (hal-mdfind.patch)
265
266* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-6
267- add BuildRequires: zlib-devel
268
269* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.5.13-5
270- rebuilt with parted 2.3
271
272* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.13-4
273- rebuilt with rpm-4.8.1 for pkg-config
274
275* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-3
276- add BuildRequires: libuuid-devel
277
278* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.13-2
279- rebuilt with python-2.6.4-3
280
281* Wed Oct 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.13-1
282- new upstream release
283- merge patches from fedora
284- disable ConsoleKit and PolicyKit support
285- disable acl management, this is now handled by udev
286- disable csr,ibm and cpufreq which is obsolete.
287
288* Sat Oct 03 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.12-2.rc1
289- add patch11 to disable acl for unpartitioned volumes (such as audio CDs)
290  ([vine-users:079605])
291
292* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.12-1.rc1
293- added BuildRequires: e2fsprogs-devel
294
295* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.12-0.rc1
296- update to 0.5.12rc1
297- add patch5 to allow introspection and Device.KillSwitch access
298  https://bugs.freedesktop.org/show_bug.cgi?id=18985
299
300* Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-6
301- rebuild with udev-135-1
302
303* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-5
304- add 10-x11-input.fdi again
305- add patch10 to disable x11 keyaboard hotplugging
306
307* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-4
308- rebuild with parted-1.8.8
309- add BuildRequires: util-linux-ng instead of util-linux
310
311* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-3
312- rebuild with new ConsoleKit/PolicyKit
313- change start/stop priority earlier
314
315* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-2
316- spec in UTF-8
317- Drop 99-redhat-storage-policy-fixed-drives.fdi; this is now
318  controlled by PolicyKit
319- Remove /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi which
320  effectively disables xorg input hotplugging again: this is only a
321  temporary workaround until a better solution is available
322  (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447666)
323
324* Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-1
325- updated to 0.5.11
326- drop gnome subpackage - obsoleted in the upstream
327  (but separated into gnome-desktop-manager)
328- drop use of find_lang - all translations dropped in the upstream
329
330* Sat Mar 08 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.9-0vl5
331- add Patch1001 to get proper LCD max brightness with pcc-acpi.
332
333* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-0vl4
334- rebuild with expat-2.0.1
335- add BuildRequires: dbus-glib-devel >= %%{dbus_glib_version}
336- update %%{SOURCE2} (drop extension from Icon entry)
337
338* Thu Oct 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.5.9-0vl3
339- add Patch600 to fix severe memory leak on the system with apm
340  initially discussed at:
341    https://bugzilla.redhat.com/show_bug.cgi?id=244995
342  then more comprehensive fixes posted at:
343    http://lists.freedesktop.org/archives/hal/2007-September/009642.html
344
345* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl2
346- add Requires: hal-info
347
348* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl1
349- new upstream release
350- add Patch1000 to revert kernel-2.6.17 specific changes
351
352* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl4
353- rebuild with dbus-1.0
354
355* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.7.1-0vl3
356- changed hal-gnome Group to Applications/System
357
358* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl2
359- add Patch10 to detecting usb optical drives
360  (https://bugs.freedesktop.org/show_bug.cgi?id=5558)
361
362* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl1
363- new upstream release
364- add Patch1 to fix confusing lid state. (<BTS:0091>)
365
366* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl3
367- add Source1 for workaround policy file to ignore fixed
368  (non-hotpluggable) disk from FC.
369
370* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
371- do not restart haldaemon in %%postun script
372
373* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
374- new upstream release
375- disable fstab-sync, clear fstab-sync entries from fstab
376- import changes from FC
377
378* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
379- remove Requires: gnome-python-* from hal-gnome
380  gnome-python sub packages are obsoleted.
381
382* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
383- new upstream release
384
385* Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
386- new upstream release
387- add Requires: pygtk2-libglade for hal-gnome
388
389* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
390- new upstream release
391- import patches from FC
392
393* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-2vl1
394- initiual build for Vine Linux based on FC package.
395
396* Thu Jan 27 2005 David Zeuthen <davidz@redhat.com> 0.4.7-2
397- Add patch that should close #146316
398
399* Mon Jan 24 2005 David Zeuthen <davidz@redhat.com> 0.4.7-1
400- New upstream release.
401- Should close #145921, #145750, #145293, #145256
402
403* Mon Jan 24 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.6-3
404- Update required dbus version to 0.23
405
406* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-2
407- Fix parameters to configure
408
409* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-1
410- New upstream release
411- Should close #145099, #144600, #140150, #145223, #137672
412
413* Wed Jan 12 2005 David Zeuthen <davidz@redhat.com> 0.4.5-1
414- New upstream release.
415- Should close #142834, #141771, #142183
416
417* Fri Dec 12 2004 David Zeuthen <davidz@redhat.com> 0.4.2.cvs20041210-1
418- Snapshot from stable branch of upstream CVS
419
420* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-8
421- Forgot to add some diffs in hal-0.4.0-pcmcia-net-support.patch
422
423* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-7
424- Change default policy such that non-hotpluggable fixed disks are not
425  added to the /etc/fstab file because a) ATARAID detection in hal is
426  incomplete (e.g. RAID members from ATARAID controllers might be added
427  to /etc/fstab); and b) default install wont corrupt multiboot
428  systems on fixed drives (#137072)
429
430* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-6
431- Fix hotplug timeout handling (#136626)
432- Detect ATARAID devices and do not add /etc/fstab entry for them
433- Probe for ext3 before ntfs (#136966)
434- Use fstype 'auto' for optical drives instead of 'iso9660,udf'
435- Properly detect wireless ethernet devices  (#136591)
436- Support 16-bit PCMCIA networking devices (by Dan Williams) (#136658)
437
438* Tue Oct 19 2004 David Zeuthen <davidz@redhat.com> 0.4.0-5
439- Make hal work with PCMCIA IDE hotpluggable devices (#133943)
440- Fixup URL listed from rpm -qi (#136396)
441- Add Portuguese translations for hal
442- Fix addition of Russian and Hungarian translations
443
444* Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
445- Make hald cope with missing hotplug events from buggy drivers (#135202)
446- Fix the order of mount options in fstab-sync (#136191)
447- Allow x86 legacy floppy drives in default policy (#133777)
448- Fix fstab-sync crashing without any options and not run from hald (#136214)
449- man page for fstab-sync references non-existing files (#136026)
450- Add Russian translations for hal (#135853)
451- Add Hungarian translations for hal
452
453* Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
454- Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
455- Never use the UUID as mount point candidate in the default policy
456  as it is unfriendly (#135907)
457- Fix a trivial bug in fstab-sync so the syslog messages actually expose
458  the device name instead of just the word foo
459
460* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
461- Fix issue with fstab-sync not cleaning /etc/fstab on startup
462
463* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
464- Update to upstream stable version 0.4.0
465- Remove patch for libhal shutdown since that is now upstream
466- fstab-sync: man page, adds comment in /etc/fstab pointing to man page
467
468* Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
469- Fix a bug so libhal actually invoke callback functions when needed
470
471* Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
472- Use "user" mount flag for now until "pamconsole" flag gets into mount
473
474* Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
475- Update to upstream CVS version
476- Enable libselinux again
477
478* Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
479- Update to upstream CVS version
480
481* Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
482- Update to upstream CVS release
483- Include libhal-storage library
484- Should close bug #132876
485
486* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
487- Rebuilt
488
489* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
490- Rebuilt
491
492* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
493- Temporarily disable explicit requirement for libselinux
494
495* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
496- Update to upstream release 0.2.98.
497- Use --with-pid-file so we don't depend on /etc/redhat-release
498
499* Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
500- Update to upstream CVS HEAD
501
502* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
503- Add UID for haldaemon user
504
505* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
506- Rebuilt with a newer snapshot.
507
508* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
509- Rebuilt
510
511* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
512- Rebuilt
513- Closes RH Bug #130971
514
515* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
516- Update to upstream CVS HEAD.
517- Should close RH Bug #130588
518
519* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
520- Rebuilt
521
522* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
523- Apply a patch so hald doesn't hang on startup.
524
525* Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
526- Update to upstream CVS HEAD
527- Remove symlinking of fstab-sync from specfile since this is now being
528  done in the package
529
530* Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
531- change the %%define names to not use "-"
532
533* Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
534- Update to upstream CVS HEAD
535- Remove suid patch as it is fixed upstream
536- Fix some dependency issues (RH Bug #130202)
537
538* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
539- Add stopgap patch to remove suid from mount flags (RH Bug #130290)
540
541* Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
542- update to upstream release 0.2.97
543- use kudzu option in fstab-sync since updfstab is now disabled
544
545* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
546- fixed Requires lines to use %{} instead of ${}
547- made dbus related requires lines use the = condition instead of =<
548  because the dbus API is still in flux
549
550* Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
551- Update to upstream release 0.2.96
552- Symlink fstab-sync into /etc/hal/device.d on install
553
554* Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
555- Base hal package no longer requires python
556
557* Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
558- Update to CVS head
559- Remove Dan's patches as they were commited to CVS
560
561* Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
562- Fix netlink sockets pointer arithmetic bug
563
564* Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
565- Update to new CVS version as of 7-12-2004
566
567* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
568- take out fstab-update.sh from install
569- add to rawhide
570 
571* Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
572- update to CVS head as of 6-11-2004 which contains dcbw's
573  network link status fix
574
575* Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
576- added dependency on udev
577
578* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
579- update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
580  and wireless network devices.
581
582* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
583- added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
584  the file system mounting script in /etc/hal/device.d
585
586* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
587- added the %{_sysconfigdir}/hal directory tree to %files
588
589* Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
590- update to CVS head as of 5-11-2004
591
592* Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
593- Install hal.dev from /etc/dev.d/default/
594
595* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
596- upstream update
597
598* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
599- initial checkin to package repository
600- added dependency to the dbus-python package
601- added %{_libexecdir}/hal.dev to teh %files section
Note: See TracBrowser for help on using the repository browser.