source: projects/specs/trunk/h/hal/hal-vl.spec @ 1872

Revision 1872, 18.7 KB checked in by inagaki, 14 years ago (diff)

update: apr, libarchive
built with rpm-4.8.1: apr, hal

Line 
1%define expat_version           1.95.5
2%define glib2_version           2.20.0
3%define dbus_version            1.2
4%define dbus_glib_version       0.80
5%define dbus_python_version     0.80
6%define pygtk2_version          2.8.0
7%define gnome_python            2.14.0
8%define udev_version            145
9%define util_linux_ng_version   2.14
10%define gettext_version         0.14.5
11%define libusb_version          0.1.10a
12%define consolekit_version      0.3.0
13%define acl_version             2.2.39
14%define policykit_version       0.9
15%define pciutils_version        2.2.1
16%define dmidecode_version       2.7
17%define gperf_version           3.0.1
18%define parted_version          1.8.8
19
20%define hal_user_uid           68
21
22%define _localstatedir %{_var}
23
24Summary: Hardware Abstraction Layer
25Summary(ja): ハードウエア抽象化レイヤ
26Name: hal
27Version: 0.5.13
28Release: 4%{?_dist_release}
29
30Group: System Environment/Libraries
31URL: http://www.freedesktop.org/Software/hal
32License: AFL/GPL
33
34Source0: %{name}-%{version}.tar.gz
35
36Patch2: hal-0.5.11-change-priority.patch
37
38# https://bugzilla.redhat.com/show_bug.cgi?id=488177
39Patch4: hal-remove-dell-killswitch.patch
40
41# http://lists.freedesktop.org/archives/hal/2009-March/013125.html
42Patch9: hal-KVM-evdev.patch
43
44# http://bugs.freedesktop.org/show_bug.cgi?id=22442
45Patch11: hal-HDAPS-blacklist.patch
46
47# https://bugzilla.redhat.com/show_bug.cgi?id=507782
48Patch12: hal-mdfind.patch
49
50Patch100: hal-use-at-console.patch
51
52Patch200: hal-0.5.13-disable-keyboard-hotplug.patch
53
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: expat-devel >= %{expat_version}
56BuildRequires: glib2-devel >= %{glib2_version}
57BuildRequires: dbus-devel  >= %{dbus_version}
58BuildRequires: python-devel
59BuildRequires: hwdata
60BuildRequires: gettext >= %{gettext_version}
61%ifnarch s390 s390x
62BuildRequires: libusb-devel >= %{libusb_version}
63%endif
64BuildRequires: desktop-file-utils >= 0.9
65BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
66BuildRequires: pciutils-devel >= %{pciutils_version}
67BuildRequires: gperf >= %{gperf_version}
68BuildRequires: parted-devel >= %{parted_version}
69BuildRequires: e2fsprogs-devel
70BuildRequires: libblkid-devel
71BuildRequires: libuuid-devel
72
73Requires: dbus >= %{dbus_version}
74Requires: dbus-glib >= %{dbus_glib_version}
75Requires: glib2 >= %{glib2_version}
76Requires: udev >= %{udev_version}
77Requires: util-linux-ng >= %{util_linux_ng_version}
78%ifnarch s390 s390x
79Requires: libusb >= %{libusb_version}
80%endif
81Requires: ConsoleKit >= %{consolekit_version}
82Requires: acl >= %{acl_version}
83Requires: hal-info
84Requires(pre): shadow-utils
85Requires(post): chkconfig
86Requires(preun): chkconfig, initscripts
87
88Obsoletes: hal-gnome
89
90%description
91HAL is daemon for collection and maintaining information from several
92sources about the hardware on the system. It provdes a live device
93list through D-BUS.
94
95%package gnome
96Summary: GNOME based device manager for HAL
97Group: Applications/System
98Requires: %name = %{version}-%{release}
99Requires: dbus-python >= %{dbus_python_version}
100Requires: pygtk2 >= %{pygtk2_version}
101Requires: pygtk2-libglade >= %{pygtk2_version}
102Requires: gnome-python >= %{gnome_python}
103
104%description gnome
105GNOME program for displaying the devices detected by HAL
106
107
108%package devel
109Summary: Libraries and headers for HAL
110Group: Development/Libraries
111Requires: %{name} = %{version}-%{release}
112Requires: dbus-devel >= %{dbus_version}
113
114%description devel
115Headers, static libraries and API docs for HAL.
116
117
118%prep
119%setup -q -n %{name}-%{version}
120%patch2 -p1 -b .priority
121
122%patch4 -p1 -b .dell-killswitch
123%patch9 -p1 -b .kvm-evdev
124%patch11 -p1 -b .hdaps-blacklist
125%patch12 -p1 -b .mdfind
126
127%patch100 -p1 -b .drop-polkit
128
129%patch200 -p1 -b .disable-keyboard-hotplug
130
131%build
132
133autoreconf -f -i
134
135%configure \
136        --with-os-type=redhat \
137        --docdir=%{_docdir}/%{name}-%{version} \
138        --with-udev-prefix=/etc \
139        --disable-docbook-docs \
140        --enable-pcmcia-support \
141        --enable-umount-helper \
142        --disable-console-kit \
143        --disable-policy-kit \
144        --disable-acpi-ibm \
145        --disable-smbios \
146        --enable-parted \
147        --enable-acpi-toshiba \
148        --without-usb-csr \
149        --without-cpufreq \
150        --with-eject=/usr/sbin/eject
151
152%__make %{?_smp_mflags}
153
154
155%install
156rm -rf %{buildroot}
157make install DESTDIR=$RPM_BUILD_ROOT
158
159rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
160
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165
166%pre
167# Add the "haldaemon" user
168/usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
169        -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
170
171%post
172/sbin/ldconfig
173/sbin/chkconfig --add haldaemon
174
175
176%preun
177if [ $1 = 0 ]; then
178    service haldaemon stop > /dev/null 2>&1
179    /sbin/chkconfig --del haldaemon
180fi
181
182
183%postun
184/sbin/ldconfig
185#if [ "$1" -ge "1" ]; then
186#  service haldaemon condrestart > /dev/null 2>&1
187#fi
188
189
190%triggerpostun -- hal < 0.5.7
191#remove lingering fstab-sync entries from /etc/fstab
192/bin/cp -f /etc/fstab /etc/fstab.hal-save
193(IFS="
194"; while read line; do echo $line | awk '{print $4}' | grep -q managed || echo $line | grep -q "^#.*fstab-sync" || echo $line; done < /etc/fstab > fstab.replace)
195
196if [ -s fstab.replace ]; then
197  /bin/cp -f fstab.replace /etc/fstab
198fi
199
200%triggerpostun -- hal < 0.5.11-3
201# reset priorities
202if [ -f /etc/rc3.d/S98haldaemon ]; then
203  /sbin/chkconfig haldaemon resetpriorities
204fi
205
206
207%files
208%defattr(-,root,root,-)
209%doc AUTHORS COPYING ChangeLog HACKING INSTALL README NEWS
210#doc examples
211
212%dir %{_sysconfdir}/dbus-1/system.d
213%{_sysconfdir}/dbus-1/system.d/*
214
215%config %{_sysconfdir}/rc.d/init.d/haldaemon
216
217%dir %{_sysconfdir}/hal
218%{_sysconfdir}/hal/*
219
220/sbin/umount.hal
221%{_sbindir}/hald
222%{_bindir}/*
223
224%{_libexecdir}/*
225
226%{_libdir}/*hal*.so.*
227
228%dir %{_datadir}/hal
229%dir %{_datadir}/hal/fdi
230%{_datadir}/hal/fdi/*
231
232%{_mandir}/man1/*
233%{_mandir}/man8/*
234
235%{_sysconfdir}/udev/rules.d/90-hal.rules
236
237%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/cache/hald
238%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/run/hald
239
240
241%files devel
242%defattr(-,root,root)
243%{_libdir}/lib*.so
244%{_libdir}/pkgconfig/*
245%{_includedir}/*
246%{_datadir}/gtk-doc/html/*
247
248#%files gnome
249#%defattr(-,root,root)
250#%dir %{_datadir}/hal/device-manager
251#%{_datadir}/hal/device-manager/*
252#%{_bindir}/hal-device-manager
253#%{_datadir}/applications/*.desktop
254
255
256%changelog
257* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.13-4
258- rebuilt with rpm-4.8.1 for pkg-config
259
260* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-3
261- add BuildRequires: libuuid-devel
262
263* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.13-2
264- rebuilt with python-2.6.4-3
265
266* Wed Oct 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.13-1
267- new upstream release
268- merge patches from fedora
269- disable ConsoleKit and PolicyKit support
270- disable acl management, this is now handled by udev
271- disable csr,ibm and cpufreq which is obsolete.
272
273* Sat Oct 03 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.12-2.rc1
274- add patch11 to disable acl for unpartitioned volumes (such as audio CDs)
275  ([vine-users:079605])
276
277* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.12-1.rc1
278- added BuildRequires: e2fsprogs-devel
279
280* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.12-0.rc1
281- update to 0.5.12rc1
282- add patch5 to allow introspection and Device.KillSwitch access
283  https://bugs.freedesktop.org/show_bug.cgi?id=18985
284
285* Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-6
286- rebuild with udev-135-1
287
288* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-5
289- add 10-x11-input.fdi again
290- add patch10 to disable x11 keyaboard hotplugging
291
292* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-4
293- rebuild with parted-1.8.8
294- add BuildRequires: util-linux-ng instead of util-linux
295
296* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-3
297- rebuild with new ConsoleKit/PolicyKit
298- change start/stop priority earlier
299
300* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-2
301- spec in UTF-8
302- Drop 99-redhat-storage-policy-fixed-drives.fdi; this is now
303  controlled by PolicyKit
304- Remove /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi which
305  effectively disables xorg input hotplugging again: this is only a
306  temporary workaround until a better solution is available
307  (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447666)
308
309* Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-1
310- updated to 0.5.11
311- drop gnome subpackage - obsoleted in the upstream
312  (but separated into gnome-desktop-manager)
313- drop use of find_lang - all translations dropped in the upstream
314
315* Sat Mar 08 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.9-0vl5
316- add Patch1001 to get proper LCD max brightness with pcc-acpi.
317
318* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-0vl4
319- rebuild with expat-2.0.1
320- add BuildRequires: dbus-glib-devel >= %%{dbus_glib_version}
321- update %%{SOURCE2} (drop extension from Icon entry)
322
323* Thu Oct 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.5.9-0vl3
324- add Patch600 to fix severe memory leak on the system with apm
325  initially discussed at:
326    https://bugzilla.redhat.com/show_bug.cgi?id=244995
327  then more comprehensive fixes posted at:
328    http://lists.freedesktop.org/archives/hal/2007-September/009642.html
329
330* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl2
331- add Requires: hal-info
332
333* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl1
334- new upstream release
335- add Patch1000 to revert kernel-2.6.17 specific changes
336
337* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl4
338- rebuild with dbus-1.0
339
340* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.7.1-0vl3
341- changed hal-gnome Group to Applications/System
342
343* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl2
344- add Patch10 to detecting usb optical drives
345  (https://bugs.freedesktop.org/show_bug.cgi?id=5558)
346
347* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl1
348- new upstream release
349- add Patch1 to fix confusing lid state. (<BTS:0091>)
350
351* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl3
352- add Source1 for workaround policy file to ignore fixed
353  (non-hotpluggable) disk from FC.
354
355* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
356- do not restart haldaemon in %%postun script
357
358* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
359- new upstream release
360- disable fstab-sync, clear fstab-sync entries from fstab
361- import changes from FC
362
363* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
364- remove Requires: gnome-python-* from hal-gnome
365  gnome-python sub packages are obsoleted.
366
367* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
368- new upstream release
369
370* Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
371- new upstream release
372- add Requires: pygtk2-libglade for hal-gnome
373
374* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
375- new upstream release
376- import patches from FC
377
378* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-2vl1
379- initiual build for Vine Linux based on FC package.
380
381* Thu Jan 27 2005 David Zeuthen <davidz@redhat.com> 0.4.7-2
382- Add patch that should close #146316
383
384* Mon Jan 24 2005 David Zeuthen <davidz@redhat.com> 0.4.7-1
385- New upstream release.
386- Should close #145921, #145750, #145293, #145256
387
388* Mon Jan 24 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.6-3
389- Update required dbus version to 0.23
390
391* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-2
392- Fix parameters to configure
393
394* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-1
395- New upstream release
396- Should close #145099, #144600, #140150, #145223, #137672
397
398* Wed Jan 12 2005 David Zeuthen <davidz@redhat.com> 0.4.5-1
399- New upstream release.
400- Should close #142834, #141771, #142183
401
402* Fri Dec 12 2004 David Zeuthen <davidz@redhat.com> 0.4.2.cvs20041210-1
403- Snapshot from stable branch of upstream CVS
404
405* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-8
406- Forgot to add some diffs in hal-0.4.0-pcmcia-net-support.patch
407
408* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-7
409- Change default policy such that non-hotpluggable fixed disks are not
410  added to the /etc/fstab file because a) ATARAID detection in hal is
411  incomplete (e.g. RAID members from ATARAID controllers might be added
412  to /etc/fstab); and b) default install wont corrupt multiboot
413  systems on fixed drives (#137072)
414
415* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-6
416- Fix hotplug timeout handling (#136626)
417- Detect ATARAID devices and do not add /etc/fstab entry for them
418- Probe for ext3 before ntfs (#136966)
419- Use fstype 'auto' for optical drives instead of 'iso9660,udf'
420- Properly detect wireless ethernet devices  (#136591)
421- Support 16-bit PCMCIA networking devices (by Dan Williams) (#136658)
422
423* Tue Oct 19 2004 David Zeuthen <davidz@redhat.com> 0.4.0-5
424- Make hal work with PCMCIA IDE hotpluggable devices (#133943)
425- Fixup URL listed from rpm -qi (#136396)
426- Add Portuguese translations for hal
427- Fix addition of Russian and Hungarian translations
428
429* Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
430- Make hald cope with missing hotplug events from buggy drivers (#135202)
431- Fix the order of mount options in fstab-sync (#136191)
432- Allow x86 legacy floppy drives in default policy (#133777)
433- Fix fstab-sync crashing without any options and not run from hald (#136214)
434- man page for fstab-sync references non-existing files (#136026)
435- Add Russian translations for hal (#135853)
436- Add Hungarian translations for hal
437
438* Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
439- Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
440- Never use the UUID as mount point candidate in the default policy
441  as it is unfriendly (#135907)
442- Fix a trivial bug in fstab-sync so the syslog messages actually expose
443  the device name instead of just the word foo
444
445* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
446- Fix issue with fstab-sync not cleaning /etc/fstab on startup
447
448* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
449- Update to upstream stable version 0.4.0
450- Remove patch for libhal shutdown since that is now upstream
451- fstab-sync: man page, adds comment in /etc/fstab pointing to man page
452
453* Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
454- Fix a bug so libhal actually invoke callback functions when needed
455
456* Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
457- Use "user" mount flag for now until "pamconsole" flag gets into mount
458
459* Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
460- Update to upstream CVS version
461- Enable libselinux again
462
463* Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
464- Update to upstream CVS version
465
466* Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
467- Update to upstream CVS release
468- Include libhal-storage library
469- Should close bug #132876
470
471* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
472- Rebuilt
473
474* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
475- Rebuilt
476
477* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
478- Temporarily disable explicit requirement for libselinux
479
480* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
481- Update to upstream release 0.2.98.
482- Use --with-pid-file so we don't depend on /etc/redhat-release
483
484* Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
485- Update to upstream CVS HEAD
486
487* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
488- Add UID for haldaemon user
489
490* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
491- Rebuilt with a newer snapshot.
492
493* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
494- Rebuilt
495
496* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
497- Rebuilt
498- Closes RH Bug #130971
499
500* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
501- Update to upstream CVS HEAD.
502- Should close RH Bug #130588
503
504* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
505- Rebuilt
506
507* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
508- Apply a patch so hald doesn't hang on startup.
509
510* Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
511- Update to upstream CVS HEAD
512- Remove symlinking of fstab-sync from specfile since this is now being
513  done in the package
514
515* Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
516- change the %%define names to not use "-"
517
518* Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
519- Update to upstream CVS HEAD
520- Remove suid patch as it is fixed upstream
521- Fix some dependency issues (RH Bug #130202)
522
523* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
524- Add stopgap patch to remove suid from mount flags (RH Bug #130290)
525
526* Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
527- update to upstream release 0.2.97
528- use kudzu option in fstab-sync since updfstab is now disabled
529
530* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
531- fixed Requires lines to use %{} instead of ${}
532- made dbus related requires lines use the = condition instead of =<
533  because the dbus API is still in flux
534
535* Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
536- Update to upstream release 0.2.96
537- Symlink fstab-sync into /etc/hal/device.d on install
538
539* Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
540- Base hal package no longer requires python
541
542* Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
543- Update to CVS head
544- Remove Dan's patches as they were commited to CVS
545
546* Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
547- Fix netlink sockets pointer arithmetic bug
548
549* Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
550- Update to new CVS version as of 7-12-2004
551
552* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
553- take out fstab-update.sh from install
554- add to rawhide
555 
556* Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
557- update to CVS head as of 6-11-2004 which contains dcbw's
558  network link status fix
559
560* Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
561- added dependency on udev
562
563* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
564- update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
565  and wireless network devices.
566
567* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
568- added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
569  the file system mounting script in /etc/hal/device.d
570
571* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
572- added the %{_sysconfigdir}/hal directory tree to %files
573
574* Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
575- update to CVS head as of 5-11-2004
576
577* Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
578- Install hal.dev from /etc/dev.d/default/
579
580* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
581- upstream update
582
583* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
584- initial checkin to package repository
585- added dependency to the dbus-python package
586- added %{_libexecdir}/hal.dev to teh %files section
Note: See TracBrowser for help on using the repository browser.