source: projects/specs/trunk/h/hal/hal-vl.spec @ 521

Revision 521, 18.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define expat_version           1.95.5
2%define glib2_version           2.20.0
3%define dbus_version            1.2
4%define dbus_glib_version       0.80
5%define dbus_python_version     0.80
6%define pygtk2_version          2.8.0
7%define gnome_python            2.14.0
8%define udev_version            145
9%define util_linux_ng_version   2.14
10%define gettext_version         0.14.5
11%define libusb_version          0.1.10a
12%define consolekit_version      0.3.0
13%define acl_version             2.2.39
14%define policykit_version       0.9
15%define pciutils_version        2.2.1
16%define dmidecode_version       2.7
17%define gperf_version           3.0.1
18%define parted_version          1.8.8
19
20%define hal_user_uid           68
21
22%define _localstatedir %{_var}
23
24Summary: Hardware Abstraction Layer
25Summary(ja): ハードウエア抽象化レイヤ
26Name: hal
27Version: 0.5.13
28Release: 3%{?_dist_release}
29URL: http://www.freedesktop.org/Software/hal
30License: AFL/GPL
31Group: System Environment/Libraries
32
33Source0: %{name}-%{version}.tar.gz
34
35Patch2: hal-0.5.11-change-priority.patch
36
37# https://bugzilla.redhat.com/show_bug.cgi?id=488177
38Patch4: hal-remove-dell-killswitch.patch
39
40# http://lists.freedesktop.org/archives/hal/2009-March/013125.html
41Patch9: hal-KVM-evdev.patch
42
43# http://bugs.freedesktop.org/show_bug.cgi?id=22442
44Patch11: hal-HDAPS-blacklist.patch
45
46# https://bugzilla.redhat.com/show_bug.cgi?id=507782
47Patch12: hal-mdfind.patch
48
49Patch100: hal-use-at-console.patch
50
51Patch200: hal-0.5.13-disable-keyboard-hotplug.patch
52
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54Requires: chkconfig
55BuildRequires: expat-devel >= %{expat_version}
56BuildRequires: glib2-devel >= %{glib2_version}
57BuildRequires: dbus-devel  >= %{dbus_version}
58BuildRequires: python-devel
59BuildRequires: hwdata
60BuildRequires: gettext >= %{gettext_version}
61%ifnarch s390 s390x
62BuildRequires: libusb-devel >= %{libusb_version}
63%endif
64BuildRequires: desktop-file-utils >= 0.9
65BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
66BuildRequires: pciutils-devel >= %{pciutils_version}
67BuildRequires: gperf >= %{gperf_version}
68BuildRequires: parted-devel >= %{parted_version}
69BuildRequires: e2fsprogs-devel
70BuildRequires: libblkid-devel
71BuildRequires: libuuid-devel
72
73Requires: dbus >= %{dbus_version}
74Requires: dbus-glib >= %{dbus_glib_version}
75Requires: glib2 >= %{glib2_version}
76Requires: udev >= %{udev_version}
77Requires: util-linux-ng >= %{util_linux_ng_version}
78%ifnarch s390 s390x
79Requires: libusb >= %{libusb_version}
80%endif
81Requires: ConsoleKit >= %{consolekit_version}
82Requires: acl >= %{acl_version}
83Requires: hal-info
84Obsoletes: hal-gnome
85
86%description
87HAL is daemon for collection and maintaining information from several
88sources about the hardware on the system. It provdes a live device
89list through D-BUS.
90
91%package gnome
92Summary: GNOME based device manager for HAL
93Group: Applications/System
94Requires: %name = %{version}-%{release}
95Requires: dbus-python >= %{dbus_python_version}
96Requires: pygtk2 >= %{pygtk2_version}
97Requires: pygtk2-libglade >= %{pygtk2_version}
98Requires: gnome-python >= %{gnome_python}
99
100%description gnome
101GNOME program for displaying the devices detected by HAL
102
103
104%package devel
105Summary: Libraries and headers for HAL
106Group: Development/Libraries
107Requires: %name = %{version}-%{release}
108Requires: dbus-devel >= %{dbus_version}
109
110%description devel
111
112Headers, static libraries and API docs for HAL.
113
114
115%prep
116%setup -q -n %{name}-%{version}
117%patch2 -p1 -b .priority
118
119%patch4 -p1 -b .dell-killswitch
120%patch9 -p1 -b .kvm-evdev
121%patch11 -p1 -b .hdaps-blacklist
122%patch12 -p1 -b .mdfind
123
124%patch100 -p1 -b .drop-polkit
125
126%patch200 -p1 -b .disable-keyboard-hotplug
127
128%build
129
130autoreconf -f -i
131
132%configure \
133        --with-os-type=redhat \
134        --docdir=%{_docdir}/%{name}-%{version} \
135        --with-udev-prefix=/etc \
136        --disable-docbook-docs \
137        --enable-pcmcia-support \
138        --enable-umount-helper \
139        --disable-console-kit \
140        --disable-policy-kit \
141        --disable-acpi-ibm \
142        --disable-smbios \
143        --enable-parted \
144        --enable-acpi-toshiba \
145        --without-usb-csr \
146        --without-cpufreq \
147        --with-eject=/usr/sbin/eject
148
149%__make %{?_smp_mflags}
150
151
152%install
153rm -rf %{buildroot}
154make install DESTDIR=$RPM_BUILD_ROOT
155
156rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
157
158
159%clean
160rm -rf %{buildroot}
161
162
163%pre
164# Add the "haldaemon" user
165/usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
166        -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
167
168# User haldaemon needs to be able to read authorizations
169/usr/bin/polkit-auth --user haldaemon --grant org.freedesktop.policykit.read >& /dev/null || :
170
171
172%post
173/sbin/ldconfig
174/sbin/chkconfig --add haldaemon
175
176
177%preun
178if [ $1 = 0 ]; then
179    service haldaemon stop > /dev/null 2>&1
180    /sbin/chkconfig --del haldaemon
181fi
182
183
184%postun
185/sbin/ldconfig
186#if [ "$1" -ge "1" ]; then
187#  service haldaemon condrestart > /dev/null 2>&1
188#fi
189
190
191%triggerpostun -- hal < 0.5.7
192#remove lingering fstab-sync entries from /etc/fstab
193/bin/cp -f /etc/fstab /etc/fstab.hal-save
194(IFS="
195"; while read line; do echo $line | awk '{print $4}' | grep -q managed || echo $line | grep -q "^#.*fstab-sync" || echo $line; done < /etc/fstab > fstab.replace)
196
197if [ -s fstab.replace ]; then
198  /bin/cp -f fstab.replace /etc/fstab
199fi
200
201%triggerpostun -- hal < 0.5.11-3
202# reset priorities
203if [ -f /etc/rc3.d/S98haldaemon ]; then
204  /sbin/chkconfig haldaemon resetpriorities
205fi
206
207
208%files
209%defattr(-,root,root,-)
210%doc AUTHORS COPYING ChangeLog HACKING INSTALL README NEWS
211%doc examples
212
213%dir %{_sysconfdir}/dbus-1/system.d
214%{_sysconfdir}/dbus-1/system.d/*
215
216%config %{_sysconfdir}/rc.d/init.d/haldaemon
217
218%dir %{_sysconfdir}/hal
219%{_sysconfdir}/hal/*
220
221/sbin/umount.hal
222%{_sbindir}/hald
223%{_bindir}/*
224
225%{_libexecdir}/*
226
227%{_libdir}/*hal*.so.*
228
229%dir %{_datadir}/hal
230%dir %{_datadir}/hal/fdi
231%{_datadir}/hal/fdi/*
232
233%{_mandir}/man1/*
234%{_mandir}/man8/*
235
236%{_sysconfdir}/udev/rules.d/90-hal.rules
237
238
239%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/cache/hald
240%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/run/hald
241
242
243%files devel
244%defattr(-,root,root)
245%{_libdir}/lib*.so
246%{_libdir}/pkgconfig/*
247%{_includedir}/*
248%{_datadir}/gtk-doc/html/*
249
250#%files gnome
251#%defattr(-,root,root)
252#%dir %{_datadir}/hal/device-manager
253#%{_datadir}/hal/device-manager/*
254#%{_bindir}/hal-device-manager
255#%{_datadir}/applications/*.desktop
256
257
258%changelog
259* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-3
260- add BuildRequires: libuuid-devel
261
262* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.13-2
263- rebuilt with python-2.6.4-3
264
265* Wed Oct 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.13-1
266- new upstream release
267- merge patches from fedora
268- disable ConsoleKit and PolicyKit support
269- disable acl management, this is now handled by udev
270- disable csr,ibm and cpufreq which is obsolete.
271
272* Sat Oct 03 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.12-2.rc1
273- add patch11 to disable acl for unpartitioned volumes (such as audio CDs)
274  ([vine-users:079605])
275
276* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.12-1.rc1
277- added BuildRequires: e2fsprogs-devel
278
279* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.12-0.rc1
280- update to 0.5.12rc1
281- add patch5 to allow introspection and Device.KillSwitch access
282  https://bugs.freedesktop.org/show_bug.cgi?id=18985
283
284* Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-6
285- rebuild with udev-135-1
286
287* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-5
288- add 10-x11-input.fdi again
289- add patch10 to disable x11 keyaboard hotplugging
290
291* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-4
292- rebuild with parted-1.8.8
293- add BuildRequires: util-linux-ng instead of util-linux
294
295* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-3
296- rebuild with new ConsoleKit/PolicyKit
297- change start/stop priority earlier
298
299* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-2
300- spec in UTF-8
301- Drop 99-redhat-storage-policy-fixed-drives.fdi; this is now
302  controlled by PolicyKit
303- Remove /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi which
304  effectively disables xorg input hotplugging again: this is only a
305  temporary workaround until a better solution is available
306  (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447666)
307
308* Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-1
309- updated to 0.5.11
310- drop gnome subpackage - obsoleted in the upstream
311  (but separated into gnome-desktop-manager)
312- drop use of find_lang - all translations dropped in the upstream
313
314* Sat Mar 08 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.9-0vl5
315- add Patch1001 to get proper LCD max brightness with pcc-acpi.
316
317* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-0vl4
318- rebuild with expat-2.0.1
319- add BuildRequires: dbus-glib-devel >= %%{dbus_glib_version}
320- update %%{SOURCE2} (drop extension from Icon entry)
321
322* Thu Oct 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.5.9-0vl3
323- add Patch600 to fix severe memory leak on the system with apm
324  initially discussed at:
325    https://bugzilla.redhat.com/show_bug.cgi?id=244995
326  then more comprehensive fixes posted at:
327    http://lists.freedesktop.org/archives/hal/2007-September/009642.html
328
329* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl2
330- add Requires: hal-info
331
332* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl1
333- new upstream release
334- add Patch1000 to revert kernel-2.6.17 specific changes
335
336* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl4
337- rebuild with dbus-1.0
338
339* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.7.1-0vl3
340- changed hal-gnome Group to Applications/System
341
342* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl2
343- add Patch10 to detecting usb optical drives
344  (https://bugs.freedesktop.org/show_bug.cgi?id=5558)
345
346* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl1
347- new upstream release
348- add Patch1 to fix confusing lid state. (<BTS:0091>)
349
350* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl3
351- add Source1 for workaround policy file to ignore fixed
352  (non-hotpluggable) disk from FC.
353
354* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
355- do not restart haldaemon in %%postun script
356
357* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
358- new upstream release
359- disable fstab-sync, clear fstab-sync entries from fstab
360- import changes from FC
361
362* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
363- remove Requires: gnome-python-* from hal-gnome
364  gnome-python sub packages are obsoleted.
365
366* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
367- new upstream release
368
369* Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
370- new upstream release
371- add Requires: pygtk2-libglade for hal-gnome
372
373* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
374- new upstream release
375- import patches from FC
376
377* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-2vl1
378- initiual build for Vine Linux based on FC package.
379
380* Thu Jan 27 2005 David Zeuthen <davidz@redhat.com> 0.4.7-2
381- Add patch that should close #146316
382
383* Mon Jan 24 2005 David Zeuthen <davidz@redhat.com> 0.4.7-1
384- New upstream release.
385- Should close #145921, #145750, #145293, #145256
386
387* Mon Jan 24 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.6-3
388- Update required dbus version to 0.23
389
390* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-2
391- Fix parameters to configure
392
393* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-1
394- New upstream release
395- Should close #145099, #144600, #140150, #145223, #137672
396
397* Wed Jan 12 2005 David Zeuthen <davidz@redhat.com> 0.4.5-1
398- New upstream release.
399- Should close #142834, #141771, #142183
400
401* Fri Dec 12 2004 David Zeuthen <davidz@redhat.com> 0.4.2.cvs20041210-1
402- Snapshot from stable branch of upstream CVS
403
404* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-8
405- Forgot to add some diffs in hal-0.4.0-pcmcia-net-support.patch
406
407* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-7
408- Change default policy such that non-hotpluggable fixed disks are not
409  added to the /etc/fstab file because a) ATARAID detection in hal is
410  incomplete (e.g. RAID members from ATARAID controllers might be added
411  to /etc/fstab); and b) default install wont corrupt multiboot
412  systems on fixed drives (#137072)
413
414* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-6
415- Fix hotplug timeout handling (#136626)
416- Detect ATARAID devices and do not add /etc/fstab entry for them
417- Probe for ext3 before ntfs (#136966)
418- Use fstype 'auto' for optical drives instead of 'iso9660,udf'
419- Properly detect wireless ethernet devices  (#136591)
420- Support 16-bit PCMCIA networking devices (by Dan Williams) (#136658)
421
422* Tue Oct 19 2004 David Zeuthen <davidz@redhat.com> 0.4.0-5
423- Make hal work with PCMCIA IDE hotpluggable devices (#133943)
424- Fixup URL listed from rpm -qi (#136396)
425- Add Portuguese translations for hal
426- Fix addition of Russian and Hungarian translations
427
428* Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
429- Make hald cope with missing hotplug events from buggy drivers (#135202)
430- Fix the order of mount options in fstab-sync (#136191)
431- Allow x86 legacy floppy drives in default policy (#133777)
432- Fix fstab-sync crashing without any options and not run from hald (#136214)
433- man page for fstab-sync references non-existing files (#136026)
434- Add Russian translations for hal (#135853)
435- Add Hungarian translations for hal
436
437* Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
438- Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
439- Never use the UUID as mount point candidate in the default policy
440  as it is unfriendly (#135907)
441- Fix a trivial bug in fstab-sync so the syslog messages actually expose
442  the device name instead of just the word foo
443
444* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
445- Fix issue with fstab-sync not cleaning /etc/fstab on startup
446
447* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
448- Update to upstream stable version 0.4.0
449- Remove patch for libhal shutdown since that is now upstream
450- fstab-sync: man page, adds comment in /etc/fstab pointing to man page
451
452* Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
453- Fix a bug so libhal actually invoke callback functions when needed
454
455* Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
456- Use "user" mount flag for now until "pamconsole" flag gets into mount
457
458* Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
459- Update to upstream CVS version
460- Enable libselinux again
461
462* Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
463- Update to upstream CVS version
464
465* Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
466- Update to upstream CVS release
467- Include libhal-storage library
468- Should close bug #132876
469
470* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
471- Rebuilt
472
473* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
474- Rebuilt
475
476* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
477- Temporarily disable explicit requirement for libselinux
478
479* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
480- Update to upstream release 0.2.98.
481- Use --with-pid-file so we don't depend on /etc/redhat-release
482
483* Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
484- Update to upstream CVS HEAD
485
486* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
487- Add UID for haldaemon user
488
489* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
490- Rebuilt with a newer snapshot.
491
492* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
493- Rebuilt
494
495* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
496- Rebuilt
497- Closes RH Bug #130971
498
499* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
500- Update to upstream CVS HEAD.
501- Should close RH Bug #130588
502
503* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
504- Rebuilt
505
506* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
507- Apply a patch so hald doesn't hang on startup.
508
509* Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
510- Update to upstream CVS HEAD
511- Remove symlinking of fstab-sync from specfile since this is now being
512  done in the package
513
514* Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
515- change the %%define names to not use "-"
516
517* Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
518- Update to upstream CVS HEAD
519- Remove suid patch as it is fixed upstream
520- Fix some dependency issues (RH Bug #130202)
521
522* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
523- Add stopgap patch to remove suid from mount flags (RH Bug #130290)
524
525* Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
526- update to upstream release 0.2.97
527- use kudzu option in fstab-sync since updfstab is now disabled
528
529* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
530- fixed Requires lines to use %{} instead of ${}
531- made dbus related requires lines use the = condition instead of =<
532  because the dbus API is still in flux
533
534* Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
535- Update to upstream release 0.2.96
536- Symlink fstab-sync into /etc/hal/device.d on install
537
538* Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
539- Base hal package no longer requires python
540
541* Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
542- Update to CVS head
543- Remove Dan's patches as they were commited to CVS
544
545* Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
546- Fix netlink sockets pointer arithmetic bug
547
548* Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
549- Update to new CVS version as of 7-12-2004
550
551* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
552- take out fstab-update.sh from install
553- add to rawhide
554 
555* Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
556- update to CVS head as of 6-11-2004 which contains dcbw's
557  network link status fix
558
559* Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
560- added dependency on udev
561
562* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
563- update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
564  and wireless network devices.
565
566* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
567- added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
568  the file system mounting script in /etc/hal/device.d
569
570* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
571- added the %{_sysconfigdir}/hal directory tree to %files
572
573* Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
574- update to CVS head as of 5-11-2004
575
576* Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
577- Install hal.dev from /etc/dev.d/default/
578
579* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
580- upstream update
581
582* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
583- initial checkin to package repository
584- added dependency to the dbus-python package
585- added %{_libexecdir}/hal.dev to teh %files section
Note: See TracBrowser for help on using the repository browser.