source: projects/specs/trunk/h/hal/hal-vl.spec @ 6580

Revision 6580, 19.3 KB checked in by Takemikaduchi, 12 years ago (diff)

parted-3.1 & gparted-0.13.0

Line 
1%define expat_version           1.95.5
2%define glib2_version           2.20.0
3%define dbus_version            1.2
4%define dbus_glib_version       0.80
5%define dbus_python_version     0.80
6%define pygtk2_version          2.8.0
7%define gnome_python            2.14.0
8%define udev_version            145
9%define util_linux_ng_version   2.14
10%define gettext_version         0.14.5
11%define libusb_version          0.1.10a
12%define consolekit_version      0.3.0
13%define acl_version             2.2.39
14%define policykit_version       0.9
15%define pciutils_version        2.2.1
16%define dmidecode_version       2.7
17%define gperf_version           3.0.1
18# %define parted_version                1.8.8
19%define parted_version          3.0
20
21%define hal_user_uid           68
22
23%define _localstatedir %{_var}
24
25Summary: Hardware Abstraction Layer
26Summary(ja): ハードウエア抽象化レイヤ
27Name: hal
28Version: 0.5.14
29Release: 3%{?_dist_release}
30
31Group: System Environment/Libraries
32URL: http://www.freedesktop.org/Software/hal
33License: AFL/GPL
34
35Source0: %{name}-%{version}.tar.bz2
36
37Patch0: hal-0.5.14-videodev.patch
38
39Patch2: hal-0.5.11-change-priority.patch
40
41# https://bugzilla.redhat.com/show_bug.cgi?id=488177
42Patch4: hal-remove-dell-killswitch.patch
43
44# http://lists.freedesktop.org/archives/hal/2009-March/013125.html
45Patch9: hal-KVM-evdev.patch
46
47# http://bugs.freedesktop.org/show_bug.cgi?id=22442
48Patch11: hal-HDAPS-blacklist.patch
49
50Patch100: hal-use-at-console.patch
51
52Patch200: hal-0.5.13-disable-keyboard-hotplug.patch
53
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: expat-devel >= %{expat_version}
56BuildRequires: glib2-devel >= %{glib2_version}
57BuildRequires: dbus-devel  >= %{dbus_version}
58BuildRequires: python-devel
59BuildRequires: hwdata
60BuildRequires: gettext >= %{gettext_version}
61%ifnarch s390 s390x
62BuildRequires: libusb-devel >= %{libusb_version}
63%endif
64BuildRequires: desktop-file-utils >= 0.9
65BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
66BuildRequires: pciutils-devel >= %{pciutils_version}
67BuildRequires: zlib-devel
68BuildRequires: gperf >= %{gperf_version}
69BuildRequires: parted-devel >= %{parted_version}
70BuildRequires: e2fsprogs-devel
71BuildRequires: libblkid-devel
72BuildRequires: libuuid-devel
73
74Requires: dbus >= %{dbus_version}
75Requires: dbus-glib >= %{dbus_glib_version}
76Requires: glib2 >= %{glib2_version}
77Requires: udev >= %{udev_version}
78Requires: util-linux-ng >= %{util_linux_ng_version}
79%ifnarch s390 s390x
80Requires: libusb >= %{libusb_version}
81%endif
82Requires: ConsoleKit >= %{consolekit_version}
83Requires: acl >= %{acl_version}
84Requires: hal-info
85Requires(pre): shadow-utils
86Requires(post): chkconfig
87Requires(preun): chkconfig, initscripts
88
89Obsoletes: hal-gnome
90
91%description
92HAL is daemon for collection and maintaining information from several
93sources about the hardware on the system. It provdes a live device
94list through D-BUS.
95
96%package gnome
97Summary: GNOME based device manager for HAL
98Group: Applications/System
99Requires: %name = %{version}-%{release}
100Requires: dbus-python >= %{dbus_python_version}
101Requires: pygtk2 >= %{pygtk2_version}
102Requires: pygtk2-libglade >= %{pygtk2_version}
103Requires: gnome-python >= %{gnome_python}
104
105%description gnome
106GNOME program for displaying the devices detected by HAL
107
108
109%package devel
110Summary: Libraries and headers for HAL
111Group: Development/Libraries
112Requires: %{name} = %{version}-%{release}
113Requires: dbus-devel >= %{dbus_version}
114
115%description devel
116Headers, static libraries and API docs for HAL.
117
118
119%prep
120%setup -q -n %{name}-%{version}
121%patch0 -p1 -b .videodev
122%patch2 -p1 -b .priority
123
124%patch4 -p1 -b .dell-killswitch
125%patch9 -p1 -b .kvm-evdev
126%patch11 -p1 -b .hdaps-blacklist
127
128%patch100 -p1 -b .drop-polkit
129
130%patch200 -p1 -b .disable-keyboard-hotplug
131
132%build
133
134sed -i "s|glib/gmain.h|glib.h|g" hald/linux/addons/*.c
135
136autoreconf -f -i
137
138%configure \
139        --with-os-type=redhat \
140        --docdir=%{_docdir}/%{name}-%{version} \
141        --with-udev-prefix=/etc \
142        --disable-docbook-docs \
143        --enable-pcmcia-support \
144        --enable-umount-helper \
145        --disable-console-kit \
146        --disable-policy-kit \
147        --disable-acpi-ibm \
148        --disable-smbios \
149        --enable-parted \
150        --enable-acpi-toshiba \
151        --without-usb-csr \
152        --without-cpufreq \
153        --with-eject=/usr/sbin/eject
154
155%__make %{?_smp_mflags}
156
157
158%install
159rm -rf %{buildroot}
160make install DESTDIR=$RPM_BUILD_ROOT
161
162rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
163
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168
169%pre
170# Add the "haldaemon" user
171/usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
172        -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
173
174%post
175/sbin/ldconfig
176/sbin/chkconfig --add haldaemon
177
178
179%preun
180if [ $1 = 0 ]; then
181    service haldaemon stop > /dev/null 2>&1
182    /sbin/chkconfig --del haldaemon
183fi
184
185
186%postun
187/sbin/ldconfig
188#if [ "$1" -ge "1" ]; then
189#  service haldaemon condrestart > /dev/null 2>&1
190#fi
191
192
193%triggerpostun -- hal < 0.5.7
194#remove lingering fstab-sync entries from /etc/fstab
195/bin/cp -f /etc/fstab /etc/fstab.hal-save
196(IFS="
197"; while read line; do echo $line | awk '{print $4}' | grep -q managed || echo $line | grep -q "^#.*fstab-sync" || echo $line; done < /etc/fstab > fstab.replace)
198
199if [ -s fstab.replace ]; then
200  /bin/cp -f fstab.replace /etc/fstab
201fi
202
203%triggerpostun -- hal < 0.5.11-3
204# reset priorities
205if [ -f /etc/rc3.d/S98haldaemon ]; then
206  /sbin/chkconfig haldaemon resetpriorities
207fi
208
209
210%files
211%defattr(-,root,root,-)
212%doc AUTHORS COPYING ChangeLog HACKING INSTALL README NEWS
213#doc examples
214
215%dir %{_sysconfdir}/dbus-1/system.d
216%{_sysconfdir}/dbus-1/system.d/*
217
218%config %{_sysconfdir}/rc.d/init.d/haldaemon
219
220%dir %{_sysconfdir}/hal
221%{_sysconfdir}/hal/*
222
223/sbin/umount.hal
224%{_sbindir}/hald
225%{_bindir}/*
226
227%{_libexecdir}/*
228
229%{_libdir}/*hal*.so.*
230
231%dir %{_datadir}/hal
232%dir %{_datadir}/hal/fdi
233%{_datadir}/hal/fdi/*
234
235%{_mandir}/man1/*
236%{_mandir}/man8/*
237
238%{_sysconfdir}/udev/rules.d/90-hal.rules
239
240%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/cache/hald
241%attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/run/hald
242
243
244%files devel
245%defattr(-,root,root)
246%{_libdir}/lib*.so
247%{_libdir}/pkgconfig/*
248%{_includedir}/*
249%{_datadir}/gtk-doc/html/*
250
251#%files gnome
252#%defattr(-,root,root)
253#%dir %{_datadir}/hal/device-manager
254#%{_datadir}/hal/device-manager/*
255#%{_bindir}/hal-device-manager
256#%{_datadir}/applications/*.desktop
257
258
259%changelog
260* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-3
261- rebuild with parted-3.1
262
263* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-2
264- rebuild with parted-3.0
265- add Patch0 (hal-0.5.14-videodev.patch)
266
267* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-1
268- update to 0.5.14
269- delete Patch12 (hal-mdfind.patch)
270
271* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-6
272- add BuildRequires: zlib-devel
273
274* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.5.13-5
275- rebuilt with parted 2.3
276
277* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.13-4
278- rebuilt with rpm-4.8.1 for pkg-config
279
280* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-3
281- add BuildRequires: libuuid-devel
282
283* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.13-2
284- rebuilt with python-2.6.4-3
285
286* Wed Oct 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.13-1
287- new upstream release
288- merge patches from fedora
289- disable ConsoleKit and PolicyKit support
290- disable acl management, this is now handled by udev
291- disable csr,ibm and cpufreq which is obsolete.
292
293* Sat Oct 03 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.12-2.rc1
294- add patch11 to disable acl for unpartitioned volumes (such as audio CDs)
295  ([vine-users:079605])
296
297* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.12-1.rc1
298- added BuildRequires: e2fsprogs-devel
299
300* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.12-0.rc1
301- update to 0.5.12rc1
302- add patch5 to allow introspection and Device.KillSwitch access
303  https://bugs.freedesktop.org/show_bug.cgi?id=18985
304
305* Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-6
306- rebuild with udev-135-1
307
308* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-5
309- add 10-x11-input.fdi again
310- add patch10 to disable x11 keyaboard hotplugging
311
312* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-4
313- rebuild with parted-1.8.8
314- add BuildRequires: util-linux-ng instead of util-linux
315
316* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-3
317- rebuild with new ConsoleKit/PolicyKit
318- change start/stop priority earlier
319
320* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-2
321- spec in UTF-8
322- Drop 99-redhat-storage-policy-fixed-drives.fdi; this is now
323  controlled by PolicyKit
324- Remove /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi which
325  effectively disables xorg input hotplugging again: this is only a
326  temporary workaround until a better solution is available
327  (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447666)
328
329* Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-1
330- updated to 0.5.11
331- drop gnome subpackage - obsoleted in the upstream
332  (but separated into gnome-desktop-manager)
333- drop use of find_lang - all translations dropped in the upstream
334
335* Sat Mar 08 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.9-0vl5
336- add Patch1001 to get proper LCD max brightness with pcc-acpi.
337
338* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-0vl4
339- rebuild with expat-2.0.1
340- add BuildRequires: dbus-glib-devel >= %%{dbus_glib_version}
341- update %%{SOURCE2} (drop extension from Icon entry)
342
343* Thu Oct 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.5.9-0vl3
344- add Patch600 to fix severe memory leak on the system with apm
345  initially discussed at:
346    https://bugzilla.redhat.com/show_bug.cgi?id=244995
347  then more comprehensive fixes posted at:
348    http://lists.freedesktop.org/archives/hal/2007-September/009642.html
349
350* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl2
351- add Requires: hal-info
352
353* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl1
354- new upstream release
355- add Patch1000 to revert kernel-2.6.17 specific changes
356
357* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl4
358- rebuild with dbus-1.0
359
360* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.7.1-0vl3
361- changed hal-gnome Group to Applications/System
362
363* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl2
364- add Patch10 to detecting usb optical drives
365  (https://bugs.freedesktop.org/show_bug.cgi?id=5558)
366
367* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl1
368- new upstream release
369- add Patch1 to fix confusing lid state. (<BTS:0091>)
370
371* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl3
372- add Source1 for workaround policy file to ignore fixed
373  (non-hotpluggable) disk from FC.
374
375* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
376- do not restart haldaemon in %%postun script
377
378* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
379- new upstream release
380- disable fstab-sync, clear fstab-sync entries from fstab
381- import changes from FC
382
383* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
384- remove Requires: gnome-python-* from hal-gnome
385  gnome-python sub packages are obsoleted.
386
387* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
388- new upstream release
389
390* Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
391- new upstream release
392- add Requires: pygtk2-libglade for hal-gnome
393
394* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
395- new upstream release
396- import patches from FC
397
398* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-2vl1
399- initiual build for Vine Linux based on FC package.
400
401* Thu Jan 27 2005 David Zeuthen <davidz@redhat.com> 0.4.7-2
402- Add patch that should close #146316
403
404* Mon Jan 24 2005 David Zeuthen <davidz@redhat.com> 0.4.7-1
405- New upstream release.
406- Should close #145921, #145750, #145293, #145256
407
408* Mon Jan 24 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.6-3
409- Update required dbus version to 0.23
410
411* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-2
412- Fix parameters to configure
413
414* Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-1
415- New upstream release
416- Should close #145099, #144600, #140150, #145223, #137672
417
418* Wed Jan 12 2005 David Zeuthen <davidz@redhat.com> 0.4.5-1
419- New upstream release.
420- Should close #142834, #141771, #142183
421
422* Fri Dec 12 2004 David Zeuthen <davidz@redhat.com> 0.4.2.cvs20041210-1
423- Snapshot from stable branch of upstream CVS
424
425* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-8
426- Forgot to add some diffs in hal-0.4.0-pcmcia-net-support.patch
427
428* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-7
429- Change default policy such that non-hotpluggable fixed disks are not
430  added to the /etc/fstab file because a) ATARAID detection in hal is
431  incomplete (e.g. RAID members from ATARAID controllers might be added
432  to /etc/fstab); and b) default install wont corrupt multiboot
433  systems on fixed drives (#137072)
434
435* Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-6
436- Fix hotplug timeout handling (#136626)
437- Detect ATARAID devices and do not add /etc/fstab entry for them
438- Probe for ext3 before ntfs (#136966)
439- Use fstype 'auto' for optical drives instead of 'iso9660,udf'
440- Properly detect wireless ethernet devices  (#136591)
441- Support 16-bit PCMCIA networking devices (by Dan Williams) (#136658)
442
443* Tue Oct 19 2004 David Zeuthen <davidz@redhat.com> 0.4.0-5
444- Make hal work with PCMCIA IDE hotpluggable devices (#133943)
445- Fixup URL listed from rpm -qi (#136396)
446- Add Portuguese translations for hal
447- Fix addition of Russian and Hungarian translations
448
449* Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
450- Make hald cope with missing hotplug events from buggy drivers (#135202)
451- Fix the order of mount options in fstab-sync (#136191)
452- Allow x86 legacy floppy drives in default policy (#133777)
453- Fix fstab-sync crashing without any options and not run from hald (#136214)
454- man page for fstab-sync references non-existing files (#136026)
455- Add Russian translations for hal (#135853)
456- Add Hungarian translations for hal
457
458* Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
459- Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
460- Never use the UUID as mount point candidate in the default policy
461  as it is unfriendly (#135907)
462- Fix a trivial bug in fstab-sync so the syslog messages actually expose
463  the device name instead of just the word foo
464
465* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
466- Fix issue with fstab-sync not cleaning /etc/fstab on startup
467
468* Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
469- Update to upstream stable version 0.4.0
470- Remove patch for libhal shutdown since that is now upstream
471- fstab-sync: man page, adds comment in /etc/fstab pointing to man page
472
473* Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
474- Fix a bug so libhal actually invoke callback functions when needed
475
476* Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
477- Use "user" mount flag for now until "pamconsole" flag gets into mount
478
479* Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
480- Update to upstream CVS version
481- Enable libselinux again
482
483* Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
484- Update to upstream CVS version
485
486* Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
487- Update to upstream CVS release
488- Include libhal-storage library
489- Should close bug #132876
490
491* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
492- Rebuilt
493
494* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
495- Rebuilt
496
497* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
498- Temporarily disable explicit requirement for libselinux
499
500* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
501- Update to upstream release 0.2.98.
502- Use --with-pid-file so we don't depend on /etc/redhat-release
503
504* Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
505- Update to upstream CVS HEAD
506
507* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
508- Add UID for haldaemon user
509
510* Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
511- Rebuilt with a newer snapshot.
512
513* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
514- Rebuilt
515
516* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
517- Rebuilt
518- Closes RH Bug #130971
519
520* Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
521- Update to upstream CVS HEAD.
522- Should close RH Bug #130588
523
524* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
525- Rebuilt
526
527* Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
528- Apply a patch so hald doesn't hang on startup.
529
530* Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
531- Update to upstream CVS HEAD
532- Remove symlinking of fstab-sync from specfile since this is now being
533  done in the package
534
535* Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
536- change the %%define names to not use "-"
537
538* Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
539- Update to upstream CVS HEAD
540- Remove suid patch as it is fixed upstream
541- Fix some dependency issues (RH Bug #130202)
542
543* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
544- Add stopgap patch to remove suid from mount flags (RH Bug #130290)
545
546* Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
547- update to upstream release 0.2.97
548- use kudzu option in fstab-sync since updfstab is now disabled
549
550* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
551- fixed Requires lines to use %{} instead of ${}
552- made dbus related requires lines use the = condition instead of =<
553  because the dbus API is still in flux
554
555* Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
556- Update to upstream release 0.2.96
557- Symlink fstab-sync into /etc/hal/device.d on install
558
559* Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
560- Base hal package no longer requires python
561
562* Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
563- Update to CVS head
564- Remove Dan's patches as they were commited to CVS
565
566* Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
567- Fix netlink sockets pointer arithmetic bug
568
569* Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
570- Update to new CVS version as of 7-12-2004
571
572* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
573- take out fstab-update.sh from install
574- add to rawhide
575 
576* Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
577- update to CVS head as of 6-11-2004 which contains dcbw's
578  network link status fix
579
580* Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
581- added dependency on udev
582
583* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
584- update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
585  and wireless network devices.
586
587* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
588- added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
589  the file system mounting script in /etc/hal/device.d
590
591* Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
592- added the %{_sysconfigdir}/hal directory tree to %files
593
594* Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
595- update to CVS head as of 5-11-2004
596
597* Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
598- Install hal.dev from /etc/dev.d/default/
599
600* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
601- upstream update
602
603* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
604- initial checkin to package repository
605- added dependency to the dbus-python package
606- added %{_libexecdir}/hal.dev to teh %files section
Note: See TracBrowser for help on using the repository browser.