source: projects/specs/trunk/g/gyp/gyp-vl.spec @ 12395

Revision 12395, 2.2 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

gyp-0.1-4.gite87d37d6

http-parser-2.9.4-1

libgit2-glib-0.28.0.1-1

libgit2-1.0.0-1

Line 
1%define githash e87d37d6
2
3Summary:        Generate Your Projects
4Name:           gyp
5Version:        0.1
6Release:        4.git%{githash}%{?_dist_release}
7Group:          Development/Tools
8Vendor:         Project Vine
9Distribution:   Vine Linux
10Packager:       iwaim
11
12License:        BSD
13URL:            https://gyp.gsrc.io
14# 1. git clone https://chromium.googlesource.com/external/gyp
15# 2. cd gyp
16# 3. version=$(grep version= setup.py|cut -d\' -f2)
17# 4. revision=$(git log --oneline|head -1|cut -d' ' -f1)
18# 5. cd ..
19# 6. tar -a --exclude-vcs -cf gyp-$version-git$revision.tar.xz gyp
20Source0:        %{name}-%{version}-git%{githash}.tar.xz
21Patch0:         gyp-rpmoptflags.patch
22Patch1:         gyp-ninja-build.patch
23Patch2:         gyp-python3.patch
24Patch3:         gyp-python38.patch
25Patch4:         gyp-fix-cmake.patch
26Patch5:         gyp-python39.patch
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29BuildArch:      noarch
30BuildRequires:  python3-devel
31BuildRequires:  python3-rpm-macros
32BuildRequires:  python3-setuptools
33BuildRequires:  ninja
34Requires:       python3
35Requires:       python3-setuptools
36
37%description
38GYP is a tool to generates native Visual Studio, Xcode and SCons
39and/or make build files from a platform-independent input format.
40
41Its syntax is a universal cross-platform build representation
42that still allows sufficient per-platform flexibility to accommodate
43irreconcilable differences.
44
45
46%prep
47%setup -q -n %{name}
48%autopatch -p1
49for i in $(find pylib -name '*.py'); do
50  sed -e '\,#![ \t]*/.*python,{d}' $i > $i.new && touch -r $i $i.new && mv $i.new $i
51done
52
53
54%build
55%py3_build
56
57
58%install
59%{__rm} -rf %{buildroot}
60%py3_install
61
62
63%check
64%{__python3} gyptest.py test/hello/gyptest-all.py
65
66
67%clean
68%{__rm} -rf %{buildroot}
69
70
71%files
72%defattr(-,root,root,-)
73%license LICENSE
74%doc AUTHORS
75%{_bindir}/gyp
76%{python3_sitelib}/*
77
78%changelog
79* Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.1-4.gite87d37d6
80- updated to git HEAD.
81- import Patch1-5 from rawhide.
82- switch to python3.
83
84* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.46-1
85- update to svn r1569
86
87* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1-2.svn827
88- rebuild with python-2.7.2
89
90* Fri Jun  4 2010 IWAI, Masaharu <iwai@alib.jp> 0.1-1.svn827
91- Initial build.
92
Note: See TracBrowser for help on using the repository browser.