source: projects/specs/trunk/g/gwget/gwget-vl.spec @ 9156

Revision 9156, 4.2 KB checked in by inagaki, 9 years ago (diff)

2014-12-15 Ryoichi INAGAKI <ryo1@…>

  • dbskkd-cdb, stone, tidy, uim-tomoe-gtk: rebuilt
  • espeak: updated
  • gwget: added Patch
  • sablotron, tomoe-gtk: updated spec


Line 
1%define name    gwget
2%define version 1.0.4
3%define release 4%{?_dist_release}
4
5Summary:        Download manager for Gnome
6Summary(ja):    Gnome 用ダウンロードマネージャ
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10License:        GPLv2+
11Group:          Applications/Internet
12URL:            http://www.gnome.org/projects/gwget/
13
14Source0:        http://ftp.gnome.org/pub/GNOME/sources/gwget/1.0/%{name}-%{version}.tar.bz2
15Patch1:         gwget-1.0.4-libnotify-0.7.0.patch
16Patch2:         gwget-glib.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  gtk2-devel >= 2.10
20BuildRequires:  libgnomeui-devel
21BuildRequires:  libglade2-devel, gnome-vfs2-devel
22BuildRequires:  dbus-devel
23BuildRequires:  libnotify-devel
24BuildRequires:  libSM-devel
25BuildRequires:  intltool >= 0.35.0
26BuildRequires:  gettext >= 0.14.1
27BuildRequires:  desktop-file-utils
28Requires:       wget >= 1.9
29Requires(post): GConf2
30Requires(preun): GConf2
31
32%description
33Gwget is a Download Manager for Gnome 2. It uses wget as a backend.
34Currently, very basic wget options are available, supporting multiple
35downloads, drag&drop and display the errors from wget process.
36
37%description -l ja
38Gwget は Gnome 2 向けのダウンロードマネージャです。バックエンドに wget を使用します。現在は基本的な wget オプションを利用することができ、複数のダウンロード、ドラッグ&ドロップ、wget プロセスからのエラー表示に対応しています。
39
40%prep
41%setup -q
42%patch1 -p1 -b .libnotify-0.7.0
43%patch2 -p1 -b .glib
44
45# convert files to UTF-8 with preserving the timestamps
46for file in ChangeLog README; do
47    mv $file timestamp
48    iconv -f ISO-8859-1 -t UTF-8 -o $file timestamp
49    touch -r timestamp $file
50done
51
52%build
53%configure --disable-epiphany-extension --disable-static
54make %{?_smp_mflags}
55
56
57%install
58%{__rm} -rf ${RPM_BUILD_ROOT}
59export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
60make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
61unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
62
63desktop-file-install \
64        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
65        --delete-original                               \
66        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
67
68%find_lang %{name}
69
70#remove unnecessary files.
71%{__rm} -rf ${RPM_BUILD_ROOT}/%{_includedir}/gwget
72
73%clean
74%{__rm} -rf ${RPM_BUILD_ROOT}
75
76%post
77export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
78gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwget.schemas > /dev/null
79
80%pre
81if [ "$1" -gt 1 ]; then
82   export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
83   gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwget.schemas > /dev/null
84fi
85
86%preun
87if [ "$1" = "0" ] ; then
88   export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
89   gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwget.schemas > /dev/null
90fi
91
92%postun
93update-desktop-database -q
94
95%files -f %{name}.lang
96%defattr(-,root,root)
97%doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
98%{_bindir}/gwget
99%{_sysconfdir}/gconf/schemas/gwget.schemas
100%{_datadir}/applications/gwget.desktop
101%{_datadir}/gwget
102%{_datadir}/pixmaps/gwget.png
103%{_datadir}/dbus-1/services/org.gnome.gwget.service
104
105%changelog
106* Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.4-4
107- added Patch1 and 2 to build with current VineSeed
108
109* Sun Feb 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-3
110- rebuilt with rpm-4.8.1
111
112* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-2
113- added BuildRequires: libSM-devel (see [BTS:VineLinux:0900])
114
115* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
116- new upstream release
117
118* Sun Oct 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.2-1
119- new upstream release
120- added --disable-static in configure option
121- changed make %{?_smp_mflags}
122- added BuildRequires:  libnotify-devel, intltool >= 0.35.0, gettext >= 0.14.1, desktop-file-utils
123
124* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-1
125- applied new versioning policy, spec in UTF-8
126- new upstream release
127
128* Wed Jul 25 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.99-0vl1
129- rebuild for Vine Seed.
130- add requried gtk2 version >= 2.10.
131
132* Wed Jul 25 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.98.2-0vl1
133- initial build for Vine Plus/4.0.
Note: See TracBrowser for help on using the repository browser.