source: projects/specs/trunk/g/gwenhywfar/gwenhywfar-vl.spec @ 12202

Revision 12202, 6.6 KB checked in by tomop, 5 years ago (diff)

updated gnucash and friends

Line 
1Summary: A multi-platform helper library for other libraries
2Name: gwenhywfar
3Version: 4.20.2
4Release: 1%{?_dist_release}
5
6Group: System Environment/Libraries
7License: LGPLv2+
8URL: https://www.aquamaniac.de/sites/aqbanking/index.php
9
10Vendor: Project Vine
11Distribution: Vine Linux
12
13Source0: https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: openssl-devel
17BuildRequires: gnutls-devel
18BuildRequires: libgcrypt-devel
19BuildRequires: gettext
20
21%description
22This is Gwenhywfar, a multi-platform helper library for networking and
23security applications and libraries. It is heavily used by libchipcard
24and AqBanking/AqHBCI, the German online banking libraries.
25
26%package devel
27Summary: Gwenhywfar development kit
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30Requires: %{name}-gui-cpp = %{version}-%{release}
31Requires: %{name}-gui-gtk3 = %{version}-%{release}
32Requires: %{name}-gui-qt5 = %{version}-%{release}
33Requires: pkgconfig
34%description devel
35This package contains gwenhywfar-config and header files for writing and
36compiling programs using Gwenhywfar.
37
38%package gui-cpp
39Summary: Gwenhywfar GUI framework for cpp
40Group: System Environment/Libraries
41Requires: %{name} = %{version}-%{release}
42%description gui-cpp
43This package contains the cpp gwenhywfar GUI backend.
44
45%package gui-gtk3
46Summary: Gwenhywfar GUI framework for GTK3
47Group: System Environment/Libraries
48BuildRequires: gtk3-devel
49Requires: %{name} = %{version}-%{release}
50Obsoletes: gui-gtk2
51%description gui-gtk3
52This package contains the gtk3 gwenhywfar GUI backend.
53
54%package gui-qt5
55Summary: Gwenhywfar GUI framework for Qt5
56Group: System Environment/Libraries
57BuildRequires: qt5-qtbase-devel
58Requires: %{name} = %{version}-%{release}
59Obsoletes: gui-qt4
60%description gui-qt5
61This package contains the qt5 gwenhywfar GUI backend.
62
63
64%prep
65%setup -q
66autoreconf -iv
67
68%build
69# help configure find qt5 lrelease/lupdate
70export PATH=$PATH:%{_qt5_bindir}
71
72%configure \
73        --disable-static \
74        --enable-system-certs \
75        --with-openssl-libs=%{_libdir} \
76        --with-guis="gtk3 qt5" \
77        --with-qt5-qmake=%{_bindir}/qmake-qt5 \
78        --with-qt5-moc=%{_bindir}/moc-qt5 \
79        --with-qt5-uic=%{_bindir}/uic-qt5
80
81# kill rpath
82sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
83sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
84
85make %{?_smp_mflags}
86
87%install
88[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
89make DESTDIR=$RPM_BUILD_ROOT install
90
91# use system ca-certificates
92rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
93ln -sf %{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
94    $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
95
96find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
97
98%find_lang %{name}
99
100%clean
101[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104
105%postun -p /sbin/ldconfig
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%license COPYING
110%doc AUTHORS README ChangeLog
111%{_bindir}/gct-tool
112%{_libdir}/libgwenhywfar.so.*
113%{_libdir}/%{name}
114%dir %{_datadir}/%{name}
115%{_datadir}/%{name}/dialogs
116%{_datadir}/%{name}/typemaker2
117%exclude %{_datadir}/%{name}/typemaker*
118%{_datadir}/%{name}/ca-bundle.crt
119
120%files devel
121%defattr(-,root,root)
122%exclude %{_bindir}/gct-tool
123%{_bindir}/*
124%{_includedir}/gwenhywfar4
125%{_libdir}/*.so
126%{_libdir}/pkgconfig/*.pc
127%{_libdir}/cmake/*
128%{_datadir}/aclocal/gwenhywfar.m4
129%{_datadir}/%{name}/typemaker*
130
131%files gui-cpp
132%defattr(-,root,root)
133%{_libdir}/libgwengui-cpp.so.*
134
135%files gui-gtk3
136%defattr(-,root,root)
137%{_libdir}/libgwengui-gtk3.so.*
138
139%files gui-qt5
140%defattr(-,root,root)
141%{_libdir}/libgwengui-qt5.so.*
142
143
144%changelog
145* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20.2-1
146- new upstream release.
147- switched guis to gtk3 and qt5.
148- added a subpackage "gui-cpp".
149
150* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.3-2
151- rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
152
153* Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.3-1
154- new upstream release
155- add BuildRequires: gtk2-devel, qt4-devel
156- create gui-gtk2, gui-qt4 subpackages (based on Fedora)
157
158* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.3-3
159- rebuilt with openssl-1.0.0d
160
161* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.3-2
162- rebuilt with rpm-4.8.1 for pkg-config
163
164* Sat Feb 13 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.11.3-1
165- new upstream release
166
167* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0-1
168- new upstream release
169- built with gnutls-2.6.3
170
171* Sat Sep 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.1-1
172- new upstream release
173- applied new versioning policy
174
175* Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.2-0vl1
176- new upstream release
177
178* Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.1-2vl1
179- initial build for VineSeed
180
181* Wed Oct 10 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-2
182- fix build, rebuild for buildid
183
184* Fri Aug  3 2007 Bill Nottingham <notting@redhat.com>
185- tweak license tag
186
187* Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-1
188- update to 2.6.1
189
190* Mon Jun 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.0-1
191- update to 2.6.0
192
193* Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.5.4-1
194- update to 2.5.4
195
196* Thu Feb 22 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-7
197- build for Extras
198
199* Wed Jan 10 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-6
200- make gwen-public-ca.crt %%config(noreplace)
201
202* Tue Jan  9 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-5
203- spec tweaks
204
205* Thu Sep  7 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-4
206- rebuild for fixed debuginfo (#205501)
207
208* Tue Sep  5 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-3
209- fix multilib conflicts (#205213)
210
211* Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-2
212- rather than modifying the m4 file, make gwenhywfar-config use pkgconfig
213
214* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.0-1.1
215- rebuild
216
217* Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-1
218- update to 2.3.0
219
220* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.2
221- bump again for double-long bug on ppc(64)
222
223* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.1
224- rebuilt for new gcc4.1 snapshot and glibc changes
225
226* Thu Dec 22 2005 Bill Nottingham <notting@redhat.com> 1.99.2-1
227- update to 1.99.2
228- use the pkgconfig file, not gwenhywfar-config
229
230* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
231- rebuilt
232
233* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> 1.7.2-3
234- rebuilt against new openssl
235
236* Wed Mar  2 2005 Bill Nottingham <notting@redhat.com> 1.7.2-2
237- rebuild against new openssl
238
239* Wed Feb  9 2005 Bill Nottingham <notting@redhat.com> 1.7.2-1
240- initial packaging, adopt upstream package
Note: See TracBrowser for help on using the repository browser.