source: projects/specs/trunk/g/gvfs/gvfs-vl.spec @ 7633

Revision 7633, 16.3 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1Summary: Backends for the gio framework in GLib
2Summary(ja): GLib の GIO フレームワークのバックエンド
3Name: gvfs
4Version: 1.16.1
5Release: 1%{?_dist_release}
6License: LGPLv2+
7Group: System Environment/Libraries
8URL: http://www.gtk.org
9Source: http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.16/%{name}-%{version}.tar.xz
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: pkgconfig
13BuildRequires: glib2-devel >= 2.24.0
14BuildRequires: gtk3-devel
15BuildRequires: dbus-glib-devel
16BuildRequires: /usr/bin/ssh
17BuildRequires: libcdio-devel >= 0.78.2
18BuildRequires: libsoup-devel >= 2.30.0
19BuildRequires: avahi-glib-devel >= 0.6
20BuildRequires: libgnome-keyring-devel
21BuildRequires: intltool
22BuildRequires: gettext
23BuildRequires: perl-XML-Parser
24BuildRequires: libgudev1-devel
25BuildRequires: udisks2-devel
26BuildRequires: libsecret-devel
27BuildRequires: libmtp-devel
28BuildRequires: gnome-online-accounts-devel
29
30Requires(post): desktop-file-utils
31Requires(postun): desktop-file-utils
32
33# The patch touches Makefile.am files:
34BuildRequires: automake autoconf
35BuildRequires: libtool
36
37Provides: gnome-mount < 0.9
38Obsoletes: gnome-mount < 0.9
39
40Patch1: gvfs-1.16.0-archive-integration.patch
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: Takemikaduchi
45
46%description
47The gvfs package provides backend implementations for the gio
48framework in GLib. It includes ftp, sftp, cifs.
49
50%package devel
51Summary: Development files for gvfs
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The gvfs-devel package contains headers and other files that are
57required to develop applications using gvfs.
58
59%package fuse
60Summary: FUSE support for gvfs
61Group: System Environment/Libraries
62Requires: %{name} = %{version}-%{release}
63BuildRequires: fuse-devel
64Requires: fuse
65
66%description fuse
67This package provides support for applications not using gio
68to access the gvfs filesystems.
69
70
71%package smb
72Summary: Windows fileshare support for gvfs
73Group: System Environment/Libraries
74Requires: %{name} = %{version}-%{release}
75BuildRequires: libsmbclient-devel
76
77%description smb
78This package provides support for reading and writing files on windows
79shares (SMB) to applications using gvfs.
80
81
82%package archive
83Summary: Archiving support for gvfs
84Group: System Environment/Libraries
85Requires: %{name} = %{version}-%{release}
86BuildRequires: libarchive-devel
87
88%description archive
89This package provides support for accessing files inside Zip and Tar archives,
90as well as ISO images, to applications using gvfs.
91
92
93%package obexftp
94Summary: ObexFTP support for gvfs
95Group: System Environment/Libraries
96Requires: %{name} = %{version}-%{release}
97BuildRequires: bluez-libs-devel >= 4.15
98BuildRequires: expat-devel
99
100%description obexftp
101This package provides support for reading files on Bluetooth mobile phones
102and devices through ObexFTP to applications using gvfs.
103
104
105%package gphoto2
106Summary: gphoto2 support for gvfs
107Group: System Environment/Libraries
108Requires: %{name} = %{version}-%{release}
109BuildRequires: libgphoto2-devel
110BuildRequires: libusb-devel
111BuildRequires: libexif-devel
112
113%description gphoto2
114This package provides support for reading and writing files on
115PTP based cameras (Picture Transfer Protocol) and MTP based
116media players (Media Transfer Protocol) to applications using gvfs.
117
118
119%package afc
120Summary: AFC support for gvfs
121Group: System Environment/Libraries
122Requires: %{name} = %{version}-%{release}
123Requires: usbmuxd
124BuildRequires: libimobiledevice-devel >= 0.9.7
125
126%description afc
127This package provides support for reading files on mobile devices
128including phones and music players to applications using gvfs.
129
130
131%package mtp
132Summary: MTP support for gvfs
133Group: System Environment/Libraries
134Requires: %{name}%{?_isa} = %{version}-%{release}
135BuildRequires: libmtp-devel >= 1.1.0
136
137%description mtp
138This package provides support for reading and writing files on
139MTP based devices (Media Transfer Protocol) to applications using gvfs.
140
141
142%package goa
143Summary: GOA support for gvfs
144Group: System Environment/Libraries
145Requires: %{name}%{?_isa} = %{version}-%{release}
146BuildRequires: gnome-online-accounts-devel >= 3.7.1
147
148%description goa
149This package provides seamless integration with gnome-online-accounts
150file services.
151
152
153%prep
154%setup -q
155%patch1 -p1 -b .archive-integration
156
157%build
158
159# Needed for gvfs-0.2.1-archive-integration.patch
160libtoolize --force  || :
161aclocal  || :
162autoheader  || :
163automake  || :
164autoconf  || :
165
166%configure \
167        --disable-hal \
168        --disable-gdu \
169        --enable-mtp
170make # %{?_smp_mflags}
171
172%install
173rm -rf $RPM_BUILD_ROOT
174make install DESTDIR=$RPM_BUILD_ROOT
175
176rm $RPM_BUILD_ROOT%{_libdir}/*.la
177rm $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.la
178
179%find_lang gvfs
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186# Reload .mount files:
187killall -USR1 gvfsd >&/dev/null || :
188# Update desktop files mime mappings:
189update-desktop-database &> /dev/null ||:
190update-gio-modules "$host" &> /dev/null || :
191
192%postun
193/sbin/ldconfig
194# Update desktop files mime mappings:
195update-desktop-database &> /dev/null ||:
196update-gio-modules "$host" &> /dev/null || :
197
198# Reload .mount files when single subpackage is installed:
199%post smb
200killall -USR1 gvfsd >&/dev/null || :
201%post archive
202killall -USR1 gvfsd >&/dev/null || :
203%post obexftp
204killall -USR1 gvfsd >&/dev/null || :
205%post gphoto2
206killall -USR1 gvfsd >&/dev/null || :
207%post afc
208killall -USR1 gvfsd >&/dev/null || :
209
210
211%files -f gvfs.lang
212%defattr(-, root, root, -)
213%doc AUTHORS COPYING NEWS README
214%dir %{_datadir}/gvfs
215%dir %{_datadir}/gvfs/mounts
216%{_datadir}/bash-completion/completions/gvfs
217%{_datadir}/gvfs/mounts/afp.mount
218%{_datadir}/gvfs/mounts/afp-browse.mount
219%{_datadir}/gvfs/mounts/sftp.mount
220%{_datadir}/gvfs/mounts/trash.mount
221%{_datadir}/gvfs/mounts/cdda.mount
222%{_datadir}/gvfs/mounts/computer.mount
223%{_datadir}/gvfs/mounts/dav.mount
224%{_datadir}/gvfs/mounts/dav+sd.mount
225%{_datadir}/gvfs/mounts/http.mount
226%{_datadir}/gvfs/mounts/localtest.mount
227%{_datadir}/gvfs/mounts/burn.mount
228%{_datadir}/gvfs/mounts/dns-sd.mount
229%{_datadir}/gvfs/mounts/network.mount
230%{_datadir}/gvfs/mounts/ftp.mount
231%{_datadir}/gvfs/mounts/recent.mount
232%{_datadir}/dbus-1/services/org.gtk.Private.UDisks2VolumeMonitor.service
233%{_datadir}/dbus-1/services/gvfs-daemon.service
234%{_datadir}/dbus-1/services/gvfs-metadata.service
235%{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
236%{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
237%{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
238%{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
239%{_libdir}/libgvfscommon.so.*
240%{_libdir}/gio/modules/libgioremote-volume-monitor.so
241%{_libdir}/gio/modules/libgvfsdbus.so
242%{_libexecdir}/gvfsd
243%{_libexecdir}/gvfsd-afp
244%{_libexecdir}/gvfsd-afp-browse
245%{_libexecdir}/gvfsd-ftp
246%{_libexecdir}/gvfsd-sftp
247%{_libexecdir}/gvfsd-trash
248%{_libexecdir}/gvfsd-cdda
249%{_libexecdir}/gvfsd-computer
250%{_libexecdir}/gvfsd-dav
251%{_libexecdir}/gvfsd-http
252%{_libexecdir}/gvfsd-localtest
253%{_libexecdir}/gvfsd-burn
254%{_libexecdir}/gvfsd-dnssd
255%{_libexecdir}/gvfsd-network
256%{_libexecdir}/gvfsd-metadata
257%{_libexecdir}/gvfsd-recent
258%{_libexecdir}/gvfs-udisks2-volume-monitor
259%{_bindir}/gvfs-cat
260%{_bindir}/gvfs-copy
261%{_bindir}/gvfs-info
262%{_bindir}/gvfs-less
263%{_bindir}/gvfs-ls
264%{_bindir}/gvfs-mime
265%{_bindir}/gvfs-mkdir
266%{_bindir}/gvfs-monitor-dir
267%{_bindir}/gvfs-monitor-file
268%{_bindir}/gvfs-mount
269%{_bindir}/gvfs-move
270%{_bindir}/gvfs-open
271%{_bindir}/gvfs-rename
272%{_bindir}/gvfs-rm
273%{_bindir}/gvfs-save
274%{_bindir}/gvfs-set-attribute
275%{_bindir}/gvfs-trash
276%{_bindir}/gvfs-tree
277%{_mandir}/man1/gvfs-cat.1.gz
278%{_mandir}/man1/gvfs-copy.1.gz
279%{_mandir}/man1/gvfs-info.1.gz
280%{_mandir}/man1/gvfs-ls.1.gz
281%{_mandir}/man1/gvfs-mime.1.gz
282%{_mandir}/man1/gvfs-mkdir.1.gz
283%{_mandir}/man1/gvfs-monitor-dir.1.gz
284%{_mandir}/man1/gvfs-monitor-file.1.gz
285%{_mandir}/man1/gvfs-mount.1.gz
286%{_mandir}/man1/gvfs-move.1.gz
287%{_mandir}/man1/gvfs-open.1.gz
288%{_mandir}/man1/gvfs-rename.1.gz
289%{_mandir}/man1/gvfs-rm.1.gz
290%{_mandir}/man1/gvfs-save.1.gz
291%{_mandir}/man1/gvfs-set-attribute.1.gz
292%{_mandir}/man1/gvfs-trash.1.gz
293%{_mandir}/man1/gvfs-tree.1.gz
294%{_mandir}/man1/gvfsd-metadata.1.gz
295%{_mandir}/man1/gvfsd.1.gz
296%{_mandir}/man7/gvfs.7.gz
297
298%files devel
299%defattr(-, root, root, -)
300%dir %{_includedir}/gvfs-client
301%dir %{_includedir}/gvfs-client/gvfs
302%{_includedir}/gvfs-client/gvfs/gvfsurimapper.h
303%{_includedir}/gvfs-client/gvfs/gvfsuriutils.h
304%{_libdir}/libgvfscommon.so
305
306
307%files fuse
308%defattr(-, root, root, -)
309%{_libexecdir}/gvfsd-fuse
310%{_mandir}/man1/gvfsd-fuse.1.gz
311
312
313%files smb
314%defattr(-, root, root, -)
315%{_libexecdir}/gvfsd-smb
316%{_libexecdir}/gvfsd-smb-browse
317%{_datadir}/gvfs/mounts/smb-browse.mount
318%{_datadir}/gvfs/mounts/smb.mount
319%{_datadir}/GConf/gsettings/gvfs-smb.convert
320%{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
321
322
323%files archive
324%defattr(-, root, root, -)
325%{_datadir}/applications/mount-archive.desktop
326%{_libexecdir}/gvfsd-archive
327%{_datadir}/gvfs/mounts/archive.mount
328
329
330%files obexftp
331%defattr(-, root, root, -)
332%{_libexecdir}/gvfsd-obexftp
333%{_datadir}/gvfs/mounts/obexftp.mount
334
335
336%files gphoto2
337%defattr(-, root, root, -)
338%{_libexecdir}/gvfsd-gphoto2
339%{_datadir}/gvfs/mounts/gphoto2.mount
340%{_libexecdir}/gvfs-gphoto2-volume-monitor
341%{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
342%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
343
344
345%files afc
346%defattr(-, root, root, -)
347%{_libexecdir}/gvfsd-afc
348%{_datadir}/gvfs/mounts/afc.mount
349%{_libexecdir}/gvfs-afc-volume-monitor
350%{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
351%{_datadir}/gvfs/remote-volume-monitors/afc.monitor
352
353
354%files mtp
355%defattr(-, root, root, -)
356%{_libexecdir}/gvfsd-mtp
357%{_datadir}/gvfs/mounts/mtp.mount
358%{_libexecdir}/gvfs-mtp-volume-monitor
359%{_datadir}/dbus-1/services/org.gtk.Private.MTPVolumeMonitor.service
360%{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
361
362
363%files goa
364%defattr(-, root, root, -)
365%{_libexecdir}/gvfs-goa-volume-monitor
366%{_datadir}/dbus-1/services/org.gtk.Private.GoaVolumeMonitor.service
367%{_datadir}/gvfs/remote-volume-monitors/goa.monitor
368
369
370
371%changelog
372* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.1-1
373- new upstream release
374- update Patch1 (gvfs-1.16.0-archive-integration.patch)
375- add BuildRequires: libmtp-devel, gnome-online-accounts
376- create %%{name}-mtp and %%{name}-goa subpackages
377
378* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-3
379- rebuild with libimobiledevice-1.1.5
380
381* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> 1.14.2-2
382- build with libgphoto2 2.5.0-1
383
384* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
385- new upstream release
386
387* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
388- new upstream release
389
390* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
391- new upstream release
392- add BuildRequires: libsecret-devel, gtk3-devel
393- remove BuildRequires: GConf2-devel
394
395* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-2
396- rebuild with libarchive-3.0.4
397
398* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-1
399- new upstream release
400
401* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
402- new upstream release
403
404* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
405- new upstream release
406- add BuildRequires: udisks2-devel
407- remove BuildRequires: gnome-disk-utility-devel
408
409* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
410- new upstream release
411
412* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
413- new upstream release
414
415* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.5-1
416- new upstream release
417
418* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.4-1
419- new upstream release
420
421* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.3-1
422- new upstream release
423
424* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2-1
425- new upstream release
426- add Provides: and Obsoletes: gnome-mount
427
428* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
429- new upstream release
430
431* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
432- new upstream release
433- drop Patch2
434
435* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-2
436- add Patch2 (gvfs-1.6.4-sftp-timeout.patch)
437
438* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
439- new upstream release
440
441* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
442- new upstream release
443
444* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
445- new upstream release
446
447* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
448- rebuilt with libcdio-0.82
449
450* Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-2
451- add configure option --enable-gdu
452- add BR: gnome-disk-utility-devel
453- add afc subpackage for new AFC backend,
454  providing access to Apple's iPhone, and iPod Touch devices
455
456* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
457- new upstream release
458
459* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
460- new upstream release
461- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
462- change BuildRequires: hal-devel -> ibgudev1-devel
463- add configure option (--disable-hal)
464
465* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
466- new upstream release
467
468* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-1
469- new upstream release
470
471* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-2
472- new upstream release
473
474* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
475- new upstream release
476
477* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-2
478- new upstream release
479
480* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
481- new upstream release
482- BR: bluez-libs-devel >= 4.15
483
484* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.1-2
485- rebuild with bluez-libs-devel-4.15
486
487* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
488- new upstream release
489
490* Mon Sep 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
491- new upstream release
492
493* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.6-1
494- new upstream release
495- split out backends to sub packages
496
497* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
498- new upstream release
499
500* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.3-1vl5
501- new upstream release
502
503* Wed Apr  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.2-1vl5
504- Initial build for Vine Linux
505
506* Fri Mar 28 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.2-1
507- Update to 0.2.2
508
509* Tue Mar 25 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-4
510- Moved fuse stuff to a dedicated package
511
512* Thu Mar 20 2008 Alexander Larsson <alexl@redhat.com> - 0.2.1-3
513- Add patch with simple archive backend UI integration
514
515* Wed Mar 19 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-2
516- Added libarchive dependency for archive backend
517- Require new libsmbclient in order to get smb backend working again
518
519* Tue Mar 18 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-1
520- Update to 0.2.1 (archive backend temporarily disabled)
521
522* Mon Mar 17 2008 Matthias Clasen  <mclasen@redhat.com> - 0.2.0.1-2
523- Silence %%post
524
525* Mon Mar 10 2008 Matthias Clasen  <mclasen@redhat.com> - 0.2.0.1-1
526- Update to 0.2.0.1
527
528* Thu Mar  6 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.1.11-2
529- Add patch that fixes a deadlock when foreign volume is removed
530
531* Tue Mar  4 2008 Matthias Clasen  <mclasen@redhat.com> - 0.1.11-1
532- Update to 0.1.11
533
534* Tue Mar 04 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.1.10-1
535- Update to 0.1.10
536
537* Mon Feb 25 2008 Alexander Larsson <alexl@redhat.com> - 0.1.8-1
538- Update to 0.1.8
539
540* Thu Feb 14 2008 Alexander Larsson <alexl@redhat.com> - 0.1.7-3
541- Add patch that fixes a smb bug that can cause short reads when copying files
542
543* Tue Feb 12 2008 Alexander Larsson <alexl@redhat.com> - 0.1.7-2
544- Fix double free in hal volume monitor
545- Ensure gconf module is built by adding build dep
546
547* Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
548- Update to 0.1.7
549
550* Tue Jan 29 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.6-1
551- Update to 0.1.6
552
553* Mon Jan 28 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.5-1
554- Update to 0.1.5
555- Reenable http/dav
556
557* Mon Jan 21 2008 Alexander Larsson <alexl@redhat.com> - 0.1.4-2
558- Remove the http/dav stuff for now, as we don't have the latest libsoup
559
560* Mon Jan 21 2008 Alexander Larsson <alexl@redhat.com> - 0.1.4-1
561- Update to 0.1.4
562- Send USR1 in post to reload config
563
564* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> 0.1.2-1
565- Update to 0.1.2
566
567* Tue Jan  8 2008 Matthias Clasen <mclasen@redhat.com> 0.1.1-1
568- Update to 0.1.1
569
570* Thu Dec 20 2007 Matthias Clasen <mclasen@redhat.com> 0.1.0-1
571- Initial packaging
Note: See TracBrowser for help on using the repository browser.