source: projects/specs/trunk/g/gvfs/gvfs-vl.spec @ 6951

Revision 6951, 14.6 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

Line 
1Summary: Backends for the gio framework in GLib
2Summary(ja): GLib の GIO フレームワークのバックエンド
3Name: gvfs
4Version: 1.14.1
5Release: 1%{?_dist_release}
6License: LGPLv2+
7Group: System Environment/Libraries
8URL: http://www.gtk.org
9Source: http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.14/%{name}-%{version}.tar.xz
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: pkgconfig
13BuildRequires: glib2-devel >= 2.24.0
14BuildRequires: gtk3-devel
15BuildRequires: dbus-glib-devel
16BuildRequires: /usr/bin/ssh
17BuildRequires: libcdio-devel >= 0.78.2
18BuildRequires: libsoup-devel >= 2.30.0
19BuildRequires: avahi-glib-devel >= 0.6
20BuildRequires: libgnome-keyring-devel
21BuildRequires: intltool
22BuildRequires: gettext
23BuildRequires: perl-XML-Parser
24BuildRequires: libgudev1-devel
25BuildRequires: udisks2-devel
26BuildRequires: libsecret-devel
27
28Requires(post): desktop-file-utils
29Requires(postun): desktop-file-utils
30
31# The patch touches Makefile.am files:
32BuildRequires: automake autoconf
33BuildRequires: libtool
34
35Provides: gnome-mount < 0.9
36Obsoletes: gnome-mount < 0.9
37
38Patch1: gvfs-0.99.2-archive-integration.patch
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: Takemikaduchi
43
44%description
45The gvfs package provides backend implementations for the gio
46framework in GLib. It includes ftp, sftp, cifs.
47
48%package devel
49Summary: Development files for gvfs
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54The gvfs-devel package contains headers and other files that are
55required to develop applications using gvfs.
56
57%package fuse
58Summary: FUSE support for gvfs
59Group: System Environment/Libraries
60Requires: %{name} = %{version}-%{release}
61BuildRequires: fuse-devel
62Requires: fuse
63
64%description fuse
65This package provides support for applications not using gio
66to access the gvfs filesystems.
67
68
69%package smb
70Summary: Windows fileshare support for gvfs
71Group: System Environment/Libraries
72Requires: %{name} = %{version}-%{release}
73BuildRequires: libsmbclient-devel
74
75%description smb
76This package provides support for reading and writing files on windows
77shares (SMB) to applications using gvfs.
78
79
80%package archive
81Summary: Archiving support for gvfs
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84BuildRequires: libarchive-devel
85
86%description archive
87This package provides support for accessing files inside Zip and Tar archives,
88as well as ISO images, to applications using gvfs.
89
90
91%package obexftp
92Summary: ObexFTP support for gvfs
93Group: System Environment/Libraries
94Requires: %{name} = %{version}-%{release}
95BuildRequires: bluez-libs-devel >= 4.15
96BuildRequires: expat-devel
97
98%description obexftp
99This package provides support for reading files on Bluetooth mobile phones
100and devices through ObexFTP to applications using gvfs.
101
102
103%package gphoto2
104Summary: gphoto2 support for gvfs
105Group: System Environment/Libraries
106Requires: %{name} = %{version}-%{release}
107BuildRequires: libgphoto2-devel
108BuildRequires: libusb-devel
109BuildRequires: libexif-devel
110
111%description gphoto2
112This package provides support for reading and writing files on
113PTP based cameras (Picture Transfer Protocol) and MTP based
114media players (Media Transfer Protocol) to applications using gvfs.
115
116
117%package afc
118Summary: AFC support for gvfs
119Group: System Environment/Libraries
120Requires: %{name} = %{version}-%{release}
121Requires: usbmuxd
122BuildRequires: libimobiledevice-devel >= 0.9.7
123
124%description afc
125This package provides support for reading files on mobile devices
126including phones and music players to applications using gvfs.
127
128
129%prep
130%setup -q
131%patch1 -p0 -b .archive-integration
132
133%build
134
135# Needed for gvfs-0.2.1-archive-integration.patch
136libtoolize --force  || :
137aclocal  || :
138autoheader  || :
139automake  || :
140autoconf  || :
141
142%configure --disable-hal --enable-gdu
143make # %{?_smp_mflags}
144
145%install
146rm -rf $RPM_BUILD_ROOT
147make install DESTDIR=$RPM_BUILD_ROOT
148
149rm $RPM_BUILD_ROOT%{_libdir}/*.la
150rm $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.la
151
152%find_lang gvfs
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159# Reload .mount files:
160killall -USR1 gvfsd >&/dev/null || :
161# Update desktop files mime mappings:
162update-desktop-database &> /dev/null ||:
163update-gio-modules "$host" &> /dev/null || :
164
165%postun
166/sbin/ldconfig
167# Update desktop files mime mappings:
168update-desktop-database &> /dev/null ||:
169update-gio-modules "$host" &> /dev/null || :
170
171# Reload .mount files when single subpackage is installed:
172%post smb
173killall -USR1 gvfsd >&/dev/null || :
174%post archive
175killall -USR1 gvfsd >&/dev/null || :
176%post obexftp
177killall -USR1 gvfsd >&/dev/null || :
178%post gphoto2
179killall -USR1 gvfsd >&/dev/null || :
180%post afc
181killall -USR1 gvfsd >&/dev/null || :
182
183
184%files -f gvfs.lang
185%defattr(-, root, root, -)
186%doc AUTHORS COPYING NEWS README
187%dir %{_datadir}/gvfs
188%dir %{_datadir}/gvfs/mounts
189%{_datadir}/bash-completion/completions/gvfs
190%{_datadir}/gvfs/mounts/afp.mount
191%{_datadir}/gvfs/mounts/afp-browse.mount
192%{_datadir}/gvfs/mounts/sftp.mount
193%{_datadir}/gvfs/mounts/trash.mount
194%{_datadir}/gvfs/mounts/cdda.mount
195%{_datadir}/gvfs/mounts/computer.mount
196%{_datadir}/gvfs/mounts/dav.mount
197%{_datadir}/gvfs/mounts/dav+sd.mount
198%{_datadir}/gvfs/mounts/http.mount
199%{_datadir}/gvfs/mounts/localtest.mount
200%{_datadir}/gvfs/mounts/burn.mount
201%{_datadir}/gvfs/mounts/dns-sd.mount
202%{_datadir}/gvfs/mounts/network.mount
203%{_datadir}/gvfs/mounts/ftp.mount
204%{_datadir}/gvfs/mounts/recent.mount
205%{_datadir}/dbus-1/services/org.gtk.Private.UDisks2VolumeMonitor.service
206%{_datadir}/dbus-1/services/gvfs-daemon.service
207%{_datadir}/dbus-1/services/gvfs-metadata.service
208%{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
209%{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
210%{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
211%{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
212%{_libdir}/libgvfscommon.so.*
213%{_libdir}/gio/modules/libgioremote-volume-monitor.so
214%{_libdir}/gio/modules/libgvfsdbus.so
215%{_libexecdir}/gvfsd
216%{_libexecdir}/gvfsd-afp
217%{_libexecdir}/gvfsd-afp-browse
218%{_libexecdir}/gvfsd-ftp
219%{_libexecdir}/gvfsd-sftp
220%{_libexecdir}/gvfsd-trash
221%{_libexecdir}/gvfsd-cdda
222%{_libexecdir}/gvfsd-computer
223%{_libexecdir}/gvfsd-dav
224%{_libexecdir}/gvfsd-http
225%{_libexecdir}/gvfsd-localtest
226%{_libexecdir}/gvfsd-burn
227%{_libexecdir}/gvfsd-dnssd
228%{_libexecdir}/gvfsd-network
229%{_libexecdir}/gvfsd-metadata
230%{_libexecdir}/gvfsd-recent
231%{_libexecdir}/gvfs-udisks2-volume-monitor
232%{_bindir}/gvfs-cat
233%{_bindir}/gvfs-copy
234%{_bindir}/gvfs-info
235%{_bindir}/gvfs-less
236%{_bindir}/gvfs-ls
237%{_bindir}/gvfs-mime
238%{_bindir}/gvfs-mkdir
239%{_bindir}/gvfs-monitor-dir
240%{_bindir}/gvfs-monitor-file
241%{_bindir}/gvfs-mount
242%{_bindir}/gvfs-move
243%{_bindir}/gvfs-open
244%{_bindir}/gvfs-rename
245%{_bindir}/gvfs-rm
246%{_bindir}/gvfs-save
247%{_bindir}/gvfs-set-attribute
248%{_bindir}/gvfs-trash
249%{_bindir}/gvfs-tree
250%{_mandir}/man1/gvfs-cat.1.gz
251%{_mandir}/man1/gvfs-copy.1.gz
252%{_mandir}/man1/gvfs-info.1.gz
253%{_mandir}/man1/gvfs-ls.1.gz
254%{_mandir}/man1/gvfs-mime.1.gz
255%{_mandir}/man1/gvfs-mkdir.1.gz
256%{_mandir}/man1/gvfs-monitor-dir.1.gz
257%{_mandir}/man1/gvfs-monitor-file.1.gz
258%{_mandir}/man1/gvfs-mount.1.gz
259%{_mandir}/man1/gvfs-move.1.gz
260%{_mandir}/man1/gvfs-open.1.gz
261%{_mandir}/man1/gvfs-rename.1.gz
262%{_mandir}/man1/gvfs-rm.1.gz
263%{_mandir}/man1/gvfs-save.1.gz
264%{_mandir}/man1/gvfs-set-attribute.1.gz
265%{_mandir}/man1/gvfs-trash.1.gz
266%{_mandir}/man1/gvfs-tree.1.gz
267%{_mandir}/man1/gvfsd-metadata.1.gz
268%{_mandir}/man1/gvfsd.1.gz
269%{_mandir}/man7/gvfs.7.gz
270
271%files devel
272%defattr(-, root, root, -)
273%dir %{_includedir}/gvfs-client
274%dir %{_includedir}/gvfs-client/gvfs
275%{_includedir}/gvfs-client/gvfs/gvfsurimapper.h
276%{_includedir}/gvfs-client/gvfs/gvfsuriutils.h
277%{_libdir}/libgvfscommon.so
278
279
280%files fuse
281%defattr(-, root, root, -)
282%{_libexecdir}/gvfsd-fuse
283%{_mandir}/man1/gvfsd-fuse.1.gz
284
285
286%files smb
287%defattr(-, root, root, -)
288%{_libexecdir}/gvfsd-smb
289%{_libexecdir}/gvfsd-smb-browse
290%{_datadir}/gvfs/mounts/smb-browse.mount
291%{_datadir}/gvfs/mounts/smb.mount
292%{_datadir}/GConf/gsettings/gvfs-smb.convert
293%{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
294
295
296%files archive
297%defattr(-, root, root, -)
298%dir %{_datadir}/applications/mount-archive.desktop
299%{_libexecdir}/gvfsd-archive
300%{_datadir}/gvfs/mounts/archive.mount
301
302
303%files obexftp
304%defattr(-, root, root, -)
305%{_libexecdir}/gvfsd-obexftp
306%{_datadir}/gvfs/mounts/obexftp.mount
307
308
309%files gphoto2
310%defattr(-, root, root, -)
311%{_libexecdir}/gvfsd-gphoto2
312%{_datadir}/gvfs/mounts/gphoto2.mount
313%{_libexecdir}/gvfs-gphoto2-volume-monitor
314%{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
315%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
316
317
318%files afc
319%defattr(-, root, root, -)
320%{_libexecdir}/gvfsd-afc
321%{_datadir}/gvfs/mounts/afc.mount
322%{_libexecdir}/gvfs-afc-volume-monitor
323%{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
324%{_datadir}/gvfs/remote-volume-monitors/afc.monitor
325
326
327%changelog
328* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
329- new upstream release
330
331* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
332- new upstream release
333- add BuildRequires: libsecret-devel, gtk3-devel
334- remove BuildRequires: GConf2-devel
335
336* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-2
337- rebuild with libarchive-3.0.4
338
339* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-1
340- new upstream release
341
342* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
343- new upstream release
344
345* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
346- new upstream release
347- add BuildRequires: udisks2-devel
348- remove BuildRequires: gnome-disk-utility-devel
349
350* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
351- new upstream release
352
353* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
354- new upstream release
355
356* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.5-1
357- new upstream release
358
359* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.4-1
360- new upstream release
361
362* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.3-1
363- new upstream release
364
365* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2-1
366- new upstream release
367- add Provides: and Obsoletes: gnome-mount
368
369* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
370- new upstream release
371
372* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
373- new upstream release
374- drop Patch2
375
376* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-2
377- add Patch2 (gvfs-1.6.4-sftp-timeout.patch)
378
379* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
380- new upstream release
381
382* Sun Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
383- new upstream release
384
385* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
386- new upstream release
387
388* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
389- rebuilt with libcdio-0.82
390
391* Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-2
392- add configure option --enable-gdu
393- add BR: gnome-disk-utility-devel
394- add afc subpackage for new AFC backend,
395  providing access to Apple's iPhone, and iPod Touch devices
396
397* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
398- new upstream release
399
400* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
401- new upstream release
402- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
403- change BuildRequires: hal-devel -> ibgudev1-devel
404- add configure option (--disable-hal)
405
406* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
407- new upstream release
408
409* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-1
410- new upstream release
411
412* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-2
413- new upstream release
414
415* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
416- new upstream release
417
418* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-2
419- new upstream release
420
421* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
422- new upstream release
423- BR: bluez-libs-devel >= 4.15
424
425* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.1-2
426- rebuild with bluez-libs-devel-4.15
427
428* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
429- new upstream release
430
431* Mon Sep 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
432- new upstream release
433
434* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.6-1
435- new upstream release
436- split out backends to sub packages
437
438* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
439- new upstream release
440
441* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.3-1vl5
442- new upstream release
443
444* Wed Apr  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.2-1vl5
445- Initial build for Vine Linux
446
447* Fri Mar 28 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.2-1
448- Update to 0.2.2
449
450* Tue Mar 25 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-4
451- Moved fuse stuff to a dedicated package
452
453* Thu Mar 20 2008 Alexander Larsson <alexl@redhat.com> - 0.2.1-3
454- Add patch with simple archive backend UI integration
455
456* Tue Mar 19 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-2
457- Added libarchive dependency for archive backend
458- Require new libsmbclient in order to get smb backend working again
459
460* Tue Mar 18 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-1
461- Update to 0.2.1 (archive backend temporarily disabled)
462
463* Mon Mar 17 2008 Matthias Clasen  <mclasen@redhat.com> - 0.2.0.1-2
464- Silence %%post
465
466* Mon Mar 10 2008 Matthias Clasen  <mclasen@redhat.com> - 0.2.0.1-1
467- Update to 0.2.0.1
468
469* Thu Mar  6 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.1.11-2
470- Add patch that fixes a deadlock when foreign volume is removed
471
472* Tue Mar  4 2008 Matthias Clasen  <mclasen@redhat.com> - 0.1.11-1
473- Update to 0.1.11
474
475* Tue Mar 04 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.1.10-1
476- Update to 0.1.10
477
478* Mon Feb 25 2008 Alexander Larsson <alexl@redhat.com> - 0.1.8-1
479- Update to 0.1.8
480
481* Thu Feb 14 2008 Alexander Larsson <alexl@redhat.com> - 0.1.7-3
482- Add patch that fixes a smb bug that can cause short reads when copying files
483
484* Tue Feb 12 2008 Alexander Larsson <alexl@redhat.com> - 0.1.7-2
485- Fix double free in hal volume monitor
486- Ensure gconf module is built by adding build dep
487
488* Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
489- Update to 0.1.7
490
491* Tue Jan 29 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.6-1
492- Update to 0.1.6
493
494* Mon Jan 28 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.5-1
495- Update to 0.1.5
496- Reenable http/dav
497
498* Mon Jan 21 2008 Alexander Larsson <alexl@redhat.com> - 0.1.4-2
499- Remove the http/dav stuff for now, as we don't have the latest libsoup
500
501* Mon Jan 21 2008 Alexander Larsson <alexl@redhat.com> - 0.1.4-1
502- Update to 0.1.4
503- Send USR1 in post to reload config
504
505* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> 0.1.2-1
506- Update to 0.1.2
507
508* Tue Jan  8 2008 Matthias Clasen <mclasen@redhat.com> 0.1.1-1
509- Update to 0.1.1
510
511* Thu Dec 20 2007 Matthias Clasen <mclasen@redhat.com> 0.1.0-1
512- Initial packaging
Note: See TracBrowser for help on using the repository browser.