source: projects/specs/trunk/g/guile18/guile18-vl.spec @ 9686

Revision 9686, 11.5 KB checked in by Takemikaduchi, 9 years ago (diff)

gnome-phone-manager: update
others: rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define mver 1.8
3
4Name: guile18
5Summary: A GNU implementation of Scheme for application extensibility.
6Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
7Version: 1.8.8
8Release: 3%{?_dist_release}
9
10Group: Development/Languages
11License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
12URL: http://www.gnu.org/software/guile/
13
14Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
15
16# following patchs are imported from fedora-dev
17Patch1: guile-1.8.7-multilib.patch
18Patch2: guile-1.8.7-testsuite.patch
19Patch4: guile-1.8.6-deplibs.patch
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
23BuildRequires: gmp-devel readline-devel emacs
24Requires(post): /sbin/install-info
25Requires(preun): /sbin/install-info
26Requires: coreutils
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30Packager:       yasumichi, Takemikaduchi
31
32%description
33GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
34implementation of the Scheme programming language, written in C.  GUILE
35provides a machine-independent execution platform that can be linked in
36as a library during the building of extensible programs.
37
38Install the guile package if you'd like to add extensibility to programs
39that you are developing.
40
41%package devel
42Summary: Libraries and header files for the GUILE extensibility library.
43Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: gmp-devel
47
48%description devel
49The guile-devel package includes the libraries, header files, etc.,
50that you'll need to develop applications that are linked with the
51GUILE extensibility library.
52
53You need to install the guile-devel package if you want to develop
54applications that will be linked to GUILE.  You'll also need to
55install the guile package.
56
57%package -n compat32-%{name}
58Summary: A GNU implementation of Scheme for application extensibility.
59Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
60Group: Development/Languages
61Requires: %{name} = %{version}-%{release}
62
63%description -n compat32-%{name}
64GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
65implementation of the Scheme programming language, written in C.  GUILE
66provides a machine-independent execution platform that can be linked in
67as a library during the building of extensible programs.
68
69Install the guile package if you'd like to add extensibility to programs
70that you are developing.
71
72%package -n compat32-%{name}-devel
73Summary: Libraries and header files for the GUILE extensibility library.
74Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77Requires: compat32-%{name} = %{version}-%{release}
78Requires: compat32-gmp-devel
79
80%description -n compat32-%{name}-devel
81The guile-devel package includes the libraries, header files, etc.,
82that you'll need to develop applications that are linked with the
83GUILE extensibility library.
84
85You need to install the guile-devel package if you want to develop
86applications that will be linked to GUILE.  You'll also need to
87install the guile package.
88
89%prep
90%setup -q -n guile-%{version}
91%patch1 -p1 -b .multilib
92%patch2 -p1 -b .testsuite
93%patch4 -p1 -b .deplibs
94
95%build
96%configure --disable-static --disable-error-on-warning
97
98# Remove RPATH
99sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
100    {,guile-readline/}libtool
101
102make %{?_smp_mflags}
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108make DESTDIR=$RPM_BUILD_ROOT install
109
110mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site
111
112rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
113rm -f $RPM_BUILD_ROOT%{_infodir}/dir
114
115# Compress large documentation
116bzip2 NEWS
117
118for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
119    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
120done
121
122touch $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slibcat
123ln -s ../../slib $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slib
124
125# rename file
126mv $RPM_BUILD_ROOT%{_bindir}/guile $RPM_BUILD_ROOT%{_bindir}/guile-%{mver}
127mv $RPM_BUILD_ROOT%{_bindir}/guile-tools $RPM_BUILD_ROOT%{_bindir}/guile-tools-%{mver}
128mv $RPM_BUILD_ROOT%{_bindir}/guile-config $RPM_BUILD_ROOT%{_bindir}/guile-config-%{mver}
129mv $RPM_BUILD_ROOT%{_bindir}/guile-snarf $RPM_BUILD_ROOT%{_bindir}/guile-snarf-%{mver}
130
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post -p /sbin/ldconfig
136
137%postun -p /sbin/ldconfig
138
139%post -n compat32-%{name} -p /sbin/ldconfig
140
141%postun -n compat32-%{name} -p /sbin/ldconfig
142
143%files
144%defattr(-,root,root,-)
145%doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
146%{_bindir}/guile-%{mver}
147%{_bindir}/guile-tools-%{mver}
148%{_libdir}/libguile*.so.*
149%{_libdir}/libguilereadline-*.so
150%{_libdir}/libguile-srfi-srfi-*.so
151%dir %{_datadir}/guile/%{mver}
152%{_datadir}/guile/%{mver}/ice-9
153%{_datadir}/guile/%{mver}/lang
154%{_datadir}/guile/%{mver}/oop
155%{_datadir}/guile/%{mver}/scripts
156%{_datadir}/guile/%{mver}/srfi
157%{_datadir}/guile/%{mver}/guile-procedures.txt
158%ghost %{_datadir}/guile/%{mver}/slibcat
159%ghost %{_datadir}/guile/%{mver}/slib
160%exclude %{_infodir}/*
161%exclude %{_mandir}/man1/guile.1*
162
163%files devel
164%defattr(-,root,root,-)
165%{_bindir}/guile-config-%{mver}
166%{_bindir}/guile-snarf-%{mver}
167%{_libdir}/libguile.so
168%{_libdir}/pkgconfig/*.pc
169%{_includedir}/guile
170%{_includedir}/libguile
171%{_includedir}/libguile.h
172%exclude %{_datadir}/aclocal/*
173
174# compat32
175%if %{build_compat32}
176%files -n compat32-%{name}
177%defattr(-,root,root,-)
178%{_libdir}/libguile*.so.*
179%{_libdir}/libguilereadline-*.so
180%{_libdir}/libguile-srfi-srfi-*.so
181
182%files -n compat32-%{name}-devel
183%defattr(-,root,root,-)
184%{_libdir}/libguile.so
185%endif
186
187%changelog
188* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-3
189- rebuild with readline-6.3
190
191* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-2
192- rename package (guile18)
193
194
195* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
196- update to 1.8.8
197- remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
198
199* Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
200- rebuilt with rpm-4.8.1
201- added Patch1, 2, 3, 5 and 6 from Fedora
202
203* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
204- new upstream release.
205- comment out Patch11,12.
206
207* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
208- added Requires: gmp-devel to guile-devel
209
210* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
211- added compat32 package for x86_64 arch support
212
213* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
214- rebuild with libtool-2.2.6a
215
216* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
217- new upstream release
218- import some patches from fedora development
219- drop some old patches
220- update spec based on fedora package
221- spec in utf-8
222
223* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
224- use macro for Release
225
226* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
227- apply new virsioning policy.
228- remove *.la
229
230* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
231- rebuilt with readline 5.1
232
233* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
234- added Patches from Fedora
235  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
236  - Fix dynamic linking on 64bit archs (#159971)
237  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
238  - Moved info files to base package as they are not devel related (#139948)
239  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
240  - Fixed guile-tools not finding guile lib dir (#142642)
241  - Added some nice tools (#142642)
242  - Removed smp build, seems to be broken atm
243
244* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
245- new upstream release
246- dropped patch2, 4, 6
247- added BuildPrereq: perl
248
249* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
250- rebuild with new toolchains
251- s/Copyright/License/
252- added srfi libs
253- patch for ppc64 from Fedora package
254
255* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
256- update to 1.6.4
257
258* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
259- rebuild with readline-4.3
260
261* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
262- based on Rawhide 1.6.0-4
263  - Included s390 as working arch as well, switch to general unknown arch patch
264  - rebuild to fix broken deps
265  - fix continuations.h on ia64
266- new upstream 1.6.3
267
268* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
269- porting for Vine Linux
270- remove 1.3 patches( not required  so that upstream upgrade )
271
272* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
273- Add version number to prereq for umb-scheme to get the post-install to
274  work properly.
275
276* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
277- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
278
279* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
280- automatic rebuild
281
282* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
283- Back down to 1.3.4.
284- Fix to actually link against the version of libguile in the package.
285
286* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
287- FHS fixups using the %%{makeinstall} macro.
288
289* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
290- fix preun-devel
291- call ldconfig directly in postun
292
293* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
294- rebuild with new readline
295- update to 1.3.4
296
297* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
298- using the same catalog as umb-scheme makes umb-scheme a prereq
299
300* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
301- readline is needed for %post
302
303* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
304- use the same catalog as umb-scheme
305
306* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
307- fix broken %postun
308
309* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
310- auto rebuild in the new build environment (release 6)
311
312* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
313- added .ansi patch to fix #endif
314
315* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
316- add patch for the scm stuff
317
318* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
319- integrate changes from rhcn version (#640)
320
321* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
322- call libtoolize first to get it to compile on the arm
323
324* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
325- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
326
327* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
328- guile-devel does depend on guile
329- remove devel dependancy on m4
330- move guile-snarf from guile to guile-devel
331- Converted to rhcn
332
333* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
334- update to 1.3.
335- don't strip libguile.so.*.0.0. (but set the execute bits).
336
337* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
338- spec file fixups
339
340* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
341- Updated for RH 5.2
342
343* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
344- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
345- added slib link
346
347* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
348- added %attr(-, root, root) for %doc,
349- in %post, %postun ldconfig runed as parameter "-p",
350- removed /bin/sh from requires,
351- added %description,
352- changes in %files.
353
354* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
355- all rewrited for using Buildroot,
356- added %postun,
357- removed making buid logs,
358- removed "--inclededir", added "--enable-dynamic-linking" to configure
359  parameters,
360- added striping shared libs and /usr/bin/guile,
361- added "Requires: /bin/sh" (for guile-snarf) in guile package and
362  "Requires: m4" for guile-devel,
363- added macro %{PACKAGE_VERSION} in "Source:" and %files,
364- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.