source: projects/specs/trunk/g/guile/guile-vl.spec @ 9467

Revision 9467, 11.6 KB checked in by inagaki, 9 years ago (diff)

2015-03-24 Ryoichi INAGAKI <ryo1@…>

  • bind, guild, js, unixODBC: rebuilt
  • ed: updated


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define mver 2.0
3
4Name: guile
5Summary: A GNU implementation of Scheme for application extensibility.
6Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
7Version: 2.0.11
8Release: 2%{?_dist_release}
9
10Group: Development/Languages
11License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
12URL: http://www.gnu.org/software/guile/
13
14Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
15
16# following patchs are imported from fedora-dev
17Patch1: guile-1.8.7-multilib.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
21BuildRequires: gmp-devel readline-devel emacs
22BuildRequires: libunistring-devel
23BuildRequires: libffi-devel
24BuildRequires: gc-devel
25Requires(post): /sbin/install-info
26Requires(preun): /sbin/install-info
27Requires: coreutils
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31Packager:       yasumichi
32
33%description
34GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
35implementation of the Scheme programming language, written in C.  GUILE
36provides a machine-independent execution platform that can be linked in
37as a library during the building of extensible programs.
38
39Install the guile package if you'd like to add extensibility to programs
40that you are developing.
41
42%package devel
43Summary: Libraries and header files for the GUILE extensibility library.
44Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: gmp-devel
48Requires: gc-devel
49
50%description devel
51The guile-devel package includes the libraries, header files, etc.,
52that you'll need to develop applications that are linked with the
53GUILE extensibility library.
54
55You need to install the guile-devel package if you want to develop
56applications that will be linked to GUILE.  You'll also need to
57install the guile package.
58
59%package -n compat32-%{name}
60Summary: A GNU implementation of Scheme for application extensibility.
61Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
62Group: System Environment/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description -n compat32-%{name}
66GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
67implementation of the Scheme programming language, written in C.  GUILE
68provides a machine-independent execution platform that can be linked in
69as a library during the building of extensible programs.
70
71Install the guile package if you'd like to add extensibility to programs
72that you are developing.
73
74%package -n compat32-%{name}-devel
75Summary: Libraries and header files for the GUILE extensibility library.
76Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79Requires: compat32-%{name} = %{version}-%{release}
80Requires: compat32-gmp-devel
81Requires: compat32-gc-devel
82
83%description -n compat32-%{name}-devel
84The guile-devel package includes the libraries, header files, etc.,
85that you'll need to develop applications that are linked with the
86GUILE extensibility library.
87
88You need to install the guile-devel package if you want to develop
89applications that will be linked to GUILE.  You'll also need to
90install the guile package.
91
92%prep
93%setup -q
94%patch1 -p1 -b .multilib
95
96%build
97%configure --disable-static --disable-error-on-warning
98
99# Remove RPATH
100sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
101    libtool
102
103make %{?_smp_mflags}
104
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109make DESTDIR=$RPM_BUILD_ROOT install
110
111mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}
112
113rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
114rm -f $RPM_BUILD_ROOT%{_infodir}/dir
115
116# Our gdb doesn't support guile yet
117rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*gdb.scm
118
119# Compress large documentation
120bzip2 NEWS
121
122for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
123    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
124done
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130/sbin/ldconfig
131/sbin/install-info  %{_infodir}/guile.info.gz %{_infodir}/dir
132/sbin/install-info  %{_infodir}/r5rs.info.gz %{_infodir}/dir
133
134%postun -p /sbin/ldconfig
135
136%preun
137if [ "$1" = 0 ]; then
138    /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
139    /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
140fi
141:
142
143%if %{build_compat32}
144%post -n compat32-%{name} -p /sbin/ldconfig
145
146%postun -n compat32-%{name} -p /sbin/ldconfig
147%endif
148
149%files
150%defattr(-,root,root,-)
151%doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
152%{_bindir}/guild
153%{_bindir}/guile
154%{_bindir}/guile-tools
155%{_libdir}/libguile*.so.*
156%{_libdir}/libguilereadline-*.so
157%dir %{_libdir}/guile/%{mver}
158%{_libdir}/guile/%{mver}/ccache
159%dir %{_datadir}/guile
160%dir %{_datadir}/guile/%{mver}
161%{_datadir}/guile/%{mver}/*.scm
162%{_datadir}/guile/%{mver}/ice-9
163%{_datadir}/guile/%{mver}/language
164%{_datadir}/guile/%{mver}/oop
165%{_datadir}/guile/%{mver}/rnrs
166%{_datadir}/guile/%{mver}/scripts
167%{_datadir}/guile/%{mver}/srfi
168%{_datadir}/guile/%{mver}/sxml
169%{_datadir}/guile/%{mver}/system
170%{_datadir}/guile/%{mver}/texinfo
171%{_datadir}/guile/%{mver}/web
172%{_datadir}/guile/%{mver}/guile-procedures.txt
173%dir %{_datadir}/guile/site
174%{_infodir}/*
175%{_mandir}/man1/guile.1*
176
177%files devel
178%defattr(-,root,root,-)
179%{_bindir}/guile-config
180%{_bindir}/guile-snarf
181%{_datadir}/aclocal/*
182%{_libdir}/libguile-%{mver}.so
183%{_libdir}/pkgconfig/*.pc
184%{_includedir}/guile/%{mver}
185
186# compat32
187%if %{build_compat32}
188%files -n compat32-%{name}
189%defattr(-,root,root,-)
190%{_libdir}/libguile*.so.*
191%{_libdir}/libguilereadline-*.so
192
193%files -n compat32-%{name}-devel
194%defattr(-,root,root,-)
195%{_libdir}/libguile-%{mver}.so
196%endif
197
198%changelog
199* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.11-2
200- rebuilt with readline 6.3
201
202* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.11-1
203- update to 2.0.11
204- add BuildRequires: libunistring-devel, libffi-devel, gc-devel
205- remove Patch2,4
206
207* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
208- update to 1.8.8
209- remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
210
211* Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
212- rebuilt with rpm-4.8.1
213- added Patch1, 2, 3, 5 and 6 from Fedora
214
215* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
216- new upstream release.
217- comment out Patch11,12.
218
219* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
220- added Requires: gmp-devel to guile-devel
221
222* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
223- added compat32 package for x86_64 arch support
224
225* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
226- rebuild with libtool-2.2.6a
227
228* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
229- new upstream release
230- import some patches from fedora development
231- drop some old patches
232- update spec based on fedora package
233- spec in utf-8
234
235* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
236- use macro for Release
237
238* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
239- apply new virsioning policy.
240- remove *.la
241
242* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
243- rebuilt with readline 5.1
244
245* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
246- added Patches from Fedora
247  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
248  - Fix dynamic linking on 64bit archs (#159971)
249  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
250  - Moved info files to base package as they are not devel related (#139948)
251  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
252  - Fixed guile-tools not finding guile lib dir (#142642)
253  - Added some nice tools (#142642)
254  - Removed smp build, seems to be broken atm
255
256* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
257- new upstream release
258- dropped patch2, 4, 6
259- added BuildPrereq: perl
260
261* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
262- rebuild with new toolchains
263- s/Copyright/License/
264- added srfi libs
265- patch for ppc64 from Fedora package
266
267* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
268- update to 1.6.4
269
270* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
271- rebuild with readline-4.3
272
273* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
274- based on Rawhide 1.6.0-4
275  - Included s390 as working arch as well, switch to general unknown arch patch
276  - rebuild to fix broken deps
277  - fix continuations.h on ia64
278- new upstream 1.6.3
279
280* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
281- porting for Vine Linux
282- remove 1.3 patches( not required  so that upstream upgrade )
283
284* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
285- Add version number to prereq for umb-scheme to get the post-install to
286  work properly.
287
288* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
289- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
290
291* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
292- automatic rebuild
293
294* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
295- Back down to 1.3.4.
296- Fix to actually link against the version of libguile in the package.
297
298* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
299- FHS fixups using the %%{makeinstall} macro.
300
301* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
302- fix preun-devel
303- call ldconfig directly in postun
304
305* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
306- rebuild with new readline
307- update to 1.3.4
308
309* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
310- using the same catalog as umb-scheme makes umb-scheme a prereq
311
312* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
313- readline is needed for %post
314
315* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
316- use the same catalog as umb-scheme
317
318* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
319- fix broken %postun
320
321* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
322- auto rebuild in the new build environment (release 6)
323
324* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
325- added .ansi patch to fix #endif
326
327* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
328- add patch for the scm stuff
329
330* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
331- integrate changes from rhcn version (#640)
332
333* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
334- call libtoolize first to get it to compile on the arm
335
336* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
337- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
338
339* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
340- guile-devel does depend on guile
341- remove devel dependancy on m4
342- move guile-snarf from guile to guile-devel
343- Converted to rhcn
344
345* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
346- update to 1.3.
347- don't strip libguile.so.*.0.0. (but set the execute bits).
348
349* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
350- spec file fixups
351
352* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
353- Updated for RH 5.2
354
355* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
356- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
357- added slib link
358
359* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
360- added %attr(-, root, root) for %doc,
361- in %post, %postun ldconfig runed as parameter "-p",
362- removed /bin/sh from requires,
363- added %description,
364- changes in %files.
365
366* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
367- all rewrited for using Buildroot,
368- added %postun,
369- removed making buid logs,
370- removed "--inclededir", added "--enable-dynamic-linking" to configure
371  parameters,
372- added striping shared libs and /usr/bin/guile,
373- added "Requires: /bin/sh" (for guile-snarf) in guile package and
374  "Requires: m4" for guile-devel,
375- added macro %{PACKAGE_VERSION} in "Source:" and %files,
376- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.