source: projects/specs/trunk/g/gucharmap/gucharmap-vl.spec @ 4616

Revision 4616, 7.1 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Summary: A Unicode/ISO10646 character map and font viewer.
2Summary(ja): Unicode/ISO10646 文字コード表およびフォントビューワ
3Name: gucharmap
4Version: 3.0.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://gucharmap.sourceforge.net/
9
10Source: http://ftp.gnome.org/pub/gnome/sources/gucharmap/3.0/%{name}-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires: glib2-devel >= 2.28.0
14BuildRequires: gtk3-devel >= 3.0.0
15BuildRequires: GConf2-devel
16BuildRequires: gnome-doc-utils >= 0.9.0
17#BuildRequires: libgnomeui-devel >= 2.2.0, libgnome-devel >= 2.2.0
18### Needed to know if we should link gnome-character-map
19BuildRequires: gnome-utils
20BuildRequires: docbook-dtds
21
22Requires(post,postun): scrollkeeper
23Requires(post,pre,preun): GConf2
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29gucharmap is a Unicode/ISO10646 character map and font viewer.
30
31%description -l ja
32gucharmap は Unicode/ISO10646 文字コード表およびフォントビューワです。
33
34%package devel
35Summary: Header files, libraries and development documentation for %{name}.
36Summary(ja): %{name} のヘッダファイル、ライブラリおよび開発用ドキュメント
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: gtk3-devel
40Requires: glib2-devel
41Requires: GConf2-devel
42
43%description devel
44This package contains the header files, static libraries and development
45documentation for %{name}. If you like to develop programs using %{name},
46you will need to install %{name}-devel.
47
48%description devel -l ja
49このパッケージには %{name} のヘッダファイル、ライブラリおよび開発用
50ドキュメントが含まれています。%{name} を使ったプログラムを開発する場合、
51%{name}-devel をインストールする必要があります。
52
53%prep
54%setup -q
55
56%build
57%configure \
58        --with-gtk=3.0 \
59        --disable-static \
60        --disable-schemas-install \
61        --disable-scrollkeeper
62make %{?_smp_mflags}
63
64%install
65[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
66%makeinstall
67%find_lang %{name}
68
69### Remove gnome-character-map link from buildroot if it is in gnome-utils
70# this process is not appropriate,
71# because gnome-character-map will be removed if gucharmap is installed
72#[ -e %{_bindir}/gnome-character-map ] && rm -f %{buildroot}%{_bindir}/gnome-character-map
73
74# remove unneeded files
75rm -rf %{buildroot}%{_localstatedir}/scrollkeeper
76rm -f %{buildroot}%{_libdir}/*.{a,la}
77rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
78
79%clean
80[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
81
82%post
83/sbin/ldconfig
84export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gucharmap.schemas > /dev/null
86scrollkeeper-update -q || :
87
88touch --no-create %{_datadir}/icons/hicolor
89if [ -x /usr/bin/gtk-update-icon-cache ]; then
90  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor;
91fi
92
93%pre
94if [ "$1" -gt 1 ]; then
95    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gucharmap.schemas > /dev/null
97fi
98
99%preun
100if [ "$1" -eq 0 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gucharmap.schemas > /dev/null
103fi
104
105%postun
106/sbin/ldconfig
107scrollkeeper-update -q || :
108
109touch --no-create %{_datadir}/icons/hicolor
110if [ -x /usr/bin/gtk-update-icon-cache ]; then
111  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor;
112fi
113
114%files -f %{name}.lang
115%defattr(-, root, root, 0755)
116%doc ChangeLog COPYING* README TODO
117%{_sysconfdir}/gconf/schemas/gucharmap.schemas
118%{_bindir}/*
119%{_libdir}/*.so.*
120%{_datadir}/applications/*
121#{_datadir}/icons/hicolor/48x48/apps/*
122%{_datadir}/omf/gucharmap
123%doc %{_datadir}/gnome/help/gucharmap
124
125%files devel
126%defattr(-, root, root, 0755)
127%{_libdir}/*.so
128%{_libdir}/pkgconfig/*.pc
129%{_includedir}/gucharmap-2.90
130
131%changelog
132* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
133- new upstream release
134- change BuildRequires: gtk3-devel instead of gtk2-devel
135
136* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
137- new upstream release
138
139* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
140- new upstream release
141
142* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
143- rebuild with rpm-4.8.1 for pkg-config file
144
145* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
146- new upstream release
147- add BuildRequires: docbook-dtds
148
149* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
150- new upstream release
151
152* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
153- new upstream release
154
155* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
156- new upstream release
157
158* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
159- new upstream release
160
161* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3.1-1
162- new upstream release
163
164* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
165- new upstream release
166
167* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
168- new upstream release
169- remove static library
170
171* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
172- new upstream release
173
174* Mon Oct 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
175- new upstream release
176- spec in UTF-8
177
178* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
179- new upstream release
180- added %%pre, %%preun section
181
182* Mon Jan 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.2-0vl1
183- new upstream release
184
185* Sun Jan  7 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
186- add Vendor/Distribution tag
187- add BuildRequires: gnome-doc-utils, libgnomeui-devel, libgnome-devel
188- add Requires: {gtk2,glib2,libgnomeui,libgnome}-devel to -devel package
189- not run gtk-query-immodules-2.0 at %%post and %%postun
190- use %%{buildroot} consistently
191
192* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl1
193- new upstream release
194- added --disable-scrollkeeper option
195
196* Thu Mar 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
197- new upstream release
198
199* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
200- new upstream release
201- added Japanese summay and description
202
203* Sun Jan 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
204- build for Vine Linux
205- based on Dag Apt Repository, http://dag.wieers.com/apt/
206
207* Sat Nov 22 2003 Dag Wieers <dag@wieers.com> - 1.2.0-0
208- Updated to release 1.2.0.
209
210* Tue Sep 09 2003 Dag Wieers <dag@wieers.com> - 1.0.0-0
211- Updated to release 1.0.0.
212
213* Fri Aug 22 2003 Dag Wieers <dag@wieers.com> - 0.9.0-0
214- Updated to release 0.9.0.
215
216* Wed Jun 11 2003 Dag Wieers <dag@wieers.com> - 0.8.0-0
217- Updated to release 0.8.0.
218
219* Wed Jun 04 2003 Dag Wieers <dag@wieers.com> - 0.6.1.20030604-0
220- Updated to release 0.6.1.20030604.
221
222* Mon May 19 2003 Dag Wieers <dag@wieers.com> - 0.6.1-0
223- Updated to release 0.6.1.
224
225* Fri May 02 2003 Dag Wieers <dag@wieers.com> - 0.6.0-0
226- Updated to release 0.6.0.
227
228* Tue Mar 25 2003 Dag Wieers <dag@wieers.com> - 0.4.0-1
229- Added extra documents.
230
231* Tue Mar 18 2003 Dag Wieers <dag@wieers.com> - 0.4.0-0
232- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.