source: projects/specs/trunk/g/gucharmap/gucharmap-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A Unicode/ISO10646 character map and font viewer.
2Summary(ja): Unicode/ISO10646 文字コード表およびフォントビューワ
3Name: gucharmap
4Version: 2.28.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://gucharmap.sourceforge.net/
9
10Source: http://ftp.gnome.org/pub/gnome/sources/gucharmap/2.26/%{name}-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires: glib2-devel >= 2.16.3
14BuildRequires: gtk2-devel >= 2.13.6
15BuildRequires: GConf2-devel
16BuildRequires: gnome-doc-utils >= 0.9.0
17#BuildRequires: libgnomeui-devel >= 2.2.0, libgnome-devel >= 2.2.0
18### Needed to know if we should link gnome-character-map
19BuildRequires: gnome-utils
20
21Requires(post,postun): scrollkeeper
22Requires(post,pre,preun): GConf2
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28gucharmap is a Unicode/ISO10646 character map and font viewer.
29
30%description -l ja
31gucharmap は Unicode/ISO10646 文字コード表およびフォントビューワです。
32
33%package devel
34Summary: Header files, libraries and development documentation for %{name}.
35Summary(ja): %{name} のヘッダファイル、ライブラリおよび開発用ドキュメント
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Requires: gtk2-devel
39Requires: glib2-devel
40Requires: GConf2-devel
41
42%description devel
43This package contains the header files, static libraries and development
44documentation for %{name}. If you like to develop programs using %{name},
45you will need to install %{name}-devel.
46
47%description devel -l ja
48このパッケージには %{name} のヘッダファイル、ライブラリおよび開発用
49ドキュメントが含まれています。%{name} を使ったプログラムを開発する場合、
50%{name}-devel をインストールする必要があります。
51
52%prep
53%setup -q
54
55%build
56%configure \
57        --disable-static \
58        --disable-schemas-install \
59        --disable-scrollkeeper
60make %{?_smp_mflags}
61
62%install
63[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
64%makeinstall
65%find_lang %{name}
66
67### Remove gnome-character-map link from buildroot if it is in gnome-utils
68# this process is not appropriate,
69# because gnome-character-map will be removed if gucharmap is installed
70#[ -e %{_bindir}/gnome-character-map ] && rm -f %{buildroot}%{_bindir}/gnome-character-map
71
72# remove unneeded files
73rm -rf %{buildroot}%{_localstatedir}/scrollkeeper
74rm -f %{buildroot}%{_libdir}/*.{a,la}
75rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
76
77%clean
78[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
79
80%post
81/sbin/ldconfig
82export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
83gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gucharmap.schemas > /dev/null
84scrollkeeper-update -q || :
85
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x /usr/bin/gtk-update-icon-cache ]; then
88  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor;
89fi
90
91%pre
92if [ "$1" -gt 1 ]; then
93    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gucharmap.schemas > /dev/null
95fi
96
97%preun
98if [ "$1" -eq 0 ]; then
99    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
100    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gucharmap.schemas > /dev/null
101fi
102
103%postun
104/sbin/ldconfig
105scrollkeeper-update -q || :
106
107touch --no-create %{_datadir}/icons/hicolor
108if [ -x /usr/bin/gtk-update-icon-cache ]; then
109  /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor;
110fi
111
112%files -f %{name}.lang
113%defattr(-, root, root, 0755)
114%doc ChangeLog COPYING* README TODO
115%{_sysconfdir}/gconf/schemas/gucharmap.schemas
116%{_bindir}/*
117%{_libdir}/*.so.*
118%{_datadir}/applications/*
119#{_datadir}/icons/hicolor/48x48/apps/*
120%{_datadir}/omf/gucharmap
121%doc %{_datadir}/gnome/help/gucharmap
122
123%files devel
124%defattr(-, root, root, 0755)
125%{_libdir}/*.so
126%{_libdir}/pkgconfig/*.pc
127%{_includedir}/gucharmap-2
128
129%changelog
130* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
131- new upstream release
132
133* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3.1-1
134- new upstream release
135
136* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
137- new upstream release
138
139* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
140- new upstream release
141- remove static library
142
143* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
144- new upstream release
145
146* Mon Oct 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
147- new upstream release
148- spec in UTF-8
149
150* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
151- new upstream release
152- added %%pre, %%preun section
153
154* Mon Jan 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.2-0vl1
155- new upstream release
156
157* Sun Jan  7 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
158- add Vendor/Distribution tag
159- add BuildRequires: gnome-doc-utils, libgnomeui-devel, libgnome-devel
160- add Requires: {gtk2,glib2,libgnomeui,libgnome}-devel to -devel package
161- not run gtk-query-immodules-2.0 at %%post and %%postun
162- use %%{buildroot} consistently
163
164* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl1
165- new upstream release
166- added --disable-scrollkeeper option
167
168* Thu Mar 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
169- new upstream release
170
171* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
172- new upstream release
173- added Japanese summay and description
174
175* Sun Jan 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
176- build for Vine Linux
177- based on Dag Apt Repository, http://dag.wieers.com/apt/
178
179* Sat Nov 22 2003 Dag Wieers <dag@wieers.com> - 1.2.0-0
180- Updated to release 1.2.0.
181
182* Tue Sep 09 2003 Dag Wieers <dag@wieers.com> - 1.0.0-0
183- Updated to release 1.0.0.
184
185* Fri Aug 22 2003 Dag Wieers <dag@wieers.com> - 0.9.0-0
186- Updated to release 0.9.0.
187
188* Wed Jun 11 2003 Dag Wieers <dag@wieers.com> - 0.8.0-0
189- Updated to release 0.8.0.
190
191* Wed Jun 04 2003 Dag Wieers <dag@wieers.com> - 0.6.1.20030604-0
192- Updated to release 0.6.1.20030604.
193
194* Mon May 19 2003 Dag Wieers <dag@wieers.com> - 0.6.1-0
195- Updated to release 0.6.1.
196
197* Fri May 02 2003 Dag Wieers <dag@wieers.com> - 0.6.0-0
198- Updated to release 0.6.0.
199
200* Tue Mar 25 2003 Dag Wieers <dag@wieers.com> - 0.4.0-1
201- Added extra documents.
202
203* Tue Mar 18 2003 Dag Wieers <dag@wieers.com> - 0.4.0-0
204- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.