source: projects/specs/trunk/g/guake/guake-vl.spec @ 10833

Revision 10833, 5.5 KB checked in by iwaim, 7 years ago (diff)

guake 0.8.7-1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary:        Drop-down terminal for GNOME Desktop Environment
4Summary(ja):    GNOME 用のドロップダウン式の端末エミュレータ
5Name:           guake
6Version:        0.8.7
7Release:        1%{?_dist_release}
8Source0:        https://github.com/Guake/guake/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
9#Source1:       guake-0.4.1-ja.po
10#Patch0:         0001-Fix-focus-issue-on-gnome-shell.patch
11#Patch1:         0001-Fix-notification.patch
12#Patch2:         0001-Let-allow-the-signal.SIGTERM-to-fail.patch
13#Patch3:         0001-Fix-regex-to-include-the-port-number-when-there-is-o.patch
14# Upstream patch at https://github.com/Guake/guake/pull/75
15#Patch4:         0001-Include-bpython-and-ipython-as-interpreters.patch
16
17License:        GPLv2+
18Group:          Applications/Accessories
19URL:            http://guake.org/
20
21Requires: gnome-python
22Requires: python-keybinder
23
24Requires(pre):  GConf2
25Requires(post): GConf2
26Requires(preun):GConf2
27
28BuildRequires: python, python-devel
29BuildRequires: gtk2-devel, pygtk2-devel
30BuildRequires: vte, GConf2-devel, libffi-devel
31BuildRequires: desktop-file-utils
32BuildRequires: intltool, gettext
33BuildRequires: gnome-common
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38Packager:       kazutaka
39
40%description
41Guake is a dropdown terminal made for the GNOME desktop environment.
42Its style of window is based on an fps games, and one of its goals
43is be easy to reach.
44
45%description -l ja
46Guake は GNOME デスクトップ環境向けに開発されたドロップダウン
47形の端末です。
48FPS ゲーム用端末と同じスタイルを採用しており、素早く利用できる、
49というのがこのプログラムのゴールの一つです。
50
51
52%prep
53%setup -q
54#%{__cp} %{SOURCE1} po/ja.po
55sed -i 's/Encoding=UTF-8//g' data/guake.desktop.in data/guake-prefs.desktop.in
56sed -i 's/Categories=GNOME;GTK;Utility;TerminalEmulator;/Categories=GNOME;GTK;Utility;/g' \
57        data/guake.desktop.in
58
59#%patch0 -p1
60#%patch1 -p1
61#%patch2 -p1
62#%patch3 -p1
63#%patch4 -p1
64
65%build
66./autogen.sh
67%configure --disable-static \
68           --disable-schemas-install
69%{__make} %{?_smp_mflags}
70
71
72%install
73%{__rm} -rf $RPM_BUILD_ROOT
74%{__make} install DESTDIR=$RPM_BUILD_ROOT
75
76%find_lang %{name}
77rm -f %{buildroot}%{_libdir}/%{name}/globalhotkeys.la
78
79if [ "%{python_sitearch}" != "%{python_sitelib}" ]; then
80  mv %{buildroot}/usr/lib/ %{buildroot}%{_libdir}
81fi
82
83%check
84desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
85desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-prefs.desktop
86
87%pre
88# uninstall old schemas before update
89if [ "$1" -gt 1 ]; then
90  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91  gconftool-2 --makefile-uninstall-rule \
92      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
93fi
94
95%post
96update-desktop-database &>/dev/null || :
97gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
98
99# install schemas after install/update
100export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
101gconftool-2 --makefile-install-rule \
102    %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
103
104%preun
105# uninstall schemas before clean remove
106if [ "$1" -eq 0 ]; then
107  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
108  gconftool-2 --makefile-uninstall-rule \
109      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null;
110fi
111
112%postun
113update-desktop-database &>/dev/null || :
114gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
115
116
117%clean
118%{__rm} -rf $RPM_BUILD_ROOT
119
120
121%files -f %{name}.lang
122%defattr(-,root,root)
123%doc AUTHORS COPYING ChangeLog INSTALL NEWS README.rst
124%{_bindir}/%{name}
125%{_bindir}/%{name}-prefs
126%{_datadir}/%{name}
127%{_datadir}/applications/%{name}-prefs.desktop
128%{_datadir}/applications/%{name}.desktop
129%{_datadir}/dbus-1/services/org.guake.Guake.service
130%{_datadir}/icons/hicolor/*/
131%{_datadir}/pixmaps/%{name}
132%{python_sitearch}/%{name}/*
133%{_mandir}/man1/guake.1*
134%{_sysconfdir}/gconf/schemas/%{name}.schemas
135#%{_sysconfdir}/xdg/autostart/%{name}.desktop
136
137
138%changelog
139* Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.8.7-1
140- new upstream release
141
142* Sun Apr 24 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.4-1
143- new upstream release
144- delete all patches
145- run autogen.sh in %%build
146- added BuildRequires: gnome-common
147- added Requires: gnome-python, python-keybinder
148- fixed %%install
149- fixed %%files and %%doc
150
151* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.4.4-2
152- add some patches from Fedora guake-0.4.4-11.fc21
153 - 0001-Let-allow-the-signal.SIGTERM-to-fail.patch (Patch2)
154 - 0001-Fix-regex-to-include-the-port-number-when-there-is-o.patch (Patch3)
155 - 0001-Include-bpython-and-ipython-as-interpreters.patch (Patch4)
156- add Vendor and Distribution tags
157
158* Sat Jul 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.4-1
159- new upstream release
160- added Patch1 from Fedora
161- run gtk-update-icon-cache in %%post, %%posutn
162
163
164* Thu Jun 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.3-2
165- run desktop-file-validate in %%check
166
167* Tue Jun 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.3-1
168- new upstream release
169- added Patch0 from Fedora rawhide
170- added BuildRequires: desktop-file-utils, gettext, intltool
171- run desktop-file-validate in %%install
172
173* Sun Oct 17 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.4.2-1
174- new upstream release
175
176* Sat Jul 17 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.4.1-1
177- initial build for Vine Linux
178- add Source1: updated japanese translation (ja.po)
Note: See TracBrowser for help on using the repository browser.