source: projects/specs/trunk/g/gtranslator/gtranslator-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNOME po file editor with many bells and whistles.
2Summary(ja): GNOME po ファイルエディタ
3Name: gtranslator
4Version: 1.9.6
5Release: 2%{?_dist_release}
6License: GPL
7Group: Applications/Development
8URL: http://www.gtranslator.org/
9Source: http://ftp.gnome.org/pub/GNOME/sources/gtranslator/1.9/%{name}-%{version}.tar.bz2
10Patch0: po_header_set_field_wrapper.patch
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: inagaki,yasumichi
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: glib2-devel >= 2.15.5
18BuildRequires: gtksourceview2-devel >= 2.4.0
19BuildRequires: GConf2-devel >= 2.18.0
20BuildRequires: gdl-devel >= 0.6.0
21BuildRequires: gtkspell-devel >= 2.0.0
22BuildRequires: gucharmap-devel
23BuildRequires: apr-devel apr-util-devel neon-devel
24BuildRequires: subversion-devel
25
26BuildRequires: gnome-doc-utils >= 0.3.2
27BuildRequires: libuuid-devel
28
29Requires(post): scrollkeeper GConf2
30Requires(pre): GConf2
31Requires(preun): GConf2
32Requires(postun): scrollkeeper
33
34Requires: glib2 >= 2.15.5
35Requires: gtksourceview2 >= 2.4.0
36Requires: gdl >= 0.6.0
37Requires: gtkspell >= 2.0.0
38Requires: gucharmap
39Requires: apr apr-util neon
40Requires: subversion
41Requires: libuuid
42
43%description
44gtranslator is a comfortable po file editor with many bells and whistles.
45It features many useful function which ease the work of translators of po
46files imminently.
47
48%package devel
49Summary: Headers for developing programs that will use %{name}
50Summary(ja): %{name} の開発用ファイル
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: libglade2-devel
54Requires: gtksourceview2-devel
55
56%description devel
57This package contains the headers that programmers will need to develop
58applications which will use %{name}.
59
60%prep
61%setup -q
62%patch0 -p1
63
64%build
65%configure --disable-static \
66        --disable-debug \
67        --disable-scrollkeeper \
68        --disable-schemas-install
69
70make %{?_smp_mflags}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
75%makeinstall
76unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
77
78%find_lang %{name}
79
80rm -f $RPM_BUILD_ROOT%{_libdir}/gtranslator/*/*.la
81
82%post
83scrollkeeper-update -q > /dev/null 2>&1 || :
84export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85gconftool-2 --makefile-install-rule \
86    %{_sysconfdir}/gconf/schemas/gtranslator.schemas >& /dev/null ||:
87
88%pre
89if [ "$1" -gt 1 ]; then
90export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91gconftool-2 --makefile-uninstall-rule \
92    %{_sysconfdir}/gconf/schemas/gtranslator.schemas >& /dev/null ||:
93fi
94
95%preun
96if [ "$1" -eq 0 ]; then
97export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
98gconftool-2 --makefile-uninstall-rule \
99    %{_sysconfdir}/gconf/schemas/gtranslator.schemas >& /dev/null ||:
100fi
101
102%postun
103scrollkeeper-update -q > /dev/null 2>&1 || :
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files -f %{name}.lang
109%defattr(-, root, root, 0755)
110%doc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
111%{_sysconfdir}/gconf/schemas/*
112%{_bindir}/*
113%{_libdir}/gtranslator
114%{_datadir}/applications/*.desktop
115%{_datadir}/gnome/help/gtranslator
116%{_datadir}/gtranslator
117%{_datadir}/omf/gtranslator
118%{_datadir}/pixmaps/*
119%{_mandir}/man?/*
120
121%files devel
122%defattr(-, root, root, -)
123%{_includedir}/gtranslator-2.0
124%{_datadir}/gtk-doc/html/gtranslator
125%{_libdir}/pkgconfig/*.pc
126
127%changelog
128* Thu Nov 19 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.9.6-2
129- add libuuid to Requires.
130- add libuuid-devel and gnome-doc-utils to BR.
131- add Patch0 (https://bugzilla.gnome.org/show_bug.cgi?id=591587)
132- export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 when install.
133
134* Thu Nov 19 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.9.6-1
135- new upstream release
136- add Requires glib2,gtksourceview2,gdl,gtkspell,gucharmap,apr,apr-util,neon,subversion
137
138* Sat May 16 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.5-1
139- applied new versioning policy, spec in UTF-8
140- new upstream release
141- updated BuildRequires:
142- split devel subpackage
143- changed Group to Applications/Development
144
145* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
146- new upstream release
147- added BuildRequires: gtkspell-devel
148
149* Thu Jan 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
150- new upstream snapshot, tarball is taken from debian pool
151- add Patch10 from debian package
152
153* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-1vl1
154- build for VineSeedPlus
155
156* Thu Sep 04 2003 Dag Wieers <dag@wieers.com> - 1.0-1
157- Updated to release 1.0.
158
159* Tue Sep 02 2003 Dag Wieers <dag@wieers.com> - 1.0-0.pre1
160- Updated to release 1.0pre1.
161
162* Fri Jun 27 2003 Dag Wieers <dag@wieers.com> - 1.0-0.cvs20030626
163- Updated to release 1.0CVS-20030626.
164
165* Sat Jun 14 2003 Dag Wieers <dag@wieers.com> - 0.99-0
166- Updated to release 0.99.
167
168* Tue Mar 18 2003 Dag Wieers <dag@wieers.com> - 0.43-0
169- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.