source: projects/specs/trunk/g/gtkmm3/gtkmm3-vl.spec @ 9791

Revision 9791, 4.2 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define ver 3.0
2
3Summary: A C++ interface for the GTK+ (a GUI library for X).
4Summary(ja): GTK+ の C++ インターフェイス
5Name: gtkmm3
6Version: 3.18.0
7Release: 1%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10Source: ftp://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.18/gtkmm-%{version}.tar.xz
11
12URL: http://gtkmm.sourceforge.net/
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14Requires: glibmm >= 2.33.13
15Requires: pangomm >= 2.27.1
16Requires: atk >= 1.9.0
17Requires: gtk3 >= 3.6.0
18BuildRequires: glibmm-devel >= 2.33.13
19BuildRequires: cairomm-devel
20BuildRequires: pangomm-devel >= 2.27.1
21BuildRequires: atkmm-devel
22BuildRequires: gtk3-devel >= 3.6.0
23BuildRequires: libsigc++-devel >= 2.0.0
24BuildRequires: doxygen
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30gtkmm (previously known as Gtk--) is the official C++ interface for the
31popular GUI library GTK+. Highlights include typesafe callbacks, widgets
32extensible via inheritance and a comprehensive set of widget classes that
33can be freely combined to quickly create complex user interfaces.
34
35The gtkmm devel package contains the static libraries and header files
36needed for developing GTK+ (GIMP ToolKit) applications in C++.
37
38
39%package        devel
40Summary:        Development tools for gtkmm applications.
41Summary(ja):    gtkmm アプリケーションの開発用ファイル
42Group:          Development/Libraries
43Requires:       %{name} = %{version}
44Requires:       gtk3-devel >= 3.6.0
45Requires:       glibmm-devel >= 2.33.13
46Requires:       cairomm-devel
47Requires:       pangomm-devel >= 2.27.1
48
49%description devel
50This package contains the headers that programmers will need to develop
51applications which will use Gtk--, the C++ interface to the GTK+
52(the Gimp ToolKit) GUI library.
53
54%prep
55%setup -q -n gtkmm-%{version}
56
57%build
58%configure --disable-static
59make %{?_smp_mflags}
60
61%install
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
63
64make install DESTDIR=$RPM_BUILD_ROOT
65
66find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
67
68# Fix documentation installation, put everything under gtk-doc
69mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/gtkmm-%{ver}
70mv ${RPM_BUILD_ROOT}%{_docdir}/gtkmm-%{ver}/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/gtkmm-%{ver}/
71
72# devhelp path fix
73sed -i 's:doc/gtkmm-%{ver}:gtk-doc/html/gtkmm-%{ver}:g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/gtkmm-%{ver}/gtkmm-%{ver}.devhelp2
74
75# remove demos, examples
76rm -rf $RPM_BUILD_ROOT%{_datadir}/gtkmm-%{ver}/demo
77rm -rf $RPM_BUILD_ROOT%{_datadir}/gtkmm-%{ver}/examples
78
79%post -p /sbin/ldconfig
80
81%postun -p /sbin/ldconfig
82
83%clean
84[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(-, root, root)
88%doc AUTHORS COPYING ChangeLog NEWS README
89%{_libdir}/lib*.so.*
90
91%files  devel
92%defattr(-, root, root)
93%{_includedir}/*
94#{_libdir}/*.la
95#{_libdir}/*.a
96%{_libdir}/*.so
97%{_libdir}/gtkmm-*
98%{_libdir}/gdkmm-*
99%{_libdir}/pkgconfig/*.pc
100
101%{_datadir}/gtk-doc/html/*
102%{_datadir}/devhelp/books/*
103
104%changelog
105* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.0-1
106- new upstream release
107
108* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
109- new upstream release
110
111* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
112- new upstream release
113
114* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
115- new upstream release
116
117* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
118- new upstream release
119
120* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
121- new upstream release
122
123* Mon Oct 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
124- new upstream release
125
126* Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.13-1
127- new upstream release
128
129* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.12-1
130- new upstream release
131- add BuildRequires: doxygen
132
133* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
134- new upstream release
135
136* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
137- new upstream release
138
139* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
140- new upstream release
141
142* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
143- new upstream release
144
145* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
146- initial build for Vine Linux
147
Note: See TracBrowser for help on using the repository browser.