source: projects/specs/trunk/g/gtkam/gtkam-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GTK front-end for gPhoto2
2Name: gtkam
3
4%define gimpdir %(/bin/ls -d %{_libdir}/gimp/*/plug-ins 2> /dev/null | tail -n 1)
5%define gimpver %(echo %gimpdir | sed 's,^%{_libdir}/,,' | cut -d'/' -f2)
6%define icondir %{_datadir}/pixmaps
7
8Version: 0.1.14
9Release: 0vl2
10License: GPL
11Group: Applications/Graphics
12
13Source0: http://prdownloads.sourceforge.net/sourceforge/gphoto/%{name}-%{version}.tar.bz2
14%{?nosrc:NoSource: 0}
15Source1: gtkam.sh
16#Patch0:        gtkam-0.1.12-fixsavefnames.patch.bz2
17#Patch1:        gtkam-0.1.10-nodebugopt.patch.bz2
18#Patch2: gtkam-gimp2.patch.bz2
19#Patch3:        gtkam-invalidxml.patch.bz2
20Patch4: gtkam-omf-install.patch.bz2
21URL: http://www.gphoto.org/proj/gtkam/
22ExcludeArch: s390 s390x
23Requires: gphoto2 >= 2.1.3
24BuildRequires: gphoto2-devel >= 2.1.3
25#BuildRequires: gdk-pixbuf-devel gimp-devel
26BuildRequires: gimp-devel
27BuildRequires: gtk2-devel libexif-devel libexif-gtk-devel
28Requires: gdk-pixbuf libexif-gtk
29BuildRequires:  gettext
30BuildRequires:  libbonobo-devel libbonoboui-devel libgnomeui-devel
31#BuildRequires: desktop-file-utils >= 0.2.92
32Prefix: %{_prefix}
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34
35%description
36The gtKam package provides a GTK-based front-end to gPhoto2.  Install
37this package if you want to use a digital camera with Linux.
38
39%package gimp
40Summary: GIMP plug-in for digital camera access through gPhoto2
41Requires: %{name} = %{version}
42Requires: gimp >= %{gimpver}
43PreReq: fileutils gawk sh-utils
44Group: Applications/Graphics
45
46%description gimp
47A GIMP plug-in for direct digital camera access through gPhoto2.
48
49%prep
50rm -rf %{buildroot}
51%setup -q
52
53#%patch0 -p1
54#%patch1 -p1
55#patch2 -p1 -b .gimp2
56#%patch3 -p1 -b .invalidxml
57%patch4 -p1
58#%__cp configure configure.gimp2
59#sed -e "s/gimpui-1.3/gimpui-%{gimpver}/" configure.gimp2 > configure
60#sed -i -e "s,gimp/1.3/plug-ins,gimp/%{gimpver}/plug-ins," src/Makefile*
61
62%build
63%configure
64make
65
66%install
67%makeinstall imagesdir=%{buildroot}%{icondir}/gtkam
68mkdir -p %{buildroot}%{_libexecdir}
69cp src/gtkam-gimp %{buildroot}%{_libexecdir}
70
71mv %{buildroot}%{_bindir}/gtkam %{buildroot}%{_bindir}/gtkam.bin
72%__install -D -m 755 %{SOURCE1} %{buildroot}%{_bindir}/gtkam
73
74#gimp plugin
75#mkdir -p %{buildroot}%{gimpdir}
76#ln -sf %{_libexecdir}/gtkam-gimp %{buildroot}%{gimpdir}/gtkam
77
78# icon
79mkdir -p %{buildroot}%{icondir}
80%__cp gtkam.png %{buildroot}%{icondir}
81#echo "Icon=gtkam.png" >> %{buildroot}%{_datadir}/applications/gtkam.desktop
82#__mv %{buildroot}%{_datadir}/images/gtkam %{buildroot}%{icondir}
83
84
85%find_lang %{name}
86
87rm -rf %{buildroot}%{_prefix}/doc %{buildroot}%{_datadir}/doc %{buildroot}/var
88#[ "%{gimpver}" = "1.3" ] || rm -rf %{buildroot}%{_libdir}/gimp/1.3
89
90%clean
91rm -rf %{buildroot}
92
93%files -f %{name}.lang
94%defattr(-,root,root)
95%doc [A-LN-Z]*
96%config(missingok,noreplace) %{_datadir}/applications/*
97%{_bindir}/*
98%{_datadir}/gtkam
99%{_datadir}/gnome/help/gtkam
100%{_datadir}/omf/gtkam
101%{_mandir}/man1/*
102%{icondir}/*
103
104%files gimp
105%defattr(-,root,root)
106%{_libexecdir}/gtkam-gimp
107%{gimpdir}/*
108
109%changelog
110* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.14-0vl2
111- rebuilt for VineSeed
112
113* Sun Mar 11 2007 Masaki Shinomiya <shino@pos.to> 0.1.14-0vl1
114- new upstream release
115- require libexif-gtk, group, desktop launcher
116
117* Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.13-0vl1
118- new upstream release
119- added BuildRequires: libexif-gtk-devel
120
121* Wed Feb 16 2005 Masaki Shinomiya <shino@pos.to> 0.1.12-0vl1
122- new upstream release, patches from Mandrake Linux
123- gimp plugin, desktop, icon, help, omf
124
125* Mon Nov 24 2003 KOBAYASHI R. taizo <tkoba@vinelinux.org> 0.1.10-0vl2
126- added source1 for ja_JP.UTF-8 wrapper
127
128* Tue Nov 11 2003 KOBAYASHI R. taizo <tkoba@vinelinux.org> 0.1.10-0vl1
129- source update
130- modified for Vine
131
132* Thu Sep 11 2003 Tim Waugh <twaugh@redhat.com> 0.1.7-6.1
133- Rebuilt.
134
135* Thu Sep 11 2003 Tim Waugh <twaugh@redhat.com> 0.1.7-6
136- Use %%{_libdir} etc throughout (bug #104204).
137
138* Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 0.1.7-5
139- Fix URL (bug #100907).
140
141* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 0.1.7-4
142- rebuilt
143
144* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 0.1.7-3
145- rebuilt
146
147* Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 0.1.7-2
148- do not build on mainframe
149
150* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 0.1.7-1
151- 0.1.7.
152- No longer need gtkam-gimp patch.
153- Don't install files not shipped.
154
155* Mon Aug  5 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-6
156- Don't require gimp-devel (bug #70754).
157- Don't ship empty NEWS file (bug #66086).
158
159* Mon Jul 22 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-5
160- Desktop file fixes (bug #69434).
161
162* Mon Jul 15 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-4
163- Use desktop-file-install.
164
165* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.1.4-3
166- automated rebuild
167
168* Sun May 26 2002 Tim Powers <timp@redhat.com> 0.1.4-2
169- automated rebuild
170
171* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-1
172- 0.1.4.
173- Update gimp patch.
174- No longer need linguas, gettext, ranlib patches.
175
176* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 0.1.3-0.cvs20020225.2
177- The gimp subpackage requires /usr/bin/gimp-config in its %%post
178  scriplet.
179
180* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 0.1.3-0.cvs20020225.1
181- Adapted for Red Hat Linux.  Tidied the spec file.
182- Made a desktop entry.
183- Fixed the gimp plug-in.
184
185* Mon Jan 28 2002 Till Kamppeter <till@mandrakesoft.com> 0.1-10mdk
186- Rebuilt for libusb 0.1.4.
187
188* Wed Jan 09 2002 David BAUDENS <baudens@mandrakesoft.com> 0.1-9mdk
189- Add %%defattr(-,root,root,-) for gtkam-gimp-plugin
190
191* Wed Jan 09 2002 David BAUDENS <baudens@mandrakesoft.com> 0.1-8mdk
192- Fix menu entry
193
194* Tue Dec  4 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-7mdk
195- Updated to the CVS snapshot from 04/12/2001.
196
197* Sat Dec  1 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-6mdk
198- Updated to the CVS of 01/12/2001.
199
200* Fri Nov 30 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-5mdk
201- Updated to the CVS of 30/11/2001.
202
203* Mon Oct 08 2001 Stefan van der Eijk <stefan@eijk.nu> 0.1-4mdk
204- BuildRequires: gettext-devel
205
206* Thu Sep 13 2001 Stefan van der Eijk <stefan@eijk.nu> 0.1-3mdk
207- fixed BuildRequires
208- Copyright --> License
209
210* Mon Aug  6 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-2mdk
211- Corrected the doc directory path again
212
213* Mon Aug  6 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-1mdk
214- Moved to main
215- Corrected the doc directory
216- Added a menu entry
217- Updated from CVS
218
219* Mon Nov 27 2000 Lenny Cartier <lenny@mandrakesoft.com> 0.1-0.20001116mdk
220- new in contribs
221- macros
222- used srpm from rufus t firefly <rufus.t.firefly@linux-mandrake.com>
223   - v0.1-0.20001116mdk (initial packaging from CVS)
Note: See TracBrowser for help on using the repository browser.