source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 9178

Revision 9178, 13.3 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.42.0
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.36.0
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.14.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.12.16
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.31.1
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 1.42.0
14
15
16%define base_version 3.14.6
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 1%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.14/gtk+-%{version}.tar.xz
35
36Patch0: gtk3-3.10.0-gtk-widget-size-allocate.patch
37
38# for Vine
39Patch100: gtk+-3.14.0-vine-default-theme.patch
40
41BuildRequires: atk-devel >= %{atk_version}
42BuildRequires: at-spi2-atk-devel
43BuildRequires: pango-devel >= %{pango_version}
44BuildRequires: glib2-devel >= %{glib2_version}
45BuildRequires: cairo-devel >= %{cairo_version}
46BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
47BuildRequires: gtk2-devel
48BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
49BuildRequires: libtiff-devel >= 3.7
50BuildRequires: libjpeg-turbo-devel
51BuildRequires: libpng-devel
52BuildRequires: jasper-devel
53BuildRequires: colord-devel
54BuildRequires: gtk-doc >= 1.20
55BuildRequires: gamin-devel
56BuildRequires: cups-devel
57BuildRequires: rest-devel
58BuildRequires: json-glib-devel
59BuildRequires: libICE-devel
60BuildRequires: libXext-devel
61BuildRequires: libXi-devel
62BuildRequires: libXrandr-devel >= 1.3.0
63BuildRequires: libXrender-devel
64BuildRequires: libXcursor-devel
65BuildRequires: libXfixes-devel
66BuildRequires: libXinerama-devel
67BuildRequires: libXcomposite-devel
68BuildRequires: libXdamage-devel
69
70BuildRoot: %{_tmppath}/gtk-%{version}-root
71
72URL: http://www.gtk.org
73
74# required for icon themes apis to work
75Requires: hicolor-icon-theme
76
77# We need to prereq these so we can run gtk-query-immodules-2.0
78Requires(post): glib2 >= %{glib2_version}
79Requires(post): atk >= %{atk_version}
80Requires(post): pango >= %{pango_version}
81Requires(post): libSM >= 1.1.0
82# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
83Requires(post): libtiff >= 3.7
84Requires: libXrandr >= 1.3.0
85
86Vendor: Project Vine
87Distribution: Vine Linux
88Packager: Takemikaduchi
89
90
91%description
92GTK+ is a multi-platform toolkit for creating graphical user
93interfaces. Offering a complete set of widgets, GTK+ is suitable for
94projects ranging from small one-off tools to complete application
95suites.
96
97%package devel
98Summary: Development tools for GTK+ applications.
99Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
100Group: Development/Libraries
101Requires: %{name} = %{version}-%{release}
102Requires: pango-devel >= %{pango_version}
103Requires: atk-devel >= %{atk_version}
104Requires: glib2-devel >= %{glib2_version}
105Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
106Requires: libX11-devel, libXcursor-devel, libXinerama-devel
107Requires: libXext-devel, libXi-devel, libXrandr-devel
108Requires: libXfixes-devel, libXcomposite-devel
109Requires: libpng-devel
110
111%description devel
112The gtk+-devel package contains the header files and developer
113docs for the GTK+ widget toolkit. 
114
115#######################################################################
116# compat32
117%package -n compat32-%{name}
118Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
119Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
120Group: System Environment/Libraries
121Requires(post): compat32-glib2 >= %{glib2_version}
122Requires(post): compat32-atk >= %{atk_version}
123Requires(post): compat32-pango >= %{pango_version}
124Requires(post): compat32-libSM >= 1.1.0
125Requires(post): compat32-libtiff >= 3.7
126Requires: compat32-libXrandr >= 1.3.0
127
128%description -n compat32-%{name}
129GTK+ is a multi-platform toolkit for creating graphical user
130interfaces. Offering a complete set of widgets, GTK+ is suitable for
131projects ranging from small one-off tools to complete application
132suites.
133
134%package -n compat32-%{name}-devel
135Summary: Development tools for GTK+ applications.
136Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
137Group: Development/Libraries
138Requires: compat32-%{name} = %{version}-%{release}
139Requires: %{name}-devel = %{version}
140Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
141Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
142Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
143Requires: compat32-libpng-devel
144
145%description -n compat32-%{name}-devel
146The gtk+-devel package contains the header files and developer
147docs for the GTK+ widget toolkit. 
148
149
150%prep
151%setup -q -n gtk+-%{version}
152%patch0 -p1 -b .allocate
153%patch100 -p1 -b .vine-default-theme
154
155#for i in config.guess config.sub ; do
156#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
157#done
158
159%build
160
161# if ! pkg-config --exists pangoxft ; then
162#         echo "No pangoxft.pc!"
163#         exit 1
164# fi
165
166#libtoolize --force --copy
167#autoreconf -i
168
169%configure \
170        --enable-gtk2-dependency \
171        --enable-man \
172        --enable-gtk-doc \
173        --enable-debug=minimum \
174        --disable-rebuilds \
175        --disable-glibtest \
176        --enable-introspection=yes \
177        --enable-xkb=yes \
178        --enable-xinerama=yes \
179        --enable-xrandr=yes \
180        --enable-xfixes=yes \
181        --enable-xcomposite=yes \
182        --enable-xdamage=yes \
183        --enable-x11-backend \
184        --disable-packagekit \
185        --enable-colord=yes
186
187# fight unused direct deps
188sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
189
190make %{?_smp_mflags}
191
192%install
193rm -rf $RPM_BUILD_ROOT
194
195make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
196
197%find_lang gtk30
198%find_lang gtk30-properties
199
200cat gtk30.lang gtk30-properties.lang > all.lang
201
202mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
203
204# We need to have separate 32-bit and 64-bit binaries
205# for places where we have two copies of the GTK+ package installed.
206# (we might have x86_64 and i686 packages on the same system, for example.)
207%if %{build_compat32}
208   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
209      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
210%endif
211touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
212
213mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
214mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
215
216# Remove unpackaged files
217find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
218rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
219
220%clean
221rm -rf $RPM_BUILD_ROOT
222
223%post
224/sbin/ldconfig
225%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
226
227%postun
228/sbin/ldconfig
229if [ $1 -gt 0 ]; then
230  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
231fi
232glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
233
234%posttrans
235glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
236
237%if %{build_compat32}
238%post -n compat32-%{name}
239/sbin/ldconfig
240%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
241
242%postun -n compat32-%{name}
243/sbin/ldconfig
244if [ $1 = 0 ]; then
245  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
246fi
247%endif
248
249%files -f all.lang
250%defattr(-, root, root)
251%doc AUTHORS COPYING ChangeLog NEWS README
252%{_bindir}/gtk3-demo
253%{_bindir}/gtk3-demo-application
254%{_bindir}/gtk3-widget-factory
255%{_bindir}/gtk-encode-symbolic-svg
256%{_bindir}/gtk3-icon-browser
257%{_bindir}/gtk-launch
258%{_bindir}/gtk-query-immodules-3.0
259%{_libdir}/libgtk-3.so.*
260%{_libdir}/libgdk-3.so.*
261%{_libdir}/libgailutil-3.so.*
262%dir %{_libdir}/gtk-3.0
263%{_libdir}/gtk-3.0/%{bin_version}
264%dir %{_libdir}/gtk-3.0/modules
265%{_libdir}/girepository-1.0/*.typelib
266%{_datadir}/applications/gtk3-demo.desktop
267%{_datadir}/applications/gtk3-icon-browser.desktop
268%{_datadir}/applications/gtk3-widget-factory.desktop
269%{_datadir}/gtk-3.0
270%{_datadir}/icons/hicolor/*/apps/*
271%{_datadir}/themes/Default
272%{_datadir}/themes/Emacs
273%dir %{_sysconfdir}/gtk-3.0
274%{_sysconfdir}/gtk-3.0/im-multipress.conf
275%{_datadir}/glib-2.0/schemas/*.xml
276
277%files devel
278%defattr(-, root, root)
279%{_libdir}/lib*.so
280%dir %{_libdir}/gtk-3.0
281%{_datadir}/gtk-doc/
282%{_datadir}/gir-1.0/*.gir
283%{_mandir}/man1/*
284%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
285%{_includedir}/*
286%{_datadir}/aclocal/*
287%{_libdir}/pkgconfig/*
288
289# compat32
290%if %{build_compat32}
291%files -n compat32-%{name}
292%defattr(-, root, root)
293%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
294%{_libdir}/libgtk-3.so.*
295%{_libdir}/libgdk-3.so.*
296%{_libdir}/libgailutil-3.so.*
297%dir %{_libdir}/gtk-3.0
298%{_libdir}/gtk-3.0/%{bin_version}
299%dir %{_libdir}/gtk-3.0/modules
300%dir %{_sysconfdir}/gtk-3.0
301
302%files -n compat32-%{name}-devel
303%defattr(-, root, root)
304%{_libdir}/lib*.so
305%dir %{_libdir}/gtk-3.0
306%endif
307
308%changelog
309* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.6-1
310- new upstream release
311
312* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.5-1
313- new upstream release
314- add BuildRequires: gtk2-devel, rest-devel, json-glib-devel
315
316* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.4-1
317- new upstream release
318- update Patch100 (gtk+-3.14.0-vine-default-theme.patch)
319
320* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
321- new upstream release
322
323* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
324- new upstream release
325
326* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
327- new upstream release
328- update Patch100 (gtk+-3.12.0-vine-default-theme.patch)
329
330* Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.7-1
331- new upstream release
332
333* Sat Dec 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.6-1
334- new upstream release
335
336* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.5-1
337- new upstream release
338
339* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
340- new upstream release
341- update Patch0 (gtk3-3.10.0-gtk-widget-size-allocate.patch)
342- remove Patch1 (gtk3-3.8.2-immodule.patch)
343
344* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
345- new upstream release
346
347* Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
348- add Patch1 (gtk3-3.8.2-immodule.patch)
349
350* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
351- new upstream release
352
353* Fri Apr 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
354- new upstream release
355
356* Tue Jan 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
357- new upstream release
358
359* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
360- new upstream release
361
362* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
363- new upstream release
364
365* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
366- new upstream release
367
368* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
369- new upstream release
370- add BuildRequires: at-spi2-atk-devel
371
372* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
373- new upstream release
374
375* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
376- new upstream release
377
378* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
379- new upstream release
380
381* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
382- new upstream release
383- update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
384
385* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
386- new upstream release
387
388* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
389- new upstream release
390
391* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
392- new upstream release
393- remove Patch1
394
395* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
396- new upstream release
397- add Patch1 (gtk3-3.2.1-bug658772.patch)
398
399* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
400- new upstream release
401
402* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
403- new upstream release
404
405* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
406- new upstream release
407
408* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
409- new upstream release
410
411* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
412- new upstream release
413- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
414
415* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
416- fix %%files
417
418* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
419- new upstream release
420- add BuildRequires: colord-devel
421
422* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
423- new upstream release
424
425* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
426- new upstream release
427
428* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
429- new upstream release
430
431* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
432- new upstream release
433
434* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
435- new upstream release
436
437* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
438- new upstream release
439
440* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
441- new upstream release
442
443* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
444- new upstream release
445
446* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
447- new upstream release
448
449* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
450- initial build for Vine Linux
451
Note: See TracBrowser for help on using the repository browser.