source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 7758

Revision 7758, 12.7 KB checked in by Takemikaduchi, 11 years ago (diff)

fix bug

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.36.0
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.34.0
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.8.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.12.14
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.28.0
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 1.36.0
14
15
16%define base_version 3.8.2
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 2%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.8/gtk+-%{version}.tar.xz
35
36Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
37
38# from upstream
39# https://bugzilla.gnome.org/show_bug.cgi?id=703533
40# https://git.gnome.org/browse/gtk+/commit/?id=837a0d3e4002e640be2aea2a67802c474997e354
41# https://git.gnome.org/browse/gtk+/commit/?id=ea715a49e481bb204e13ca1f24733cfc40017e30
42Patch1: gtk3-3.8.2-immodule.patch
43
44# for Vine
45Patch100: gtk+-3.4.0-vine-default-theme.patch
46
47BuildRequires: atk-devel >= %{atk_version}
48BuildRequires: at-spi2-atk-devel
49BuildRequires: pango-devel >= %{pango_version}
50BuildRequires: glib2-devel >= %{glib2_version}
51BuildRequires: cairo-devel >= %{cairo_version}
52BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
53BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
54BuildRequires: libtiff-devel >= 3.7
55BuildRequires: libjpeg-turbo-devel
56BuildRequires: libpng-devel
57BuildRequires: jasper-devel
58BuildRequires: colord-devel
59BuildRequires: gtk-doc
60BuildRequires: gamin-devel
61BuildRequires: cups-devel
62BuildRequires: libICE-devel
63BuildRequires: libXext-devel
64BuildRequires: libXi-devel
65BuildRequires: libXrandr-devel >= 1.3.0
66BuildRequires: libXrender-devel
67BuildRequires: libXcursor-devel
68BuildRequires: libXfixes-devel
69BuildRequires: libXinerama-devel
70BuildRequires: libXcomposite-devel
71BuildRequires: libXdamage-devel
72
73BuildRoot: %{_tmppath}/gtk-%{version}-root
74
75URL: http://www.gtk.org
76
77# required for icon themes apis to work
78Requires: hicolor-icon-theme
79
80# We need to prereq these so we can run gtk-query-immodules-2.0
81Requires(post): glib2 >= %{glib2_version}
82Requires(post): atk >= %{atk_version}
83Requires(post): pango >= %{pango_version}
84Requires(post): libSM >= 1.1.0
85# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
86Requires(post): libtiff >= 3.7
87Requires: libXrandr >= 1.3.0
88
89Vendor: Project Vine
90Distribution: Vine Linux
91Packager: Takemikaduchi
92
93
94%description
95GTK+ is a multi-platform toolkit for creating graphical user
96interfaces. Offering a complete set of widgets, GTK+ is suitable for
97projects ranging from small one-off tools to complete application
98suites.
99
100%package devel
101Summary: Development tools for GTK+ applications.
102Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
103Group: Development/Libraries
104Requires: %{name} = %{version}-%{release}
105Requires: pango-devel >= %{pango_version}
106Requires: atk-devel >= %{atk_version}
107Requires: glib2-devel >= %{glib2_version}
108Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
109Requires: libX11-devel, libXcursor-devel, libXinerama-devel
110Requires: libXext-devel, libXi-devel, libXrandr-devel
111Requires: libXfixes-devel, libXcomposite-devel
112Requires: libpng-devel
113
114%description devel
115The gtk+-devel package contains the header files and developer
116docs for the GTK+ widget toolkit. 
117
118#######################################################################
119# compat32
120%package -n compat32-%{name}
121Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
122Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
123Group: System Environment/Libraries
124Requires(post): compat32-glib2 >= %{glib2_version}
125Requires(post): compat32-atk >= %{atk_version}
126Requires(post): compat32-pango >= %{pango_version}
127Requires(post): compat32-libSM >= 1.1.0
128Requires(post): compat32-libtiff >= 3.7
129Requires: compat32-libXrandr >= 1.3.0
130
131%description -n compat32-%{name}
132GTK+ is a multi-platform toolkit for creating graphical user
133interfaces. Offering a complete set of widgets, GTK+ is suitable for
134projects ranging from small one-off tools to complete application
135suites.
136
137%package -n compat32-%{name}-devel
138Summary: Development tools for GTK+ applications.
139Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
140Group: Development/Libraries
141Requires: compat32-%{name} = %{version}-%{release}
142Requires: %{name}-devel = %{version}
143Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
144Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
145Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
146Requires: compat32-libpng-devel
147
148%description -n compat32-%{name}-devel
149The gtk+-devel package contains the header files and developer
150docs for the GTK+ widget toolkit. 
151
152
153%prep
154%setup -q -n gtk+-%{version}
155%patch0 -p1 -b .allocate
156%patch1 -p1 -b .immodules
157%patch100 -p1 -b .vine-default-theme
158
159#for i in config.guess config.sub ; do
160#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
161#done
162
163%build
164
165# if ! pkg-config --exists pangoxft ; then
166#         echo "No pangoxft.pc!"
167#         exit 1
168# fi
169
170#libtoolize --force --copy
171#autoreconf -i
172
173%configure \
174        --enable-gtk-doc \
175        --enable-man \
176        --enable-debug=minimum \
177        --disable-rebuilds \
178        --disable-glibtest \
179        --enable-introspection=yes \
180        --enable-xkb=yes \
181        --enable-xinerama=yes \
182        --enable-xrandr=yes \
183        --enable-xfixes=yes \
184        --enable-xcomposite=yes \
185        --enable-xdamage=yes \
186        --enable-x11-backend \
187        --disable-packagekit \
188        --enable-colord=yes
189
190# fight unused direct deps
191sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
192
193make %{?_smp_mflags}
194
195%install
196rm -rf $RPM_BUILD_ROOT
197
198make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
199
200%find_lang gtk30
201%find_lang gtk30-properties
202
203cat gtk30.lang gtk30-properties.lang > all.lang
204
205mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
206#
207# Make cleaned-up versions of examples and tutorial for installation
208#
209mkdir -p tmpdocs/tutorial
210# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
211for dir in examples/* ; do
212    if [ -d $dir ] ; then
213       mkdir -p tmpdocs/$dir
214       for file in $dir/* ; do
215          case $file in
216             *pre1.2.7)
217                ;;
218             *)
219                install -m 0644 $file tmpdocs/$dir
220                ;;
221          esac
222       done
223    fi
224done
225
226
227# We need to have separate 32-bit and 64-bit binaries
228# for places where we have two copies of the GTK+ package installed.
229# (we might have x86_64 and i686 packages on the same system, for example.)
230%if %{build_compat32}
231   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
232      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
233%endif
234touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
235
236mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
237mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
238
239# Remove unpackaged files
240find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
241rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
242
243mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
244   $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
245
246%clean
247rm -rf $RPM_BUILD_ROOT
248
249%post
250/sbin/ldconfig
251%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
252
253%postun
254/sbin/ldconfig
255if [ $1 -gt 0 ]; then
256  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
257fi
258glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
259
260%posttrans
261glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
262
263%if %{build_compat32}
264%post -n compat32-%{name}
265/sbin/ldconfig
266%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
267
268%postun -n compat32-%{name}
269/sbin/ldconfig
270if [ $1 = 0 ]; then
271  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
272fi
273%endif
274
275%files -f all.lang
276%defattr(-, root, root)
277%doc AUTHORS COPYING ChangeLog NEWS README
278%{_bindir}/gtk3-demo
279%{_bindir}/gtk3-demo-application
280%{_bindir}/gtk3-widget-factory
281%{_bindir}/gtk-launch
282%{_bindir}/gtk-query-immodules-3.0
283%{_bindir}/gtk-update-icon-cache-3.0
284%{_libdir}/libgtk-3.so.*
285%{_libdir}/libgdk-3.so.*
286%{_libdir}/libgailutil-3.so.*
287%dir %{_libdir}/gtk-3.0
288%{_libdir}/gtk-3.0/%{bin_version}
289%dir %{_libdir}/gtk-3.0/modules
290#%{_libdir}/gtk-3.0/modules/lib*.so
291%{_libdir}/girepository-1.0/*.typelib
292%{_datadir}/gtk-3.0
293%{_datadir}/themes/Default
294%{_datadir}/themes/Emacs
295%dir %{_sysconfdir}/gtk-3.0
296%{_sysconfdir}/gtk-3.0/im-multipress.conf
297%{_datadir}/glib-2.0/schemas/*.xml
298
299%files devel
300%defattr(-, root, root)
301%{_libdir}/lib*.so
302%dir %{_libdir}/gtk-3.0
303%{_datadir}/gtk-doc/
304%{_datadir}/gir-1.0/*.gir
305%{_mandir}/man1/*
306%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
307%{_includedir}/*
308%{_datadir}/aclocal/*
309%{_libdir}/pkgconfig/*
310%doc tmpdocs/tutorial
311
312# compat32
313%if %{build_compat32}
314%files -n compat32-%{name}
315%defattr(-, root, root)
316%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
317%{_libdir}/libgtk-3.so.*
318%{_libdir}/libgdk-3.so.*
319%{_libdir}/libgailutil-3.so.*
320%dir %{_libdir}/gtk-3.0
321%{_libdir}/gtk-3.0/%{bin_version}
322%dir %{_libdir}/gtk-3.0/modules
323#%{_libdir}/gtk-3.0/modules/lib*.so
324%dir %{_sysconfdir}/gtk-3.0
325
326%files -n compat32-%{name}-devel
327%defattr(-, root, root)
328%{_libdir}/lib*.so
329%dir %{_libdir}/gtk-3.0
330%endif
331
332%changelog
333* Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
334- add Patch1 (gtk3-3.8.2-immodule.patch)
335
336* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
337- new upstream release
338
339* Fri Apr 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
340- new upstream release
341
342* Tue Jan 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
343- new upstream release
344
345* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
346- new upstream release
347
348* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
349- new upstream release
350
351* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
352- new upstream release
353
354* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
355- new upstream release
356- add BuildRequires: at-spi2-atk-devel
357
358* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
359- new upstream release
360
361* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
362- new upstream release
363
364* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
365- new upstream release
366
367* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
368- new upstream release
369- update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
370
371* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
372- new upstream release
373
374* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
375- new upstream release
376
377* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
378- new upstream release
379- remove Patch1
380
381* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
382- new upstream release
383- add Patch1 (gtk3-3.2.1-bug658772.patch)
384
385* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
386- new upstream release
387
388* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
389- new upstream release
390
391* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
392- new upstream release
393
394* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
395- new upstream release
396
397* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
398- new upstream release
399- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
400
401* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
402- fix %%files
403
404* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
405- new upstream release
406- add BuildRequires: colord-devel
407
408* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
409- new upstream release
410
411* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
412- new upstream release
413
414* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
415- new upstream release
416
417* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
418- new upstream release
419
420* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
421- new upstream release
422
423* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
424- new upstream release
425
426* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
427- new upstream release
428
429* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
430- new upstream release
431
432* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
433- new upstream release
434
435* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
436- initial build for Vine Linux
437
Note: See TracBrowser for help on using the repository browser.