source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 7633

Revision 7633, 12.2 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.36.0
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.34.0
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.8.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.12.14
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.28.0
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 1.36.0
14
15
16%define base_version 3.8.1
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 1%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.8/gtk+-%{version}.tar.xz
35
36Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
37Patch100: gtk+-3.4.0-vine-default-theme.patch
38
39BuildRequires: atk-devel >= %{atk_version}
40BuildRequires: at-spi2-atk-devel
41BuildRequires: pango-devel >= %{pango_version}
42BuildRequires: glib2-devel >= %{glib2_version}
43BuildRequires: cairo-devel >= %{cairo_version}
44BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
45BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
46BuildRequires: libtiff-devel >= 3.7
47BuildRequires: libjpeg-turbo-devel
48BuildRequires: libpng-devel
49BuildRequires: jasper-devel
50BuildRequires: colord-devel
51BuildRequires: gtk-doc
52BuildRequires: gamin-devel
53BuildRequires: cups-devel
54BuildRequires: libICE-devel
55BuildRequires: libXext-devel
56BuildRequires: libXi-devel
57BuildRequires: libXrandr-devel >= 1.3.0
58BuildRequires: libXrender-devel
59BuildRequires: libXcursor-devel
60BuildRequires: libXfixes-devel
61BuildRequires: libXinerama-devel
62BuildRequires: libXcomposite-devel
63BuildRequires: libXdamage-devel
64
65BuildRoot: %{_tmppath}/gtk-%{version}-root
66
67URL: http://www.gtk.org
68
69# required for icon themes apis to work
70Requires: hicolor-icon-theme
71
72# We need to prereq these so we can run gtk-query-immodules-2.0
73Requires(post): glib2 >= %{glib2_version}
74Requires(post): atk >= %{atk_version}
75Requires(post): pango >= %{pango_version}
76Requires(post): libSM >= 1.1.0
77# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
78Requires(post): libtiff >= 3.7
79Requires: libXrandr >= 1.3.0
80
81Vendor: Project Vine
82Distribution: Vine Linux
83Packager: Takemikaduchi
84
85
86%description
87GTK+ is a multi-platform toolkit for creating graphical user
88interfaces. Offering a complete set of widgets, GTK+ is suitable for
89projects ranging from small one-off tools to complete application
90suites.
91
92%package devel
93Summary: Development tools for GTK+ applications.
94Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
95Group: Development/Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: pango-devel >= %{pango_version}
98Requires: atk-devel >= %{atk_version}
99Requires: glib2-devel >= %{glib2_version}
100Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
101Requires: libX11-devel, libXcursor-devel, libXinerama-devel
102Requires: libXext-devel, libXi-devel, libXrandr-devel
103Requires: libXfixes-devel, libXcomposite-devel
104Requires: libpng-devel
105
106%description devel
107The gtk+-devel package contains the header files and developer
108docs for the GTK+ widget toolkit. 
109
110#######################################################################
111# compat32
112%package -n compat32-%{name}
113Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
114Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
115Group: System Environment/Libraries
116Requires(post): compat32-glib2 >= %{glib2_version}
117Requires(post): compat32-atk >= %{atk_version}
118Requires(post): compat32-pango >= %{pango_version}
119Requires(post): compat32-libSM >= 1.1.0
120Requires(post): compat32-libtiff >= 3.7
121Requires: compat32-libXrandr >= 1.3.0
122
123%description -n compat32-%{name}
124GTK+ is a multi-platform toolkit for creating graphical user
125interfaces. Offering a complete set of widgets, GTK+ is suitable for
126projects ranging from small one-off tools to complete application
127suites.
128
129%package -n compat32-%{name}-devel
130Summary: Development tools for GTK+ applications.
131Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
132Group: Development/Libraries
133Requires: compat32-%{name} = %{version}-%{release}
134Requires: %{name}-devel = %{version}
135Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
136Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
137Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
138Requires: compat32-libpng-devel
139
140%description -n compat32-%{name}-devel
141The gtk+-devel package contains the header files and developer
142docs for the GTK+ widget toolkit. 
143
144
145%prep
146%setup -q -n gtk+-%{version}
147%patch0 -p1 -b .allocate
148%patch100 -p1 -b .vine-default-theme
149
150#for i in config.guess config.sub ; do
151#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
152#done
153
154%build
155
156# if ! pkg-config --exists pangoxft ; then
157#         echo "No pangoxft.pc!"
158#         exit 1
159# fi
160
161#libtoolize --force --copy
162#autoreconf -i
163
164%configure \
165        --enable-gtk-doc \
166        --enable-man \
167        --enable-debug=minimum \
168        --disable-rebuilds \
169        --disable-glibtest \
170        --enable-introspection=yes \
171        --enable-xkb=yes \
172        --enable-xinerama=yes \
173        --enable-xrandr=yes \
174        --enable-xfixes=yes \
175        --enable-xcomposite=yes \
176        --enable-xdamage=yes \
177        --enable-x11-backend \
178        --disable-packagekit \
179        --enable-colord=yes
180
181# fight unused direct deps
182sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
183
184make %{?_smp_mflags}
185
186%install
187rm -rf $RPM_BUILD_ROOT
188
189make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
190
191%find_lang gtk30
192%find_lang gtk30-properties
193
194cat gtk30.lang gtk30-properties.lang > all.lang
195
196mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
197#
198# Make cleaned-up versions of examples and tutorial for installation
199#
200mkdir -p tmpdocs/tutorial
201# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
202for dir in examples/* ; do
203    if [ -d $dir ] ; then
204       mkdir -p tmpdocs/$dir
205       for file in $dir/* ; do
206          case $file in
207             *pre1.2.7)
208                ;;
209             *)
210                install -m 0644 $file tmpdocs/$dir
211                ;;
212          esac
213       done
214    fi
215done
216
217
218# We need to have separate 32-bit and 64-bit binaries
219# for places where we have two copies of the GTK+ package installed.
220# (we might have x86_64 and i686 packages on the same system, for example.)
221%if %{build_compat32}
222   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
223      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
224%endif
225touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
226
227mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
228mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
229
230# Remove unpackaged files
231find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
232rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
233
234mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
235   $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
236
237%clean
238rm -rf $RPM_BUILD_ROOT
239
240%post
241/sbin/ldconfig
242%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
243
244%postun
245/sbin/ldconfig
246if [ $1 -gt 0 ]; then
247  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
248fi
249glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
250
251%posttrans
252glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
253
254%if %{build_compat32}
255%post -n compat32-%{name}
256/sbin/ldconfig
257%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
258
259%postun -n compat32-%{name}
260/sbin/ldconfig
261if [ $1 = 0 ]; then
262  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
263fi
264%endif
265
266%files -f all.lang
267%defattr(-, root, root)
268%doc AUTHORS COPYING ChangeLog NEWS README
269%{_bindir}/gtk3-demo
270%{_bindir}/gtk3-demo-application
271%{_bindir}/gtk3-widget-factory
272%{_bindir}/gtk-launch
273%{_bindir}/gtk-query-immodules-3.0
274%{_bindir}/gtk-update-icon-cache-3.0
275%{_libdir}/libgtk-3.so.*
276%{_libdir}/libgdk-3.so.*
277%{_libdir}/libgailutil-3.so.*
278%dir %{_libdir}/gtk-3.0
279%{_libdir}/gtk-3.0/%{bin_version}
280%dir %{_libdir}/gtk-3.0/modules
281#%{_libdir}/gtk-3.0/modules/lib*.so
282%{_libdir}/girepository-1.0/*.typelib
283%{_datadir}/gtk-3.0
284%{_datadir}/themes/Default
285%{_datadir}/themes/Emacs
286%dir %{_sysconfdir}/gtk-3.0
287%{_sysconfdir}/gtk-3.0/im-multipress.conf
288%{_datadir}/glib-2.0/schemas/*.xml
289
290%files devel
291%defattr(-, root, root)
292%{_libdir}/lib*.so
293%dir %{_libdir}/gtk-3.0
294%{_datadir}/gtk-doc/
295%{_datadir}/gir-1.0/*.gir
296%{_mandir}/man1/*
297%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
298%{_includedir}/*
299%{_datadir}/aclocal/*
300%{_libdir}/pkgconfig/*
301%doc tmpdocs/tutorial
302
303# compat32
304%if %{build_compat32}
305%files -n compat32-%{name}
306%defattr(-, root, root)
307%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
308%{_libdir}/libgtk-3.so.*
309%{_libdir}/libgdk-3.so.*
310%{_libdir}/libgailutil-3.so.*
311%dir %{_libdir}/gtk-3.0
312%{_libdir}/gtk-3.0/%{bin_version}
313%dir %{_libdir}/gtk-3.0/modules
314#%{_libdir}/gtk-3.0/modules/lib*.so
315%dir %{_sysconfdir}/gtk-3.0
316
317%files -n compat32-%{name}-devel
318%defattr(-, root, root)
319%{_libdir}/lib*.so
320%dir %{_libdir}/gtk-3.0
321%endif
322
323%changelog
324* Fri Apr 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
325- new upstream release
326
327* Tue Jan 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
328- new upstream release
329
330* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
331- new upstream release
332
333* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
334- new upstream release
335
336* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
337- new upstream release
338
339* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
340- new upstream release
341- add BuildRequires: at-spi2-atk-devel
342
343* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
344- new upstream release
345
346* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
347- new upstream release
348
349* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
350- new upstream release
351
352* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
353- new upstream release
354- update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
355
356* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
357- new upstream release
358
359* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
360- new upstream release
361
362* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
363- new upstream release
364- remove Patch1
365
366* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
367- new upstream release
368- add Patch1 (gtk3-3.2.1-bug658772.patch)
369
370* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
371- new upstream release
372
373* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
374- new upstream release
375
376* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
377- new upstream release
378
379* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
380- new upstream release
381
382* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
383- new upstream release
384- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
385
386* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
387- fix %%files
388
389* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
390- new upstream release
391- add BuildRequires: colord-devel
392
393* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
394- new upstream release
395
396* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
397- new upstream release
398
399* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
400- new upstream release
401
402* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
403- new upstream release
404
405* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
406- new upstream release
407
408* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
409- new upstream release
410
411* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
412- new upstream release
413
414* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
415- new upstream release
416
417* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
418- new upstream release
419
420* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
421- initial build for Vine Linux
422
Note: See TracBrowser for help on using the repository browser.