source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 6179

Revision 6179, 11.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.32.2
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.30.0
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.4.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.12.0
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.26.1
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 1.32.1
14
15
16%define base_version 3.4.3
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 1%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.4/gtk+-%{version}.tar.xz
35
36Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
37Patch100: gtk+-3.4.0-vine-default-theme.patch
38
39BuildRequires: atk-devel >= %{atk_version}
40BuildRequires: pango-devel >= %{pango_version}
41BuildRequires: glib2-devel >= %{glib2_version}
42BuildRequires: cairo-devel >= %{cairo_version}
43BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
44BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
45BuildRequires: libtiff-devel >= 3.7
46BuildRequires: libjpeg-turbo-devel
47BuildRequires: libpng-devel
48BuildRequires: jasper-devel
49BuildRequires: colord-devel
50BuildRequires: gtk-doc
51BuildRequires: gamin-devel
52BuildRequires: cups-devel
53BuildRequires: libICE-devel
54BuildRequires: libXext-devel
55BuildRequires: libXi-devel
56BuildRequires: libXrandr-devel >= 1.3.0
57BuildRequires: libXrender-devel
58BuildRequires: libXcursor-devel
59BuildRequires: libXfixes-devel
60BuildRequires: libXinerama-devel
61BuildRequires: libXcomposite-devel
62BuildRequires: libXdamage-devel
63
64BuildRoot: %{_tmppath}/gtk-%{version}-root
65
66URL: http://www.gtk.org
67
68# required for icon themes apis to work
69Requires: hicolor-icon-theme
70
71# We need to prereq these so we can run gtk-query-immodules-2.0
72Requires(post): glib2 >= %{glib2_version}
73Requires(post): atk >= %{atk_version}
74Requires(post): pango >= %{pango_version}
75Requires(post): libSM >= 1.1.0
76# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
77Requires(post): libtiff >= 3.7
78Requires: libXrandr >= 1.3.0
79
80Vendor: Project Vine
81Distribution: Vine Linux
82Packager: Takemikaduchi
83
84
85%description
86GTK+ is a multi-platform toolkit for creating graphical user
87interfaces. Offering a complete set of widgets, GTK+ is suitable for
88projects ranging from small one-off tools to complete application
89suites.
90
91%package devel
92Summary: Development tools for GTK+ applications.
93Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96Requires: pango-devel >= %{pango_version}
97Requires: atk-devel >= %{atk_version}
98Requires: glib2-devel >= %{glib2_version}
99Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
100Requires: libX11-devel, libXcursor-devel, libXinerama-devel
101Requires: libXext-devel, libXi-devel, libXrandr-devel
102Requires: libXfixes-devel, libXcomposite-devel
103Requires: libpng-devel
104
105%description devel
106The gtk+-devel package contains the header files and developer
107docs for the GTK+ widget toolkit. 
108
109#######################################################################
110# compat32
111%package -n compat32-%{name}
112Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
113Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
114Group: System Environment/Libraries
115Requires(post): compat32-glib2 >= %{glib2_version}
116Requires(post): compat32-atk >= %{atk_version}
117Requires(post): compat32-pango >= %{pango_version}
118Requires(post): compat32-libSM >= 1.1.0
119Requires(post): compat32-libtiff >= 3.7
120Requires: compat32-libXrandr >= 1.3.0
121
122%description -n compat32-%{name}
123GTK+ is a multi-platform toolkit for creating graphical user
124interfaces. Offering a complete set of widgets, GTK+ is suitable for
125projects ranging from small one-off tools to complete application
126suites.
127
128%package -n compat32-%{name}-devel
129Summary: Development tools for GTK+ applications.
130Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
131Group: Development/Libraries
132Requires: compat32-%{name} = %{version}-%{release}
133Requires: %{name}-devel = %{version}
134Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
135Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
136Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
137Requires: compat32-libpng-devel
138
139%description -n compat32-%{name}-devel
140The gtk+-devel package contains the header files and developer
141docs for the GTK+ widget toolkit. 
142
143
144%prep
145%setup -q -n gtk+-%{version}
146%patch0 -p1 -b .allocate
147%patch100 -p1 -b .vine-default-theme
148
149#for i in config.guess config.sub ; do
150#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
151#done
152
153%build
154
155# if ! pkg-config --exists pangoxft ; then
156#         echo "No pangoxft.pc!"
157#         exit 1
158# fi
159
160#libtoolize --force --copy
161#autoreconf -i
162
163%configure --enable-gtk-doc \
164        --enable-man \
165        --enable-debug=minimum \
166        --disable-rebuilds \
167        --disable-glibtest \
168        --enable-introspection=yes \
169        --enable-xrandr \
170        --enable-xfixes \
171        --enable-xcomposite \
172        --enable-xdamage \
173        --enable-x11-backend
174
175make ARCH=%{_arch}
176#make
177
178%install
179rm -rf $RPM_BUILD_ROOT
180
181make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
182
183%find_lang gtk30
184%find_lang gtk30-properties
185
186cat gtk30.lang gtk30-properties.lang > all.lang
187
188mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
189#
190# Make cleaned-up versions of examples and tutorial for installation
191#
192mkdir -p tmpdocs/tutorial
193# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
194for dir in examples/* ; do
195    if [ -d $dir ] ; then
196       mkdir -p tmpdocs/$dir
197       for file in $dir/* ; do
198          case $file in
199             *pre1.2.7)
200                ;;
201             *)
202                install -m 0644 $file tmpdocs/$dir
203                ;;
204          esac
205       done
206    fi
207done
208
209
210# We need to have separate 32-bit and 64-bit binaries
211# for places where we have two copies of the GTK+ package installed.
212# (we might have x86_64 and i686 packages on the same system, for example.)
213%if %{build_compat32}
214   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
215      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
216%endif
217touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
218
219mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
220mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
221
222# Remove unpackaged files
223find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
224rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
225
226mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
227   $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
228
229%clean
230rm -rf $RPM_BUILD_ROOT
231
232%post
233/sbin/ldconfig
234%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
235
236%postun
237/sbin/ldconfig
238if [ $1 -gt 0 ]; then
239  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
240fi
241glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
242
243%posttrans
244glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
245
246%if %{build_compat32}
247%post -n compat32-%{name}
248/sbin/ldconfig
249%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
250
251%postun -n compat32-%{name}
252/sbin/ldconfig
253if [ $1 = 0 ]; then
254  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
255fi
256%endif
257
258%files -f all.lang
259%defattr(-, root, root)
260%doc AUTHORS COPYING ChangeLog NEWS README
261%{_bindir}/gtk3-demo
262%{_bindir}/gtk3-demo-application
263%{_bindir}/gtk3-widget-factory
264%{_bindir}/gtk-query-immodules-3.0
265%{_bindir}/gtk-update-icon-cache-3.0
266%{_libdir}/libgtk-3.so.*
267%{_libdir}/libgdk-3.so.*
268%{_libdir}/libgailutil-3.so.*
269%dir %{_libdir}/gtk-3.0
270%{_libdir}/gtk-3.0/%{bin_version}
271%dir %{_libdir}/gtk-3.0/modules
272#%{_libdir}/gtk-3.0/modules/lib*.so
273%{_libdir}/girepository-1.0/*.typelib
274%{_datadir}/gtk-3.0
275%{_datadir}/themes/Default
276%{_datadir}/themes/Emacs
277%dir %{_sysconfdir}/gtk-3.0
278%{_sysconfdir}/gtk-3.0/im-multipress.conf
279%{_datadir}/glib-2.0/schemas/*.xml
280
281%files devel
282%defattr(-, root, root)
283%{_libdir}/lib*.so
284%dir %{_libdir}/gtk-3.0
285%{_datadir}/gtk-doc/
286%{_datadir}/gir-1.0/*.gir
287%{_mandir}/man1/*
288%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
289%{_includedir}/*
290%{_datadir}/aclocal/*
291%{_libdir}/pkgconfig/*
292%doc tmpdocs/tutorial
293
294# compat32
295%if %{build_compat32}
296%files -n compat32-%{name}
297%defattr(-, root, root)
298%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
299%{_libdir}/libgtk-3.so.*
300%{_libdir}/libgdk-3.so.*
301%{_libdir}/libgailutil-3.so.*
302%dir %{_libdir}/gtk-3.0
303%{_libdir}/gtk-3.0/%{bin_version}
304%dir %{_libdir}/gtk-3.0/modules
305#%{_libdir}/gtk-3.0/modules/lib*.so
306%dir %{_sysconfdir}/gtk-3.0
307
308%files -n compat32-%{name}-devel
309%defattr(-, root, root)
310%{_libdir}/lib*.so
311%dir %{_libdir}/gtk-3.0
312%{_libdir}/pkgconfig/*
313%endif
314
315%changelog
316* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
317- new upstream release
318
319* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
320- new upstream release
321
322* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
323- new upstream release
324- update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
325
326* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
327- new upstream release
328
329* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
330- new upstream release
331
332* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
333- new upstream release
334- remove Patch1
335
336* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
337- new upstream release
338- add Patch1 (gtk3-3.2.1-bug658772.patch)
339
340* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
341- new upstream release
342
343* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
344- new upstream release
345
346* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
347- new upstream release
348
349* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
350- new upstream release
351
352* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
353- new upstream release
354- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
355
356* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
357- fix %%files
358
359* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
360- new upstream release
361- add BuildRequires: colord-devel
362
363* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
364- new upstream release
365
366* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
367- new upstream release
368
369* Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
370- new upstream release
371
372* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
373- new upstream release
374
375* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
376- new upstream release
377
378* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
379- new upstream release
380
381* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
382- new upstream release
383
384* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
385- new upstream release
386
387* Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
388- new upstream release
389
390* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
391- initial build for Vine Linux
392
Note: See TracBrowser for help on using the repository browser.