source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 5007

Revision 5007, 10.8 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.30.0
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.29.3
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.2.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.10.2
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.24.0
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 1.30.0
14
15
16%define base_version 3.2.1
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 1%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.2/gtk+-%{version}.tar.xz
35
36Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
37Patch1: gtk3-3.2.1-bug658772.patch
38Patch100: gtk+-2.99.3-vine-default-theme.patch
39
40BuildRequires: atk-devel >= %{atk_version}
41BuildRequires: pango-devel >= %{pango_version}
42BuildRequires: glib2-devel >= %{glib2_version}
43BuildRequires: cairo-devel >= %{cairo_version}
44BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
45BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
46BuildRequires: libtiff-devel >= 3.7
47BuildRequires: libjpeg-turbo-devel
48BuildRequires: libpng-devel
49BuildRequires: jasper-devel
50BuildRequires: colord-devel
51BuildRequires: gtk-doc
52BuildRequires: gamin-devel
53BuildRequires: cups-devel
54BuildRequires: libICE-devel
55BuildRequires: libXext-devel
56BuildRequires: libXi-devel
57BuildRequires: libXrandr-devel >= 1.3.0
58BuildRequires: libXrender-devel
59BuildRequires: libXcursor-devel
60BuildRequires: libXfixes-devel
61BuildRequires: libXinerama-devel
62BuildRequires: libXcomposite-devel
63BuildRequires: libXdamage-devel
64
65BuildRoot: %{_tmppath}/gtk-%{version}-root
66
67URL: http://www.gtk.org
68
69# required for icon themes apis to work
70Requires: hicolor-icon-theme
71
72# We need to prereq these so we can run gtk-query-immodules-2.0
73Requires(post): glib2 >= %{glib2_version}
74Requires(post): atk >= %{atk_version}
75Requires(post): pango >= %{pango_version}
76Requires(post): libSM >= 1.1.0
77# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
78Requires(post): libtiff >= 3.7
79Requires: libXrandr >= 1.3.0
80
81Vendor: Project Vine
82Distribution: Vine Linux
83Packager: Takemikaduchi
84
85
86%description
87GTK+ is a multi-platform toolkit for creating graphical user
88interfaces. Offering a complete set of widgets, GTK+ is suitable for
89projects ranging from small one-off tools to complete application
90suites.
91
92%package devel
93Summary: Development tools for GTK+ applications.
94Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
95Group: Development/Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: pango-devel >= %{pango_version}
98Requires: atk-devel >= %{atk_version}
99Requires: glib2-devel >= %{glib2_version}
100Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
101Requires: libX11-devel, libXcursor-devel, libXinerama-devel
102Requires: libXext-devel, libXi-devel, libXrandr-devel
103Requires: libXfixes-devel, libXcomposite-devel
104Requires: libpng-devel
105
106%description devel
107The gtk+-devel package contains the header files and developer
108docs for the GTK+ widget toolkit. 
109
110#######################################################################
111# compat32
112%package -n compat32-%{name}
113Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
114Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
115Group: System Environment/Libraries
116Requires(post): compat32-glib2 >= %{glib2_version}
117Requires(post): compat32-atk >= %{atk_version}
118Requires(post): compat32-pango >= %{pango_version}
119Requires(post): compat32-libSM >= 1.1.0
120Requires(post): compat32-libtiff >= 3.7
121Requires: compat32-libXrandr >= 1.3.0
122
123%description -n compat32-%{name}
124GTK+ is a multi-platform toolkit for creating graphical user
125interfaces. Offering a complete set of widgets, GTK+ is suitable for
126projects ranging from small one-off tools to complete application
127suites.
128
129%package -n compat32-%{name}-devel
130Summary: Development tools for GTK+ applications.
131Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
132Group: Development/Libraries
133Requires: compat32-%{name} = %{version}-%{release}
134Requires: %{name}-devel = %{version}
135Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
136Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
137Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
138Requires: compat32-libpng-devel
139
140%description -n compat32-%{name}-devel
141The gtk+-devel package contains the header files and developer
142docs for the GTK+ widget toolkit. 
143
144
145%prep
146%setup -q -n gtk+-%{version}
147%patch0 -p1 -b .allocate
148%patch1 -p1 -b .bug658772
149%patch100 -p1 -b .vine-default-theme
150
151#for i in config.guess config.sub ; do
152#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
153#done
154
155%build
156
157# if ! pkg-config --exists pangoxft ; then
158#         echo "No pangoxft.pc!"
159#         exit 1
160# fi
161
162#libtoolize --force --copy
163#autoreconf -i
164
165%configure --enable-gtk-doc \
166        --enable-man \
167        --enable-debug=minimum \
168        --disable-rebuilds \
169        --disable-glibtest \
170        --enable-introspection=yes \
171        --enable-xrandr \
172        --enable-xfixes \
173        --enable-xcomposite \
174        --enable-xdamage \
175        --enable-x11-backend
176
177make ARCH=%{_arch}
178#make
179
180%install
181rm -rf $RPM_BUILD_ROOT
182
183make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
184
185%find_lang gtk30
186%find_lang gtk30-properties
187
188cat gtk30.lang gtk30-properties.lang > all.lang
189
190mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
191#
192# Make cleaned-up versions of examples and tutorial for installation
193#
194mkdir -p tmpdocs/tutorial
195# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
196for dir in examples/* ; do
197    if [ -d $dir ] ; then
198       mkdir -p tmpdocs/$dir
199       for file in $dir/* ; do
200          case $file in
201             *pre1.2.7)
202                ;;
203             *)
204                install -m 0644 $file tmpdocs/$dir
205                ;;
206          esac
207       done
208    fi
209done
210
211
212# We need to have separate 32-bit and 64-bit binaries
213# for places where we have two copies of the GTK+ package installed.
214# (we might have x86_64 and i686 packages on the same system, for example.)
215%if %{build_compat32}
216   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
217      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
218%endif
219touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
220
221mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
222mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
223
224# Remove unpackaged files
225find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
226rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
227
228mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
229   $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
230
231%clean
232rm -rf $RPM_BUILD_ROOT
233
234%post
235/sbin/ldconfig
236%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
237
238%postun
239/sbin/ldconfig
240if [ $1 -gt 0 ]; then
241  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
242fi
243glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
244
245%posttrans
246glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
247
248%if %{build_compat32}
249%post -n compat32-%{name}
250/sbin/ldconfig
251%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
252
253%postun -n compat32-%{name}
254/sbin/ldconfig
255if [ $1 = 0 ]; then
256  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
257fi
258%endif
259
260%files -f all.lang
261%defattr(-, root, root)
262%doc AUTHORS COPYING ChangeLog NEWS README
263%{_bindir}/gtk3-demo
264%{_bindir}/gtk-query-immodules-3.0
265%{_bindir}/gtk-update-icon-cache-3.0
266%{_libdir}/libgtk-3.so.*
267%{_libdir}/libgdk-3.so.*
268%{_libdir}/libgailutil-3.so.*
269%dir %{_libdir}/gtk-3.0
270%{_libdir}/gtk-3.0/%{bin_version}
271%dir %{_libdir}/gtk-3.0/modules
272#%{_libdir}/gtk-3.0/modules/lib*.so
273%{_libdir}/girepository-1.0/*.typelib
274%{_datadir}/gtk-3.0
275%{_datadir}/themes/Default
276%{_datadir}/themes/Emacs
277%dir %{_sysconfdir}/gtk-3.0
278%{_sysconfdir}/gtk-3.0/im-multipress.conf
279%{_datadir}/glib-2.0/schemas/*.xml
280
281%files devel
282%defattr(-, root, root)
283%{_libdir}/lib*.so
284%dir %{_libdir}/gtk-3.0
285%{_datadir}/gtk-doc/
286%{_datadir}/gir-1.0/*.gir
287%{_mandir}/man1/*
288%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
289%{_includedir}/*
290%{_datadir}/aclocal/*
291%{_libdir}/pkgconfig/*
292%doc tmpdocs/tutorial
293
294# compat32
295%if %{build_compat32}
296%files -n compat32-%{name}
297%defattr(-, root, root)
298%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
299%{_libdir}/libgtk-3.so.*
300%{_libdir}/libgdk-3.so.*
301%{_libdir}/libgailutil-3.so.*
302%dir %{_libdir}/gtk-3.0
303%{_libdir}/gtk-3.0/%{bin_version}
304%dir %{_libdir}/gtk-3.0/modules
305#%{_libdir}/gtk-3.0/modules/lib*.so
306%dir %{_sysconfdir}/gtk-3.0
307
308%files -n compat32-%{name}-devel
309%defattr(-, root, root)
310%{_libdir}/lib*.so
311%dir %{_libdir}/gtk-3.0
312%{_libdir}/pkgconfig/*
313%endif
314
315%changelog
316* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
317- new upstream release
318- add Patch1 (gtk3-3.2.1-bug658772.patch)
319
320* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
321- new upstream release
322
323* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
324- new upstream release
325
326* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
327- new upstream release
328
329* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
330- new upstream release
331
332* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
333- new upstream release
334- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
335
336* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
337- fix %%files
338
339* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
340- new upstream release
341- add BuildRequires: colord-devel
342
343* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
344- new upstream release
345
346* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
347- new upstream release
348
349* Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
350- new upstream release
351
352* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
353- new upstream release
354
355* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
356- new upstream release
357
358* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
359- new upstream release
360
361* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
362- new upstream release
363
364* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
365- new upstream release
366
367* Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
368- new upstream release
369
370* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
371- initial build for Vine Linux
372
Note: See TracBrowser for help on using the repository browser.