source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 4704

Revision 4704, 10.4 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.28.8
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.28.4
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.0.1
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.10.2
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.23.2
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 0.10.8
14
15
16%define base_version 3.1.16
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 1%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.1/gtk+-%{version}.tar.xz
35
36Patch0: gtk3-3.1.12-gtk-widget-size-allocate.patch
37Patch100: gtk+-2.99.3-vine-default-theme.patch
38
39BuildRequires: atk-devel >= %{atk_version}
40BuildRequires: pango-devel >= %{pango_version}
41BuildRequires: glib2-devel >= %{glib2_version}
42BuildRequires: cairo-devel >= %{cairo_version}
43BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
44BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
45BuildRequires: libtiff-devel >= 3.7
46BuildRequires: libjpeg-turbo-devel
47BuildRequires: libpng-devel
48BuildRequires: jasper-devel
49BuildRequires: colord-devel
50BuildRequires: gtk-doc
51#BuildRequires: automake17, autoconf
52BuildRequires: gamin-devel
53BuildRequires: cups-devel
54BuildRequires: libICE-devel
55BuildRequires: libXext-devel
56BuildRequires: libXi-devel
57BuildRequires: libXrandr-devel >= 1.3.0
58BuildRequires: libXrender-devel
59BuildRequires: libXcursor-devel
60BuildRequires: libXfixes-devel
61BuildRequires: libXinerama-devel
62BuildRequires: libXcomposite-devel
63BuildRequires: libXdamage-devel
64
65BuildRoot: %{_tmppath}/gtk-%{version}-root
66
67URL: http://www.gtk.org
68
69# required for icon themes apis to work
70Requires: hicolor-icon-theme
71
72# We need to prereq these so we can run gtk-query-immodules-2.0
73Requires(post): glib2 >= %{glib2_version}
74Requires(post): atk >= %{atk_version}
75Requires(post): pango >= %{pango_version}
76Requires(post): libSM >= 1.1.0
77# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
78Requires(post): libtiff >= 3.7
79Requires: libXrandr >= 1.3.0
80
81Vendor: Project Vine
82Distribution: Vine Linux
83Packager: Takemikaduchi
84
85
86%description
87GTK+ is a multi-platform toolkit for creating graphical user
88interfaces. Offering a complete set of widgets, GTK+ is suitable for
89projects ranging from small one-off tools to complete application
90suites.
91
92%package devel
93Summary: Development tools for GTK+ applications.
94Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
95Group: Development/Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: pango-devel >= %{pango_version}
98Requires: atk-devel >= %{atk_version}
99Requires: glib2-devel >= %{glib2_version}
100Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
101Requires: libX11-devel, libXcursor-devel, libXinerama-devel
102Requires: libXext-devel, libXi-devel, libXrandr-devel
103Requires: libXfixes-devel, libXcomposite-devel
104Requires: libpng-devel
105
106%description devel
107The gtk+-devel package contains the header files and developer
108docs for the GTK+ widget toolkit. 
109
110#######################################################################
111# compat32
112%package -n compat32-%{name}
113Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
114Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
115Group: System Environment/Libraries
116Requires(post): compat32-glib2 >= %{glib2_version}
117Requires(post): compat32-atk >= %{atk_version}
118Requires(post): compat32-pango >= %{pango_version}
119Requires(post): compat32-libSM >= 1.1.0
120Requires(post): compat32-libtiff >= 3.7
121Requires: compat32-libXrandr >= 1.3.0
122
123%description -n compat32-%{name}
124GTK+ is a multi-platform toolkit for creating graphical user
125interfaces. Offering a complete set of widgets, GTK+ is suitable for
126projects ranging from small one-off tools to complete application
127suites.
128
129%package -n compat32-%{name}-devel
130Summary: Development tools for GTK+ applications.
131Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
132Group: Development/Libraries
133Requires: compat32-%{name} = %{version}-%{release}
134Requires: %{name}-devel = %{version}
135Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
136Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
137Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
138Requires: compat32-libpng-devel
139
140%description -n compat32-%{name}-devel
141The gtk+-devel package contains the header files and developer
142docs for the GTK+ widget toolkit. 
143
144
145%prep
146%setup -q -n gtk+-%{version}
147%patch0 -p1 -b .allocate
148%patch100 -p1 -b .vine-default-theme
149
150#for i in config.guess config.sub ; do
151#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
152#done
153
154%build
155
156# if ! pkg-config --exists pangoxft ; then
157#         echo "No pangoxft.pc!"
158#         exit 1
159# fi
160
161#libtoolize --force --copy
162#autoreconf -i
163
164%configure --enable-gtk-doc \
165        --enable-man \
166        --enable-debug=minimum \
167        --disable-rebuilds \
168        --disable-glibtest \
169        --enable-introspection=yes \
170        --enable-xrandr \
171        --enable-xfixes \
172        --enable-xcomposite \
173        --enable-xdamage \
174        --enable-x11-backend
175
176make ARCH=%{_arch}
177#make
178
179%install
180rm -rf $RPM_BUILD_ROOT
181
182make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
183
184%find_lang gtk30
185%find_lang gtk30-properties
186
187cat gtk30.lang gtk30-properties.lang > all.lang
188
189mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
190#
191# Make cleaned-up versions of examples and tutorial for installation
192#
193mkdir -p tmpdocs/tutorial
194# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
195for dir in examples/* ; do
196    if [ -d $dir ] ; then
197       mkdir -p tmpdocs/$dir
198       for file in $dir/* ; do
199          case $file in
200             *pre1.2.7)
201                ;;
202             *)
203                install -m 0644 $file tmpdocs/$dir
204                ;;
205          esac
206       done
207    fi
208done
209
210
211# We need to have separate 32-bit and 64-bit binaries
212# for places where we have two copies of the GTK+ package installed.
213# (we might have x86_64 and i686 packages on the same system, for example.)
214%if %{build_compat32}
215   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
216      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
217%endif
218touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
219
220mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
221mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
222
223# Remove unpackaged files
224find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
225rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
226
227mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
228   $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
229
230%clean
231rm -rf $RPM_BUILD_ROOT
232
233%post
234/sbin/ldconfig
235%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
236
237%postun
238/sbin/ldconfig
239if [ $1 -gt 0 ]; then
240  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
241fi
242glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
243
244%posttrans
245glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
246
247%if %{build_compat32}
248%post -n compat32-%{name}
249/sbin/ldconfig
250%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
251
252%postun -n compat32-%{name}
253/sbin/ldconfig
254if [ $1 = 0 ]; then
255  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
256fi
257%endif
258
259%files -f all.lang
260%defattr(-, root, root)
261%doc AUTHORS COPYING ChangeLog NEWS README
262%{_bindir}/gtk3-demo
263%{_bindir}/gtk-query-immodules-3.0
264%{_bindir}/gtk-update-icon-cache-3.0
265%{_libdir}/libgtk-3.so.*
266%{_libdir}/libgdk-3.so.*
267%{_libdir}/libgailutil-3.so.*
268%dir %{_libdir}/gtk-3.0
269%{_libdir}/gtk-3.0/%{bin_version}
270%dir %{_libdir}/gtk-3.0/modules
271#%{_libdir}/gtk-3.0/modules/lib*.so
272%{_libdir}/girepository-1.0/*.typelib
273%{_datadir}/gtk-3.0
274%{_datadir}/themes/Default
275%{_datadir}/themes/Emacs
276%dir %{_sysconfdir}/gtk-3.0
277%{_sysconfdir}/gtk-3.0/im-multipress.conf
278%{_datadir}/glib-2.0/schemas/*.xml
279
280%files devel
281%defattr(-, root, root)
282%{_libdir}/lib*.so
283%dir %{_libdir}/gtk-3.0
284%{_datadir}/gtk-doc/
285%{_datadir}/gir-1.0/*.gir
286%{_mandir}/man1/*
287%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
288%{_includedir}/*
289%{_datadir}/aclocal/*
290%{_libdir}/pkgconfig/*
291%doc tmpdocs/tutorial
292
293# compat32
294%if %{build_compat32}
295%files -n compat32-%{name}
296%defattr(-, root, root)
297%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
298%{_libdir}/libgtk-3.so.*
299%{_libdir}/libgdk-3.so.*
300%{_libdir}/libgailutil-3.so.*
301%dir %{_libdir}/gtk-3.0
302%{_libdir}/gtk-3.0/%{bin_version}
303%dir %{_libdir}/gtk-3.0/modules
304#%{_libdir}/gtk-3.0/modules/lib*.so
305%dir %{_sysconfdir}/gtk-3.0
306
307%files -n compat32-%{name}-devel
308%defattr(-, root, root)
309%{_libdir}/lib*.so
310%dir %{_libdir}/gtk-3.0
311%{_libdir}/pkgconfig/*
312%endif
313
314%changelog
315* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
316- new upstream release
317
318* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
319- new upstream release
320- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
321
322* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
323- fix %%files
324
325* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
326- new upstream release
327- add BuildRequires: colord-devel
328
329* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
330- new upstream release
331
332* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
333- new upstream release
334
335* Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
336- new upstream release
337
338* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
339- new upstream release
340
341* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
342- new upstream release
343
344* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
345- new upstream release
346
347* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
348- new upstream release
349
350* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
351- new upstream release
352
353* Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
354- new upstream release
355
356* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
357- initial build for Vine Linux
358
Note: See TracBrowser for help on using the repository browser.