source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 4616

Revision 4616, 10.1 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.28.8
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.28.4
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.0.1
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.10.2
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.23.2
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 0.10.8
14
15
16%define base_version 3.1.10
17%define bin_version 3.0.0
18
19# biarch support
20%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
21%define _query_suffix %{nil}
22%if %{build_compat32}
23%define _query_suffix -32
24%endif
25
26Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
27Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
28Name: gtk3
29Version: %{base_version}
30Release: 2%{?_dist_release}
31License: LGPL
32Group: System Environment/Libraries
33
34Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.1/gtk+-%{version}.tar.xz
35
36Patch100: gtk+-2.99.3-vine-default-theme.patch
37
38BuildRequires: atk-devel >= %{atk_version}
39BuildRequires: pango-devel >= %{pango_version}
40BuildRequires: glib2-devel >= %{glib2_version}
41BuildRequires: cairo-devel >= %{cairo_version}
42BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
43BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
44BuildRequires: libtiff-devel >= 3.7
45BuildRequires: libjpeg-turbo-devel
46BuildRequires: libpng-devel
47BuildRequires: jasper-devel
48BuildRequires: colord-devel
49BuildRequires: gtk-doc
50#BuildRequires: automake17, autoconf
51BuildRequires: gamin-devel
52BuildRequires: cups-devel
53BuildRequires: libICE-devel
54BuildRequires: libXext-devel
55BuildRequires: libXi-devel
56BuildRequires: libXrandr-devel >= 1.3.0
57BuildRequires: libXrender-devel
58BuildRequires: libXcursor-devel
59BuildRequires: libXfixes-devel
60BuildRequires: libXinerama-devel
61BuildRequires: libXcomposite-devel
62BuildRequires: libXdamage-devel
63
64BuildRoot: %{_tmppath}/gtk-%{version}-root
65
66URL: http://www.gtk.org
67
68# required for icon themes apis to work
69Requires: hicolor-icon-theme
70
71# We need to prereq these so we can run gtk-query-immodules-2.0
72Requires(post): glib2 >= %{glib2_version}
73Requires(post): atk >= %{atk_version}
74Requires(post): pango >= %{pango_version}
75Requires(post): libSM >= 1.1.0
76# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
77Requires(post): libtiff >= 3.7
78Requires: libXrandr >= 1.3.0
79
80Vendor: Project Vine
81Distribution: Vine Linux
82Packager: Takemikaduchi
83
84
85%description
86GTK+ is a multi-platform toolkit for creating graphical user
87interfaces. Offering a complete set of widgets, GTK+ is suitable for
88projects ranging from small one-off tools to complete application
89suites.
90
91%package devel
92Summary: Development tools for GTK+ applications.
93Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96Requires: pango-devel >= %{pango_version}
97Requires: atk-devel >= %{atk_version}
98Requires: glib2-devel >= %{glib2_version}
99Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
100Requires: libX11-devel, libXcursor-devel, libXinerama-devel
101Requires: libXext-devel, libXi-devel, libXrandr-devel
102Requires: libXfixes-devel, libXcomposite-devel
103Requires: libpng-devel
104
105%description devel
106The gtk+-devel package contains the header files and developer
107docs for the GTK+ widget toolkit. 
108
109#######################################################################
110# compat32
111%package -n compat32-%{name}
112Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
113Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
114Group: System Environment/Libraries
115Requires(post): compat32-glib2 >= %{glib2_version}
116Requires(post): compat32-atk >= %{atk_version}
117Requires(post): compat32-pango >= %{pango_version}
118Requires(post): compat32-libSM >= 1.1.0
119Requires(post): compat32-libtiff >= 3.7
120Requires: compat32-libXrandr >= 1.3.0
121
122%description -n compat32-%{name}
123GTK+ is a multi-platform toolkit for creating graphical user
124interfaces. Offering a complete set of widgets, GTK+ is suitable for
125projects ranging from small one-off tools to complete application
126suites.
127
128%package -n compat32-%{name}-devel
129Summary: Development tools for GTK+ applications.
130Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
131Group: Development/Libraries
132Requires: compat32-%{name} = %{version}-%{release}
133Requires: %{name}-devel = %{version}
134Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
135Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
136Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
137Requires: compat32-libpng-devel
138
139%description -n compat32-%{name}-devel
140The gtk+-devel package contains the header files and developer
141docs for the GTK+ widget toolkit. 
142
143
144%prep
145%setup -q -n gtk+-%{version}
146%patch100 -p1 -b .vine-default-theme
147
148#for i in config.guess config.sub ; do
149#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
150#done
151
152%build
153
154# if ! pkg-config --exists pangoxft ; then
155#         echo "No pangoxft.pc!"
156#         exit 1
157# fi
158
159#libtoolize --force --copy
160#autoreconf -i
161
162%configure --enable-gtk-doc \
163        --enable-man \
164        --enable-debug=minimum \
165        --disable-rebuilds \
166        --disable-glibtest \
167        --enable-introspection=yes \
168        --enable-xrandr \
169        --enable-xfixes \
170        --enable-xcomposite \
171        --enable-xdamage \
172        --enable-x11-backend
173
174make ARCH=%{_arch}
175#make
176
177%install
178rm -rf $RPM_BUILD_ROOT
179
180make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
181
182%find_lang gtk30
183%find_lang gtk30-properties
184
185cat gtk30.lang gtk30-properties.lang > all.lang
186
187mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
188#
189# Make cleaned-up versions of examples and tutorial for installation
190#
191mkdir -p tmpdocs/tutorial
192# install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
193for dir in examples/* ; do
194    if [ -d $dir ] ; then
195       mkdir -p tmpdocs/$dir
196       for file in $dir/* ; do
197          case $file in
198             *pre1.2.7)
199                ;;
200             *)
201                install -m 0644 $file tmpdocs/$dir
202                ;;
203          esac
204       done
205    fi
206done
207
208
209# We need to have separate 32-bit and 64-bit binaries
210# for places where we have two copies of the GTK+ package installed.
211# (we might have x86_64 and i686 packages on the same system, for example.)
212%if %{build_compat32}
213   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
214      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
215%endif
216touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
217
218mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
219mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
220
221# Remove unpackaged files
222find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
223rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
224
225mv $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache \
226   $RPM_BUILD_ROOT%{_bindir}/gtk-update-icon-cache-3.0
227
228%clean
229rm -rf $RPM_BUILD_ROOT
230
231%post
232/sbin/ldconfig
233%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
234
235%postun
236/sbin/ldconfig
237if [ $1 -gt 0 ]; then
238  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
239fi
240glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
241
242%posttrans
243glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
244
245%if %{build_compat32}
246%post -n compat32-%{name}
247/sbin/ldconfig
248%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
249
250%postun -n compat32-%{name}
251/sbin/ldconfig
252if [ $1 = 0 ]; then
253  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
254fi
255%endif
256
257%files -f all.lang
258%defattr(-, root, root)
259%doc AUTHORS COPYING ChangeLog NEWS README
260%{_bindir}/gtk3-demo
261%{_bindir}/gtk-query-immodules-3.0
262%{_bindir}/gtk-update-icon-cache-3.0
263%{_libdir}/libgtk-3.so.*
264%{_libdir}/libgdk-3.so.*
265%{_libdir}/libgailutil-3.so.*
266%dir %{_libdir}/gtk-3.0
267%{_libdir}/gtk-3.0/%{bin_version}
268%dir %{_libdir}/gtk-3.0/modules
269#%{_libdir}/gtk-3.0/modules/lib*.so
270%{_libdir}/girepository-1.0/*.typelib
271%{_datadir}/gtk-3.0
272%{_datadir}/themes/Default
273%{_datadir}/themes/Emacs
274%dir %{_sysconfdir}/gtk-3.0
275%{_sysconfdir}/gtk-3.0/im-multipress.conf
276%{_datadir}/glib-2.0/schemas/*.xml
277
278%files devel
279%defattr(-, root, root)
280%{_libdir}/lib*.so
281%dir %{_libdir}/gtk-3.0
282%{_datadir}/gtk-doc/
283%{_datadir}/gir-1.0/*.gir
284%{_mandir}/man1/*
285%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
286%{_includedir}/*
287%{_datadir}/aclocal/*
288%{_libdir}/pkgconfig/*
289%doc tmpdocs/tutorial
290
291# compat32
292%if %{build_compat32}
293%files -n compat32-%{name}
294%defattr(-, root, root)
295%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
296%{_libdir}/libgtk-3.so.*
297%{_libdir}/libgdk-3.so.*
298%{_libdir}/libgailutil-3.so.*
299%dir %{_libdir}/gtk-3.0
300%{_libdir}/gtk-3.0/%{bin_version}
301%dir %{_libdir}/gtk-3.0/modules
302#%{_libdir}/gtk-3.0/modules/lib*.so
303%dir %{_sysconfdir}/gtk-3.0
304
305%files -n compat32-%{name}-devel
306%defattr(-, root, root)
307%{_libdir}/lib*.so
308%dir %{_libdir}/gtk-3.0
309%{_libdir}/pkgconfig/*
310%endif
311
312%changelog
313* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
314- fix %%files
315
316* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
317- new upstream release
318- add BuildRequires: colord-devel
319
320* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
321- new upstream release
322
323* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
324- new upstream release
325
326* Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
327- new upstream release
328
329* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
330- new upstream release
331
332* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
333- new upstream release
334
335* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
336- new upstream release
337
338* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
339- new upstream release
340
341* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
342- new upstream release
343
344* Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
345- new upstream release
346
347* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
348- initial build for Vine Linux
349
Note: See TracBrowser for help on using the repository browser.