source: projects/specs/trunk/g/gtk3/gtk3-vl.spec @ 11602

Revision 11602, 15.4 KB checked in by iwaim, 6 years ago (diff)

gtk3 3.22.10-1

Line 
1# Note that this is NOT a relocatable package
2
3%define glib2_base_version 2.48.0
4%define glib2_version %{glib2_base_version}-1
5%define pango_base_version 1.40.0
6%define pango_version %{pango_base_version}-1
7%define atk_base_version 2.20.0
8%define atk_version %{atk_base_version}-1
9%define cairo_base_version 1.14.4
10%define cairo_version %{cairo_base_version}-1
11%define gdkpixbuf2_base_version 2.32.0
12%define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
13%define gobject_introspection_version 1.46.0
14
15%define base_version 3.22.10
16%define bin_version 3.0.0
17
18# biarch support
19%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
20%define _query_suffix %{nil}
21%if %{build_compat32}
22%define _query_suffix -32
23%endif
24
25Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
26Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
27Name: gtk3
28Version: %{base_version}
29Release: 1%{?_dist_release}
30License: LGPL
31Group: System Environment/Libraries
32
33Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.20/gtk+-%{version}.tar.xz
34
35Patch0: gtk3-3.10.0-gtk-widget-size-allocate.patch
36
37# for Vine
38Patch100: gtk+-3.14.0-vine-default-theme.patch
39
40# from CentOS
41#  - 3.22.10-5.el7_4
42# Downstream fix to filter out X-RHEL-AliasOf
43# https://bugzilla.redhat.com/show_bug.cgi?id=1259292
44Source10001: ja.po
45Patch10018: app-chooser-fixes.patch
46Patch10019: 0001-gdk-Always-emit-motion-after-enter.patch
47
48BuildRequires: atk-devel >= %{atk_version}
49BuildRequires: at-spi2-atk-devel
50BuildRequires: pango-devel >= %{pango_version}
51BuildRequires: glib2-devel >= %{glib2_version}
52BuildRequires: cairo-devel >= %{cairo_version}
53BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
54BuildRequires: gtk2-devel
55BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
56BuildRequires: libtiff-devel >= 3.7
57BuildRequires: libjpeg-turbo-devel
58BuildRequires: libpng-devel
59BuildRequires: jasper-devel
60BuildRequires: colord-devel
61BuildRequires: gtk-doc >= 1.20
62BuildRequires: gamin-devel
63BuildRequires: cups-devel
64BuildRequires: rest-devel
65BuildRequires: json-glib-devel
66BuildRequires: libepoxy-devel
67BuildRequires: libICE-devel
68BuildRequires: libXext-devel
69BuildRequires: libXi-devel
70BuildRequires: libXrandr-devel >= 1.3.0
71BuildRequires: libXrender-devel
72BuildRequires: libXcursor-devel
73BuildRequires: libXfixes-devel
74BuildRequires: libXinerama-devel
75BuildRequires: libXcomposite-devel
76BuildRequires: libXdamage-devel
77
78BuildRoot: %{_tmppath}/gtk-%{version}-root
79
80URL: http://www.gtk.org
81
82# required for icon themes apis to work
83Requires: hicolor-icon-theme
84
85# We need to prereq these so we can run gtk-query-immodules-2.0
86Requires(post): glib2 >= %{glib2_version}
87Requires(post): atk >= %{atk_version}
88Requires(post): pango >= %{pango_version}
89Requires(post): libSM >= 1.1.0
90# We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
91Requires(post): libtiff >= 3.7
92Requires: libXrandr >= 1.3.0
93
94Vendor: Project Vine
95Distribution: Vine Linux
96Packager: Takemikaduchi
97
98
99%description
100GTK+ is a multi-platform toolkit for creating graphical user
101interfaces. Offering a complete set of widgets, GTK+ is suitable for
102projects ranging from small one-off tools to complete application
103suites.
104
105%package devel
106Summary: Development tools for GTK+ applications.
107Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
108Group: Development/Libraries
109Requires: %{name} = %{version}-%{release}
110Requires: pango-devel >= %{pango_version}
111Requires: atk-devel >= %{atk_version}
112Requires: glib2-devel >= %{glib2_version}
113Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
114Requires: libX11-devel, libXcursor-devel, libXinerama-devel
115Requires: libXext-devel, libXi-devel, libXrandr-devel
116Requires: libXfixes-devel, libXcomposite-devel
117Requires: libpng-devel
118
119%description devel
120The gtk+-devel package contains the header files and developer
121docs for the GTK+ widget toolkit. 
122
123#######################################################################
124# compat32
125%package -n compat32-%{name}
126Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
127Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
128Group: System Environment/Libraries
129Requires(post): compat32-glib2 >= %{glib2_version}
130Requires(post): compat32-atk >= %{atk_version}
131Requires(post): compat32-pango >= %{pango_version}
132Requires(post): compat32-libSM >= 1.1.0
133Requires(post): compat32-libtiff >= 3.7
134Requires: compat32-libXrandr >= 1.3.0
135
136%description -n compat32-%{name}
137GTK+ is a multi-platform toolkit for creating graphical user
138interfaces. Offering a complete set of widgets, GTK+ is suitable for
139projects ranging from small one-off tools to complete application
140suites.
141
142%package -n compat32-%{name}-devel
143Summary: Development tools for GTK+ applications.
144Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
145Group: Development/Libraries
146Requires: compat32-%{name} = %{version}-%{release}
147Requires: %{name}-devel = %{version}
148Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
149Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
150Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
151Requires: compat32-libpng-devel
152
153%description -n compat32-%{name}-devel
154The gtk+-devel package contains the header files and developer
155docs for the GTK+ widget toolkit. 
156
157
158%prep
159%setup -q -n gtk+-%{version}
160%patch0 -p1 -b .allocate
161%patch100 -p1 -b .vine-default-theme
162
163# from CentOS
164%patch10018 -p1
165%patch10019 -p1
166cp %{SOURCE10001} po/
167
168#for i in config.guess config.sub ; do
169#       test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
170#done
171
172%build
173
174# if ! pkg-config --exists pangoxft ; then
175#         echo "No pangoxft.pc!"
176#         exit 1
177# fi
178
179#libtoolize --force --copy
180#autoreconf -i
181
182%configure \
183        --enable-gtk2-dependency \
184        --enable-man \
185        --enable-gtk-doc \
186        --enable-debug=minimum \
187        --disable-rebuilds \
188        --disable-glibtest \
189        --enable-introspection=yes \
190        --enable-xkb=yes \
191        --enable-xinerama=yes \
192        --enable-xrandr=yes \
193        --enable-xfixes=yes \
194        --enable-xcomposite=yes \
195        --enable-xdamage=yes \
196        --enable-x11-backend \
197        --disable-packagekit \
198        --enable-colord=yes
199
200# fight unused direct deps
201sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
202
203make %{?_smp_mflags}
204
205%install
206rm -rf $RPM_BUILD_ROOT
207
208make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
209
210%find_lang gtk30
211%find_lang gtk30-properties
212
213cat gtk30.lang gtk30-properties.lang > all.lang
214
215mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
216
217# We need to have separate 32-bit and 64-bit binaries
218# for places where we have two copies of the GTK+ package installed.
219# (we might have x86_64 and i686 packages on the same system, for example.)
220%if %{build_compat32}
221   cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
222      $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
223%endif
224touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
225
226mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
227mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
228
229# Remove unpackaged files
230find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
231rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
232
233%clean
234rm -rf $RPM_BUILD_ROOT
235
236%post
237/sbin/ldconfig
238%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
239
240%postun
241/sbin/ldconfig
242if [ $1 -gt 0 ]; then
243  %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
244fi
245glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
246
247%posttrans
248glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
249
250%if %{build_compat32}
251%post -n compat32-%{name}
252/sbin/ldconfig
253%{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
254
255%postun -n compat32-%{name}
256/sbin/ldconfig
257if [ $1 = 0 ]; then
258  %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
259fi
260%endif
261
262%files -f all.lang
263%defattr(-, root, root)
264%doc AUTHORS COPYING ChangeLog NEWS README
265%{_bindir}/gtk3-demo
266%{_bindir}/gtk3-demo-application
267%{_bindir}/gtk3-widget-factory
268%{_bindir}/gtk-encode-symbolic-svg
269%{_bindir}/gtk3-icon-browser
270%{_bindir}/gtk-builder-tool
271%{_bindir}/gtk-launch
272%{_bindir}/gtk-query-settings
273%exclude %{_bindir}/gtk-update-icon-cache
274%{_bindir}/gtk-query-immodules-3.0
275%{_libdir}/libgtk-3.so.*
276%{_libdir}/libgdk-3.so.*
277%{_libdir}/libgailutil-3.so.*
278%dir %{_libdir}/gtk-3.0
279%{_libdir}/gtk-3.0/%{bin_version}
280%dir %{_libdir}/gtk-3.0/modules
281%{_libdir}/girepository-1.0/*.typelib
282%{_datadir}/applications/gtk3-demo.desktop
283%{_datadir}/applications/gtk3-icon-browser.desktop
284%{_datadir}/applications/gtk3-widget-factory.desktop
285%{_datadir}/gettext/its/gtkbuilder*
286%{_datadir}/gtk-3.0
287%{_datadir}/icons/hicolor/*/apps/*
288%{_datadir}/themes/Default
289%{_datadir}/themes/Emacs
290%dir %{_sysconfdir}/gtk-3.0
291%{_sysconfdir}/gtk-3.0/im-multipress.conf
292%{_datadir}/glib-2.0/schemas/*.xml
293
294%files devel
295%defattr(-, root, root)
296%{_libdir}/lib*.so
297%dir %{_libdir}/gtk-3.0
298%{_datadir}/gtk-doc/
299%{_datadir}/gir-1.0/*.gir
300%{_mandir}/man1/*
301%exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
302%{_includedir}/*
303%{_datadir}/aclocal/*
304%{_libdir}/pkgconfig/*
305
306# compat32
307%if %{build_compat32}
308%files -n compat32-%{name}
309%defattr(-, root, root)
310%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
311%{_libdir}/libgtk-3.so.*
312%{_libdir}/libgdk-3.so.*
313%{_libdir}/libgailutil-3.so.*
314%dir %{_libdir}/gtk-3.0
315%{_libdir}/gtk-3.0/%{bin_version}
316%dir %{_libdir}/gtk-3.0/modules
317%dir %{_sysconfdir}/gtk-3.0
318
319%files -n compat32-%{name}-devel
320%defattr(-, root, root)
321%{_libdir}/lib*.so
322%dir %{_libdir}/gtk-3.0
323%endif
324
325%changelog
326* Mon Mar 26 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.22.10-1
327- update to 3.22.10
328- sync CentOS 7 - 3.22.10-5.el7_4
329 - add ja.po (Source10001)
330 - add patches (Patch10018, 10019)
331
332* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.6-1
333- new upstream release
334
335* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.6-1
336- new upstream release
337
338* Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
339- new upstream release
340
341* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
342- new upstream release
343
344* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
345- new upstream release
346
347* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.7-1
348- new upstream release
349
350* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.6-1
351- new upstream release
352
353* Fri Jul 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
354- new upstream release
355
356* Thu Jun 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
357- new upstream release
358
359* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
360- new upstream release
361
362* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
363- new upstream release
364
365* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
366- new upstream release
367- add BuildRequires: libepoxy-devel
368
369* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.9-1
370- new upstream release
371
372* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.8-1
373- new upstream release
374
375* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.7-1
376- new upstream release
377
378* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.6-1
379- new upstream release
380
381* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.5-1
382- new upstream release
383- add BuildRequires: gtk2-devel, rest-devel, json-glib-devel
384
385* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.4-1
386- new upstream release
387- update Patch100 (gtk+-3.14.0-vine-default-theme.patch)
388
389* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
390- new upstream release
391
392* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
393- new upstream release
394
395* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
396- new upstream release
397- update Patch100 (gtk+-3.12.0-vine-default-theme.patch)
398
399* Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.7-1
400- new upstream release
401
402* Sat Dec 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.6-1
403- new upstream release
404
405* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.5-1
406- new upstream release
407
408* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
409- new upstream release
410- update Patch0 (gtk3-3.10.0-gtk-widget-size-allocate.patch)
411- remove Patch1 (gtk3-3.8.2-immodule.patch)
412
413* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
414- new upstream release
415
416* Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
417- add Patch1 (gtk3-3.8.2-immodule.patch)
418
419* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
420- new upstream release
421
422* Fri Apr 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
423- new upstream release
424
425* Tue Jan 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
426- new upstream release
427
428* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
429- new upstream release
430
431* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
432- new upstream release
433
434* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
435- new upstream release
436
437* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
438- new upstream release
439- add BuildRequires: at-spi2-atk-devel
440
441* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
442- new upstream release
443
444* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
445- new upstream release
446
447* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
448- new upstream release
449
450* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
451- new upstream release
452- update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
453
454* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
455- new upstream release
456
457* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
458- new upstream release
459
460* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
461- new upstream release
462- remove Patch1
463
464* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
465- new upstream release
466- add Patch1 (gtk3-3.2.1-bug658772.patch)
467
468* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
469- new upstream release
470
471* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
472- new upstream release
473
474* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
475- new upstream release
476
477* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
478- new upstream release
479
480* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
481- new upstream release
482- add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
483
484* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
485- fix %%files
486
487* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
488- new upstream release
489- add BuildRequires: colord-devel
490
491* Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
492- new upstream release
493
494* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
495- new upstream release
496
497* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
498- new upstream release
499
500* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
501- new upstream release
502
503* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
504- new upstream release
505
506* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
507- new upstream release
508
509* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
510- new upstream release
511
512* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
513- new upstream release
514
515* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
516- new upstream release
517
518* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
519- initial build for Vine Linux
520
Note: See TracBrowser for help on using the repository browser.