source: projects/specs/trunk/g/gtk2-engines/gtk2-engines-vl.spec @ 521

Revision 521, 9.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Theme engines for GTK+ 2.x
4Summary(ja):    GTK+ 2.x 用テーマエンジン
5Name:           gtk2-engines
6Version:        2.18.4
7Release:        1%{?_dist_release}
8License:        GPL
9Group:          System Environment/Libraries
10Source:         ftp://ftp.gnome.org/pub/gnome/sources/gtk-engines/2.18/gtk-engines-%{version}.tar.bz2
11
12Requires:       gtk2 >= 2.10.0
13BuildPrereq:    gtk2-devel >= 2.10.0
14Conflicts:      gnome-themes < 2.8.2-0vl1
15Conflicts:      gnome-themes-extras < 0.8-0vl2
16
17URL:            http://www.gnome.org/
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21%description
22The gtk2-engines package contains shared objects and configuration
23files that implement a number of GTK+ theme engines. Theme engines
24provide different looks for GTK+, some of which resemble other
25toolkits or operating systems. This package is for GTK+ 2.0,
26the gtk+-engines package is for GTK+ 1.2.
27
28# compat32
29%package -n compat32-%{name}
30Summary:        Theme engines for GTK+ 2.x
31Summary(ja):    GTK+ 2.x 用テーマエンジン
32Group:          System Environment/Libraries
33Requires:       %{name} = %{version}-%{release}
34
35%description -n compat32-%{name}
36The gtk2-engines package contains shared objects and configuration
37files that implement a number of GTK+ theme engines. Theme engines
38provide different looks for GTK+, some of which resemble other
39toolkits or operating systems. This package is for GTK+ 2.0,
40the gtk+-engines package is for GTK+ 1.2.
41
42%prep
43%setup -q -n gtk-engines-%{version}
44
45%build
46
47%configure
48%__make
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%makeinstall
54
55#find_lang gtk-engines
56
57# remove backup files that shouldn't be here.  Fix me.
58find $RPM_BUILD_ROOT%{_datadir}/themes -name \*~ | xargs rm -rvf
59
60# No, we don't need to package these either
61find $RPM_BUILD_ROOT%{_datadir}/themes -type d -name ".xvpics" | xargs rm -rvf
62
63# sanitize permissions
64find $RPM_BUILD_ROOT%{_datadir}/themes -type d -exec chmod 755 {} \;
65find $RPM_BUILD_ROOT%{_datadir}/themes -type f -name "*.png" -exec chmod 644 {} \;
66find $RPM_BUILD_ROOT%{_datadir}/themes -name "gtkrc*" -perm +111 -exec chmod 644 {} \;
67
68# remove unpackaged files
69rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/lib*.la
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644, root, root, 755)
76%doc COPYING README ChangeLog
77%attr (755, root, root) %{_libdir}/gtk-2.0/*/engines/*.so
78%dir %{_libdir}/gtk-2.0
79%dir %{_libdir}/gtk-2.0/*
80%dir %{_libdir}/gtk-2.0/*/engines
81%{_datadir}/themes/*
82%{_datadir}/gtk-engines/*.xml
83%{_libdir}/pkgconfig/*
84
85# compat32
86%if %{build_compat32}
87%files -n compat32-%{name}
88%defattr(644, root, root, 755)
89%attr (755, root, root) %{_libdir}/gtk-2.0/*/engines/*.so
90%dir %{_libdir}/gtk-2.0
91%dir %{_libdir}/gtk-2.0/*
92%dir %{_libdir}/gtk-2.0/*/engines
93%{_libdir}/pkgconfig/*
94%endif
95
96%changelog
97* Fri Oct  9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.4-1
98- new upstream release
99
100* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.18.2-2
101- added compat32 package for x86_64 arch support.
102
103* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
104- new upstream release
105
106* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
107- new upstream release
108
109* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
110- new upstream release
111
112* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
113- new upstream release
114
115* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
116- new upstream release
117
118* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
119- new upstream release
120
121* Fri May 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
122- new upstream release
123
124* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-1vl5
125- new upstream release
126
127* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.2-0vl1
128- new upstream release
129- build with gtk+-2.12
130
131* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
132- new upstream release
133- build with gtk+-2.10
134
135* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
136- new upstream release
137
138* Tue Jan 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.2-0vl1
139- new upstream release
140
141* Sat Dec 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-0vl1
142- new upstream release
143- use License tag instead of Copyright
144
145* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.6-0vl1
146- new upstream release
147
148* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
149- new upstream release
150
151* Thu Apr 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
152- new upstream release
153
154* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
155- new upstream version
156
157* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
158- new upstream release
159- add Conflicts: gnome-themes < 2.8.2-0vl1, gnome-themes-extras < 0.8-0vl2
160
161* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl5
162- rebuild with gtk+-2.4.0
163
164* Sat Feb  2 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl4
165- remove all additional engines and move it to gnome-themes.
166
167* Sat Feb  2 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl3
168- add missing files.
169
170* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
171- add gtk-mist-engines
172
173* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
174- new upstream release
175
176* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl2
177- fixed to make and install addon engines correctly.
178- remove gnuaquase
179
180* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
181- build for Vine Linux
182- add some theme (gtk-xfce, lighthouseblue, gnuaquase)
183
184* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
185- automated rebuild
186
187* Thu May 23 2002 Tim Powers <timp@redhat.com>
188- automated rebuild
189
190* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
191- rebuild in different environment
192
193* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
194- converted to gtk2-engines package
195
196* Mon Apr 15 2002 Alex Larsson <alexl@redhat.com>
197- Added Adept-Raleigh theme
198
199* Thu Apr 11 2002 Owen Taylor <otaylor@redhat.com>
200- Fix major pixmap leak that occurred with certain theme/app
201  combinations (#59528)
202
203* Wed Mar 13 2002 Owen Taylor <otaylor@redhat.com>
204- Add gtk-hicontrast theme
205- Un-automake-1.4
206
207* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
208- remove acinclude.m4 to avoid funky libtool crackrock
209
210* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
211- automake14
212
213* Thu Aug  9 2001 Owen Taylor <otaylor@redhat.com>
214- Install %{_sysconfdir}/skel/.gtkrc as /root/.gtkrc as well, or we
215  don't get Raleigh for our nice config tools
216
217* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
218- Add BuildPrereq on imlib-devel (#49478)
219
220* Tue Jul 10 2001 Owen Taylor <otaylor@redhat.com>
221- Version 0.11
222- Install a %{_sysconfdir}/skel/.gtkrc
223
224* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
225- Bump release + rebuild.
226
227* Sat Feb 10 2001 Owen Taylor <otaylor@redhat.com>
228- New, slightly improved version of Raleigh
229
230* Sun Feb 04 2001 Owen Taylor <otaylor@redhat.com>
231- Require as well as BuildPrereq a sufficiently new GTK+ package.
232
233* Wed Jan 17 2001 Owen Taylor <otaylor@redhat.com>
234- remove references to /home/raster from a couple of themes
235
236* Tue Nov 21 2000 Owen Taylor <otaylor@redhat.com>
237- Add 'Raleigh' theme
238
239* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
240- Up Epoch and release
241
242* Thu Jul 13 2000 Owen Taylor <otaylor@redhat.com>
243- Go back to real gtk-engines-0.10.tar.gz instead of hosed
244  cvs snapshot that someone had inserted.
245
246* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
247- automatic rebuild
248
249* Mon Jun 19 2000 Dave Mason <dcm@redhat.com>
250- Removed many themes to speed up control center and get rid of ugly themes
251
252* Sat Jun 17 2000 Matt Wilson <msw@redhat.com>
253- defattr files 644 and dirs 755, list attr of 755 for libraries explicitly
254- use %%makeinstall
255- remove spec file stupidism (defining docdir, using own prefix macro, rel, ver, etc)
256
257* Tue May 16 2000 Dave Mason <dcm@redhat.com>
258- fixed Tiger, RatsTheme, OldWood, and LCD themes as they had no gtk subdirectory
259
260* Tue Feb 22 2000 Bill Nottingham <notting@redhat.com>
261- sanitize various things (permissions, .xv thumbnails)
262
263* Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
264- remove backup files from package
265
266* Tue Jan 25 2000 Owen Taylor <otaylor@redhat.com>
267- Update to 0.10 (fixing problem with text in eventboxes
268  becoming garbled)
269
270* Wed Sep 15 1999 Elliot Lee <sopwith@redhat.com>
271- Misc fixes from DrMike suggestions
272
273* Thu Sep 09 1999 Elliot Lee <sopwith@redhat.com>
274- Update to 0.6, etc.
275
276* Wed Apr 14 1999 Michael Fulbright <drmike@redhat.com>
277- removed Odo (has issues)
278
279* Fri Apr 9 1999 The Rasterman <raster@redhat.com>
280- patched metal theme - fixed handlebox redraw.
281
282* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
283- removed some themes that were misbehaving
284
285* Tue Mar 16 1999 Michael Fulbright <drmike@redhat.com>
286- removed enlightened themes, seems to be defective
287
288* Thu Mar 11 1999 Michael Fulbright <drmike@redhat.com>
289- removed Default theme data, this comes with gtk+ package
290
291* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
292- added extra gtk themes
293
294* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
295- version 0.5
296
297* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
298- version 0.4
299
300* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
301- version 0.3
302
303* Mon Dec 18 1998 Michael Fulbright <drmike@redhat.com>
304- version 0.2
305
306* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
307- rebuild because gtk+ version changed
308
309* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
310- in preparation for GNOME freeze
311
312* Fri Nov 20 1998 Michael Fulbright <drmike@redhat.com>
313- First try at a spec file
Note: See TracBrowser for help on using the repository browser.