source: projects/specs/trunk/g/gtk-vnc/gtk-vnc-vl.spec @ 805

Revision 805, 6.7 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1# Plugin isn't ready for real world use yet - it needs
2# a security audit at very least
3%define with_plugin 0
4
5Summary: A GTK widget for VNC clients
6Summary(ja): VNCクライアント用 GTK ウィジェット
7
8Name: gtk-vnc
9Version: 0.3.10
10Release: 1%{?_dist_release}
11License: LGPLv2+
12Group: Development/Libraries
13Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14Patch100: gtk-vnc-0.3.8-fast.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17URL: http://gtk-vnc.sf.net/
18BuildRequires: gtk2-devel pygtk2-devel python-devel zlib-devel
19BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
20%if %{with_plugin}
21BuildRequires: xulrunner-devel
22%endif
23
24%description
25gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
26allowing it to be completely asynchronous while remaining single threaded.
27
28%package devel
29Summary: Development filesdor gtk-vnc library
30Summary(ja): gtk-vnc ライブラリの開発ファイル
31Group: Development/Libraries
32Requires: %{name} = %{version}
33Requires: pkgconfig
34Requires: pygtk2-devel gtk2-devel gnutls-devel
35
36%description devel
37gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
38allowing it to be completely asynchronous while remaining single threaded.
39
40Libraries, includes, etc. to compile with the gtk-vnc library
41
42%package python
43Summary: Python bindings for the gtk-vnc library
44Summary(ja): gtk-vnc ライブラリの python バインディング
45Group: Development/Libraries
46Requires: %{name} = %{version}
47
48%description python
49gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
50allowing it to be completely asynchronous while remaining single threaded.
51
52A module allowing use of the GTK-VNC widget from python
53
54%if %{with_plugin}
55%package plugin
56Summary: Mozilla plugin for the gtk-vnc library
57Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
58Group: Development/Libraries
59Requires: %{name} = %{version}
60
61%description plugin
62gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
63allowing it to be completely asynchronous while remaining single threaded.
64
65This package provides a web browser plugin for Mozilla compatible
66browsers.
67%endif
68
69%prep
70%setup -q
71%patch100 -p1
72
73%build
74%if %{with_plugin}
75%configure --enable-plugin=yes
76%else
77%configure
78%endif
79%__make %{?_smp_mflags}
80
81%install
82rm -fr %{buildroot}
83%__make install DESTDIR=%{buildroot}
84rm -f %{buildroot}%{_libdir}/*.a
85rm -f %{buildroot}%{_libdir}/*.la
86rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
87rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
88%if %{with_plugin}
89rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
90rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
91%endif
92
93%find_lang %{name}
94
95%clean
96rm -fr %{buildroot}
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102%files -f %{name}.lang
103%defattr(-, root, root)
104%doc AUTHORS ChangeLog NEWS README COPYING.LIB
105%{_libdir}/lib*.so.*
106
107%files devel
108%defattr(-, root, root)
109%doc examples/gvncviewer.c
110%{_libdir}/lib*.so
111%dir %{_includedir}/%{name}-1.0/
112%{_includedir}/%{name}-1.0/*.h
113%{_libdir}/pkgconfig/%{name}-1.0.pc
114
115%files python
116%defattr(-, root, root)
117%doc examples/gvncviewer.py
118%{_libdir}/python*/site-packages/gtkvnc.so
119
120%if %{with_plugin}
121%files plugin
122%defattr(-, root, root)
123%{_libdir}/mozilla/plugins/%{name}-plugin.so
124%endif
125
126%changelog
127* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
128- new upstream release
129
130* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
131- rebuild with python-2.6
132
133* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
134- new upstream release
135- add Patch100 to speed up
136- add BR: cyrus-sasl-devel
137
138* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
139- rebuild with gnutls-2.6.3
140
141* Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
142- new upstream release
143
144* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
145- initial build for Vine Linux
146
147* Fri Sep  5 2008 Matthias Clasen  <mclasen@redhat.com> - 0.3.7-1
148- Update to 0.3.7
149
150* Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
151- Fix key/mouse event propagation (rhbz #454627)
152
153* Mon Jul  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
154- fix conditional comparison
155
156* Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
157- Rebuild for GNU TLS ABI change
158
159* Wed May  7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
160- Updated to 0.3.6 release
161
162* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
163- Update to 0.3.5
164
165* Fri Apr  4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
166- Remove bogus chunk of render patch
167
168* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
169- Fix OpenGL rendering artifacts (rhbz #440184)
170
171* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
172- Fixed endianness conversions
173- Fix makecontext() args crash on x86_64
174- Fix protocol version negotiation
175
176* Thu Mar  6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
177- Update to 0.3.4 release
178- Fix crash with OpenGL scaling code
179
180* Sun Feb  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
181- Update to 0.3.3 release
182
183* Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
184- Track keystate to avoid stuck modifier keys
185
186* Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
187- Update to 0.3.2 release
188- Added dep on zlib-devel
189
190* Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
191- Update to 0.3.1 release
192
193* Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
194- Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
195
196* Thu Oct  4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
197- Fixed coroutine caller to avoid SEGV
198
199* Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
200- Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
201
202* Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
203- Update to 0.2.0 release
204
205* Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
206- Fixed handling of mis-matched client/server colour depths
207
208* Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
209- Fix mixed endian handling & BGR pixel format (rhbz #253597)
210- Clear widget areas outside of framebuffer (rhbz #253599)
211- Fix off-by-one in python demo
212
213* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
214- Tweaked post scripts
215- Removed docs from sub-packages
216- Explicitly set license to LGPLv2+
217- Remove use of macro for install rule
218
219* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
220- Added gnutls-devel requirement to -devel package
221
222* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
223- Initial official release
Note: See TracBrowser for help on using the repository browser.