source: projects/specs/trunk/g/gtk-vnc/gtk-vnc-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Plugin isn't ready for real world use yet - it needs
2# a security audit at very least
3%define with_plugin 0
4
5Summary: A GTK widget for VNC clients
6Summary(ja): VNCクライアント用 GTK ウィジェット
7
8Name: gtk-vnc
9Version: 0.3.9
10Release: 2%{?_dist_release}
11License: LGPLv2+
12Group: Development/Libraries
13Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14Patch100: gtk-vnc-0.3.8-fast.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17URL: http://gtk-vnc.sf.net/
18BuildRequires: gtk2-devel pygtk2-devel python-devel zlib-devel
19BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
20%if %{with_plugin}
21BuildRequires: xulrunner-devel
22%endif
23
24%description
25gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
26allowing it to be completely asynchronous while remaining single threaded.
27
28%package devel
29Summary: Development filesdor gtk-vnc library
30Summary(ja): gtk-vnc ライブラリの開発ファイル
31Group: Development/Libraries
32Requires: %{name} = %{version}
33Requires: pkgconfig
34Requires: pygtk2-devel gtk2-devel gnutls-devel
35
36%description devel
37gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
38allowing it to be completely asynchronous while remaining single threaded.
39
40Libraries, includes, etc. to compile with the gtk-vnc library
41
42%package python
43Summary: Python bindings for the gtk-vnc library
44Summary(ja): gtk-vnc ライブラリの python バインディング
45Group: Development/Libraries
46Requires: %{name} = %{version}
47
48%description python
49gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
50allowing it to be completely asynchronous while remaining single threaded.
51
52A module allowing use of the GTK-VNC widget from python
53
54%if %{with_plugin}
55%package plugin
56Summary: Mozilla plugin for the gtk-vnc library
57Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
58Group: Development/Libraries
59Requires: %{name} = %{version}
60
61%description plugin
62gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
63allowing it to be completely asynchronous while remaining single threaded.
64
65This package provides a web browser plugin for Mozilla compatible
66browsers.
67%endif
68
69%prep
70%setup -q
71%patch100 -p1
72
73%build
74%if %{with_plugin}
75%configure --enable-plugin=yes
76%else
77%configure
78%endif
79%__make %{?_smp_mflags}
80
81%install
82rm -fr %{buildroot}
83%__make install DESTDIR=%{buildroot}
84rm -f %{buildroot}%{_libdir}/*.a
85rm -f %{buildroot}%{_libdir}/*.la
86rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
87rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
88%if %{with_plugin}
89rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
90rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
91%endif
92
93%clean
94rm -fr %{buildroot}
95
96%post -p /sbin/ldconfig
97
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(-, root, root)
102%doc AUTHORS ChangeLog NEWS README COPYING.LIB
103%{_libdir}/lib*.so.*
104
105%files devel
106%defattr(-, root, root)
107%doc examples/gvncviewer.c
108%{_libdir}/lib*.so
109%dir %{_includedir}/%{name}-1.0/
110%{_includedir}/%{name}-1.0/*.h
111%{_libdir}/pkgconfig/%{name}-1.0.pc
112
113%files python
114%defattr(-, root, root)
115%doc examples/gvncviewer.py
116%{_libdir}/python*/site-packages/gtkvnc.so
117
118%if %{with_plugin}
119%files plugin
120%defattr(-, root, root)
121%{_libdir}/mozilla/plugins/%{name}-plugin.so
122%endif
123
124%changelog
125* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
126- rebuild with python-2.6
127
128* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
129- new upstream release
130- add Patch100 to speed up
131- add BR: cyrus-sasl-devel
132
133* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
134- rebuild with gnutls-2.6.3
135
136* Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
137- new upstream release
138
139* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
140- initial build for Vine Linux
141
142* Fri Sep  5 2008 Matthias Clasen  <mclasen@redhat.com> - 0.3.7-1
143- Update to 0.3.7
144
145* Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
146- Fix key/mouse event propagation (rhbz #454627)
147
148* Mon Jul  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
149- fix conditional comparison
150
151* Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
152- Rebuild for GNU TLS ABI change
153
154* Wed May  7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
155- Updated to 0.3.6 release
156
157* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
158- Update to 0.3.5
159
160* Fri Apr  4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
161- Remove bogus chunk of render patch
162
163* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
164- Fix OpenGL rendering artifacts (rhbz #440184)
165
166* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
167- Fixed endianness conversions
168- Fix makecontext() args crash on x86_64
169- Fix protocol version negotiation
170
171* Thu Mar  6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
172- Update to 0.3.4 release
173- Fix crash with OpenGL scaling code
174
175* Sun Feb  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
176- Update to 0.3.3 release
177
178* Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
179- Track keystate to avoid stuck modifier keys
180
181* Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
182- Update to 0.3.2 release
183- Added dep on zlib-devel
184
185* Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
186- Update to 0.3.1 release
187
188* Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
189- Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
190
191* Thu Oct  4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
192- Fixed coroutine caller to avoid SEGV
193
194* Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
195- Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
196
197* Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
198- Update to 0.2.0 release
199
200* Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
201- Fixed handling of mis-matched client/server colour depths
202
203* Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
204- Fix mixed endian handling & BGR pixel format (rhbz #253597)
205- Clear widget areas outside of framebuffer (rhbz #253599)
206- Fix off-by-one in python demo
207
208* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
209- Tweaked post scripts
210- Removed docs from sub-packages
211- Explicitly set license to LGPLv2+
212- Remove use of macro for install rule
213
214* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
215- Added gnutls-devel requirement to -devel package
216
217* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
218- Initial official release
Note: See TracBrowser for help on using the repository browser.