source: projects/specs/trunk/g/gtk-vnc/gtk-vnc-vl.spec @ 5701

Revision 5701, 8.0 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1# Plugin isn't ready for real world use yet - it needs
2# a security audit at very least
3%define with_plugin 0
4
5Summary: A GTK widget for VNC clients
6Summary(ja): VNCクライアント用 GTK ウィジェット
7
8Name: gtk-vnc
9Version: 0.4.4
10Release: 2%{?_dist_release}
11License: LGPLv2+
12Group: Development/Libraries
13Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
14Patch100: gtk-vnc-0.3.8-fast.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17URL: http://gtk-vnc.sf.net/
18BuildRequires: gtk3-devel pygtk2-devel python-devel zlib-devel
19BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
20BuildRequires: vala-tools
21%if %{with_plugin}
22BuildRequires: xulrunner-devel
23%endif
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: Takemikaduchi
28
29%description
30gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
31allowing it to be completely asynchronous while remaining single threaded.
32
33%package devel
34Summary: Development filesdor gtk-vnc library
35Summary(ja): gtk-vnc ライブラリの開発ファイル
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Requires: pkgconfig
39Requires: pygtk2-devel gtk3-devel gnutls-devel
40
41%description devel
42gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
43allowing it to be completely asynchronous while remaining single threaded.
44
45Libraries, includes, etc. to compile with the gtk-vnc library
46
47%package python
48Summary: Python bindings for the gtk-vnc library
49Summary(ja): gtk-vnc ライブラリの python バインディング
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description python
54gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
55allowing it to be completely asynchronous while remaining single threaded.
56
57A module allowing use of the GTK-VNC widget from python
58
59%package vala
60Summary: Vala bindings for gtk-vnc
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires: vala
64
65%description vala
66Vala bindings for gtk-vnc
67
68%if %{with_plugin}
69%package plugin
70Summary: Mozilla plugin for the gtk-vnc library
71Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
72Group: Development/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description plugin
76gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
77allowing it to be completely asynchronous while remaining single threaded.
78
79This package provides a web browser plugin for Mozilla compatible
80browsers.
81%endif
82
83%prep
84%setup -q
85## %patch100 -p1
86
87%build
88%if %{with_plugin}
89%configure --enable-plugin=yes --with-gtk=3.0
90%else
91%configure --with-gtk=3.0
92%endif
93%__make %{?_smp_mflags}
94
95%install
96rm -fr %{buildroot}
97%__make install DESTDIR=%{buildroot}
98rm -f %{buildroot}%{_libdir}/*.a
99rm -f %{buildroot}%{_libdir}/*.la
100rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
101rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
102%if %{with_plugin}
103rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
104rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
105%endif
106
107%find_lang %{name}
108
109%clean
110rm -fr %{buildroot}
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%files -f %{name}.lang
117%defattr(-, root, root)
118%doc AUTHORS ChangeLog NEWS README COPYING.LIB
119%{_bindir}/gvnccapture
120%{_libdir}/lib*.so.*
121%{_libdir}/girepository-1.0/*.typelib
122%{_mandir}/man1/gvnccapture.1.gz
123
124%files devel
125%defattr(-, root, root)
126%doc examples/gvncviewer.c
127%{_libdir}/lib*.so
128%dir %{_includedir}/%{name}-2.0/
129%dir %{_includedir}/gvnc-1.0/
130%{_includedir}/%{name}-2.0/*.h
131%{_includedir}/gvnc-1.0/*.h
132%{_libdir}/pkgconfig/%{name}-2.0.pc
133%{_libdir}/pkgconfig/gvnc-1.0.pc
134%{_datadir}/gir-1.0/*.gir
135
136%files python
137%defattr(-, root, root)
138%doc examples/gvncviewer.py
139# %{_libdir}/python*/site-packages/gtkvnc.so
140
141%files vala
142%defattr(-, root, root)
143%{_datadir}/vala/vapi/gtk-vnc-2.0.*
144%{_datadir}/vala/vapi/gvnc-1.0.*
145
146%if %{with_plugin}
147%files plugin
148%defattr(-, root, root)
149%{_libdir}/mozilla/plugins/%{name}-plugin.so
150%endif
151
152%changelog
153* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-2
154- rebuild with python-2.7.2
155
156* Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
157- new upstream release
158- add BuildRequires: vala-tools
159- create %%{name}-vala sub package
160
161* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-2
162- change BuildRequires: gtk3-devel instead of gtk2-devel
163- add configure option: --with-gtk=3.0
164
165* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
166- new upstream release
167
168* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-2
169- rebuild with rpm-4.8.1 for pkg-config file
170
171* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
172- new upstream release
173- drop Patch100
174- fix %files
175
176* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
177- new upstream release
178
179* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
180- rebuild with python-2.6
181
182* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
183- new upstream release
184- add Patch100 to speed up
185- add BR: cyrus-sasl-devel
186
187* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
188- rebuild with gnutls-2.6.3
189
190* Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
191- new upstream release
192
193* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
194- initial build for Vine Linux
195
196* Fri Sep  5 2008 Matthias Clasen  <mclasen@redhat.com> - 0.3.7-1
197- Update to 0.3.7
198
199* Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
200- Fix key/mouse event propagation (rhbz #454627)
201
202* Mon Jul  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
203- fix conditional comparison
204
205* Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
206- Rebuild for GNU TLS ABI change
207
208* Wed May  7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
209- Updated to 0.3.6 release
210
211* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
212- Update to 0.3.5
213
214* Fri Apr  4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
215- Remove bogus chunk of render patch
216
217* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
218- Fix OpenGL rendering artifacts (rhbz #440184)
219
220* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
221- Fixed endianness conversions
222- Fix makecontext() args crash on x86_64
223- Fix protocol version negotiation
224
225* Thu Mar  6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
226- Update to 0.3.4 release
227- Fix crash with OpenGL scaling code
228
229* Sun Feb  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
230- Update to 0.3.3 release
231
232* Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
233- Track keystate to avoid stuck modifier keys
234
235* Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
236- Update to 0.3.2 release
237- Added dep on zlib-devel
238
239* Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
240- Update to 0.3.1 release
241
242* Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
243- Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
244
245* Thu Oct  4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
246- Fixed coroutine caller to avoid SEGV
247
248* Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
249- Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
250
251* Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
252- Update to 0.2.0 release
253
254* Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
255- Fixed handling of mis-matched client/server colour depths
256
257* Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
258- Fix mixed endian handling & BGR pixel format (rhbz #253597)
259- Clear widget areas outside of framebuffer (rhbz #253599)
260- Fix off-by-one in python demo
261
262* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
263- Tweaked post scripts
264- Removed docs from sub-packages
265- Explicitly set license to LGPLv2+
266- Remove use of macro for install rule
267
268* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
269- Added gnutls-devel requirement to -devel package
270
271* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
272- Initial official release
Note: See TracBrowser for help on using the repository browser.