source: projects/specs/trunk/g/gtk-vnc/gtk-vnc-vl.spec @ 4616

Revision 4616, 7.5 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1# Plugin isn't ready for real world use yet - it needs
2# a security audit at very least
3%define with_plugin 0
4
5Summary: A GTK widget for VNC clients
6Summary(ja): VNCクライアント用 GTK ウィジェット
7
8Name: gtk-vnc
9Version: 0.4.3
10Release: 2%{?_dist_release}
11License: LGPLv2+
12Group: Development/Libraries
13Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14Patch100: gtk-vnc-0.3.8-fast.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17URL: http://gtk-vnc.sf.net/
18BuildRequires: gtk3-devel pygtk2-devel python-devel zlib-devel
19BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
20%if %{with_plugin}
21BuildRequires: xulrunner-devel
22%endif
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Takemikaduchi
27
28%description
29gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
30allowing it to be completely asynchronous while remaining single threaded.
31
32%package devel
33Summary: Development filesdor gtk-vnc library
34Summary(ja): gtk-vnc ライブラリの開発ファイル
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: pkgconfig
38Requires: pygtk2-devel gtk3-devel gnutls-devel
39
40%description devel
41gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
42allowing it to be completely asynchronous while remaining single threaded.
43
44Libraries, includes, etc. to compile with the gtk-vnc library
45
46%package python
47Summary: Python bindings for the gtk-vnc library
48Summary(ja): gtk-vnc ライブラリの python バインディング
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description python
53gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
54allowing it to be completely asynchronous while remaining single threaded.
55
56A module allowing use of the GTK-VNC widget from python
57
58%if %{with_plugin}
59%package plugin
60Summary: Mozilla plugin for the gtk-vnc library
61Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description plugin
66gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
67allowing it to be completely asynchronous while remaining single threaded.
68
69This package provides a web browser plugin for Mozilla compatible
70browsers.
71%endif
72
73%prep
74%setup -q
75## %patch100 -p1
76
77%build
78%if %{with_plugin}
79%configure --enable-plugin=yes --with-gtk=3.0
80%else
81%configure --with-gtk=3.0
82%endif
83%__make %{?_smp_mflags}
84
85%install
86rm -fr %{buildroot}
87%__make install DESTDIR=%{buildroot}
88rm -f %{buildroot}%{_libdir}/*.a
89rm -f %{buildroot}%{_libdir}/*.la
90rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
91rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
92%if %{with_plugin}
93rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
94rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
95%endif
96
97%find_lang %{name}
98
99%clean
100rm -fr %{buildroot}
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%files -f %{name}.lang
107%defattr(-, root, root)
108%doc AUTHORS ChangeLog NEWS README COPYING.LIB
109%{_bindir}/gvnccapture
110%{_libdir}/lib*.so.*
111%{_libdir}/girepository-1.0/*.typelib
112%{_mandir}/man1/gvnccapture.1.gz
113
114%files devel
115%defattr(-, root, root)
116%doc examples/gvncviewer.c
117%{_libdir}/lib*.so
118%dir %{_includedir}/%{name}-2.0/
119%dir %{_includedir}/gvnc-1.0/
120%{_includedir}/%{name}-2.0/*.h
121%{_includedir}/gvnc-1.0/*.h
122%{_libdir}/pkgconfig/%{name}-2.0.pc
123%{_libdir}/pkgconfig/gvnc-1.0.pc
124%{_datadir}/gir-1.0/*.gir
125
126%files python
127%defattr(-, root, root)
128%doc examples/gvncviewer.py
129# %{_libdir}/python*/site-packages/gtkvnc.so
130
131%if %{with_plugin}
132%files plugin
133%defattr(-, root, root)
134%{_libdir}/mozilla/plugins/%{name}-plugin.so
135%endif
136
137%changelog
138* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-2
139- change BuildRequires: gtk3-devel instead of gtk2-devel
140- add configure option: --with-gtk=3.0
141
142* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
143- new upstream release
144
145* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-2
146- rebuild with rpm-4.8.1 for pkg-config file
147
148* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
149- new upstream release
150- drop Patch100
151- fix %files
152
153* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
154- new upstream release
155
156* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
157- rebuild with python-2.6
158
159* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
160- new upstream release
161- add Patch100 to speed up
162- add BR: cyrus-sasl-devel
163
164* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
165- rebuild with gnutls-2.6.3
166
167* Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
168- new upstream release
169
170* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
171- initial build for Vine Linux
172
173* Fri Sep  5 2008 Matthias Clasen  <mclasen@redhat.com> - 0.3.7-1
174- Update to 0.3.7
175
176* Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
177- Fix key/mouse event propagation (rhbz #454627)
178
179* Mon Jul  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
180- fix conditional comparison
181
182* Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
183- Rebuild for GNU TLS ABI change
184
185* Wed May  7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
186- Updated to 0.3.6 release
187
188* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
189- Update to 0.3.5
190
191* Fri Apr  4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
192- Remove bogus chunk of render patch
193
194* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
195- Fix OpenGL rendering artifacts (rhbz #440184)
196
197* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
198- Fixed endianness conversions
199- Fix makecontext() args crash on x86_64
200- Fix protocol version negotiation
201
202* Thu Mar  6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
203- Update to 0.3.4 release
204- Fix crash with OpenGL scaling code
205
206* Sun Feb  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
207- Update to 0.3.3 release
208
209* Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
210- Track keystate to avoid stuck modifier keys
211
212* Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
213- Update to 0.3.2 release
214- Added dep on zlib-devel
215
216* Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
217- Update to 0.3.1 release
218
219* Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
220- Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
221
222* Thu Oct  4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
223- Fixed coroutine caller to avoid SEGV
224
225* Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
226- Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
227
228* Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
229- Update to 0.2.0 release
230
231* Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
232- Fixed handling of mis-matched client/server colour depths
233
234* Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
235- Fix mixed endian handling & BGR pixel format (rhbz #253597)
236- Clear widget areas outside of framebuffer (rhbz #253599)
237- Fix off-by-one in python demo
238
239* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
240- Tweaked post scripts
241- Removed docs from sub-packages
242- Explicitly set license to LGPLv2+
243- Remove use of macro for install rule
244
245* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
246- Added gnutls-devel requirement to -devel package
247
248* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
249- Initial official release
Note: See TracBrowser for help on using the repository browser.