source: projects/specs/trunk/g/gtk-vnc/gtk-vnc-vl.spec @ 1443

Revision 1443, 7.0 KB checked in by Takemikaduchi, 14 years ago (diff)

pidgin: rebuild only, others: new upstream release

Line 
1# Plugin isn't ready for real world use yet - it needs
2# a security audit at very least
3%define with_plugin 0
4
5Summary: A GTK widget for VNC clients
6Summary(ja): VNCクライアント用 GTK ウィジェット
7
8Name: gtk-vnc
9Version: 0.4.1
10Release: 1%{?_dist_release}
11License: LGPLv2+
12Group: Development/Libraries
13Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14Patch100: gtk-vnc-0.3.8-fast.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17URL: http://gtk-vnc.sf.net/
18BuildRequires: gtk2-devel pygtk2-devel python-devel zlib-devel
19BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
20%if %{with_plugin}
21BuildRequires: xulrunner-devel
22%endif
23
24%description
25gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
26allowing it to be completely asynchronous while remaining single threaded.
27
28%package devel
29Summary: Development filesdor gtk-vnc library
30Summary(ja): gtk-vnc ライブラリの開発ファイル
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: pkgconfig
34Requires: pygtk2-devel gtk2-devel gnutls-devel
35
36%description devel
37gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
38allowing it to be completely asynchronous while remaining single threaded.
39
40Libraries, includes, etc. to compile with the gtk-vnc library
41
42%package python
43Summary: Python bindings for the gtk-vnc library
44Summary(ja): gtk-vnc ライブラリの python バインディング
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description python
49gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
50allowing it to be completely asynchronous while remaining single threaded.
51
52A module allowing use of the GTK-VNC widget from python
53
54%if %{with_plugin}
55%package plugin
56Summary: Mozilla plugin for the gtk-vnc library
57Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description plugin
62gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
63allowing it to be completely asynchronous while remaining single threaded.
64
65This package provides a web browser plugin for Mozilla compatible
66browsers.
67%endif
68
69%prep
70%setup -q
71## %patch100 -p1
72
73%build
74%if %{with_plugin}
75%configure --enable-plugin=yes
76%else
77%configure
78%endif
79%__make %{?_smp_mflags}
80
81%install
82rm -fr %{buildroot}
83%__make install DESTDIR=%{buildroot}
84rm -f %{buildroot}%{_libdir}/*.a
85rm -f %{buildroot}%{_libdir}/*.la
86rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
87rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
88%if %{with_plugin}
89rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
90rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
91%endif
92
93%find_lang %{name}
94
95%clean
96rm -fr %{buildroot}
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102%files -f %{name}.lang
103%defattr(-, root, root)
104%doc AUTHORS ChangeLog NEWS README COPYING.LIB
105%{_bindir}/gvnccapture
106%{_libdir}/lib*.so.*
107%{_mandir}/man1/gvnccapture.1.gz
108
109%files devel
110%defattr(-, root, root)
111%doc examples/gvncviewer.c
112%{_libdir}/lib*.so
113%dir %{_includedir}/%{name}-1.0/
114%dir %{_includedir}/gvnc-1.0/
115%{_includedir}/%{name}-1.0/*.h
116%{_includedir}/gvnc-1.0/*.h
117%{_libdir}/pkgconfig/%{name}-1.0.pc
118%{_libdir}/pkgconfig/gvnc-1.0.pc
119
120%files python
121%defattr(-, root, root)
122%doc examples/gvncviewer.py
123%{_libdir}/python*/site-packages/gtkvnc.so
124
125%if %{with_plugin}
126%files plugin
127%defattr(-, root, root)
128%{_libdir}/mozilla/plugins/%{name}-plugin.so
129%endif
130
131%changelog
132* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
133- new upstream release
134- drop Patch100
135- fix %files
136
137* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
138- new upstream release
139
140* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
141- rebuild with python-2.6
142
143* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
144- new upstream release
145- add Patch100 to speed up
146- add BR: cyrus-sasl-devel
147
148* Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
149- rebuild with gnutls-2.6.3
150
151* Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
152- new upstream release
153
154* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
155- initial build for Vine Linux
156
157* Fri Sep  5 2008 Matthias Clasen  <mclasen@redhat.com> - 0.3.7-1
158- Update to 0.3.7
159
160* Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
161- Fix key/mouse event propagation (rhbz #454627)
162
163* Mon Jul  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
164- fix conditional comparison
165
166* Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
167- Rebuild for GNU TLS ABI change
168
169* Wed May  7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
170- Updated to 0.3.6 release
171
172* Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
173- Update to 0.3.5
174
175* Fri Apr  4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
176- Remove bogus chunk of render patch
177
178* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
179- Fix OpenGL rendering artifacts (rhbz #440184)
180
181* Thu Apr  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
182- Fixed endianness conversions
183- Fix makecontext() args crash on x86_64
184- Fix protocol version negotiation
185
186* Thu Mar  6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
187- Update to 0.3.4 release
188- Fix crash with OpenGL scaling code
189
190* Sun Feb  3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
191- Update to 0.3.3 release
192
193* Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
194- Track keystate to avoid stuck modifier keys
195
196* Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
197- Update to 0.3.2 release
198- Added dep on zlib-devel
199
200* Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
201- Update to 0.3.1 release
202
203* Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
204- Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
205
206* Thu Oct  4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
207- Fixed coroutine caller to avoid SEGV
208
209* Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
210- Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
211
212* Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
213- Update to 0.2.0 release
214
215* Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
216- Fixed handling of mis-matched client/server colour depths
217
218* Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
219- Fix mixed endian handling & BGR pixel format (rhbz #253597)
220- Clear widget areas outside of framebuffer (rhbz #253599)
221- Fix off-by-one in python demo
222
223* Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
224- Tweaked post scripts
225- Removed docs from sub-packages
226- Explicitly set license to LGPLv2+
227- Remove use of macro for install rule
228
229* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
230- Added gnutls-devel requirement to -devel package
231
232* Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
233- Initial official release
Note: See TracBrowser for help on using the repository browser.