source: projects/specs/trunk/g/gtk-sharp/gtk-sharp-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define monodir %(/usr/bin/monodir)
2Summary: .Net language bindings for Gtk+ and GNOME
3Summary(ja): Gtk+ と GNOME 用の .Net 言語バインディング
4Name: gtk-sharp
5Version: 1.0.10
6Release: 3%{?_dist_release}
7License: LGPL
8Group: Development/Libraries
9URL: http://gtk-sharp.sourceforge.net/
10Source: gtk-sharp-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: mono-core, mono-devel
13BuildRequires: libgnomeui-devel >= 2.0, libgnomecanvas-devel >= 2.2
14BuildRequires: libglade2-devel, gtk2-devel >= 2.2.0
15BuildRequires: libgnomedb-devel, libgda-devel, librsvg2-devel
16BuildRequires: glib2-devel, libart_lgpl-devel, libgsf-devel
17BuildRequires: vte-devel, libgnomeprintui-devel
18Requires: librsvg2
19
20%description
21A C source parser and C# code generator to produce .Net assemblies
22which bind to GObject based libraries.  The Gtk+-2.0 libraries are
23included along with several GNOME platform libraries.
24
25%description -l ja
26GObject ベースのライブラリにバインドされた .Net アセンブリを
27生成する為の、C 言語のソースパーサと C# 言語ののコードジェネ
28レータです。Gtk+-2.0 ライブラリは色々な GNOME プラットフォーム
29ライブラリに含まれています。
30
31%package gapi
32Summary: C source parser and C code generator
33Summary(ja): C 言語のソースパーサとコードジェネレータ
34Group: Development/Libraries
35Requires: perl-libxml-perl, perl-XML-NamespaceSupport
36Requires: perl-XML-SAX, gtk-sharp = %{version}-%{release}
37
38%description gapi
39The gtk-sharp-gapi package includes the parser and code
40generator used by the Gtk if you want to bind
41GObject-based libraries, or need to compile a project that
42uses it to bind such a library.
43
44%description gapi -l ja
45gtk-sharp-gapi パッケージは、GObject ベースの Gtk や、同じよ
46うな他のライブラリにバインドされたプロジェクトを、コンパイル
47するのに必要なパーサとコードジェネレータを含んでいます。
48
49%package devel
50Summary: Header files, libraries and development documentation for %{name}
51Summary(ja): %{name} 用のヘッダファイルやライブラリ及び開発用ドキュメント
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56This package contains the header files, static libraries and development
57documentation for %{name}. If you like to develop programs using %{name},
58you will need to install %{name}-devel.
59
60%description devel -l ja
61このパッケージは %{name} 用のヘッダファイルや静的ライブラリ及び
62開発用ドキュメントを含んでいます。もし  %{name} を使用したプログ
63ラムを開発する場合は、このパッケージをインストールする必要があり
64ます。
65
66
67%prep
68%setup -q
69
70%build
71%configure
72make %{?_smp_mflags}
73
74%install
75rm -rf %{buildroot}
76make install \
77    DESTDIR="%{buildroot}" \
78    GACUTIL_FLAGS="/package gtk-sharp /root %{buildroot}%{_prefix}/lib"
79
80%post
81/sbin/ldconfig 2>/dev/null
82
83%postun
84/sbin/ldconfig 2>/dev/null
85
86%clean
87rm -rf %{buildroot}
88
89%files
90%defattr(-, root, root, 0755)
91%doc ChangeLog COPYING README
92%{_bindir}/gconfsharp-*
93%{monodir}/gac
94%{monodir}/gtk-sharp
95%{_libdir}/*.so
96
97%files gapi
98%defattr(-, root, root, 0755)
99%{_bindir}/gapi*
100%{_libdir}/pkgconfig/gapi.pc
101%{_datadir}/gapi
102
103%files devel
104%defattr(-, root, root, 0755)
105%doc README.generator sample
106%{_libdir}/*.a
107%{_libdir}/pkgconfig/*.pc
108%exclude %{_libdir}/pkgconfig/gapi.pc
109%exclude %{_libdir}/*.la
110
111%changelog
112* Thu Sep 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.10-3vl5
113- rebuild with mono-2.0
114
115* Mon Sep 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.10-2vl5
116- fixed library path (for x86_64)
117
118* Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.10-1vl5
119- applied new versioning policy, spec in utf-8
120
121* Sat Sep 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> - 1.0.10-0vl1
122- new upstream release.
123- update BuildRequires (from mono to mono-core).
124- add japanese Summary and Description.
125
126* Wed Mar 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.8-1vl1
127- new upstream release
128- rebuild for Vine Linux
129
130* Sun Jan 02 2005 Dag Wieers <dag@wieers.com> - 1.0.4-1
131- Updated to release 1.0.4.
132
133* Thu Apr 01 2004 Dag Wieers <dag@wieers.com> - 0.18-1
134- Updated to release 0.18.
135
136* Sat Feb 28 2004 Dag Wieers <dag@wieers.com> - 0.17-0
137- Updated to release 0.17.
138
139* Sat Jan 31 2004 Dag Wieers <dag@wieers.com> - 0.15-1
140- Symlinked gtk-sharp.pc to gapi.pc.
141
142* Mon Jan 05 2004 Dag Wieers <dag@wieers.com> - 0.15-0
143- Updated to release 0.15.
144
145* Thu Nov 20 2003 Dag Wieers <dag@wieers.com> - 0.14-0
146- Updated to release 0.14.
147
148* Mon Nov 17 2003 Dag Wieers <dag@wieers.com> - 0.13-0
149- Updated to release 0.13.
150
151* Wed Oct 29 2003 Dag Wieers <dag@wieers.com> - 0.12-0
152- Updated to release 0.12.
153
154* Fri Sep 19 2003 Dag Wieers <dag@wieers.com> - 0.11-0
155- Updated to release 0.11.
156
157* Sun Jun 15 2003 Dag Wieers <dag@wieers.com> - 0.10-0
158- Updated to release 0.10.
159
160* Sun May 25 2003 Dag Wieers <dag@wieers.com> - 0.9-0
161- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.