source: projects/specs/trunk/g/gtk+/gtk+-vl.spec @ 521

Revision 521, 20.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define ver     1.2.10
3%define rel     2%{?_dist_release}
4%define debug   off
5%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
6
7Name:           gtk+
8Version:        %{ver}
9Release:        %{rel}
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://www.gtk.org
13
14Obsoletes:      gtk
15BuildRequires:  glib-devel >= 1.2.10
16BuildRequires:  libX11-devel libXext-devel libXi-devel
17BuildRequires:  linuxdoc-tools automake14 autoconf213
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Source:         ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{ver}.tar.gz
21Source1:        gtkrc-default
22Source2:        gtkrc.ja-vine
23
24#
25# merged RH patches.
26#
27Patch1:         gtk+-1.2.6-ahiguti.patch
28Patch5:         gtk+-1.2.8-wrap-alnum.patch
29## Supress alignment warnings on ia64
30Patch10:        gtk+-1.2.10-alignment.patch
31## Improve exposure compression
32Patch11:        gtk+-1.2.10-expose.patch
33## Handle focus tracking for embedded window properly
34Patch12:        gtk+-1.2.10-focus.patch
35## Find gtkrc files for the current encoding better
36Patch13:        gtk+-1.2.10-encoding.patch
37## Don't screw up CTEXT encoding for UTF-8
38Patch14:        gtk+-1.2.10-ctext.patch
39## Don't warn about missing fonts for UTF-8
40Patch15:        gtk+-1.2.10-utf8fontset.patch
41## Accept KP_Enter as a synonym for Return everywhere
42Patch16:        gtk+-1.2.10-kpenter.patch
43## Allow theme switching to work properly when no windows are realized
44Patch17:        gtk+-1.2.10-themeswitch.patch
45## Fix crash when switching themes
46Patch18:        gtk+-1.2.10-pixmapref.patch
47## Fix computation of width of missing characters
48Patch19:        gtk+-1.2.10-missingchar.patch
49# Fix sizes of Ukrainian fontsets
50Patch20:        gtk+-1.2.10-ukfont.patch
51# Fix file selection delete-dir when changing directory problem
52# also, fix memory corruption problem when changing directories.
53Patch21:        gtk+-1.2.10-deletedir.patch
54# Improve warning for missing fonts
55Patch22:        gtk+-1.2.10-fontwarning.patch
56# Allow themes to make scrollbar trough always repaint
57Patch23:        gtk+-1.2.10-troughpaint.patch
58# Fix a crash that can happen in some apps when the current
59# locale is not supported by XLib.
60Patch24:        gtk+-1.2.10-localecrash.patch
61# Use lib64 in X11R6 path if it exists.
62Patch25:        gtk+-1.2.10-xlibs.patch
63# Patch from CVS to fix b.g.o #56349
64Patch26:        gtk+-1.2.10-dndorder.patch
65# Patch from CVS to fix b.g.o #94812
66Patch27:        gtk+-1.2.10-clistfocusrow.patch
67# Fix GTK+ to obey X server's default bell volume
68Patch28:        gtk+-1.2.10-bellvolume.patch
69# Hack up the configure scripts to deal with some obscure
70# breakage with ancient libtool
71Patch29:        gtk+-1.2.10-libtool.patch
72# Add a dependency on libgdk to libgtk
73Patch30:        gtk+-1.2.10-gtkgdkdep.patch
74
75# Add x86_64
76Patch31: gtk+-1.2.10-config.sub-x86_64.patch
77
78#
79# Vine-specific patches.
80#
81# This is still necessary.
82Patch101:       gtk+-1.2.3-eventmask.patch
83Patch102:       gtk+-1.2.8-fontselector.patch
84Patch103:       gtk+-1.2.6-event_send.patch
85# Security Patch
86Patch110:       gtk+-1.2.8-gtkmod.patch
87
88
89Summary:        The GIMP ToolKit (GTK+), a library for creating GUIs for X.
90Summary(ja):    X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
91
92
93%description
94The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
95graphical user interfaces for the X Window System.  GTK+ was originally
96written for the GIMP (GNU Image Manipulation Program) image processing
97program, but is now used by several other programs as well. 
98
99If you are planning on using the GIMP or another program that uses GTK+,
100you'll need to have the gtk+ package installed.
101
102%description -l ja
103gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
104ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
105(GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
106プログラムで用いられています。
107
108もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
109パッケージをインストールしてください。
110
111
112%package -n compat32-%{name}
113Summary:        The GIMP ToolKit (GTK+), a library for creating GUIs for X.
114Summary(ja):    X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
115Group:          System Environment/Libraries
116Requires:       %{name} = %{version}
117
118%description -n compat32-%{name}
119The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
120graphical user interfaces for the X Window System.  GTK+ was originally
121written for the GIMP (GNU Image Manipulation Program) image processing
122program, but is now used by several other programs as well. 
123
124If you are planning on using the GIMP or another program that uses GTK+,
125you'll need to have the gtk+ package installed.
126
127%description -n compat32-%{name} -l ja
128gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
129ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
130(GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
131プログラムで用いられています。
132
133もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
134パッケージをインストールしてください。
135
136
137%package devel
138Summary:        Development tools for GTK+ (GIMP ToolKit) applications.
139Summary(ja):    GTK+ (GIMP ツールキット) アプリケーション開発ツール
140Group:          Development/Libraries
141Requires:       %{name} = %{version}
142Requires:       glib-devel
143Requires:       libX11-devel
144Requires:       libXext-devel
145Requires:       libXi-devel
146Obsoletes:      gtk-devel
147Requires(post):  /sbin/install-info
148Requires(preun): /sbin/install-info
149
150%description devel
151The gtk+-devel package contains the static libraries and header files
152needed for developing GTK+ (GIMP ToolKit) applications.  The gtk+-devel
153package contains glib (a collection of routines for simplifying the
154development of GTK+ applications), GDK (the General Drawing Kit, which
155simplifies the interface for writing GTK+ widgets and using GTK+ widgets
156in applications), and GTK+ (the widget set).
157
158Install gtk+-devel if you need to develop GTK+ applications.  You'll also
159need to install the gtk+ package.
160
161%description devel -l ja
162gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
163な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
164glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
165ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
166そして、GTK+ (ウィジッド・セット) を含んでいます。
167
168もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
169ールしてください。gtk+ パッケージもインストールしておく必要があります。
170
171
172%package -n compat32-%{name}-devel
173Summary:        Development tools for GTK+ (GIMP ToolKit) applications.
174Summary(ja):    GTK+ (GIMP ツールキット) アプリケーション開発ツール
175Group:          Development/Libraries
176Requires:       %{name}-devel    = %{version}
177Requires:       compat32-%{name} = %{version}
178
179%description -n compat32-%{name}-devel
180The gtk+-devel package contains the static libraries and header files
181needed for developing GTK+ (GIMP ToolKit) applications.  The gtk+-devel
182package contains glib (a collection of routines for simplifying the
183development of GTK+ applications), GDK (the General Drawing Kit, which
184simplifies the interface for writing GTK+ widgets and using GTK+ widgets
185in applications), and GTK+ (the widget set).
186
187Install gtk+-devel if you need to develop GTK+ applications.  You'll also
188need to install the gtk+ package.
189
190%description -n compat32-%{name}-devel -l ja
191gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
192な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
193glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
194ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
195そして、GTK+ (ウィジッド・セット) を含んでいます。
196
197もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
198ールしてください。gtk+ パッケージもインストールしておく必要があります。
199
200
201%prep
202%setup -q
203
204%patch1 -p1 -b .ahiguti
205%patch5 -p1 -b .alnum
206%patch10 -p1 -b .alignment
207%patch11 -p1 -b .expose
208%patch12 -p1 -b .focus
209%patch13 -p1 -b .encoding
210%patch14 -p1 -b .ctext
211%patch15 -p1 -b .utf8fontset
212%patch16 -p1 -b .kpenter
213%patch17 -p1 -b .themeswitch
214%patch18 -p1 -b .pixmapref
215%patch19 -p1 -b .missingchar
216%patch20 -p1 -b .ukfont
217%patch21 -p1 -b .deletedir
218%patch22 -p1 -b .fontwarning
219%patch23 -p0 -b .troughpaint
220%patch24 -p1 -b .localecrash
221%patch25 -p1 -b .xlibs
222%patch26 -p0 -b .dndorder
223%patch27 -p0 -b .clistfocusrow
224%patch28 -p1 -b .bellvolume
225%patch29 -p1 -b .libtool
226
227%patch31 -p1 -b .x86_64
228
229%patch101 -p1 -b .nocore
230%patch102 -p1 -b .fontsel
231%patch103 -p1 -b .event_send
232%patch110 -p1 -b .gtkmod
233
234#libtoolize --force
235#aclocal-1.4
236automake-1.4
237autoconf-2.13
238autoheader-2.13
239
240%build
241if [ %{debug} = "on" ] ; then
242  export CFLAGS="$RPM_OPT_FLAGS -g"
243else
244  export CFLAGS="$RPM_OPT_FLAGS"
245fi
246
247# gcc-2.95.3 with '-O2' option causes problems on Alpha
248%ifarch alpha
249export CFLAGS="-O -mieee"
250%endif
251
252AUTOMAKE=automake-1.4 %configure --with-xinput=xfree --with-native-locale
253
254if [ "$SMP" != "" ]; then
255  (make "MAKE=make -k -j $SMP"; exit 0)
256  make AUTOMAKE=automake-1.4
257else
258  make AUTOMAKE=automake-1.4
259fi
260
261
262%install
263[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
264
265%makeinstall
266
267# rename gtk-config to gtk-config-32 if build_compat32 option is enabled
268%if %{build_compat32}
269mv $RPM_BUILD_ROOT%{_bindir}/gtk-config $RPM_BUILD_ROOT%{_bindir}/gtk-config-32
270%endif
271
272#
273# Make cleaned-up versions of examples and tutorial for installation
274#
275./mkinstalldirs tmpdocs/tutorial
276install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
277for dir in examples/*; do
278        if [ -d $dir ]; then
279                ./mkinstalldirs tmpdocs/$dir
280                for file in $dir/*; do
281                        case $file in
282                        *pre1.2.7)
283                                ;;
284                        *)
285                                install -m 0644 $file tmpdocs/$dir
286                                ;;
287                        esac
288                done
289        fi
290done
291
292install -m 444 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc
293install -m 444 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc.ja
294
295%find_lang %{name}
296
297# remove unneeded files
298%__rm -f %{buildroot}%{_libdir}/lib{gdk,gtk}.la
299
300%clean
301[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
302
303
304%post -p /sbin/ldconfig
305
306%postun -p /sbin/ldconfig
307
308%post -n compat32-%{name} -p /sbin/ldconfig
309
310%postun -n compat32-%{name} -p /sbin/ldconfig
311
312%post devel
313/sbin/install-info %{_infodir}/gdk.info.gz %{_infodir}/dir
314/sbin/install-info %{_infodir}/gtk.info.gz %{_infodir}/dir
315
316%preun devel
317if [ $1 = 0 ]; then
318    /sbin/install-info --delete %{_infodir}/gdk.info.gz %{_infodir}/dir
319    /sbin/install-info --delete %{_infodir}/gtk.info.gz %{_infodir}/dir
320fi
321
322
323%files -f %{name}.lang
324%defattr(-, root, root)
325
326%doc AUTHORS COPYING ChangeLog NEWS README TODO
327%{_libdir}/libgtk-1.2.so.*
328%{_libdir}/libgdk-1.2.so.*
329%{_datadir}/themes/Default
330%config %{_sysconfdir}/gtk/*
331
332
333%files devel
334%defattr(-, root, root)
335
336%{_libdir}/lib*.so
337%{_libdir}/*.a
338%{_libdir}/pkgconfig
339%{_mandir}/man1/*
340%{_includedir}/*
341%{_infodir}/*info*
342%{_datadir}/aclocal/*
343%{_bindir}/*
344%doc tmpdocs/tutorial
345%doc tmpdocs/examples
346
347
348%if %{build_compat32}
349%files -n compat32-%{name}
350%defattr(-, root, root)
351
352%{_libdir}/libgtk-1.2.so.*
353%{_libdir}/libgdk-1.2.so.*
354
355
356%files -n compat32-%{name}-devel
357%defattr(-, root, root)
358
359%{_libdir}/lib*.so
360%{_libdir}/*.a
361%{_libdir}/pkgconfig
362%{_bindir}/*
363%endif
364
365
366%changelog
367* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.10-2
368- spec in utf-8
369
370* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
371- applied new versioning policy
372- rebuilt with xorg-x11 7.3 (updated denepdancies)
373
374* Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl10
375- rename gtk-config to gtk-config-32 if build_compat32 option is enabled
376
377* Mon Mar 06 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.10-0vl9
378- added compat32-* packages for x86_64 architecture support
379
380* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl8
381- added gtk+-1.2.10-config.sub-x86_64.patch
382
383* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl7
384- rebuild
385- not run libtoolize --force, aclocal-1.4
386- remove %%{_libdir}/lib{gdk,gtk}.la
387- compress info files by brp-compress
388
389* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl6
390- merge more RH patches (Patch26-Patch29)
391  * Mon Oct 27 2003 Owen Taylor <otaylor@redhat.com> 1:1.2.10-28.1
392  - Cave like a cheap house of cards and add gdk-pixbuf dependency (#105613)
393  - Add gtkrc.*.utf8 RC files for CJK (#84593)
394  - Add a dependency on libgdk to libgtk (#106677)
395
396  * Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 1.2.10-26
397  - Run libtoolize/auto* to get an updated libtool that recognizes ppc64
398
399  * Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com> 1.2.10-24
400  - Add a couple of patches from GNOME CVS, fixing a crash
401    with CList focus row tracking, and a place where DND
402    would get confused.
403  - Obey the system bell volume (#74802)
404  - Ship the pkg-config files
405
406  * Mon Nov  4 2002 Tim Waugh <twaugh@redhat.com> 1.2.10-23
407  - Don't install files not shipped.
408  - Fix gtk-config output for multilib archs.
409   
410* Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl5
411- merge more RH patches (Patch20-Patch25)
412- rawhide's changelog since last merge (except "automated rebuild") are:
413
414  - Thu Aug 22 2002 Owen Taylor <otaylor@redhat.com>
415  - Fix a crash that can happen in some apps when the current
416    locale is not supported by XLib. (#72157)
417
418  - Fri Jul 26 2002 Owen Taylor <otaylor@redhat.com>
419  - Fix a small memory leak in the .encoding patch (Kjartan Maraas)
420
421  - Fri Jul 19 2002 Alexander Larsson <alexl@redhat.com>
422  - Add troughpaint patch
423
424  - Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
425  - Fix UTF-8 font specification not to pick up *-c-* fonts
426
427  - Thu May 16 2002 Alex Larsson <alexl@redhat.com>
428  - Require automake 1.4
429
430  - Wed Apr 17 2002 Owen Taylor <otaylor@redhat.com>
431  - Fix problem with incorrect directory contents when changing directories (#63726)
432
433  - Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
434  - Fix filesel delete-filename-on-dir-change problem
435  - Improve warning for missing fontset elements
436
437  - Thu Apr 11 2002 Owen Taylor <otaylor@redhat.com>
438  - Fix ukrainian font sizes, minor tweak to russian fonts (#63135)
439  - Own /etc/gtk/ as well as the files in it (#63139)
440
441* Thu Mar 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl4
442- changed default theme to BeCool.
443
444* Mon Oct 15 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
445- Merged several RH patches.
446  * Mon Aug 13 2001 Owen Taylor <otaylor@redhat.com>
447  - Fix problem with width computation for missing characters
448
449  * Sun Aug 12 2001 Owen Taylor <otaylor@redhat.com>
450  - Fix refcounting problem in gtk_style_copy() that might affect
451    theme switching. (#51580)
452
453  * Wed Aug  8 2001 Owen Taylor <otaylor@redhat.com>
454  - Add fix for theme switching in nautilus sidebar tabs
455    (and other similar situations)
456
457  * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
458  - Accept KP_Enter as well as Return (#21111)
459
460  * Wed Jul 11 2001 Owen Taylor <otaylor@redhat.com>
461  - Further improve exposure compression code
462
463  * Tue Jul 10 2001 Owen Taylor <otaylor@redhat.com>
464  - Omit warnings about character sets not found in fontset,
465    if current locale is UTF-8 based. (Hack!)
466
467  * Tue Jul  3 2001 Owen Taylor <otaylor@redhat.com>
468  - Add patch for alignment warnings on ia64
469  - Add from Alex to vastly improve expose compression
470  - Add patch to fix focus tracking for embedded windows
471  - Add patch by Pablo Saratxaga to improve encoding handling
472  - Add patch to not screw up CTEXT for UTF-8 locales
473
474* Tue Jul 17 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
475- 1.2.10-0vl2
476- change CFLAGS on alpha (gcc-2.95.3 with -O2 causes problems)
477
478* Tue Apr  3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
479- New upstream release.
480
481* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
482- New upstream release.
483
484* Wed Feb 14 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl6
485- correct configure for stablity
486
487* Tue Feb 13 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl5
488- correct configure (for --enable-xinput)
489- add DESTDIR patch for po/Makefile.in.in
490
491* Wed Feb  7 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl4
492- add gtk+-1.2.8-gtktextwcfix.patch
493
494* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
495- 1.2.8-0vl2
496- applied security patch (http://www.securityfocus.com/bid/2165)
497
498* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
499- updated to 1.2.8
500
501* Fri Feb 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
502- added fontselector based on kondara's patch
503
504* Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
505- updated to 1.2.7
506- remove morioka marged to the original gtk source tree.
507
508 Tue Dec 28 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
509- added event_send patch to be more stable when switching themes.
510
511* Sat Dec 11 1999 Jun Nishii <jun@flatout.org>
512- smaller fontset in gtkrc.ja
513
514* Thu Nov 25 1999 Jun NISHII <jun@flatout.org>
515- use morioka patch instead of fontsel patches
516
517* Sat Oct 23 1999 Jun Nishii <jun@flatout.org>
518- gtk+-1.2.6-1vl2
519- added fontsel patches from gtk/gnome-ML
520
521* Tue Oct 12 1999 Jun Nishii <jun@flatout.org>
522- gtk+-1.2.6-1vl1
523
524* Thu Sep 30 1999 Jun Nishii <jun@flatout.org>
525- gtk+-1.2.5-1vl2
526- with wordwrap patch
527
528* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
529- gtk+-1.2.5-1vl1
530
531* Fri Sep 11 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
532  [gtk+-1.2.4-1vl2]
533- removed fontsel patch.
534
535* Fri Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
536  [gtk+-1.2.4-1vl1]
537- install gzipped info.
538- changed release tag with 'vl.'
539
540* Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
541  [gtk+-1.2.4-1]
542- Update for GTK+-1.2.4.
543- bzip2 source.
544- use %{sysconfdir} as /etc.
545
546* Sun Aug 22 1999 Jun Nishii <jun@flatout.org>
547- bzip2 source
548
549* Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
550- build for Vine-1.9
551- merge fontset patch
552
553* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
554- Update for GTK+-1.2.3
555- Patches that will be in GTK+-1.2.4
556- Patch to keep GTK+ from coredumping on X IO errors
557- Patch to improve compatilibity with GTK-1.2.1 (allow
558  event mask to be set on realized widgets)
559
560* Mon Apr 19 1999 Michael Fulbright <drmike@redhat.com>
561- fixes memory leak
562
563* Mon Apr 12 1999 Owen Taylor <otaylor@redhat.com>
564- The important bug fixes that will be in GTK+-1.2.2
565
566* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
567- patches from owen to handle various gdk bugs
568
569* Sun Mar 28 1999 Michael Fulbright <drmike@redhat.com>
570- added XFree86-devel requirement for gtk+-devel
571
572* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
573- version 1.2.1
574
575* Wed Mar 17 1999 Michael Fulbright <drmike@redhat.com>
576- removed /usr/info/dir.gz file from package
577
578* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
579- Version 1.2.0
580
581* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
582- version 1.2.0pre2, patched to use --sysconfdir=/etc
583
584* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
585- patched in Owen's patch to fix Metal theme
586
587* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
588- bumped up to 1.1.15
589
590* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
591- bumped up to 1.1.14
592
593* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
594- bumped up to 1.1.13
595
596* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
597- bumped up to 1.1.12
598
599* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
600- added Theme directory to file list
601- up to 1.1.7 for GNOME freeze
602
603* Sun Oct 25 1998 Shawn T. Amundson <amundson@gtk.org>
604- Fixed Source: to point to v1.1
605
606* Tue Aug 04 1998 Michael Fulbright <msf@redhat.com>
607- change %postun to %preun
608
609* Mon Jun 27 1998 Shawn T. Amundson
610- Changed version to 1.1.0
611
612* Thu Jun 11 1998 Dick Porter <dick@cymru.net>
613- Removed glib, since it is its own module now
614
615* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
616- Split out glib package
617
618* Tue Apr  8 1998 Shawn T. Amundson <amundson@gtk.org>
619- Changed version to 1.0.0
620
621* Tue Apr  7 1998 Owen Taylor <otaylor@gtk.org>
622- Changed version to 0.99.10
623
624* Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
625- Changed version to 0.99.9
626- Changed gtk home page to www.gtk.org
627
628* Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
629- Changed version to 0.99.8
630
631* Sun Mar 15 1998 Marc Ewing <marc@redhat.com>
632- Added aclocal and bin stuff to file list.
633- Added -k to the SMP make line.
634- Added lib/glib to file list.
635
636* Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
637- Changed version to 0.99.7
638
639* Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
640- Updated ftp url and changed version to 0.99.6
641
642* Thu Mar 12 1998 Marc Ewing <marc@redhat.com>
643- Reworked to integrate into gtk+ source tree
644- Truncated ChangeLog.  Previous Authors:
645  Trond Eivind Glomsrod <teg@pvv.ntnu.no>
646  Michael K. Johnson <johnsonm@redhat.com>
647  Otto Hammersmith <otto@redhat.com>
Note: See TracBrowser for help on using the repository browser.