source: projects/specs/trunk/g/gtest/gtest-vl.spec @ 6085

Revision 6085, 4.3 KB checked in by kudoh, 12 years ago (diff)
Line 
1Summary:        Google C++ testing framework
2Summary(ja):    Google C++ テスティングフレームワーク
3Name:           gtest
4Version:        1.6.0
5Release:        1%{?_dist_release}
6License:        New BSD
7Group:          Development/Tools
8URL:            http://code.google.com/p/googletest/
9Source0:        http://googletest.googlecode.com/files/%{name}-%{version}.tar.xz
10Patch0:         gtest-1.6.0_install.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  chrpath
15BuildRequires:  python >= 2.3
16
17%description
18Google's framework for writing C++ tests on a variety of platforms (GNU/Linux,
19Mac OS X, Windows, Windows CE, and Symbian). Based on the xUnit architecture.
20Supports automatic test discovery, a rich set of assertions, user-defined
21assertions, death tests, fatal and non-fatal failures, various options for
22running the tests, and XML test report generation.
23
24%package devel
25Summary:        Development files for %{name}
26Summary(ja):    %{name} の開発ファイル
27Group:          Development/Libraries
28
29Requires:       automake
30Requires:       %{name} = %{version}-%{release}
31
32%description devel
33This package contains development files for %{name}.
34
35%prep
36%setup -q
37%patch0 -p1
38
39# Keep a clean copy of samples.
40cp -pr ./samples ./samples.orig
41
42%build
43%configure --disable-static
44
45# Omit unused direct shared library dependencies.
46sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
47
48make %{?_smp_mflags}
49
50%check
51# Two tests fail here, unclear as to why.
52make check
53
54# Restore the clean copy of samples.
55# To be later listed against %doc.
56rm -rf ./samples
57mv ./samples.orig ./samples
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
63find $RPM_BUILD_ROOT -type f -name "*.la" -delete
64
65# Remove rpaths.
66chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libgtest_main.so.0.0.0
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72
73%postun -p /sbin/ldconfig
74
75%files
76%defattr(-,root,root,-)
77%doc CHANGES
78%doc CONTRIBUTORS
79%doc COPYING
80%doc README
81%{_libdir}/libgtest.so.*
82%{_libdir}/libgtest_main.so.*
83
84%files devel
85%defattr(-,root,root,-)
86%doc samples
87#%{_bindir}/%{name}-config
88%{_datadir}/aclocal/%{name}.m4
89%{_libdir}/libgtest.so
90%{_libdir}/libgtest_main.so
91
92%dir %{_includedir}/%{name}
93%{_includedir}/%{name}/*.h
94%{_includedir}/%{name}/internal
95
96%changelog
97* Sun Apr 29 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.0-1
98- new upstream release
99- changed source archive type to xz
100- added Patch0 from Mandriva
101
102* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
103- rebuilt with rpm-4.8.1 for pkg-config
104
105* Sun May 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
106- initial build for VineSeed
107
108* Sat Nov 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.4.0-1
109- Version bump to 1.4.0.
110  * New feature: the event listener API.
111  * New feature: test shuffling.
112  * New feature: the XML report format is closer to junitreport and can
113    be parsed by Hudson now.
114  * New feature: elapsed time for the tests is printed by default.
115  * New feature: comes with a TR1 tuple implementation such that Boost
116    is no longer needed for Combine().
117  * New feature: EXPECT_DEATH_IF_SUPPORTED macro and friends.
118  * New feature: the Xcode project can now produce static gtest libraries in
119    addition to a framework.
120  * Compatibility fixes for gcc and minGW.
121  * Bug fixes and implementation clean-ups.
122
123* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 1.3.0-2.20090601svn257
124- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
125
126* Mon Jun 01 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.0-1
127- Version bump to 1.3.0.
128  * New feature: ability to use Google Test assertions in other testing
129    frameworks.
130  * New feature: ability to run disabled test via
131    --gtest_also_run_disabled_tests.
132  * New feature: the --help flag for printing the usage.
133  * New feature: access to Google Test flag values in user code.
134  * New feature: a script that packs Google Test into one .h and one .cc file
135    for easy deployment.
136  * New feature: support for distributing test functions to multiple machines
137    (requires support from the test runner).
138  * Bug fixes and implementation clean-ups.
139
140* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
142
143* Sat Jul 05 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.0.0-1
144- Initial build.
Note: See TracBrowser for help on using the repository browser.