source: projects/specs/trunk/g/gtest/gtest-vl.spec @ 12200

Revision 12200, 6.2 KB checked in by tomop, 5 years ago (diff)

gtest-1.8.1-1

RevLine 
[1067]1Summary:        Google C++ testing framework
2Summary(ja):    Google C++ テスティングフレームワーク
3Name:           gtest
[12200]4Version:        1.8.1
5Release:        1%{?_dist_release}
[1067]6License:        New BSD
7Group:          Development/Tools
[12200]8URL:            https://github.com/google/googletest
[1067]9
[12200]10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13Source0:        https://github.com/google/googletest/archive/release-%{version}.tar.gz
14
15# https://github.com/google/googletest/pull/967
16Patch0:         gtest-1.8.1-null-pointer.patch
17# https://github.com/google/googletest/pull/1839
18Patch1:         gtest-PR1839-Fix-Python3-support.patch
19# Fedora-specific patches
20## Set libversion for libraries to version of gtest
21Patch100:       gtest-1.8.1-libversion.patch
22## Add missing pkgconfig requires information to reflect reality
23Patch101:       gtest-1.8.1-add-missing-pkgconfig-requires.patch
[1067]24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
[12200]26BuildRequires:  cmake
27BuildRequires:  python3-devel
28BuildRequires:  python3-rpm-macros
[1067]29
30%description
31Google's framework for writing C++ tests on a variety of platforms (GNU/Linux,
32Mac OS X, Windows, Windows CE, and Symbian). Based on the xUnit architecture.
33Supports automatic test discovery, a rich set of assertions, user-defined
34assertions, death tests, fatal and non-fatal failures, various options for
35running the tests, and XML test report generation.
36
[12200]37
[1067]38%package devel
39Summary:        Development files for %{name}
40Summary(ja):    %{name} の開発ファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description devel
45This package contains development files for %{name}.
46
47
[12200]48%package     -n gmock
49Summary:        Google C++ Mocking Framework
50Group:          Development/Tools
51Requires:       %{name} = %{version}-%{release}
[1067]52
[12200]53%description -n gmock
54Inspired by jMock, EasyMock, and Hamcrest, and designed with C++s
55specifics in mind, Google C++ Mocking Framework (or Google Mock for
56short) is a library for writing and using C++ mock classes.
[1067]57
[12200]58Google Mock:
[1067]59
[12200]60 o lets you create mock classes trivially using simple macros,
61 o supports a rich set of matchers and actions,
62 o handles unordered, partially ordered, or completely ordered
63   expectations,
64 o is extensible by users, and
65 o works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
66   Symbian.
[1067]67
68
[12200]69%package     -n gmock-devel
70Summary:        Development files for gmock
71Group:          Development/Libraries
72Requires:       gmock = %{version}-%{release}
[1067]73
[12200]74%description -n gmock-devel
75This package contains development files for gmock.
76
77
78%prep
79%autosetup -p1 -n googletest-release-%{version}
80
81# Set the version correctly
82sed -e "s/set(GOOGLETEST_VERSION .*)/set(GOOGLETEST_VERSION %{version})/" -i CMakeLists.txt
83
84
85%build
86mkdir build && cd build
87%cmake -DBUILD_SHARED_LIBS=ON \
88       -DPYTHON_EXECUTABLE=%{__python3} \
89       -Dgtest_build_tests=ON ..
90%make_build
91
92
[1067]93%install
[12200]94cd build
95%make_install
[1067]96
97
[12200]98%check
99cd build
100make test
[1067]101
[12200]102
[1067]103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
[12200]110%post -n gmock -p /sbin/ldconfig
111
112%postun -n gmock -p /sbin/ldconfig
113
[1067]114%files
115%defattr(-,root,root,-)
[12200]116%license googletest/LICENSE
117%{_libdir}/libgtest.so.%{version}
118%{_libdir}/libgtest_main.so.%{version}
[1067]119
120%files devel
121%defattr(-,root,root,-)
[12200]122%doc googletest/{CHANGES,CONTRIBUTORS,README.md}
123%doc googletest/docs/
124%doc googletest/samples
125%{_includedir}/gtest/
[1067]126%{_libdir}/libgtest.so
127%{_libdir}/libgtest_main.so
[12200]128%{_libdir}/cmake/GTest/
129%{_libdir}/pkgconfig/gtest.pc
130%{_libdir}/pkgconfig/gtest_main.pc
[1067]131
[12200]132%files -n gmock
133%license googlemock/LICENSE
134%{_libdir}/libgmock.so.%{version}
135%{_libdir}/libgmock_main.so.%{version}
[1067]136
[12200]137%files -n gmock-devel
138%doc googlemock/{CHANGES,CONTRIBUTORS,README.md}
139%doc googlemock/docs/
140%{_includedir}/gmock/
141%{_libdir}/libgmock.so
142%{_libdir}/libgmock_main.so
143%{_libdir}/pkgconfig/gmock.pc
144%{_libdir}/pkgconfig/gmock_main.pc
145
146
[1067]147%changelog
[12200]148* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.1-1
149- new upstream release.
150- dropped Patch0.
151- imported patches from rawhide.
152
[10495]153* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.0-2
154- rebuilt with new toolchain.
155
[8713]156* Tue Jul 01 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-1
157- new upstream release
158
[6085]159* Sun Apr 29 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.0-1
160- new upstream release
161- changed source archive type to xz
162- added Patch0 from Mandriva
163
[1948]164* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
165- rebuilt with rpm-4.8.1 for pkg-config
166
[1067]167* Sun May 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
168- initial build for VineSeed
169
170* Sat Nov 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.4.0-1
171- Version bump to 1.4.0.
172  * New feature: the event listener API.
173  * New feature: test shuffling.
174  * New feature: the XML report format is closer to junitreport and can
175    be parsed by Hudson now.
176  * New feature: elapsed time for the tests is printed by default.
177  * New feature: comes with a TR1 tuple implementation such that Boost
178    is no longer needed for Combine().
179  * New feature: EXPECT_DEATH_IF_SUPPORTED macro and friends.
180  * New feature: the Xcode project can now produce static gtest libraries in
181    addition to a framework.
182  * Compatibility fixes for gcc and minGW.
183  * Bug fixes and implementation clean-ups.
184
185* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 1.3.0-2.20090601svn257
186- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
187
188* Mon Jun 01 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.0-1
189- Version bump to 1.3.0.
190  * New feature: ability to use Google Test assertions in other testing
191    frameworks.
192  * New feature: ability to run disabled test via
193    --gtest_also_run_disabled_tests.
194  * New feature: the --help flag for printing the usage.
195  * New feature: access to Google Test flag values in user code.
196  * New feature: a script that packs Google Test into one .h and one .cc file
197    for easy deployment.
198  * New feature: support for distributing test functions to multiple machines
199    (requires support from the test runner).
200  * Bug fixes and implementation clean-ups.
201
202* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
204
205* Sat Jul 05 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.0.0-1
206- Initial build.
Note: See TracBrowser for help on using the repository browser.