source: projects/specs/trunk/g/gstreamer1/gstreamer1-vl.spec @ 9986

Revision 9986, 7.5 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           1.0
3
4%define _gtk_doc_ver    1.6
5
6%define po_package      gstreamer-%{major}
7
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9
10Name:           gstreamer1
11Summary:        GStreamer streaming media framework runtime.
12Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
13Version:        1.6.3
14Release:        1%{?_dist_release}
15
16Group:          System Environment/Libraries
17License:        LGPL
18URL:            http://gstreamer.freedesktop.org/
19Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires:  gobject-introspection-devel
24BuildRequires:  bison
25BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
26BuildRequires:  flex
27
28Vendor:                 Project Vine
29Distribution:   Vine Linux
30Packager:       Takemikaduchi
31
32%description
33GStreamer is a streaming-media framework, based on graphs of filters which
34operate on media data. Applications using this library can do anything
35from real-time sound processing to playing videos, and just about anything
36else media-related.  Its plugin-based architecture means that new data
37types or processing capabilities can be added simply by installing new
38plugins.
39
40%package devel
41Summary:        Libraries/header files for GStreamer streaming media framework.
42Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45
46%description devel
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new   
52plugins.
53
54This package contains the libraries and includes files necessary to develop
55applications and plugins for GStreamer.
56
57# compat32
58%package -n compat32-%{name}
59Summary:        GStreamer streaming media framework runtime.
60Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
61Group:          System Environment/Libraries
62
63%description -n compat32-%{name}
64GStreamer is a streaming-media framework, based on graphs of filters which
65operate on media data. Applications using this library can do anything
66from real-time sound processing to playing videos, and just about anything
67else media-related.  Its plugin-based architecture means that new data
68types or processing capabilities can be added simply by installing new
69plugins.
70
71%package -n compat32-%{name}-devel
72Summary:        Libraries/header files for GStreamer streaming media framework.
73Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
74Group:          Development/Libraries
75Requires:       compat32-%{name} = %{version}-%{release}
76Requires:       %{name}-devel = %{version}-%{release}
77
78%description -n compat32-%{name}-devel
79GStreamer is a streaming-media framework, based on graphs of filters which
80operate on media data. Applications using this library can do anything
81from real-time sound processing to playing videos, and just about anything
82else media-related.  Its plugin-based architecture means that new data
83types or processing capabilities can be added simply by installing new   
84plugins.
85
86This package contains the libraries and includes files necessary to develop
87applications and plugins for GStreamer.
88
89%prep
90%setup -q -n gstreamer-%{version}
91
92%build
93%configure \
94        --with-package-name='Vine Linux gstreamer package' \
95        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
96        --enable-introspection=yes \
97        --disable-docbook --enable-gtk-doc \
98        --disable-static --disable-examples \
99        --disable-tests --disable-debug
100
101make %{?_smp_mflags}
102
103%install
104[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
105
106make install DESTDIR=$RPM_BUILD_ROOT
107
108mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
109
110rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
111rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
112#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
113
114%find_lang %{po_package}
115
116%clean
117[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%post -n compat32-%{name} -p /sbin/ldconfig
124
125%postun -n compat32-%{name} -p /sbin/ldconfig
126
127%files -f %{po_package}.lang
128%defattr(-, root, root)
129%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
130%doc TODO ABOUT-NLS
131%{_bindir}/*
132%dir %{_libdir}/gstreamer-%{major}
133%{_libdir}/gstreamer-%{major}/*.so*
134%{_libdir}/*.so.*
135%{_libdir}/girepository-1.0/*.typelib
136%dir %{_libexecdir}/gstreamer-%{major}
137%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
138%{_libexecdir}/gstreamer-%{major}/gst-ptp-helper
139%{_datadir}/bash-completion/completions/gst-inspect-1.0
140%{_datadir}/bash-completion/completions/gst-launch-1.0
141%{_datadir}/bash-completion/helpers/gst
142%{_datadir}/bash-completion/helpers/gst-completion-helper-1.0
143%{_mandir}/man1/*
144%dir %{_var}/cache/gstreamer-%{major}
145
146%files devel
147%defattr(-, root, root)
148%dir %{_includedir}/gstreamer-%{major}
149%{_includedir}/gstreamer-%{major}/*
150%{_libdir}/gstreamer-%{major}/include/gst/gstconfig.h
151%{_libdir}/*.so
152%{_libdir}/pkgconfig/gstreamer*.pc
153%{_datadir}/aclocal/*.m4
154%{_datadir}/gtk-doc/html/gstreamer-%{major}
155%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
156%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
157%{_datadir}/gir-1.0/*.gir
158
159# compat32
160%if %{build_compat32}
161%files -n compat32-%{name}
162%defattr(-, root, root)
163%dir %{_libdir}/gstreamer-%{major}
164%{_libdir}/gstreamer-%{major}/*.so*
165%{_libdir}/*.so.*
166
167%files -n compat32-%{name}-devel
168%defattr(-, root, root)
169%{_libdir}/*.so
170%endif
171
172%changelog
173* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
174- new upstream release
175
176* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
177- new upstream release
178
179* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
180- new upstream release
181
182* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
183- new upstream release
184
185* Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
186- new upstream release
187
188* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
189- new upstream release
190
191* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
192- new upstream release
193
194* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
195- new upstream release
196
197* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
198- new upstream release
199
200* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
201- new upstream release
202
203* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
204- new upstream release
205
206* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
207- new upstream release
208
209* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
210- new upstream release
211
212* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
213- new upstream release
214
215* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
216- new upstream release
217
218* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
219- new upstream release
220
221* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
222- new upstream release
223
224* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
225- new upstream release
226
227* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
228- new upstream release
229
230* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
231- new upstream release
232
233* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
234- initial build
Note: See TracBrowser for help on using the repository browser.