source: projects/specs/trunk/g/gstreamer1-plugins-base/gstreamer1-plugins-base-vl.spec @ 9986

Revision 9986, 9.3 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define major 1.0
4
5%define _gst_ver        1.6.3
6%define _glib2_ver      2.38.0
7%define _gtk3_ver       3.10.0
8%define _gtk_doc_ver    1.3
9%define _qt4_ver        4.6
10%define _check_ver      0.9.2
11%define _python_ver     2.6
12%define _alsa_lib_ver   0.9.1
13%define _libogg_ver     1.0
14%define _libvorbis_ver  1.0
15%define _freetype2_ver  2.0.9
16%define _orc_ver        0.4.22
17
18%define po_package      gst-plugins-base-%{major}
19
20Summary:        GStreamer Streaming-media framework base plugins
21Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
22Name:           gstreamer1-plugins-base
23Version:        1.6.3
24Release:        1%{?_dist_release}
25License:        LGPL
26Group:          System Environment/Libraries
27URL:            http://gstreamer.freedesktop.org/
28Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Requires:       gstreamer1 >= %{_gst_ver}
32
33BuildRequires:  gstreamer1-devel >= %{_gst_ver}
34BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
35BuildRequires:  python >= %{_python_ver}, python-pyxml
36BuildRequires:  glib2-devel >= %{_glib2_ver}
37BuildRequires:  check >= %{_check_ver}
38BuildRequires:  gtk3-devel >= %{_gtk3_ver}
39BuildRequires:  qt4-devel >= %{_qt4_ver}
40BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
41BuildRequires:  cdparanoia-devel
42BuildRequires:  libogg-devel >= %{_libogg_ver}
43BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
44BuildRequires:  pango-devel
45BuildRequires:  freetype2-devel >= %{_freetype2_ver}
46BuildRequires:  fontconfig-devel
47BuildRequires:  libX11-devel
48BuildRequires:  libXv-devel
49BuildRequires:  libvisual-devel
50BuildRequires:  orc-devel >= %{_orc_ver}
51BuildRequires:  gobject-introspection-devel
52
53Vendor:         Project Vine
54Distribution:   Vine Linux
55Packager:       Takemikaduchi
56
57%description
58GStreamer is a streaming-media framework, based on graphs of filters which
59operate on media data. Applications using this library can do anything
60from real-time sound processing to playing videos, and just about anything
61else media-related.  Its plugin-based architecture means that new data
62types or processing capabilities can be added simply by installing new
63plugins.
64
65This package contains a set of well-maintained base plugins.
66
67%package devel
68Summary:        Libraries/include files for GStreamer base plugins
69Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
70Group:          Development/Libraries
71Requires:       %{name} = %{version}-%{release}
72Requires:       gstreamer1-devel >= %{_gst_ver}
73
74%description devel
75GStreamer is a streaming-media framework, based on graphs of filters which
76operate on media data. Applications using this library can do anything
77from real-time sound processing to playing videos, and just about anything
78else media-related.  Its plugin-based architecture means that new data
79types or processing capabilities can be added simply by installing new
80plugins.
81
82This package contains GStreamer base plugins library depvelopment and header
83files.
84
85# compat32
86%package -n compat32-%{name}
87Summary:        GStreamer Streaming-media framework base plugins
88Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
89Group:          System Environment/Libraries
90Requires:       %{name} = %{version}-%{release}
91
92%description -n compat32-%{name}
93GStreamer is a streaming-media framework, based on graphs of filters which
94operate on media data. Applications using this library can do anything
95from real-time sound processing to playing videos, and just about anything
96else media-related.  Its plugin-based architecture means that new data
97types or processing capabilities can be added simply by installing new
98plugins.
99
100This package contains a set of well-maintained base plugins.
101
102%package -n compat32-%{name}-devel
103Summary:        Libraries/include files for GStreamer base plugins
104Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
105Group:          Development/Libraries
106Requires:       compat32-%{name} = %{version}-%{release}
107Requires:       %{name}-devel = %{version}-%{release}
108Requires:       compat32-gstreamer1-devel >= %{_gst_ver}
109
110%description -n compat32-%{name}-devel
111GStreamer is a streaming-media framework, based on graphs of filters which
112operate on media data. Applications using this library can do anything
113from real-time sound processing to playing videos, and just about anything
114else media-related.  Its plugin-based architecture means that new data
115types or processing capabilities can be added simply by installing new
116plugins.
117
118This package contains GStreamer base plugins library depvelopment and header
119files.
120
121
122%prep
123%setup -q -n gst-plugins-base-%{version}
124
125%build
126%ifarch alpha
127%define optflags -O2 -mieee -fPIC
128%endif
129
130%configure \
131        --with-package-name='Vine Linux gstreamer-plugins-base package' \
132        --enable-gtk-doc \
133        --disable-static \
134        --disable-debug \
135        --enable-orc \
136        --enable-introspection=yes
137
138make %{?_smp_mflags}
139
140%install
141[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
142make install DESTDIR=$RPM_BUILD_ROOT
143
144# Clean out files that should not be part of the rpm.
145rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
146rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
147
148%find_lang %{po_package}
149
150%clean
151[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
152
153%post -p /sbin/ldconfig
154
155%postun -p /sbin/ldconfig
156
157%post -n compat32-%{name} -p /sbin/ldconfig
158
159%postun -n compat32-%{name} -p /sbin/ldconfig
160
161%files -f %{po_package}.lang
162%defattr(-,root,root)
163%doc AUTHORS ChangeLog COPYING* NEWS README RELEASE REQUIREMENTS
164
165# helper programs
166%{_bindir}/gst-*
167%{_mandir}/man1/gst-*
168
169%{_datadir}/gst-plugins-base/1.0/license-translations.dict
170
171# libraries
172%{_libdir}/libgst*-%{major}.so.*
173%{_libdir}/girepository-1.0/*.typelib
174
175# base plugins without external dependencies
176%{_libdir}/gstreamer-%{major}/libgstadder.so
177%{_libdir}/gstreamer-%{major}/libgstaudioconvert.so
178%{_libdir}/gstreamer-%{major}/libgstaudiorate.so
179%{_libdir}/gstreamer-%{major}/libgstaudioresample.so
180%{_libdir}/gstreamer-%{major}/libgstaudiotestsrc.so
181%{_libdir}/gstreamer-%{major}/libgstapp.so
182%{_libdir}/gstreamer-%{major}/libgstcdparanoia.so
183%{_libdir}/gstreamer-%{major}/libgstencodebin.so
184%{_libdir}/gstreamer-%{major}/libgstgio.so
185%{_libdir}/gstreamer-%{major}/libgstplayback.so
186%{_libdir}/gstreamer-%{major}/libgstsubparse.so
187%{_libdir}/gstreamer-%{major}/libgsttcp.so
188%{_libdir}/gstreamer-%{major}/libgsttypefindfunctions.so
189%{_libdir}/gstreamer-%{major}/libgstvideoconvert.so
190%{_libdir}/gstreamer-%{major}/libgstvideorate.so
191%{_libdir}/gstreamer-%{major}/libgstvideoscale.so
192%{_libdir}/gstreamer-%{major}/libgstvideotestsrc.so
193%{_libdir}/gstreamer-%{major}/libgstvolume.so
194%{_libdir}/gstreamer-%{major}/libgstximagesink.so
195%{_libdir}/gstreamer-%{major}/libgstxvimagesink.so
196
197# base plugins with external dependencies, but in the main package
198%{_libdir}/gstreamer-%{major}/libgstalsa.so
199%{_libdir}/gstreamer-%{major}/libgstpango.so
200%{_libdir}/gstreamer-%{major}/libgstlibvisual.so
201%{_libdir}/gstreamer-%{major}/libgstogg.so
202%{_libdir}/gstreamer-%{major}/libgsttheora.so
203%{_libdir}/gstreamer-%{major}/libgstvorbis.so
204
205%files devel
206%defattr(-,root,root)
207%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
208%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
209%{_datadir}/gir-1.0/*.gir
210%{_includedir}/gstreamer-%{major}/gst/*
211%{_libdir}/pkgconfig/*.pc
212%{_libdir}/libgst*-%{major}.so
213
214# compat32
215%if %{build_compat32}
216%files -n compat32-%{name}
217%defattr(-,root,root)
218%{_libdir}/libgst*-%{major}.so.*
219%{_libdir}/gstreamer-%{major}/*.so
220
221%files -n compat32-%{name}-devel
222%defattr(-,root,root)
223%{_libdir}/libgst*-%{major}.so
224%endif
225
226
227%changelog
228* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
229- new upstream release
230
231* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
232- new upstream release
233
234* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
235- new upstream release
236
237* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
238- new upstream release
239
240* Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
241- new upstream release
242
243* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
244- new upstream release
245
246* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
247- new upstream release
248
249* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
250- new upstream release
251
252* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
253- new upstream release
254
255* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
256- new upstream release
257
258* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
259- new upstream release
260
261* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
262- new upstream release
263
264* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
265- new upstream release
266
267* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
268- new upstream release
269
270* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
271- new upstream release
272
273* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
274- new upstream release
275
276* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
277- new upstream release
278
279* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
280- new upstream release
281
282* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
283- new upstream release
284
285* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
286- new upstream release
287
288* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
289- initial build
Note: See TracBrowser for help on using the repository browser.